SurfaceXplorer :: Help content

SurfaceXplorer by Microtestmachines Co. SurfaceXplorer
[Содержание]

Программа обработки, визуализации и анализа СЗМ-изображений
SurfaceXplorer
Руководство пользователя

 Содержание

  1. Введение
    1.1 Общая информация
    1.2 Функции программы
    1.3 Требования к системе
    1.4 Установка и запуск программы SurfaceXplorer
    1.5 Техническая поддержка и обновление
    1.6 Условные обозначения и сокращения, принятые в тексте
  2. Интерфейс пользователя
    2.1 Главное окно программы
    2.2 Специализированные окна визуализации данных
    2.2.1 Окно двухмерного представления
    2.2.2 Окно трехмерного представления
    2.2.3 Окно представления профиля поперечного сечения
    2.2.4 Окно представления данных анализа
    2.3 Команды меню
    2.4 Панель инструментов
    2.4.1 Панель работы с файлами
    2.4.2 Панель типов визуализации
    2.4.3 Панель инструментов выделения
    2.4.4 Панель инструментов обработки СЗМ-изображения
    2.4.5 Панель инструментов обработки АСМ NT-206
    2.5 Сектор объектов
    2.5.1 Вкладка Browse (Обзор)
    2.5.1.1 Панель [Objects] (Объекты)
    2.5.1.2 Панель [Folders] (Папки)
    2.5.1.3 Панель [Favorites] (Избранное)
    2.5.1.4 Сектор быстрого просмотра (сектор пиктограмм)
    2.5.2 Вкладка Properties (Свойства)
    2.5.2.1 Панель настройки двухмерного представления - [2D]
    2.5.2.2 Панель настройки трехмерного представления - [3D]
    2.5.2.3 Панель настройки цветовой палитры - [Palette]
    2.5.2.4 Панель настройки профиля поперечного сечения - [Profile]
    2.5.2.5 Панель настройки диаграмм анализа - [Histogram]
    2.5.3 Вкладка Data (Данные)
    2.6 Сектор управления АСМ
    2.6.1
    2.6.2
    2.6.3
  3. Работа с СЗМ-изображениями : обработка, визуализация и анализ
    3.1 Файлы данных
    3.1.1 Структура данных
    3.1.2 Открытие файлов данных
    3.1.3 Сохранение данных в файле
    3.2 Двухмерное представление СЗМ-данных
     3.2.1 Визуализация совместных полей данных
    3.2.2 Виртуальная подсветка (имитация освещения)
    3.2.3 Преобразование СЗМ-изображения в окне двухмерного представления
    3.3 Коррекция СЗМ-изображения
    3.3.1 Искажение положения поверхности при получении СЗМ-изображения
    3.3.2 Выравнивание по линиям
    3.3.3 Выравнивание по поверхности
    3.3.4 Выравнивание по выделению
    3.3.5 Особенности применения процедуры выравнивания СЗМ-изображения
    3.3.6 Сглаживание дефектов сканирования на СЗМ-изображении
    3.4 Настройка цветовой палитры
    3.5 Выделение объектов на СЗМ-изображении
    3.6 Вырезание части СЗМ-изображения
    3.7 Построение и анализ профиля поперечного сечения
    3.8 Анализ высотных и угловых характеристик СЗМ-изображения
    3.9 Трехмерное представление данных
    3.10 Арифметические операции с СЗМ-изображениями
    3.11 Макрокоманды
  4. Специализированные функции обработки и анализа СЗМ-изображений
    4.1
    4.2
    ....
  5. Измерения с помощью атомно-силового микроскопа
    5.1 Атомно-силовой микроскоп NT-206
    5.1.1 Комплектация АСМ NT-206
    5.1.2 Характеристики АСМ NT-206
    5.1.3 Блок сканирования
    5.1.4 Блок электроники управления
    5.2 Установка АСМ NT-206
    5.2.1 Размещение АСМ
    5.2.2 Подключение АСМ
    5.3 Подготовка АСМ NT-206 к работе
    5.3.1 Включение и выключение АСМ
    5.3.2 Установка зонда
    5.3.3 Настройка системы детектирования
    5.3.4 Установка образца
    5.4 Работа с АСМ NT-206
    5.4.1 Статический режим
    5.4.2 Динамический режим
    5.4.3 Режим двухпроходного сканирования
    5.4.4 Многослойное сканирование
    5.4.5 Силовая спектроскопия
    5.4.6 Микротрибометрические измерения
    5.4.7 Использование термоячейки
    5.5 Калибровка измерительной системы АСМ
    5.5.1 Калибровка пьезосканера
    5.5.2 Коррекция нелинейности пьезосканера
  6. Приложение
    Обзор основных принципов сканирующей зондовой микроскопии
    Перечень "быстрых" клавиш, используемых в программе SurfaceXplorer
    Предметный указатель

Copyright © 2005-2006, Microtestmachines Co.
All rights reserved.


SurfaceXplorer :: Introduction

[Введение]

1. Введение

1.1 Общая информация
1.2 Функции обработки, визуализации и анализа, реализованные в программе SurfaceXplorer
1.3 Требования к системе
1.4 Установка и запуск программы SurfaceXplorer
1.5 Техническая подержка и обновление
1.6 Условные обозначения и сокращения, принятые в тексте

Go to Help Index 1.1 Общая информация

Программа SurfaceXplorer предназначена для обработки, визуализации и анализа данных сканирующей зондовой микроскопии. В программу интегрирован модуль управления атомно-силовым микроскопом NT-206 (Microtestmachines Co.), что при наличии и подключении его к компьютеру позволяет проводить измерения непосредственно в среде программы и оперативно обрабатывать полученные данные. Программа оптимизирована для работы с файлами данных специального формата, в котором также сохраняются результаты измерений.

Функции представления и преобразования СЗМ-изображений в SurfaceXplorer базируются на использовании технологии OpenGL, обеспечивающей гибкий и удобный для пользователя контроль над параметрами визуализации. В SurfaceXplorer предусмотрена возможность подключения внешних автономных программных модулей (plug-ins), что позволяет реализовать высокую гибкость в использовании, модернизации и добавлении новых специализированных функций обработки и анализа СЗМ-изображений.

Настоящее руководство структурно разделяется на следующие части:

  1. Введение - данная часть с общей и вводной информацией.
  2. Интерфейс пользователя - описание графических компонентов главного окна программы, элементов и методов управления ими; команд меню; назначения и функций кнопок панели инструментов; средств настройки и управления графическим представлением данных на панели настроек; элементов специализированной панели управления атомно-силовым микроскопом, используемой для проведения измерений.
  3. Обработка, визуализация и анализ СЗМ-изображений - описание основных приемов и методов работы с СЗМ-изображениями.
  4. Специализированные функции обработки и анализа СЗМ-изображений - описание дополнительных функций для работы и анализа СЗМ-данных, программно реализованных в виде отдельных присоединяемых модулей (plug-ins).
  5. Измерения с помощью атомно-силового микроскопа - описание методов управления и работы с аппаратным обеспечением атомно-силового микроскопа NT-206 с помощью специализированной панели

Go to Help Index 1.2 Функции обработки, визуализации и анализа, реализованные в программе SurfaceXplorer

SurfaceXplorer разрабатывается командой исследователей, имеющих широкий опыт в области сканирующей зондовой микроскопии, в том числе в сфере интерпретации и анализа СЗМ-данных. Как результат, SurfaceXplorer содержит сбалансированный набор функций, важных для понимания данных, полученных с помощью сканирующего зондового микроскопа, а также реализует ряд специальных методик.

1. Функции визуализации СЗМ-изображений

  • двухмерное представление
  • трехмерное представление с возможностью непосредственной (интерактивной) трансформации СЗМ-изображения в окне визуализации
  • уникальная функция – построение совместного изображения: совмещение трехмерной топографии с данными карты свойств
  • имитация подсветки
  • настройка цветовой палитры изображения пользователем в том числе с использованием имеющихся цветовых схем
  • возможность имитации фактуры материалов (для трехмерного представления)
  • импорт/экспорт файлов данных в текстовом формате
  • импорт файлов растрового графического формата (*.bmp, *.jpg) с конвертацией их в трехмерное изображение (возможность работы с изображениями, полученными с помощью электронных микроскопов)
  • экспорт обработанных изображений в файлы растрового графического формата (*.bmp, *.jpg)
  • быстрый предварительный просмотр файлов данных и их содержания (с помощью пиктограмм)
  • создание отчета с сохранением подготовленных в программе изображений и вспомогательной информации в формате *.doc или *.htm

2. Функции обработки и преобразования СЗМ-изображений

  • выравнивание по линиям сканирования: вычитание прямой линии или параболы
  • выравнивание по поверхности: вычитание плоскости или параболоида
  • выравнивание по выделению: вычитание плоскости, задаваемой тремя установленными опорными точками, вычитание параболических линий, плоскости или параболоида внутри или по образцу выделенной прямоугольной области
  • сглаживание линии сканирования или прямоугольной области интерполяцией граничных данных
  • вырезание прямоугольного участка
  • арифметические операции с матрицами СЗМ-данных
  • произвольное и ступенчатое масштабирование СЗМ-изображения
  • нормализация
  • транспонирование (зеркальное отображение) по вертикали, по горизонтали, поворот изображения на 90°

3. Построение профилей поперечного сечения

  • по произвольной прямой линии
  • по произвольной ломаной линии
  • по линии сканирования
  • возможность совместного анализа профилей топографии и карт свойств
  • автономное выравнивание линий профиля с вычитанием прямой или параболической линии; возможность задания пользователем произвольной прямой линии для вычитания из профиля
  • транспонирование (зеркальное отображение) линии по вертикали, по горизонтали
  • анализ статистических параметров линий профиля и расчет параметров шероховатости Ra, Rq, Rsk, Rku
  • возможность расстановки текстовых меток в произвольных точках линий профиля
  • возможность импорта данных линейного типа для анализа в специализированном окне

4. Расчет статистических параметров СЗМ-изображений

  • анализ высот с построением гистограммы распределения и опорной кривой
  • анализ локальных углов наклона
  • анализ локальных ориентационных характеристик
  • определение стандартных параметров шероховатости: Ra, Rq, Rsk, Rku
  • определение номинальной (проекционной) и полной (истинной) площади поверхности.

5. Специализированные функции

  • набор функций фильтрации СЗМ-изображений: Медианный, Импульсный, Фурье 2D, Гаусса, Максимизирующий, Усредняющий линейный, Усредняющий, Минимизирующий, Медианный, Лапласа, Нормали, Резкостный, Резкостный восьмиугольный, Собела
  • сравнение СЗМ-изображений для определения автокорреляции
  • расчет и анализ модуля упругости по СЗМ-данным силовой спектроскопии (кривым подвода-отвода)
  • функция построения многослойных изображений (нанотомография)
  • расчет формы острия зонда и вычитание факторов ее влияния из СЗМ-изображения топографии
  • исключение артефактов, обусловленных неоднородностью локальной жесткости образца
  • фрактальный анализ
  • зеренный анализ
  • выделение изолиний
  • моделирование контакта участков поверхностей, задаваемых отсканированными СЗМ-изображениями, и др.

Go to Help Index 1.3 Требования к системе

SurfaceXplorer предназначен для работы на персональных компьютерах в среде Win32. Минимальные требования к компьютеру и системе:

  • Процессор: Pentium IV / iCeleron 1700 MHz
  • RAM: 128 MB
  • HDD: 80 GB
  • VRAM: 128 MB (предпочтительно NVidia)
  • Монитор: 17", 1280 by 1024 px, 32 bit color
  • OS: Microsoft Windows 98SE/2000/XP
  • USB порт*.

* Примечание. Наличие свободного USB-порта необходимо при использовании компьютера для управления атомно-силовым микроскопом NT-206 (для подключения контроллера АСМ). Рекомендуется также иметь дополнительный свободный USB-порт для подключения встроенной видеокамеры. Необходимые драйверы для работы с системами АСМ NT-206 (контроллера и видео) входят в комплект поставки данного прибора.

Go to Help Index 1.4 Установка и запуск программы SurfaceXplorer

Установка программы SurfaceXplorer осуществляется запуском инсталляционного файла sxinstall.exe. После запуска этого файла мастер установки предложит последовательно указать:

  1. папку на жестком диске, в которой будет установлена программа SurfaceXplorer,
  2. папку и ярлык в меню Start (Старт) операционной системы (опция - не создавать эту папку),
  3. дополнительные параметры - создание ярлыка (иконки) на рабочем столе (Desktop) операционной системы для быстрого запуска и ярлыка (иконки) в меню быстрого запуска (Quick Launch).

После указания необходимых параметров необходимо на панели мастера установки нажимать кнопку Next > (Далее). По окончании процедуры мастер отобразит все сделанные настройки и предложит начать установку нажатием кнопку Next > (Далее). На любом этапе до этого момента в процедуре можно вернуться назад нажатием соответствующей кнопки < Back (Назад) на панели матера установки. Отмена процедуры установки осуществляется нажатием кнопки Cancel (Отмена).

Запуск программы SurfaceXplorer осуществляется с помощью файла sx.exe, либо с помощью соответствующего ярлыка (иконки) либо на рабочем столе (Windows Desktop), либо в меню Start (Старт), либо в меню быстрого запуска (Quick Launch). После запуска программы на рабочем столе операционной системы открывается главное окно SurfaceXplorer, в котором осуществляется дальнейшая работа с данными.

Выход из программы SurfaceXplorer осуществляется с помощью пункта меню File > Exit, либо нажатием кнопки X в правом верхнем углу главного окна программы (крайняя правая кнопка в строке заголовка программы).

Удаление (деинсталяция) установленной программы SurfaceXplorer производится запуском файла unins000.exe в папке программы или с помощью системной процедуры Add or Remove Programs выбором в ней, соответственно, пункта SurfaceXplorer.

Go to Help Index 1.5 Техническая подержка и обновление

Компания-разработчик программы SurfaceXplorer - ОДО "Микротестмашины" - обеспечивает техническую поддержку зарегистрированным пользователям программы. Регистрация предоставляется при приобретении программы, в т.ч. при поставке ее в комплекте с атомно-силовым микроскопом NT-206. Установка программы SurfaceXplorer на компьютер также подразумевает, что пользователь согласен с условиями пользовательского соглашения.

Техническая поддержка осуществляется:

  • по телефону/факсу: +375 (0)232 555463
  • по электронной почте: microtm@mail.ru
  • иным образом, обеспечивающим решение вопросов пользователя по работе с программой SurfaceXplorer.

Обновление программы производится для зарегистрированных пользователей по мере разработки новых версий после официального извещения со стороны разработчика или его авторизованного представителя.

Компания-разработчик предусматривает возможность* адаптации программы для выполнения специальных задач пользователей в т.ч. путем разработки и включения в состав SurfaceXplorer специализированных модулей и функций. При наличии у пользователей готовых модулей и функций обеспечивается поддержка* по их включению в состав программы.
*Примечание. Условия реализации оговариваются отдельно.

Разработчики приветствуют комментарии, советы, предложения и замечания по работе и структуре программы SurfaceXplorer от всех ее пользователей.

Go to Help Index 1.6 Условные обозначения и сокращения, принятые в тексте

SurfaceXplorer logo | логотип программы SurfaceXplorer; быстрый переход к общему содержанию настоящего руководства
Go to Help Index | структурная часть описания; кнопка быстрого перехода к началу текущей страницы
Go to Help Index | подзаголовок структурной части; кнопка быстрого перехода к началу структурной части
 | пункт описания; кнопка быстрого перехода к началу структурной части
Operation description logo | описание приема или метода работы
Useful information logo | полезная информация, рекомендации по оптимальной работе, расширенные возможности
Go to detailed description button / Go to detailed description button | переход к подробному или расширенному описанию (на данной странице / на другой странице)
 | определение, термин
Attention logo | "ВНИМАНИЕ!" - предупреждение о критичных или важных особенностях
 | кнопка быстрого перехода к началу текущей страницы
АСМ | атомно-силовой микроскоп; атомно-силовая микроскопия
СЗМ | сканирующая зондовая микроскопия; сканирующий зондовый микроскоп
Click once with left mouse button when cursor is over the target object | один щелчок левой кнопкой мыши - выбор (активация) объекта; установка точки, сегмента ломаной, уровня островка, уровня изолинии; нажатие кнопки или переключателя на элементе графического интерфейса на который указывает курсор мыши
Click twice with left mouse button when cursor is over the target object | двойной щелчок левой кнопкой мыши - открытие объекта, активация панели настроек для элемента, на который указывает курсор мыши
Hold pressed left mouse button and drag cursor into necessary position | нажатие и удержание левой кнопки мыши - при перетаскавании объектов или их границ; установка отрезка, прямоугольной области; настройка регулятора аналогового типа, на который указывает курсор мыши
Click once with right mouse button when cursor is over the target object | один щелчок правой кнопкой мыши - вызов контекстного меню для объекта, на который указывает курсор мыши


SurfaceXplorer :: User Interface

[Интерфейс пользователя]

2. Интерфейс пользователя

Интерфейс пользователя - совокупность графических средств программы, предоставляющих пользователю информацию, данные или доступ к элементам управления и настройки как самих визуализируемых данных, так и аппаратной частью подключенного к компьютеру измерительного прибора (т.е. совокупность средств взаимодействия пользователя с компьютерной системой, графически реализованных исполняемой программой). Взаимодействие пользователя с программой SurfaceXplorer осуществляется с помощью следующих элементов:

2.1 Главное окно программы
2.2 Специализированные окна визуализации данных
2.2.1 Окно двухмерного представления
2.2.2 Окно трехмерного представления
2.2.3 Окно представления профиля поперечного сечения
2.2.4 Окно представления данных анализа
2.3 Команды меню
2.4 Панель инструментов
2.4.1 Панель работы с файлами
2.4.2 Панель типов визуализации
2.4.3 Панель инструментов выделения
2.4.4 Панель инструментов обработки СЗМ-изображения
2.4.5 Панель инструментов управления АСМ NT-206
2.5 Сектор объектов
2.5.1 Вкладка Browse (Обзор)
2.5.1.1 Панель [Objects] (Объекты)
2.5.1.2 Панель [Folders] (Папки)
2.5.1.3 Панель [Favorites] (Избранное)
2.5.1.4 Сектор быстрого просмотра (сектор пиктограмм)
2.5.2 Вкладка Properties (Свойства)
2.5.2.1 Панель настройки двухмерного представления - [2D]
2.5.2.2 Панель настройки трехмерного представления - [3D]
2.5.2.3 Панель настройки цветовой палитры - [Palette]
2.5.2.4 Панель настройки профиля поперечного сечения - [Profile]
2.5.2.5 Панель настройки диаграмм анализа - [Histogram]
2.5.3 Вкладка Data (Данные)
2.6 Сектор управления АСМ
2.6.1
2.6.2
2.6.3


SurfaceXplorer :: Main window

SurfaceXplorer
[Интерфейс пользователя] > [Главное окно]

2.1 Главное окно программы

При запуске программы SurfaceXplorer открывается главное окно (рис. 2.1.1), содержащее инструменты для работы с объектами и рабочую область - зону главного окна, в которой в специализированных окнах отображаются результаты визуализации или обработки данных.

SurfaceXplorer Desktop Window title line Menu line Toolbar Toolbar Object operations sector 2D visualization window 2D visualization window 2D visualiztion window AFM NT-206 control sector 3D visualization window 3D visualization window Window for cross-section visualisation and analysis Window of analysis data Status line: Open file and data type in active 2D window Status line: Cursor coordinates in current window Status line: Progress bar Status line: Free memory info Status line: Indicator for Z-extension of the piezotube Status line: Indicator for the probe loading level Status line: Indicator for torsion or phase angle readings
Рис. 2.1.1 - Главное окно программы SurfaceXplorer с примерами открытых специализированных окон представления данных.

Заголовок главного окна - строка в верхней части главного окна программы, содержащая слева название 'SurfaceXplorer' , а справа - кнопки управления окном - <Minimize>, <Maximize> / <Restore Down>, <Close>.

Функции заголовка стандартны для операционной системы. Кнопки управления окном используются, соответственно, для сворачивания главного окна, разворачивания окна на весь экран / восстановления размера в оконном режиме, закрытия программы. При функционировании программы в оконном режиме заголовок используется для перетаскивания главного окна по рабочему столу (Windows Desktop) с помощью мыши. В оконном режиме допускается также изменять размеры главного окна путем перетягивания мышью его границ.

Строка меню - текстовая строка непосредственно под заголовком главного окна, в которой перечислены пункты выпадающего меню программы. Меню содержит статические и динамические пункты. Статические пункты отображаются в строке меню постоянно. Динамические пункты появляются в строке меню только при активации соответствующих им специализированных окон представления данных (например, Profile или Histogram).

Сектор инструментов - область под строкой меню, в которой размещаются панели с кнопками быстрого доступа к наиболее часто используемым процедурам и функциям программы. Панели допускают их перетаскивание (перестроение), отстыковку от зоны панелей и размещение в виде плавающей панели в пределах рабочего стола (Windows Desktop), а также обратную пристыковку. Предусматривается также возможность закрытия/открытия панели и настройки ее вида изменением очередности кнопок или отключением/включением их отображения на панели.

Сектор объектов - зона у левой границы главного окна, в которой на тематических вкладках сгруппированы средства для управления объектами и настройки визуализируемых данных в специализированных окнах программы.

Сектор управления АСМ - зона у правой границы главного окна, в которой на вкладках сгруппированы виртуальные органы управления процессом настройки и измерения с помощью атомно-силового миркроскопа NT-206 [image] . Переключение отображения сектора производится нажатием кнопки [image] на панели инструментов управления АСМ

При необходимости освободить пространство рабочего окна, сектор объектов и сектор управления АСМ могут быть свернуты однократным нажатием левой кнопкой мыши по вертикальной граничной полосе, отделяющей сектор от рабочей области. Обратное развертывание сектора осуществляется нажатием на соответствующую вертикальную полосу у левой или правой кромки главного окна.

Hold pressed left mouse button and drag cursor into necessary position Помимо полного свертывания секторов допускается также произвольное изменение их ширины. Для этого:
1. Переместите курсор мыши на полосу границы между сектором объектов и рабочей областью. Курсор при этом изменит конфигурацию на [image].
2. Нажмите левую кнопку мыши и, удерживая ее нажатой, передвиньте границу в новое положение.
Например:

Picking up object sector border Shifting object sector border

Рабочая область - зона главного окна, в которой в специализированных окнах представления данных отображаются результаты визуализации или обработки данных. Рабочая область не ограничивается размерами главного окна (или рабочего стола - Windows Desktop), и при перетаскивании специализированных окон за пределы рабочей области она автоматически расширяется, а в соответствующем направлении у ее нижней и/или правой границы отображаются полосы прокрутки (скроллинга) для смещения видимой зоны.

Строка состояния (Статус-строка) - строка у нижней границы главного окна, в которой в отображается вспомогательная информация.

Наименование данных - первая слева зона строки состояния, в которой отображается информация об активном типе данных в текущем специализированном окне.

- Если текущим является окно двухмерного представления 2D, то отображается информация о названии файла и типе визуализируемых СЗМ-данных в формате: <Имя файла> - <Наименование типа данных>). Например: Cellulose6.spm - Phase.

- Если текущим является окно трехмерного представления 3D, то отображается информация о названии файла и типе СЗМ-данных, использованных для построения трехмерного каркаса, в формате: <Имя файла> - <Наименование типа данных>. Например: Cellulose6.spm - Topography .

- Если текущим является окно представления профиля поперечного сечения Profile, то отображается информация о типе СЗМ-данных, соответствующих активной линии профиля, в формате: - CS-<Наименование типа данных>. Например: - CS-Amplitude .

- Если текущим является окно представления данных анализа Histogram, то отображается информация, соответствующая родительскому окну - т.е. тому окну, анализ которого производится. Например: Cellulose6.spm - Phase (формат: <Имя файла> - <Наименование типа данных> для окна двухмерного представления) или - CS-Amplitude (формат: - CS-<Наименование типа данных> для окна профиля поперечного сечения).

Координаты курсора - вторая слева зона строки состояния, в которой отображается информация о координатах точки на двухмерном СЗМ-изображении, над которой в данный момент находится курсор мыши. Формат представления информации:
[<координата по X в матрице>;<координата по Y в матрице>] X:<Линейная координата по X>nm; Y:<Линейная координата по Y>nm; Z:<Линейная координата по Z>nm

Например: [73;85] X:300.403nm; Y:349.785nm; Z:-8.653nm

Координаты точки в матрице приводятся в точках матрицы данных, линейные координаты - в нанометрах.

Информация о координатах отображается при перемещении курсора над видимым в данный момент СЗМ-изображением независимо от того, активно или неактивно его окно двухмерного представления (т.е. координаты будут отслеживаться даже в том случае, если видна только часть СЗМ-изображения). При смещении курсора за пределы СЗМ-изображения обновление информации о координатах курсора прекращается.

При интерактивной трансформации трехмерного СЗМ-изображения вместо координат курсора в зоне отображается информация о времени, затраченном системой на перерисовку изображения после остановки курсора.

Индикатор выполнения - третья слева зона строки состояния, в которой отображается информация о выполнении процедуры. Процесс выполнения длительных процедур программы сопровождается соответствующим закрашиванием индикатора слева направо. По окончании выполнения процедуры в зоне индикатора отображается надпись Ok .

Свободная память - четвертая слева зона строки состояния, в которой отображается информация о свободной оперативной памяти компьютера. Например: Free mem: 58.136 KB.

Положение пьезосканера Z - третья справа зона строки состояния - индикатор, который в текстовом и графическом виде отображает текущее удлинение пьезосканера (положение поверхности) относительно зонда АСМ. Подробнее см. в разделе, описывающем работу с модулем управления АСМ.

Нагрузка на зонд L - вторая справа зона строки состояния - индикатор, которsй в текстовом и графическом виде отображает текущую нагрузка, прикладываемую зондом АСМ к поверхности образца. Подробнее см. в разделе, описывающем работу с модулем управления АСМ.

Боковое отклонение T / Сдвиг фазы колебаний P - первая справа зона строки состояния - индикатор, которsй в текстовом и графическом виде отображает: в статическом режиме работы АСМ - величину бокового отклонения (кручения) кантилевера, характеризующую латеральные силы при движении зонда АСМ; в динамическом режиме - величину сдвига фазы колебаний зонда АСМ при контакте с поверхностью образца. Подробнее см. в разделе, описывающем работу с модулем управления АСМ.


SurfaceXplorer :: Help content

[Интерфейс пользователя] > [Команды меню]

2.3 Команды меню

Пункт меню «Файл».

  • Открыть – открытие нового файла с данными. Дублируется кнопкой быстрого доступа на панели инструментов и горячей клавишей Ctrl+O. Открываемый файл регистрируется в выпадающем списке с названием «File» на панели инструментов. При наличии в памяти множества файлов выпадающий список помогает отыскать нужный и активировать его. При этом появляется окно 2D для топографии поверх всех окон.
  • Сохранить – запись всех полей на диск. Дублируется кнопкой быстрого доступа на панели инструментов.
  • Сохранить выборочно – выборочная запись полей на диск. Дублируется кнопкой быстрого доступа на панели инструментов и горячей клавишей Ctrl+S
  • Настройка – определение параметров программы. Здесь указываются директории нахождения подключаемых компонентов и временных файлов.
  • Проводник –просмотр имеющихся файлов сканирования и их составляющих (рис. 4). Для этого надо выбрать меню Файл/Проводник или нажать комбинацию клавиш Ctrl+Alt+O. Дублируется кнопкой быстрого доступа на панели инструментов.
    В левом окне проводника расположено дерево папок для быстрой навигации по диску. В ценральном окне осуществляется просмотр имеющихся в текущей (выбранной) папке файлов специального формата (*.spm, *.ppm), созданных программой сканирования SurfaceScan. В правом окне возможен просмотр составляющих полей файла сканирования. Для этого необходимо щелкнуть мышью на интересующем скане. В верхней части окна расположены сервисные кнопки управления, переключающие различные режимы отображения файловой систамы. Кнопка позволяет быстро перемещаться по дереву папок в корень каталога. Кнопка запукает команду перечитывания текущей директории. Кнопка запускает режим визуального представления файлов, а также указывает название и количество точек сканирования файла. Кнопка запускает режим вертикального представления файлов. Кнопка запускает режим горизонтального представления файлов. Кнопка запускает режим отображения файловой системы, представляющий информацию о размере и типе файлов текущей (выбранной) папки. В нижней части окна расположена строка состояния, указывающая путь к текущему каталогу.

Пункт меню «Вид».

  • Настройка меню – управление расположением пунктов меню и их включением/выключением для отображения в стоке меню.
  • Настройка – настройка панели инструментов.
  • 2D вид – отображение окна с двумерным изображением топографии (рис.5). Дублируется кнопкой на панели инструментов с выпадающим списком, в котором можно выбрать тип отображаемых полей.
  • 3D вид – этот пункт выводит на экран окно с трехмерным изображением исследуемой поверхности. Дублируется кнопкой на панели инструментов . Просмотр поверхности осуществляется в различных положениях. Имеется возможность вращения в двух направлениях (вокруг оси X и оси Y в экранных координатах) при помощи мыши, для чего необходимо, удерживая левую кнопку, перемещать ее. При этом передвижение мыши по горизонтали вызывает вращение поверхности вокруг вертикальной экранной оси Y, а передвижение по вертикали – вокруг горизонтальной экранной оси X. Также в данной программе имеется возможность изменять расстояние от точки наблюдения до поверхности (приближать и отдалять). Для этого следует воспользоваться правой кнопкой мыши. Удерживая клавишу Ctrl и мышь в нажатом положении, и перемещая ее по вертикали, можно приблизить поверхность для детального осмотра или отдалить.
  • Profile – данный пункт позволяет построить профиль поверхности в необходимом для вас сечении. Дублируется кнопкой панели инструментов .

Пункт меню «Функции».

  • Сравнить изображения – данная опция позволяет сопоставить любых два изображения с целью анализа их совпадения.

Пункт меню «Обработка».

  • Выравнивание – содержит шесть пунктов подменю, которые проводят линейное, параболическое, плоскостное и параболоидное выравнивание. Дублируется кнопками на панели инструментов .
  • Пункт меню «Помощь».
  • Модули – предоставление справочной информации о подключенных библиотеках, обеспечивающих выполнение специализированных функций (рис.10).


SurfaceXplorer :: Toolbar

SurfaceXplorer
[Интерфейс пользователя] > [Панель инструментов]

2.4 Панель инструментов

Панель инструментов (рис. 2.4.1) содержит кнопки быстрого доступа к наиболее часто используемым процедурам и функциям программы. Процедуры и функции, выполняемые при нажатии кнопок на панели, идентичны выполняемым по соответствующим командам меню.

File panel Selection panel View panel
Process panel Process panel

Рис. 2.4.1 - Панель инструментов программы SurfaceXplorer.

Все кнопки быстрого доступа согласно их функциям сгруппированы на следующих автономных панелях:

File panel
Панель работы с файлами.

View panel
Панель типов визуализации.

Selection panel
Панель инструментов выделения.

Process panel
Панель инструментов обработки СЗМ-изображения.

Process panel
Панель инструментов управления АСМ NT-206.

В программе SurfaceXplorer предусмотрено размещения автономных панелей инструментов либо присоединенными (пристыкованными) в секторе инструментов непосредственно под строкой меню в главном окне программы (рис. 2.4.1), либо как плавающих панелей в любом месте рабочего окна (Windows Desktop). Отсоединение панели инструментов от сектора или перемещение в его пределах осуществляется перетаскиванием с помощью мыши за указатель Toolbar ancor у левого края панели. Присоединение (пристыковка) плавающей панели инструментов к сектору инструментов также производится перетаскиванием ее с помощью мыши за заголовок в этот сектор.

Context menu of toolbar

Контекстное меню, вызываемое щелчком правой кнопки мыши в области панели, содержит команду Customize... для настройки данной панели инструментов, а также перечень всех имеющихся в программе панелей инструментов:
- панель работы с файлами - ToolBarFile;
- панель типов визуализации - ToolBarView;
- панель инструментов выделения - ToolBarView2D;
- панель инструментов обработки СЗМ-изображения - ToolBarProcess;
- панель управления АСМ NT-206 - ToolBarAFM.

Имя панели инструментов действует также как переключатель включения или отключения ее отображения. В случае, если панель активирована (т.е. отображается на экране), перед именем панели устанавливается отметка [image].

Настройка панели инструментов производится в специализированном окне Customize toolbar (Настройка панели инструментов) (рис.2.4.2). Активизация окна настройки осуществляется индивидуально для каждой автономной панели с помощью команд подменю View > Customize toolbar > или с помощью команды Customize... в контекстном меню, вызываемом щелчком правой кнопки мыши в области данной панели инструментов.

Рис. 2.4.2 - Пример окна настройки панели инструментов обработки СЗМ-изображений.

В окне настройки перечисляются все доступные для отображения на данной панели инструментов команды, функции и процедуры. Команды в списке перечисляются сверху вниз в соответствии с очередностью их размещения на панели инструментов слева направо. Для отображения команды на панели инструментов необходимо активировать соответствующий переключаетль перед графическим символом (иконкой) команды (т.е. установить отметку [image]). Изменение порядка следования команд на панели инструментов и другие сервисные процедуры настройки производятся с помощью кнопок у правой границы окна настройки:

Move command up - Перемещение текущей команды вверх на одну позицию;

Move command down - Перемещение текущей команды вниз на одну позицию;

Set separator line before current command - Установка разделительной линии (сепаратора) перед текущей командой;

Delete current command - Удаление текущей команды (команда восстанавливается при следующем запуске программы SurfaceXporer).

Delete all unused commands - Удаление всех неиспользуемых команд;

Show information about the toolbar element - Вывод технической информации о текущей команде. Информация отображается в окне Toolbar element info... (рис. 2.4.3) и содержит следующие данные:
- наименование команды (функции, процедуры) (внутреннее имя) - Name ;
- наименование подключаемого модуля - Module name ;
- имя файла подключаемого модуля - Module filename ;
- описание - Description ;
- соответствующий команде графический символ (иконка) - Icon.

Рис. 2.4.3 - Пример окна технической информации о текущей команде.


SurfaceXplorer :: File Operations Toolbar

[Панель инструментов] > [Файл]

2.4.1 Панель работы с файлами

Панель работы с файлами (рис. 2.4.1.1) обеспечивает быстрый доступ к процедурам открытия и сохранения файлов, а также команде копирования изображения в текущем окне в системный буфер.

Toolbar File Button for bringing up dialog window for file opening Button for bringing up dialog window to save file on disk Copy bitmap image of current visualization window content to system clipboard Selector of report preparation commands
Рис. 2.4.1.1 - Панель работы с файлами.

Кнопки на панели работы с файлами имеют следующие функции:
Open file button | Открытие файла. Вызывает системный диалог открытия файла. Предусмотрено открытие файлов специального формата, а также импорт файлов данных других форматов (в т.ч. растровых и текстовых). Аналог - команда меню File > Open или сочетание"горячих" клавиш <Ctrl+O>.
Save file button | Сохранение текущего СЗМ-изображения в файле. Вызывает системный диалог сохранения файла. Предусмотрено сохранение данных в файлах специального формата, а также экспорт данных в файлы других форматов (в т.ч. растровых и текстовых). Аналог - команда меню File > Save.
Copy image into clipboard button | Копирование изображения в текущем специализированном окне представления данных в системный буфер обмена. Изображение заносится в буфер в растровом формате (*.bmp), стандартном для ОС Windows. Аналог - команда меню File > Copy to clipboard или сочетание"горячих" клавиш <Ctrl+C>.
Submenu of report control commands | Селектор команд подготовки отчета. Содержит следующие команды: New report (Новый отчет) Add to report (Добавить к отчету) Save report (Сохранить отчет) View report (Просмотр отчета)

Кроме указанных кнопок, отображаемых на панели работы с файлами по умолчанию, при настройке панели доступны также следующие кнокпи быстрого доступа:

 | Выборочное сохранение полей данных текущего СЗМ-изображения в файле специального формата. Вызывает системный диалог сохранения файла для задания его имени, а затем панель выбора полей данных. Аналог - команда меню File > Save.
 | Управление полями данных текущего файла данных. Аналог - команда меню File > Data Set management.
Button Image simulation | Вызов процедуры генерации СЗМ-изображения с помощью периодических поверхностей, преиодических геометрических фигур и шумового фона. Аналог - команда меню File > Image simulation.
 | Команда New report (Новый отчет) - создание нового файла отчета.
 | Команда Add to report (Добавить к отчету) - добавления текущего окна к файлу отчета.
 | Команда Save report (Сохранить отчет) - сохранения текущего файла отчета.
 | Команда View report (Просмотр отчета) - отобразить файл отчета в окне соответствующего приложения (MS Word или нтернет-браузер)


SurfaceXplorer :: View Toolbar

SurfaceXplorer
[Панель инструментов] > [Визуализация]

2.4.2 Панель типов визуализации

Панель типов визуализации (рис. 2.4.2.1) обеспечивает быстрый доступ к процедурам открытия и сохранения файлов, а также команде копирования изображения в текущем окне в системный буфер.

Toolbar Selection Selector of data fields for visualization in 2D window Zoom ratio selector Construction of 3D image from current 2D SPM image Building cross section profile based on the selected line View analysis data for SPM image from current 2D window
Рис. 2.4.2.1 - Панель типов визуализации.

Кнопки на панели типов визуализации имеют следующие функции:
View 2D | Отображение СЗМ-данных в окне двухмерного представления. Селектор для отображения в окне двухмерного представления совместных полей данных, содержащихся в файле СЗМ-данных. Аналог - команда вызова подменю View > View 2D >.
Selector of 2D window zoom factor | Селектор масштаба (размера) СЗМ-изображения в окне двухмерного представления. В выпадающем списке предусмотрено масштабирование СЗМ-изображения до 25%, 50%, 75%, 100%, 150%, 200%, 400%, 800% от исходного размера. В поле ввода допускается ввод произвольного значения масштаба.
View 3D | Построение в специализированном окне трехмерного СЗМ-изображения для данных, отображаемых в текущем окне двухмерного представления. Аналог - команда меню View > View 3D.
Create profile line | Построение в специализированном окне профиля поперечного сечения для линии, выделенной в текущем окне двухмерного представления. Аналог - команда меню View > Profile.
Show analysis data | Вызов специализированного окна представления данных анализа для текущего СЗМ-изображения. Аналог - команда меню View > Histogram.


SurfaceXplorer :: Selection Toolbar

SurfaceXplorer
[Панель инструментов] > [Выделение]

2.4.3 Панель инструментов выделения

Панель инструментов выделения (рис. 2.4.3.1) предоставляет средства для задания на двухмерном СЗМ-изображении объекта, который в дальнейшем будет использован для последующих операций.

Toolbar Selection Switch off selection tools Select Point Select Line Select Polyline Select Rectangular Area Select Scan Line Select Island Select Isoline
Рис. 2.4.3.1 - Панель инструментов выделения

Объектом выделения могут выступать:

  1. Отдельная точка (точка измерений в СЗМ-матрице).
  2. Произвольный отрезок прямой.
  3. Произвольная ломаная линия.
  4. Прямоугольная область.
  5. Прямая линия, параллельная оси X или Y СЗМ-матрицы (линия быстрого или медленного сканирования).
  6. Единичная область, ограничиваемая указываемым уровнем по высоте ("островок").
  7. Набор всех областей, соответствующих указываемому уровню по высоте ("изолиния").
Функция выделения объекта активируется при выборе соответствующего инструмента на панели нажатием одной из кнопок:
Point selection tool | Инструмент выделения точки на СЗМ-изображении.
Line selection tool | Инструмент выделения произвольного отрезка прямой на СЗМ-изображении.
Polyline selection tool | Инструмент выделения произвольной ломаной линии на СЗМ-изображении.
Area selection tool | Инструмент выделения прямоугольной области на СЗМ-изображении.
Scan line selection tool / Scan line selection | Инструмент выделения линии сканирования вдоль направления X / Y на СЗМ-изображении (переключение осуществляется повторным нажатием).
Select inside Island / Select around Island | Инструмент выделения единичного островка на СЗМ-изображении с заполнением пространства ниже/выше изолинии (переключение осуществляется повторным нажатием).
Select Isoline / Select Isoline | Инструмент выделения уровня на СЗМ-изображении с заполнением пространства ниже/выше изолинии (переключение осуществляется повторным нажатием).
Deactivate selection tools | Отключение функции выделения - используется для отключения отображения выделенного объекта на СЗМ-изображении.

ВНИМАНИЕ! Активация функций выделения не продублирована командами меню и доступна только с панели инструментов выделения.

Инструменты выделения включаются для текущего окна двухмерного представления независимо друг от друга. Тип отображаемого в данный момент в окне выделенного объекта определяется типом активизированного инструмента. Если функция выделения в текущем окне отключена, то выделенные ранее объекты отображаться не будут.

Практически на одном СЗМ-изображении можно выделить одновременно любые типы объектов, но отображен будет только тот (а соответственно, и работать только с тем), тип которого в данный момент активирован на панели инструментов. Отключение функции выделения при этом не уничтожает сами объекты выделения, а только "прячет" их (выключает их визуализацию).


SurfaceXplorer :: Process Toolbar

SurfaceXplorer
[Панель инструментов] > [Выделение]

2.4.4 Панель инструментов обработки СЗМ-изображения

Панель инструментов обработки СЗМ-изображения (рис. 2.4.4.1) обеспечивает быстрый доступ к процедурам и вспомогательным функциям обработки СЗМ-изображений.

Toolbar Selection Button 'Duplicate current 2D image' Button 'Arithmetic operations with SPM image' Button 'Normalize current SPM image' Button 'Macros operations' Button of flatten the selecetd line or area in the SPM image Button of flatten selecetd area in lines parallel to X axis Button of flatten selecetd area in lines parallel to Y axis Button for rotation of the SPM image 90 degree clockwise Button for horizontal flip of the SPM image Button for vertical flip of the SPM image Button 'Crop selected rectangular area' Leveling general paraboloid surface Leveling general inclination plane Leveling parabola lines on Y axis Leveling parabola lines on X axis Leveling lines on Y axis Leveling lines on X axis Undo button
Рис. 2.4.4.1 - Панель инструментов обработки СЗМ-изображения

Кнопки на панели инструментов обработки имеют следующие функции:
Undo button | Отмена последнего действия обработки СЗМ-изображения ("откат"). Аналогично команде меню Process > Undo или сочетанию "горячих" клавиш <Ctrl - Z>.
Leveling lines on X | Выравнивание текущего СЗМ-изображения по линиям сканирования вдоль направления X с вычитанием аппроксимирующей прямой. Аналогично команде меню Process > Leveling > Line on X direction.
Leveling lines on Y | Выравнивание текущего СЗМ-изображения по линиям сканирования вдоль направления Y с вычитанием аппроксимирующей прямой. Аналогично команде меню Process > Leveling > Line on Y direction.
Leveling parabola lines on X | Выравнивание текущего СЗМ-изображения по линиям сканирования вдоль направления X с вычитанием аппроксимирующей параболы. Аналогично команде меню Process > Leveling > Parabola on X direction.
Leveling parabola lines on Y | Выравнивание текущего СЗМ-изображения по линиям сканирования вдоль направления Y с вычитанием аппроксимирующей параболы. Аналогично команде меню Process > Leveling > Parabola on Y direction.
Leveling general inclination plane | Выравнивание текущего СЗМ-изображения по всей поверхности с вычитанием аппроксимирующей плоскости. При наличии на текущем СЗМ-изображении активных трех выделенных точек производится вычитание аппроксимирующей плоскости, определяемой этими установленными точками. При наличии на текущем СЗМ-изображении активного выделенного прямоугольного участка производится вычитание аппроксимирующей плоскости, определяемой этим установленным участком. Аналогично команде меню Process > Leveling > Plane.
Leveling general paraboloid | Выравнивание текущего СЗМ-изображения по всей поверхности с вычитанием аппроксимирующего параболоида. При наличии на текущем СЗМ-изображении активного выделенного прямоугольного участка производится вычитание аппроксимирующего параболоида, определяемого этим установленным участком. Аналогично команде меню Process > Leveling > Paraboloid.
Crop rectangular area off the SPM image | Вырезание из текущего СЗМ-изображения выделенного прямоугольного участка и формирование из него нового СЗМ-изображения. В дереве на вкладке Objects (Объекты) новое изображение выделяется как отдельный объект. Подробнее см. в §3.5 . Аналогично команде меню Process > Crop.
Duplication of current 2D window | Дублирование текущего окна двухмерного представления в его текущем состоянии. Создается автономное новое окно с копией СЗМ-изображения, над которым можно производить операции независимо от родительского окна. В перечне на вкладке Objects (Объекты) новое изображение выделяется как отдельный объект. Аналогично команде меню Process > Duplicate или сочетанию "горячих" клавиш <Ctrl - D>.
Arithmetic procedures with SPM matrices | Арифметические операции с СЗМ-изображением - сложение, вычитание, умножение, деление и пр. исходной СЗМ-матрицы либо с другой СЗМ-матрицей, либо с числом, либо с задаваемой поверхностью (до второго порядка). Предусматривается возможность задания пользователем сценария преобразований в виде произвольного выражения. Подробнее см. в §3.9 [image] . Аналогично команде меню Process > Arithmetic.
Normalize button | Нормализация - смещение точки начала отсчета шкалы высот на один уровень с нижней точкой рельефа на СЗМ-изображения. Аналогично команде меню Process > Normalize.
Button for Operations with macros | Операции с макрокомандами - создание, исполнение записанных. В качестве команд используются имена процедур обработки СЗМ-изображений. Подробнее см. в §3.10 [image] . Аналогично команде вызова подменю Process > Macros >.
Flip image vertically | Транспонирование (зеркальное отображение) текущего СЗМ-изображения по вертикали (относительно горизонтальной оси). Аналогично команде меню Process > Flip vertically.
Flip image horizontally | Транспонирование (зеркальное отображение) текущего СЗМ-изображения по горизонтали (относительно вертикальной оси). Аналогично команде меню Process > Flip horizontally.
Rotate SPM image 90 degree clockwise | Поворот текущего СЗМ-изображения на 90 градусов по ходу часовой стрелки. Аналогично команде меню Process > Rotate 90 right.
Flatten selected scan line/area | Коррекция выделенной линии сканирования или прямоугольной области интерполяцией граничных данных. Аналогично команде меню Process > Flatten > Selection.
Flatten selected area on lines parallel to X axis | Коррекция выделенной прямоугольной области интерполяцией граничных данных на линиях, параллельных оси X. Аналогично команде меню Process > Flatten > Area on X direction.
Flatten selected area on lines parallel to Y axis | Коррекция выделенной прямоугольной области интерполяцией граничных данных на линиях, параллельных оси Y. Аналогично команде меню Process > Flatten > Area on Y direction.


SurfaceXplorer :: Hot keys

["Быстрые" клавиши]

SurfaceXplorer :: "Быстрые" клавиши

Общие клавиши программы (меню)

Клавиатура:

<Ctrl + C> - Копирование изображения в текущем окне или выделенного текста в системный буфер обмена

<Ctrl + D> - Дублирование текущего окна двухмерного представления в его текущем состоянии

<Ctrl + O> - Вызов системного диалога открытия файла

<Ctrl + S> - Вызов системного диалога сохранения данных в файле

<Ctrl + Z> - Отмена последнего действия обработки ("откат")

<Alt> + <F4> - Завершение работыпрограммы (выход)

<F1> - Вызов помощи (данного руководства)

В окне 3D

Мышь

<Left mouse button> - При удержании кнопки и перемещении мыши - поворот СЗМ-изображения

Клавиатура + мышь

<Ctrl> + <Left mouse button> - При удержании кнопки и перемещении мыши - увеличение/уменьшение СЗМ-изображения в окне

<Alt> + <Left mouse button> - При удержании кнопки и перемещении мыши - Перемещение точки обзора СЗМ-изображения

<Shift> + <Left mouse button> - При удержании кнопки и перемещении мыши - Управление положением источника света

В окне профиля

Клавиатура:

<Left arrow> - Передвижение левого маркера [a] влево

<Right arrow> - Передвижение левого маркера [a] вправо

<Up arrow> - Передвижение правого маркера [b] вправо

<Down arrow> - Передвижение правого маркера [b] влево

<Ctrl> + <Up arrow> - Переключение между линиями профиля (выбор активной линии)

<Ctrl> + <Down arrow> - Переключение между линиями профиля (выбор активной линии)

<Space bar> - Установка метки на активной линии в текущем положении текущего маркера

Клавиатура + мышь

<Shift> + <Left mouse button> - Установить / удалить метку на активной линии в текущей горизонтальной позиции курсора

Ctrl + Left top - Right bottom dragging - Приближение выделенного участка графика с его масштабированием до размеров области построения (Zoom-in) /при отключенном автомасштабировании/

Ctrl + Right bottom - Left top dragging - Возврат отображения всего графика с его масштабированием до размеров области построения (Zoom-out) /при отключенном автомасштабировании/

Alt + Mouse dragging - Перемещение графика области построения (перетаскивание) /при отключенном автомасштабировании/


SurfaceXplorer :: Program Preferences

SurfaceXplorer
[Интерфейс пользователя] > [Команды меню] > [Настройки программы]

2.3.* Панель общих настроек программы

Панель общих настроек программы
2.3.*.1 Настройки графического интефейса
2.3.*.2 Настройки секции быстрого просмотра
2.3.*.3 Настройки отображения цветовой палитры
2.3.*.4 Настройки окна профиля
2.3.*.5 Настройки процедуры подготовки отчета
2.3.*.6 Настройки типов файлов

Панель общих настроек программы

2.3.*.1 Настройки графического интефейса

2.3.*.2 Настройки секции быстрого просмотра

Размер пиктограмм

Маска файлов для предварительного просмотра

Использование базы данных для пиктограмм

Данная опция - Use database for thumbnails (Использовать БД для пиктограмм) - позволяет при включении значительно ускорять процесс отображение пиктограмм в секторе быстрого просмотра.

Специальный файл - база данных - представляет собой стандартный файл формата MPS с именем sxthumb.db, в котором хранятся сокращенные (в зависимости от настроек размера пиктограмм) варианты расположенных в выбранной папке файлов данных. При обращении программы к папке на жестком диске содержимое имеющейся в ней базы данных сравнивается с реальными файлами данных, и при обнаружении расхождений база данных обновляется.

2.3.*.3 Настройки отображения цветовой палитры

2.3.*.4 Настройки окна профиля

2.3.*.5 Настройки процедуры подготовки отчета

2.3.*.6 Настройки типов файлов


SurfaceXplorer :: Visualization Windows

SurfaceXplorer
[Интерфейс пользователя] > [Окна визуализации]

2.2 Специализированные окна визуализации данных

2.2.1 Окно двухмерного представления
Заголовок окна
СЗМ-изображение
Информация о параметрах СЗМ-изображения
Цветовая шкала высот
Ось X
Ось Y
Изменение размера окна двухмерного представления
Контекстное меню окна двухмерного представления
2.2.2 Окно трехмерного представления
Заголовок окна
СЗМ-изображение
Краткая информация
Цветовая шкала высот
Интерактивная трансформация
Контекстное меню окна трехмерной визуализации
2.2.3 Окно представления профиля поперечного сечения
Заголовок окна
Область построения (график)
Нижняя (горизонтальная) ось
Левая ось
Правая ось
Кнопки управления марекром
Кнопки выбора активной линии
Кнопки зеркального отображения активной линии
Условные обозначения (легенда)
Информационное поле
Контекстное меню
2.2.4 Окно представления данных анализа
Заголовок окна
Диаграмма распределения высот
Гистограмма распределения локальных углов наклона
Ориентационная диаграмма
Информационное поле
Контекстное меню

Специализированные окна визуализации данных располагаются в рабочей области главного окна программы SurfaceXplorer. Они предназначены для отображения в графической форме как исходных данных, так и результатов их обработки или анализа. Данные в зависимости от их специфики и задач могут отображаться в следующих окнах:

  • 2D - Окно двухмерного представления
  • 3D - Окно трехмерного представления
  • Profile - Окно представления профиля поперечного сечения
  • Histogram - Окно представления данных анализа

2.2.1 Окно двухмерного представления

Окно двухмерного представления используется для отображения данных в виде карты высот или свойств в соотвтествии с цветовой шкалой. Общий вид окна двухмерного представления и его элементы представлены на рис. 2.2.1.1. При работе с СЗМ-данными окно двухмерного представления является основным для отображения как самих данных, так и результатов их обработки, а также проведения процедур выделения объектов.

File name Data field name Last operation over the image Window control buttons SurfaceXplore icon SPM data matrix size (resolution of the image in points) SPM image in 2D representation Color scale Y axis scale X axis scale 2D window in angular representation (sunlight simulation)
Рис. 2.2.1.1 - Окно двухмерного представления СЗМ данных (нажмите на соответствующий элемент для перехода к его описанию).

Настройка параметров отображения графической информации в окне двухмерного представления осуществляется на панели [2D] вкладки Properties (Свойства).

Заголовок окна формируется следующим образом:
[имя файла с СЗМ-данными] : [имя типа (поля) данных] < [наименование последней операции, произведенной над СЗМ-изображением в данном окне] >

Содержание окна:

  • СЗМ-изображение в двухмерном представлении - в центральной части окна. При наличии в файле совместных полей данных по умолчанию визуализируется СЗМ-изображение топографии. Выбор другого типа СЗМ-данных для визуализации производится либо с помощью селектора полей данных [image] на панели инструментов, либо с помощью контекстного меню. Настройка изображения производится на панели 2D вкладки Properties (Свойства), а также с помощью панели настройки цветовой палитры Palette.
  • Информация о параметрах СЗМ-изображения - текстовая строка непосредственно над СЗМ-изображением с числовыми данными о следующих величинах (cлева направо):
    - Линейный размер СЗМ-изображения по оси X
    - Линейный размер СЗМ-изображения по оси Y
    - Полная высота СЗМ-изображения (линейный размер по оси Z)
    - [Размер матрицы данных XxY]
    Числовые параметры разделяются знаком "x". Единицы измерения, приводимые за числовыми значениями, соответствуют: um = микрометры, nm = нанометры. Размер матрицы данных (параметр в квадратных скобках) приводится в точках.
  • Цветовая шкала высот - справа от СЗМ-изображения. Вверху над шкалой указывается наименование вертикальной оси Z и единицы измерения по ней (например, um = микрометры, nm = нанометры, o - градусы и др.). Справа от цветовой линейки размещена вертикальная шкала с делениями и метками в единицах, указанных над шкалой.
    Двойной щелчок левой кнопкой мыши по области цветовой шкалы высот вызывает (активизирует) панель настройки цветовой палитры для текущего СЗМ-изображения
  • Ось X - шкала внизу под СЗМ-изображением с делениями и метками в физических единицах длины, наименование оси и единицы измерения по ней (um = микрометры, nm = нанометры). При включенной опции Left-top axis (Изменить положение начала координат) ось X отображается сверху над СЗМ-изображением.
  • Ось Y - шкала слева от СЗМ-изображения с делениями и метками в физических единицах длины, наименование оси и единицы измерения по ней (um = микрометры, nm = нанометры). При включенной опции Left-top axis (Изменить положение начала координат) отсчет по шкале начинается сверху.

Двойной щелчок левой кнопкой мыши по области окна (кроме области цветовой шкалы высот и заголовка) вызывает (активизирует) панель настройки двухмерного представления [2D] (аналогично команде Properties контекстного меню).

Изменение размера окна двухмерного представления
Исходный размер СЗМ-изображения в окне двухмерного представления определяется размером матрицы данных: кажая точка СЗМ-матрицы представляется на экране одним пикселом. Таким образом, СЗМ-изображение с матрицей 256*256 точек данных на экране будет представлено избражением размером 256*256 пикселов. При необходимости, размер области визуализации СЗМ-изображения (а соответственно, и размер самого СЗМ-изображения) может быть изменен.

Ступенчатое пропорциональное изменение размера области визуализации производится:

  • с помощью команд контекстного меню, вызываемого однократным щелчком правой кнопкой мыши в поле окна. Предусмотрено масштабирование СЗМ-изображения до 25%, 50%, 75%, 100%, 150%, 200%, 400%, 800% от исходного размера;
  • с помощью команд пункта меню View > Zoom >, предусматривающих масштабирование СЗМ-изображения до 25%, 50%, 75%, 100%, 150%, 200%, 400%, 800% от исходного размера;
  • с помощью селектора масштаба на панели инструментов (панель типов визуализации). В выпадающем списке предусмотрено масштабирование СЗМ-изображения до 25%, 50%, 75%, 100%, 150%, 200%, 400%, 800% от исходного размера.

Произвольное пропорциональное изменение размера области визуализации производится:

  • с помощью селектора масштаба на панели инструментов (панель типов визуализации) вводом произвольного масштаба представления текущего СЗМ-изображения.
    Ввод нового значения предусматривает установку курсора в числовом поле селектора (щелчок левой кнопкой мыши в поле ввода), набор нового значения масштаба вручную на клавиатуре компьютера, завершение процедуры - нажатие клавиши Enter на клавиатуре компьютера    ;
  • перетаскиванием угловой зоны окна двухмерного представления (рис. 2.2.1.2 слева).
    Перетаскивание осуществляется установкой курсора мыши над угловой зоной окна (при этом конфигурация курсора изменяется на наклонную стрелку, как на рис. 2.2.1.2 слева), нажатием и удержанием в нажатом положении левой кнопки мыши, перемещением курсора мыши в новое положение и, в завершение, отпусканием левой кнопки мыши.
Рис. 2.2.1.2 - Произвольное изменение размеров окна двухмерного представления: слева - пропорциональное с помощью перетаскивания угловой зоны границы окна; справа - непропорциональное (в одном направлении) перетаскиванием границы окна (здесь - в вертикальном направлении).

Произвольное непропорциональное изменение размера окна двухмерного представления (и, соответственно, самого СЗМ-изображения в нем) производится перетаскиванием границ окна при нажатой левой кнопке мыши (рис. 2.2.1.2 справа). При этом перетаскивание вертикальной или горизонтальной границы окна вызывает непропорциональное изменение одного размера, соотвественно, по горизонтали или вертикали.

Увеличение СЗМ-изображения до размера рабочей области программы производится с помощью кнопки [image] (Maximize) в заголовке окна.

Вернуть исходный размер СЗМ-изображению можно
- с помощью команды 100% в подменю масштабирования Zoom > контекстного меню окна;
- выбрав масштаб 100% в селекторе масштаба на панели типов визуализации.

Context menu of 2D visualization window

Контекстное меню окна двухмерной визуализации предоставляет быстрый доступ к наиболее частоиспользуемым для двухмерного изображения функциям, командам и процедурам:

- Properties (Свойства) - команда вызова панели настройки двухмерного представления [2D];
- Refresh (Обновить) - команда обновления (перерисовки) изображения в окне двухмерного представления;
- Zoom > - подменю предустановленных масштабов СЗМ-изображения в окне двухмерного представления. Предусмотрены варианты масштабирования до 25%, 50%, 75%, 100%, 150%, 200%, 400%, 800% от исходного размера окна;
- Leveling > (Выравнивание) - вызов подменю процедур автоматического выравнивания СЗМ-изображения;
- Change palette (Изменить палитру) - команда вызова панели настройки цветовой шкалы. Аналогична двойному щелчку левой кнопкой мыши по области цветовой шкалы высот в окне;
- Show 2D for... > (Показать 2D для...) - вызов подменю для визуализации совместных полей данных в новом окне двухмерного представления;
- View 3D (Просмотр в 3D) - построение трехмерного изображения на основе данных из текущего окна двухмерного представления.
- Duplicate (Дупликация) - команда создания дубликата текущего окна двухмерного представления;
- Macros > (Макрокоманды) - вызов подменю работы с макрокомандами: редактирвование Edit и запуск макрокоманд из ранее определенного набора;
- Compare images (Сравнить изображения) - исполнение функции сравнения СЗМ-изображений;
- Create profile (Построить профиль) - команда автоматического выделения отрезка на текущем СЗМ-изображении и построения по нему профиля поперечного сечения в вызываемом окне визуализации профиля. Выделяемый отрезок автоматически размещается параллельно оси X посредине оси Y. После выполнения команды допускается произвольное интерактивное изменение положения выделенного отрезка;
- Histogram (Гистограмма) - команда вызова окна визуализации данных анализа;
- Crop (Вырезать) - команда вырезания выделенного прямоугольного участка СЗМ-изображения необходимо предварительно выделить прямоугольный участок);
- Arithmetic (Арифметика) - вызов функции проведения арифметических опреаций с СЗМ-изображением;
- Normalize (Нормализовать) - команда [image] нормализации текущего СЗМ-изображения: точка начала отсчета шкалы высот устанавливается на один уровень с нижней точкой рельефа на СЗМ-изображения;
- Save protocol (Сохранить протокол) - команда записи последовательности произведенных над текущим СЗМ-изображением процедур в файл без изменения исходной матрицы данных. При последующей загрузке этого файла последовательность может быть воспроизведена для автоматического повторения записанных операций и восстановления последнего состояния СЗМ-изображения. Аналогична команде меню File > Save protocol;
- Filters > (Фильтры) - подменю специальных фильтров для обработки текущего СЗМ-изображения. Аналогично пункту меню Functions > Filters> . При наличии в текущем окне выделенной прямоугольной области действует на этот выделенный участок изображения.

Помимо перечисленных выше пунктов контекстного меню при выделении на СЗМ-изображении прямоугольной области в список доступных команд добавляется команда Adjust palette by selection - настройка цветовой палитры всего изображения по образцу диапазона высот выделенного участка.

2.2.2 Окно трехмерного представления

Окно трехмерного представления СЗМ-изображения (рис. 2.2.2.1) строится по данным, отображаемым в текущем окне двухмерного представления и является по отношению к последнему вспомогательным. Тем не менее, трехмерная визуализация, обеспечиваемая в нем, является наиболее естественной для восприятия. СЗМ-изображение в окне трехмерного представления может быть интерактивно трансформировано для наилучшего обзора деталей или соотношения элементов рельефа. Кроме того трехмерное изображение может одновременно совмещать данные двух типов (двух СЗМ-матриц), что значительно повышает информативность этой функции визуализации и предоставляет, например, возможность непосредственного визуального анализа распределения свойств материала по поверхности.

Window for 3D representation of the SPM data 3D window title 3D SPM image Brief info about the SPM image topography (image size) Brief info about the SPM image topography (rough parameters) Color scale of the skin palette
Рис. 2.2.2.1 - Окно трехмерного представления СЗМ-изображения.

Окно трехмерного представления отображается в рабочей области окна программы для текущего СЗМ-изображения (активного окна двухмерного представления):
- при выборе команды меню View > View 3D;
- при выборе команды в контекстном меню окна двухмерного представления View 3D;
- при нажатии кнопки [image] на панели инструментов программы.

Настройка параметров отображения графической и текстовой информации в окне трехмерного представления осуществляется на панели [3D] вкладки Properties (Свойства).

Произвольное изменение размера окна трехмерного представления осуществляется принятыми в операционной системе Windows способами. При этом изменение вертикального размера окна (в любом случае) вызывает пропорциональное масштабирование самого СЗМ-изображения. Изменение горизонтального размера окна не влияет на масштаб СЗМ-изображения.

Заголовок окна формируется следующим образом:
[имя файла с СЗМ-данными] : [имя типа (поля) данных, образующих трехмерный каркас]

В окне представлены:

  • СЗМ-изображение в трехмерном представлении - в центральной части окна. Вместе с трехмерным СЗМ-изображением могут отображаться координатные оси. Настройка параметров визуализации СЗМ-изображения производится на панели [3D] вкладки Properties. Трансформация СЗМ-изображения интерактивно может быть также произведена с помощью мыши при нажатой левой кнопке в комбинации с другими клавишами на клавиатуре компьютера [image] .
  • Краткая информация - в верхнем левом углу окна - представляет основные геометрические и статистические характеристики СЗМ-изображения. Включение и отключение опции отображения краткой информации осуществляется в развернутом варианте панели [3D] вкладки Properties (Свойства).
    - В верхней строке указываются размеры СЗМ-изображения - диапазоны по осям X, Y и Z (X:## Y:## Z:##), а также текущий масштаб представления высот (данных по оси Z) по отношению к наиболее длинной (в физических единицах) из сторон СЗМ-изображения ([#.#:1]). За единицу в масштабе принимается самая длинная сторона.
    - В нижней строке приводятся среднее арифметическое отклонение профиля Ra и среднее квадратическое отклонение профиля Rq для участка поверхности, отображаемого на данном СЗМ-изображении.
  • Цветовая шкала высот - в правом верхнем углу окна - представляет информацию о распределении цветов по вертикальной оси для оболочки, определяющей палитру трехмерного каркаса. Вверху над шкалой указывается наименование вертикальной оси Z и единицы измерения по ней (например, um = микрометры, nm = нанометры, o - градусы и др.). Слева от цветовой линейки размещена вертикальная шкала с делениями и метками в единицах, указанных над шкалой. Включение и отключение опции отображения цветовой шкалы высот осуществляется в развернутом варианте панели [3D] вкладки Properties (Свойства).

Комбинации кнопок для управления трехмерным СЗМ-изображением в окне 3D

Left mouse button - Поворот СЗМ-изображения

Клавиатура + мышь

Ctrl + Left mouse button - Увеличение/уменьшение СЗМ-изображения в окне

Alt + Left mouse button - Перемещение точки обзора СЗМ-изображения

Shift + Left mouse button - Управление положением источника света

Интерактивная трансформация трехмерного изображения в окне производится с помощью мыши при нажатой левой кнопке. В комбинации с нажатием и удержанием кнопок Ctrl, Alt или Shift на клавиатуре компьютера предусматриваются следующие четыре функции управления трехмерным СЗМ-изображением.

  • Left mouse button - При нажатии левой кнопки мыши перемещение курсора мыши в поле окна трехмерного представления вызывает поворот СЗМ-изображения вокруг своего центра в окне. Данная функция активирована по умолчанию, на что указывает конфигурация курсора [image] при нахождении в поле окна. Данная функция дублируется в секции управления положением камеры на панели [3D] вкладки Properties (Свойства).
  • Ctrl + Left mouse button - при нажатии левой кнопки мыши при удержании клавиши Ctrl на клавиатуре компьютера перемещение курсора мыши вверх или вниз в поле окна трехмерного представления вызывает, соответственно, уменьшение или увеличение СЗМ-изображения. На активацию функции (т.е. при удержании нажатой клавиши Ctrl на клавиатуре компьютера) указывает конфигурация курсора [image] при нахождении в поле окна. Данная функция дублируется регулятором Distance в секции управления положением камеры на панели [3D] вкладки Properties (Свойства).
  • Alt + Left mouse button - при нажатии левой кнопки мыши при удержании клавиши Alt на клавиатуре компьютера перемещение курсора мыши в поле окна трехмерного представления вызывает перемещение точки обзора СЗМ-изображения. Например, при перемещении курсора вправо СЗМ-изображение будет перемещаться влево, и т.д. На активацию функции (т.е. при удержании нажатой клавиши Alt на клавиатуре компьютера) указывает конфигурация курсора [image] при нахождении в поле окна. Данная функция не дублируется.
  • Shift + Left mouse button - при нажатии левой кнопки мыши при удержании клавиши Shift на клавиатуре компьютера перемещение курсора мыши в поле окна трехмерного представления изменяет положение виртуального источника света для СЗМ-изображения. На активацию функции (т.е. при удержании нажатой клавиши Shift на клавиатуре компьютера) указывает конфигурация курсора [image] при нахождении в поле окна. Данная функция дублируется в секции управления положением источника света Light на панели [3D] вкладки Properties (Свойства). Пример изображения в окне трехмерного представления при интерактивном изменении положения источника света показан на рис. 2.2.2.2.
Moving the light source with mouse
Рис. 2.2.2.2 - Пример изображения в окне трехмерного представления при интерактивном изменении положения источника света.

Context menu of 3D window Command for bringing up 3D settings panel Command for detalized rendering of current 3D image Command for saving current 3D image in a bitmap file Submenu for visualizing joint SPM data in new 2D window Macros submenu Comand for saving processing protocol in the SPM image file Контекстное меню окна трехмерной визуализации предоставляет быстрый доступ к наиболее часто используемым для трехмерного изображения функциям, командам и процедурам:

- 3D View properties (Свойства трехмерной визуализации) - команда вызова панели настройки трехмерного представления [3D];
- Render (Детализировать изображение) - команда перерисовки текущего изображения с повышенной детализацией. Детализация сохраняется до следующего преобразования трехмерного изображения. Данную процедуру рекомендуется выполнять непосредственно перед сохранением графического изображения после его окончательной настройки;
- Edit skin palette (Редактировать палитру оболочки) - команда вызова панели настройки цветовой шкалы для текущей оболочки трехмерного каркаса. По умолчанию в качестве оболочки используются тот же тип данных, что и для построения трехмерного каркаса, т.е. данные СЗМ-матрицы для топографи;
- Save to bitmap file (Сохранить растровое изображение) - команда вызова диалога сохранения трехмерного изображения в его текущем состоянии в файле растрового формата (*.bmp) на жестком диске;
- Show 2D for... > (Показать 2D для...) - вызов подменю для визуализации совместных полей данных в новом окне двухмерного представления;
- Macros > (Макрокоманды) - вызов подменю работы с макрокомандами: редактирвование Edit и запуск макрокоманд из ранее определенного набора.
- Save protocol (Сохранить протокол) - команда записи последовательности произведенных над текущим СЗМ-изображением процедур в файл без изменения исходной матрицы данных. При последующей загрузке этого файла последовательность может быть воспроизведена для автоматического повторения записанных операций и восстановления последнего состояния СЗМ-изображения. Аналогична команде меню File > Save protocol.

2.2.3 Окно представления профиля поперечного сечения

Окно профиля предназначено для отображения в графической форме линейных данных (одномерных массивов данных), полученных при построении профиля поперечного сечения СЗМ-изображения или из других источников, а также обработки и анализа этих данных. На рис. 2.2.3.1 представлено окно, в котором визуализированы линии профиля поперечного сечения для изображений топографии и фазового сдвига одного и того же файла СЗМ-данных.

Window of profile line visualization Title of the profile visualization window Left axis of the profile plot Right axis of profile plot Legend of the plotted lines Bottom axis (absciss) Title of bottom axis Label on profile line Label on profile line Label on profile line A line showing border point between segments of the polyline Label on profile line Arera for displaying information about marker state Buttons for control over right marker position Buttons for control over left marker position Acitve line info and selector Left vertical marker Right vertical marker Button to flip horizonally current profile line Button to flip vertically current profile line Fit line between markers
Рис. 2.2.3.1 - Окно визуализации линии профиля.

Настройка параметров отображения графической и текстовой информации в окне профиля поперечного сечения осуществляется в панели [Profile] вкладки Properties. Активации панели производится двойным щелчком левой кнопки мыши в свободном месте окна профиля или выбором пункта Properties в контекстном меню окна.

Произвольное изменение размера окна профиля осуществляется принятыми в операционной системе Windows способами.

Заголовок окна формируется следующим образом:
[имя файла с СЗМ-данными] : [имя типа (поля) данных] - [наименование Profile]

В верхней части окна размещено поле графика, в нижней части (под горизонтальной линией) - информационное поле, отображающее данные о текущих параметрах маркеров на графике.

"Быстрые" клавиши

Клавиатура:

[Left arrow] - Передвижение левого маркера [a] влево

[Right arrow] - Передвижение левого маркера [a] вправо

[Up arrow] - Передвижение правого маркера [b] вправо

[Down arrow] - Передвижение правого маркера [b] влево

[Ctrl] + [Up arrow] - Переключение между линиями профиля (выбор активной линии)

[Ctrl] + [Down arrow] - Переключение между линиями профиля (выбор активной линии)

[Space bar] - Установка метки на активной линии в текущем положении текущего маркера

Клавиатура + мышь

Shift + Left mouse button - Установить / удалить метку на активной линии в текущей горизонтальной позиции курсора

Ctrl + Left top - Right bottom dragging - Приближение выделенного участка графика с его масштабированием до размеров области построения (Zoom-in) /при отключенном автомасштабировании/

Ctrl + Right bottom - Left top dragging - Возврат отображения всего графика с его масштабированием до размеров области построения (Zoom-out) /при отключенном автомасштабировании/

Alt + Mouse dragging - Перемещение графика области построения (перетаскивание) /при отключенном автомасштабировании/

Поле графика содержит следующие элементы.

Область построения (график) - прямоугольная область в центре окна, в которой графически отображаются линии профиля (линейные данные). На графике отображаются как линии данных, так и вспомогательные графические элементы:

  • Линия профиля - линейные данные (например, профиль поперечного сечения) в графическом представлении. Предусмотрено отображение одной и более линий. Настройка параметров отображения каждой линии осуществляется с помощью панели [Profile] на вкладке Properties в секторе работы с объектами.
    Предусматривается возожность интерактивного масштабирования и перемещения линий профиля (графика) в области построения при отключении опции автомасштабирования у всех осей.
  • Средняя линия - прямая линия, автоматически рассчитываемая аппроксимацией всех точек соответствующего профиля по методу наименьших квадратов для определения общего наклона профиля. Отображается для каждой линии профиля при включенной опции Show middle line на панели [Profile].
    Если для данной линии профиля отключены другие опции в секции Line на панели [Profile] (Normalize, Eliminate tilt, 1st order derrivative), то при этом допускается произвольное перемещение отдельно левой и правой частей средней линии. Для этого необходимо установить курсор над отображаемой средней линией соотвтетственно в левой или правой ее половине (конфигурация курсора изменяется при этом на [image]) и переместить ее в новое положение при нажатой левой кнопке мыши. Функция автоматического устранения наклона после этого будет ориентированться именно на прямую линию, установленную вручную. При необходимости вернуть программно рассчитанное положение средней линии воспользуйтесь командой Calculate middle line либо в контекстном меню, вызываемом щелчком правой кнопкой мыши в окне профиля, либо в интерактивном пункте меню Profile программы. На рис. 2.2.3.1 средняя линия для профиля топографии (красная линия, CS-Topography) отображается без изменения ее программно рассчитанного положения и автоматического устранения наклона. Для средней линии профиля фазового сдвига (синяя линия, CS-Phase) активирована опция автоматического усранения наклона Eliminate tilt.
  • Аппроксимирующая линия - прямая линия между вертикальными маркерами, автоматически рассчитываемая аппроксимацией по методу наименьших квадратов всех точек соответствующего участка профиля, ограниченного маркерами. Отображение аппроксимирующей линии включается в опции Fit line between markers на панели [Profile].
    При размещении вертикальных маркеров в исходных положениях (на границах области построения) аппроксимирующая линия совпадает с автоматически рассчитываемой средней линией для данного профиля.
  • Вертикальные маркеры - левый [a] и правый [b] - произвольно перемещаемые вертикальные линии, позволяющие измерять расстояние между точками их пересечения с линиями профиля. По умолчанию маркеры установлены соответственно на левой и правой осях графика. Точки на линиях профиля, в которых они пересекаются с вертикальными маркерами, графически отмечаются закрашенными окружностями - [image]. При этом точки, соответствующие активному маркеру (т. е. тому вертикальному маркеру, который перемещался последним) закрашиваются в синий цвет - [image].
    Перемещение маркера осуществляется:
    а) позиционированием над ним крусора (курсор при этом изменяет конфигурацию на [image]) и перетаскиванием в новое положение при нажатой левой кнопке мыши. Координаты текущего положения курсора в поле графика можно при этом отследить по показаниям в статус-строке;
    б) [image] с помощью кнопок Marker [a] control buttons и Marker [b] control buttons соответственно под левой и правой вертикальными осями графика [image] ;
    в) с помощью кнопок на клавиатуре компьютера:
    - [Left arrow] - передвижение левого маркера [a] влево;
    - [Right arrow] - передвижение левого маркера [a] вправо;
    - [Down arrow] - передвижение правого маркера [b] влево;
    - [Up arrow] - передвижение правого маркера [b] вправо;
    Положение перемещаемых вертикальных маркеров на графике профилей параллельно отмечается на линии выделения в окне двухмерного представления СЗМ-изображения двумя зелеными треугольными метками [image] (рис. 2.2.3.2).
Рис. 2.2.3.2 - Метки на линии выделения в окне двухмерного представления СЗМ-изображения для обозначения текущего положения подвижных вертикальных маркеров на графике профилей.
  • Текстовые метки точек данных - прямоугольные текстовые рамки (желтого цвета) с выносными линиями, прикрепленных к точкам данных. Предоставляют информацию об абсолютных величинах точек данных на линии профиля. В верхней строке отображается абсолютная координата точки по горизонтальной оси графика (оси абсцисс), во второй строке - абсолютная координата этой точки по вертикальной оси графика (оси ординат).
    Текстовая метка точки данных устанавливается на активной в данный момент линии профиля (при наличии более одной линии на графике). Линия профиля активируется с помощью селектора на панели [Profile] вкладки Properties либо непосредственно в окне профиля - щелчком по интересующей линии левой кнопкой мыши или с помощью кнопок выбора активной линии [image] под горизонтальной осью графика. Текущее положение курсора по горизонтальной оси графика (вертикаль, соответствующая координате x или номеру точки данных #) можно отследить по показаниям в статус-строке программы: . Одновременно там же отображается значение по вертикальной оси для текущей точки данных на активной линии.
    Shift +
    Add label
    Установка текстовой метки точки данных производится одним из следующих способов:
    а) Позиционировать курсор на одной вертикали с интересующей точкой на линии профиля и, удерживая нажатой клавишу Shift клавиатуры компьютера, щелкнуть левой кнопкой мыши;
    б) Переместить вертикальный маркер в интересующую точку на линии профиля и установить метку с помощью:
    - команды Add label либо в контекстном меню, вызываемом щелчком правой кнопкой мыши в окне профиля, либо в интерактивном пункте меню Profile программы;
    - кнопки [image] в группе кнопок управления маркером (отдельно для левого [a] и правого [b] марекров) [image] .
    Перемещение установленной текстовой метки точки данных производится перетаскиванием ее мышью. Для этого необходимо позиционировать курсор над интересующей меткой и при нажатой левой кнопке мыши передвинуть ее в новое место. Конфигурация курсора при этом изменяется на [image]. Допускается перемещение метки точки данных в любое место в окне профиля. При этом точка закрепления выносной линии остается неизменной - т.е. метка закреплена за одной и той же точкой данных при любых процедурах в окне профиля.
    Тем не менее необходимо помнить, что любое изменение в положении линии выделения на СЗМ-изображении в родительском окне двухмерного представления автоматически удаляет все метки точек данных в окне профиля и устанавливает оба маркера в исходное полпожение на левой и правой осях графика.
    List of labels in tab Data Список всех установленных меток с указанием координат соответствующих им точек данных приводится на вкладке Data в секторе работы с объектами (см. рисунок справа).
    Shift + [image] = Delete label
    Удаление метки точки данных производится позиционированием курсора над этой меткой и щелчком левой кнопкой мыши по ней при нажатой клавише Shift на клавиатуре компьютера. Конфигурация курсора, указывающая на возможность удаления метки точки данных, изменяется на "X". Удалить все метки одновременно можно воспользовавшись командой Clear all labels либо в контекстном меню, вызываемом щелчком правой кнопкой мыши в окне профиля, либо в интерактивном пункте меню Profile программы.
  • Линия разграничения сегментов ломаной - вертикалльная сине-желтая пунктирная линия, соответствующая узловой точке произвольной ломаной линии, выделенной на СЗМ-изображении в родительском окне двухмерного представления. Автоматически устанавливается на графике при построении профиля поперечного сечения по ломаной.
  • Линии сетки - пунктирные линии на графике, проведенные перпендикулярно оси в точках основных меток значений. Отображение линий сетки независимо для левой, правой и нижней осей графика активируется в панели [Profile] вкладки Properties

Нижняя (горизонтальная) ось - ось абсцисс графика. Начало (левая граница) оси соответствует первой узловой точке на выделенной линии. Точки данных размещаются по оси через промежутки, определяемые расстоянием между соответствующими точками данных в СЗМ-матрице. Название оси (Length) и единицы измерения (um = мкм, nm = нм) указаны под осью (ниже числовых отметок) посредине. При автоматическом масштабировании оси отображаемые линии профиля размещаются во всем горизонтальном диапазоне. При установке минимального и максимального значений по горизонтальной оси вручную отображаемые линии профиля будут размещены начиная с точки 0 на оси и далее в диапазоне, который они охватывают.

Левая ось - ось вертикальных значений точек данных. По умолчанию все строящиеся линии профиля относятся к левой оси. Название отображаемого по оси типа данных и единицы измерения указаны слева от оси посредине. При автоматическом масштабировании оси отображаемые линии профиля растягиваются во всем вертикальном диапазоне, определяемом диапазоном численных значений точек данных. При установке минимального и максимального значений по левой оси вручную отображаемые линии профиля будут размещены соответственно диапазону высот, который они охватывают.

Правая ось - ось вертикальных значений точек данных. По умолчанию правая ось не отображается, и появляется при отнесении к ней какой-либо линии профиля. Название отображаемого по оси типа данных и единицы измерения указаны справа от оси посредине. При автоматическом масштабировании оси отображаемые линии профиля растягиваются во всем вертикальном диапазоне, определяемом диапазоном численных значений точек данных. При установке минимального и максимального значений по левой оси вручную отображаемые линии профиля будут размещены соответственно диапазону высот, который они охватывают.

При отключении опции автомасштабирования у всех осей пользователю предоставляется возможность интерактивного масштабирования и перемещения графика в области построения.

Кнопки управления марекром Marker [a] control buttons и Marker [b] control buttons - две симметричные группы кнопок для перемещения соответственно левого [a] и правого [b] маркеров в поле графика, а также установке на текущей линии текстовой метки для точки данных. Функции кнопок управления следующие:
- Move left marker to left axis - перемещение левого маркера в исходное положение (на левой оси);
- Move right marker to right axis - перемещение правого маркера в исходное положение (на правой оси);
- [image] - перемещение маркера влево на один шаг к следующей точке данных на линии профиля;
- [image] - перемещение маркера вправо на один шаг к следующей точке данных на линии профиля;
- [image] - установка текстовой метки в текущей точке данных на активной линии профиля. Кнопка в левой группе (под левой осью) используется для установки метки в полизции левого маркера [a], кнопка в правой группе (под правой осью) используется для установки метки в полизции правого маркера [b].

Кнопки выбора активной линии [image] - циклически переключают активную линию профиля на графике. Название и цвет текущей активной линии отображаются справа от кнопок. Альтернативные способы переключения активной линии профиля - щелчок левой кнопкой мыши непосредственно по линии профиля на графике или с помощью селектора активной линии на панели [Profile] вкладки Properties.

Кнопки зеркального отображения активной линии - [image] [image] - кнопки для зеркального отображения активной линии профиля на графике:
- [image] - отображение по горизонтали;
- [image] - отображение по вертикали.
После каждого выполнения отображения кнопка изменяет свой цвет на инвертированный: и [image] соответственно. При смене активной линии состояние кнопок обновляется (актуализируется) в соответствии с выполненными для них процедурами зеркального отображения. Таким образом, состояние кнопки (исходное или инвертированное) указывает на проведенную над активной линией профиля процедуру заеркального отображения. Повторное нажатие на кнопку в инвертированном состоянии возвращает исходное положение активной линии в соответствующем направлении (горизонтальном или вертикальном) и исходный цвет кнопки.

Условные обозначения (легенда) - текстовая рамка в правом верхнем углу поля графика с подписями к линиям данных. Образцы цветов отображаемых на графике линий подписываются в соответствии с названиями полей данных, профили которых они представляют. Рамка легенды отображается в окне при включенной опции Show legend (Показывать легенду) на панели [Profile] вкладки Properties.

Информационное поле - текстовая зона в нижней части окна профиля, где приводится информация о точках данных, отмечаемых на линиях профиля вертикальными маркерами (рис. 2.2.3.3).

Example of information field in the profile window
Рис. 2.2.3.3 - Пример отображения данных в информационном поле окна профиля.

Отображение в информационном поле строк данных активируется на вкладке Cross section панели настроек Preferences программы (команда меню File > Preferences).

В верхней строке поля указываются абсолютные значения (Absolute values:) для точек данных на графике профиля. Данные сгруппированы по принадлежности к маркерам [a] и [b]. После указания имени маркера следует его текущая координата по горизонталной оси (x), а затем - значения для точек данных по вертикальной оси (z). Цифровые индексы в скобках после названия оси z указывают принадлежность координаты к линии профиля с соответствующим номером (номер определяется при задании новой линии в селекторе активной линии). Практически, в данной строке приводится та же информация для точек на линиях профиля, что и на текстовых маркерах, установленных в них, например, с помощью кнопок [image] под осями графика.

В средней строке Difference between markers приводятся данные для разницы между точками, отмечаемыми маркерами. Значение dx соответствует разнице между маркерами по горизонтальной оси. Значения dz(#) указывают разницу по вертикальной оси z между точками данных, отмечаемых маркерами на линиях профиля. Цифровые индексы в скобках после названия параметра dz указывают принадлежность значения к линии профиля с соответствующим номером (номер определяется при задании новой линии в селекторе активной линии). Например, запись dz(1)=17.6 nm означает, что разность между высотами точек, отмечаемых маркерами на линии профиля с номером 1 составляет 17.6 нм.

В нижней строке Difference between first two lines указываются значения разницы межды высотами точек данных, отмечаемых одним маркером, но располагающихся на двух первых линиях профиля. Таким образом можно анализировать две линии однородных данных (например, линии профиля СЗМ-изображения топографии, полученные при прямом и обратном движениях зонда). При отображении линиями №1 и №2 графика разнородных данных (например, топографии и фазового сдвига) показания в данной строке представляют ненормированные данные. Величины x[a] и x[b] характеризуют горизонтальные координаты маркеров [a] и [b] соответственно. Значения dz[a] и dz[b] указывают на разницу по вертикальной оси между двумя точками данных, отмечаемых, соответственно, маркерами [a] (левым) и [b] (правым).

Context menu of the profile window Command for bringing up panel [Profile] Command for automatic calculation of middle line for current profile Command for calculating coefficients of the software correction equations Command for inserting label on current profile line in current position of active vertical marker Command for deleting all installed labels on the plot Submenu of macros operations Command for bringing up height analysis window for active profile line Comand for saving processing protocol in the SPM image file

Контекстное меню, вызываемое в окне профиля щелчком правой кнопкой мыши, содержит следующие команды.

- Properties (Свойства) - команда вызова панели настройки параметров профиля поперечного сечения [Profile]. Аналогична команде динамического пункта меню Profile > Properties. Альтерантивный способ активации панели - двойной щелчок левой кнопкой мыши в свободном месте окна профиля;
- Calculate middle line (Рассчитать среднюю линию) - команда автоматического определния средней линии текущего профиля по методу наименьших квадратов. Используется для восстановления программно рассчитываемого положения средней линии, измененного пользователем. Аналогична команде инерактивного пункта меню Profile > Calculate middle line;
- Calculate correction (Рассчитать коррекцию) - команда расчета коэффициентов для программной коррекции движения сканера сканирующего зондового микроскопа [image]. Предварительно на профиле известной периодической структуры необходимо установить не менее четырех меток в однотипных характерных точках. Аналогична команде инерактивного пункта меню Profile > Calculate correction;
- Add label (Добавить текстовую метку) - команда установки текстовой метки в текущей точке на активной линии профиля. Действует для текущего маркера - т.е. того маркера, который перемещался последним. Аналогична команде инерактивного пункта меню Profile > Add label;
- Clear all labels (Удалить все текстовые метки) - команда удаления всех установленных текстовых меток в окне профиля. Аналогична команде инерактивного пункта меню Profile > Clear all labels;
- Macros> (Макрокоманды) - вызов подменю работы с макрокомандами: редактирвование Edit и запуск макрокоманд из ранее определенного набора;
- Histogram (Гистограмма) - команда открытия окна данных анализа (в сокращенном виде) для текущей линии профиля;
- Save protocol (Сохранить протокол) - команда записи последовательности произведенных над текущим СЗМ-изображением процедур в файл без изменения исходной матрицы данных. При последующей загрузке этого файла последовательность может быть воспроизведена для автоматического повторения записанных операций и восстановления последнего состояния СЗМ-изображения. Аналогична команде меню File > Save protocol.

2.2.4 Окно представления данных анализа

Окно представления данных анализа Histogram предназначено для отображения в графической форме статистических характеристик текущего СЗМ-изображения (рис. 2.2.4.1).

Окно представления данных анализа отображается в рабочей области окна программы для текущего СЗМ-изображения (активного окна двухмерного представления):
- при выборе команды меню View > Histogram;
- при выборе команды в контекстном меню окна двухмерного представления Histogram;
- при нажатии кнопки Button for bringing up Histogram window на панели инструментов программы.

Title of Histogram window Height distribution diagram Diagram for tilt angles distribution Orientation angle distribution over the horizontal plane Text information field of the Histogram window
Рис. 2.2.4.1 - Окно представления данных анализа Histogram

Окно представления данных анализа имеет фиксированный размер, т.е. изменение его размера не предусматривается.

Заголовок окна отображает:
[Наименование поля данных, для которых производится анализ] - [название окна Histogram]

В верхней части окна размещено графическое поле, в нижней части (под горизонтальной линией) - информационное поле, отображающее статистические и текущие данные в текстовой форме.

В графическом поле представлены следующие диаграммы:

Диаграмма распределения высот (в левой части графического поля) - сочетает гистограмму распределения высот Heigh distribution, % на СЗМ-изображении и опорную кривую Bearing ratio, % для всей его площади. Вертикальные оси диаграммы соответствуют диапазону высот на СЗМ-изображении. При этом левая ось Height проградуирована в физических единицах (например, нм), а правая Relative height - в относительных единицах от 0 для нижней точки до 1 для верхней. На нижней оси нанесена шкала гистограммы распределения высот Heigh distribution, %. Диапазон шкалы определяется максимальным значением частоты встречаемости. Верхняя ось Bearing ratio, % относится к опорной кривой, и ее диапазон составляет 100% (0 - отсутствие материала в поперечном сечении, 100% - сечение полностью пересекает материала образца).

На диаграмме распределения высот размещается горизонтальный маркер, позволяющий точно определить значения частоты встречаемости и опорной кривой на данной высоте. Маркер перемещается мышью при нажатой левой кнопке мыши (т.е. перетаскиванием). Предусмотрена также установка маркера на определенной высоте вводом вручную необходимого числового значения в поле ввода ###Marker position панели настройки [Histogram] на вкладке Properties. Текущее значение высоты (в физичесих и относительных единицах), а также соответствующие данной высоте частота встречаемости и значение по опорной кривой приводятся в верхней сторке информационного поля.

Гистограмма распределения локальных углов наклона (в средней части графического поля) - представляет гистограмму для частоты встречаемости углов между нормалями к элементарным площадкам СЗМ-изображения и вертикальной осью - угол a на рис. 2.2.4.2. Элементарная площадка - участок СЗМ-изображения, определяемый тремя ближайшими точками СЗМ-матрицы (т.е. минимальный треугольник).

Рис. 2.2.4.2 - Схема определения: угол a - угол наклона между нормалью к элементарной площадке и вертикальной осью; угол b - угол ориентации проекции нормали к элементарной площадке на горизонтальной плоскости СЗМ-изображения

Ориентационная диаграмма (в правой части графического поля) - отображает распределение на горизонтальной плоскости углов ориентации проекций нормалей к элементарным площадкам СЗМ-изображения (угол b на рис. 2.2.4.2).

Информационное поле окна представления данных анализа отображает в текстовой форме следующие параметры рельефа на СЗМ-изображении.

В верхней строке - параметры для диаграммы распределения высот:
- Height - текущее положение горизонтального маркера на вертикальной шкале высот СЗМ-изображения в физических единицах (фактически - на левой вертикальной оси диаграммы);
- Relative height - текущее положение горизонтального маркера на вертикальной шкале высот СЗМ-изображения в относительных единицах (фактически - на правой вертикальной оси диаграммы);
- Height distribution - текущее значение по гистограмме распределения высот, определяемое положением горизонтального маркера;
- Bearing ratio - текущее значение по опорной кривой, определяемое положением горизонтального маркера.

В средней строке - параметры для гистограммы распределения углов наклона и ориентационной диаграммы:
- Tilt: middle - среднеарифметический угол наклона нормалей к элементарным площадкам;
- Tilt: most frequent - наиболее часто встречаемый угол наклона нормалей к элементарным площадкам;
- Orientation: most frequent - наиболее часто встречаемый угол ориентации проекций нормалей к элементарным площадкам на горизонтальной плоскости.

В нижней строке - параметры шероховатости для участка поверхности, отображаемого анализируемым СЗМ-изображением:

- Hmean - средняя высота СЗМ-изображения (практически - положение среднеарифметической горизонтальной плоскости для всей поверхности на текущей вертикальной шкале высот СЗМ-изображения)
;

- Ra - среднеарифметическая шероховатость
;

- Rq - среднеквадратичное отклонение
;

- Rsk - асимметрия распределения высот (skewness)
;

- Rku - эксцесс распределения высот (kurtosis)
.

В приведенных формулах Nx – количество столбцов СЗМ-матрицы; Ny – количество строк СЗМ-матрицы.

Вариант окна представления данных анализа, отображаемый для линий профиля поперечного сечения (рис. 2.2.4.3), содержит диаграмму распределения высот и гистограмму распределения углов наклона элементарных участков кривой (отрезков между двумя соседними точками данных). В отличие от диаграмм для всей поверхности, эти представляют анализ для линейных данных, однако параметры определяются аналогичны.

Рис. 2.2.4.3 - Вариант окна представления данных анализа, отображаемый для линий профиля поперечного сечения

Настройка параметров отображения графической и текстовой информации на диаграммах окна представления данных анализа производится в панели [Histogram] вкладки Properties.

Command for bringing up panel Histogram Save height range above marker vertical position Save heiht range below marker vertical position Submenu for visualizing joint SPM data in new 2D window Submenu of macros operations Comand for saving processing protocol in the SPM image file

Контекстное меню окна представления данных анализа предоставляет доступ к следующим командам и процедурам:

- Properties (Свойства) - команда вызова панели настройки параметров диаграмм в окне данных анализа [Histogram]. Аналогична команде динамического пункта меню Histogram > Properties. Альтерантивный способ активации панели - двойной щелчок левой кнопкой мыши в окне данных анализа;
- Save tops (Сохранить вершины) - команда сохранения диапазона высот СЗМ-изображения выше текущего положения горизонтального маркера на диаграмме распределения высот (см. пример на рис. 2.2.4.4 слева). Данная команда имитирует равномерное заполнение впадин на СЗМ-изображении ниже уровня маркера;
- Save valleys (Сохранить впадины) - команда сохранения диапазона высот СЗМ-изображения ниже текущего положения горизонтального маркера на диаграмме распределения высот (см. пример на рис. 2.2.4.4 справа). Данная команда имитирует равномерное срезание вершин на СЗМ-изображении выше уровня маркера.

Рис. 2.2.4.4 - Результат сохранения вершин (диапазона выше горизонтального маркера) (слева) и впадин (диапазона ниже горизонтального маркера) (справа) по командам, соответственно, Save tops и Save valleys.

- Show 2D for... > (Показать 2D для...) - вызов подменю для визуализации совместных полей данных в новом окне двухмерного представления;
- Macros > (Макрокоманды) - вызов подменю работы с макрокомандами: редактирвование Edit и запуск макрокоманд из ранее определенного набора.
- Save protocol (Сохранить протокол) - команда записи последовательности произведенных над текущим СЗМ-изображением процедур в файл без изменения исходной матрицы данных. При последующей загрузке этого файла последовательность может быть воспроизведена для автоматического повторения записанных операций и восстановления последнего состояния СЗМ-изображения. Аналогична команде меню File > Save protocol.

Copyright © 2005-2006, Microtestmachines Co.
All rights reserved.

Show panel for adjusting 2D properties Refresh image Zoom presets Duplicate current 2D window Macros operationcommands Compare SPM images function Create default cross-section on midline of the image View SPM image analysis data Submenu of SPM image leveling procedures Bring up the panel for adjusting color scale parameters Crop selected rectangular area Bring up arithmetic function dialog panel Normalize current SPM image (move zero plane to one level with the lowest point of the SPM image) Command for adjusting palette of all image according to color distribution scale for selected area Submenu to select a joint data field for visualization in a new 2D window Build a 3D image of current data in a new specialized 3D window Command for recording current processing sequence of the image in the SPM file Submenu of filters for processing current SPM image


SurfaceXplorer :: Object sector

SurfaceXplorer
[Интерфейс пользователя] > [Сектор объектов]

2.5 Сектор объектов

Сектор объектов размещается у левой границы главного окна программы SurfaceXplorer (справа от рабочей области) (рис. 2.5.1).

Tab Browse Tab Properties Tab Data Head of panel [Objects] Head of panel [Folders] Head of panel [Favorites] Object tree in panel [Objects] Border area for panel resize Sector for thumbnails preview Object sector border
Рис. 2.5.1 - Сектор объектов. По умолчанию активна вкладка Browse (Обзор).

В секторе расположены:
средства управления рабочими объектами и быстрого просмотра;
средства интерактивной настройки параметров отображения данных в специализированных окнах программы;
статистическая и служебная информация для текущего окна визуализации данных, параметры объектов выделения в текущем окне двухмерного представления, а также протокол операций над текущим СЗМ-изображением.

Все перечисленные функции сгруппированы соответственно на следующих вкладках:

Browse | Properties | Data
(Обзор) | (Свойства) | (Данные)

Переключение между вкладками производится выбором соотвествующего ярлыка в верхней части сектора. Панели вкладки Properties (Свойства) также автоматически активируются при двойном щелчке левой кнопкой мыши по соответствующим им элементам в специализированных окнах программы. При запуске программы в секторе объектов по умолчанию отображается панель [Objects] (Объекты) вкладки Browse (Обзор) (рис. 2.5.1).

Свертывание/развертывание сектора объектов. При необходимости освободить пространство рабочего окна, сектор объектов может быть свернут однократным нажатием левой кнопкой мыши по правой вертикальной границе, отделяющей сектор от рабочей области. Обратное развертывание сектора осуществляется нажатием на ту же полосу вертикальной границы у левой кромки главного окна.

Hold pressed left mouse button and drag cursor into necessary position Изменение ширины сектора объектов. Помимо полного свертывания сектора объектов допускается также произвольное изменение его размера (ширины). Для этого:
1. Переместите курсор мыши на полосу границы между сектором объектов и рабочей областью. Курсор при этом изменит конфигурацию на [image].
2. Нажмите левую кнопку мыши и, удерживая ее нажатой, передвиньте границу в новое положение.
Например:

Picking up object sector border Shifting object sector border

Аналогично изменяется вертикальный размер верхней и нижней частей вкладки Browse (Обзор).


SurfaceXplorer :: Tab Browse

SurfaceXplorer
[Интерфейс пользователя] > [Сектор объектов] > [Вкладка Обзор]

2.5.1 Вкладка Browse (Обзор)

Вкладка Browse (Обзор)
2.5.1.1 Панель [Objects] (Объекты)
2.5.1.2 Панель [Folders] (Папки)
2.5.1.3 Панель [Favorites] (Избранное)
2.5.1.4 Секция быстрого просмотра (секция пиктограмм)
Блок просмотра содержания файла

Вкладка Browse (Обзор) (рис. 2.5.1.1) отображает структуру файлов данных и наборов измеренных данных, открытых в текущем сеансе работы программы SurfaceXplorer, а также обеспечивает доступ к имеющимся на жестком диске СЗМ-данным и предоставляет средства для обеспечения быстрого доступа к ним.

Tab Browse Tab Properties Tab Data Head of panel [Objects] Head of panel [Folders] Head of panel [Favorites] Object tree in panel [Objects] Border area for panel resize Sector for thumbnails preview Object sector border Object sector border Button for hiding the object sector
Рис. 2.5.1.1 - Вкладка Browse (Обзор). Панель [Objects] (Объекты) активна по умолчанию (перечень объектов показан в свернутом виде).

Вкладка разделена на верхнюю и нижнюю части. В верхней части размещаются следующие панели:

[Objects] (Объекты) - панель для отображения открытых объектов (файлов и измеренных даных);
[Folders] (Папки) - панель для отображения структуры папок (директорий) на жестком диске;
[Favorites] (Избранное) - панель ссылок на наиболее часто используемые папки с СЗМ-данными, обеспечивающая быстрый доступ к ним.

Переключение между панелями производится щелчком левой кнопкой мыши по ярлыку с соответствующим названием панели.

В нижней части вкладки Browse (Обзор) размещается секция быстрого просмотра (пиктограмм) [image] . В этой секции в виде пиктограмм отображается содержание файлов с СЗМ-данными, перечисленных на панели [Objects] (Объекты) либо содержащихся в активной (выбранной) папке на панелях [Folders] (Папки) и [Favorites] (Избранное). Содержание секции обновляется в зависимости от активной в данный момент панели в верхней части вкладки.

Hold pressed left mouse button and drag cursor into necessary position

Размер верхней и нижней частей вкладки по вертикали регулируется. Для этого:
1. Переместите курсор мыши на разделительную полосу между верхней (панель) и нижней (сектор пиктограмм) частями. Цвет разделительной полосы изменится на желтый, а курсор при этом изменит конфигурацию на [image].
2. Нажмите левую кнопку мыши (цвет разделительной полосы при этом изменится на синий) и, удерживая ее нажатой, передвиньте рамку в новое положение. Например:

См. также: изменение ширины сектора объектов.

2.5.1.1 Панель [Objects] (Объекты)

Панель [Objects] (Объекты) (рис. 2.5.1.1.1 ) служит для отображения в структурированном виде открытых в текущий момент [image] рабочих объектов - файлов специального формата и содержащихся в них полей данных, а также наборов данных, полученных при измерении.

Рис. 2.5.1.1.1 - Панель [Objects] (Объекты) вкладки Browse (Обзор) c развернутым перечнем объектов.

Перечень открытых рабочих объектов отображается в графической форме - в виде структурного дерева, подобно тому, как это осуществляется в MS Windows Explorer. При этом перечень имет два раздела:
- FILES (Файлы) - группа объектов, открытых из имеющихся.на жестком диске файлов СЗМ-данных;
- AFM (АСМ) - группа объектов-наборов СЗМ-данных, полученных при измерении с помощью модуля атомно-силового микроскопа в данном сеансе работы программы.

В перечне объектов используются следующие графические символы (рис. 2.5.1.1.1 ):

символ файла (объект Файл);
символ типа данных (объект Тип данных);
символ поля данных (объект Поле данных);
кнопка разворачивания подуровня; знак наличия у объекта подуровней;
кнопка сворачивания подуровней.

Открытие файла СЗМ-данных сопровождается появлением его имени в перечне на вкладке (рис. 2.5.1.1.1 ), например:

- [image] Sample1.spm
Click once with left mouse button when cursor is over the target object

Если файл содержит множественные поля данных, то в перечне они будут представлены как подуровни данного объекта, разворачиваемые при нажатии на знак [image] перед именем файла (рис. 2.5.1.1.1). После разворачивания подуровней знак перед объектом изменяется на [image], и при следующем нажатии на этот знак подуровень будет свернут.

Data field Click once with left mouse button when cursor is over the target object Load...

Непосредственно СЗМ-данные содержатся в полях данных, отмечаемых символом Data field. Двойной щелчок левой кнопкой мыши по имени поля данных или его символу загружает соответствующее СЗМ-изображение в окне двухмерного представления.

Context menu of [Object] panel

Закрытие загруженного файла СЗМ-изображения или его отдельных полей данных (т.е. рабочих объектов) в текущем сеансе работы программы осуществляется с помощью команды Close контекстного меню, вызываемого правой кнопкой мыши в зоне перечня. Дополнительная команда контекстного меню Close all позволяет закрыть все открытые объекты сразу.

Закрытие специализированнго окна двухмерной визуализации в рабочей области программы не удаляет открытый объект из перечня на панели настроек. Это позволяет при необходимости восстановить СЗМ-изображение в рабочем окне программы заново не прибегая к командам открытия файла: дважды щелкнув левой кнопкой мыши по интересующему полю данных имеющегося файла в перечне. В случае, если один и тот же файл был открыт многократно без удаления из перечня на панели, все его рабочие копии будут доступны для повторного восстановления в рабочем окне программы, что потребует от пользователя внимания при работе с объектами во избежание путаницы с версиями.

Вновь образующиеся при обработке поля данных (т.е. производные поля от исходных данных, например, дубликаты окон или вырезанные участки) отображаются в структурном перечне как подуровни соответствующих исходных полей. При этом все производные поля нумеруются в порядке очередности их образования.

Необходимо отметить, что функция вырезания прямоугольного участка при наличии в файле более одного поля данных вырезание участка в одном окне визуализации автоматически будет повторяться в остальных совместных полях этого файла. Поэтому поля соответствующие вырезанным участкам (#.Crop), формируются одновременно для всех типов за исключением случая, когда вырезание производится в дубликате окна, которое автоматически не имеет совместных полей.

2.5.1.2 Панель [Folders] (Папки)

Рис. 2.5.1.2.1 - Панель [Folders] (Папки) вкладки Browse (Обзор) представляет структуру папок на жестком диске и отображает содержащиеся в текущей (выбранной) папке данные в нижней части панели в виде пиктограмм. Tab Browse Tab Properties Tab Data Head of panel [Objects] Head of panel [Folders] Head of panel [Favorites] Folder tree in panel [Folders] Border area for panel resize Sector for thumbnails preview Object sector border Object sector border Button for hiding the object sector

Панель [Folders] (Папки) служит для отображения структуры папок (директорий) на жестком диске в виде дерева, как это реализовано в MS Windows Explorer.

Click once with left mouse button when cursor is over the target object

Разворачивание подуровня папок (каталогов) производится либо одиночным щелчком левой кнопки мыши по символу [image] перед именем папки (диска), либо двойным щелчком левой кнопки мыши по имени папки (диска). Сворачивание развернутых подуровней производится аналогично - одиночным щелчком левой кнопки мыши по символу [image] перед именем папки (диска) либо двойным щелчком по имени папки (диска).

Click once with left mouse button when cursor is over the target object / Click once with left mouse button when cursor is over the target object

Активация (выбор) папки в дереве на панели [Folders] (Папки) осуществляется одним или двумя щелчками левой кнопки мыши по имени папки. При этом графический символ папки изменяется с [image] (неактивная папка) на [image] (активная папка).

При активации (выборе) папки в панели ее содержание анализируется на наличие файлов данных и в положительном случае в секторе быстрого просмотра эти файлы данных отображаются в виде пиктограмм (в нижней части вкладки Browse (Обзор)).

Анализ содержания папок программой SurfaceXplorer производится по маскам расширений файлов. Список расширений, по которым осуществляется поиск файлов данных в папках, задается в строке Scan folder mask (Маска файлов для обзора; раздел Browse (Обзор) на панели настроек программы). Расширения указываются через пробел. Все файлы в папке, чьи расширения совпадают с имеющимися в данной строке, дополнительно обрабатываются для представления в графическом виде - в виде пиктограмм в секторе быстрого просмотра. Если в строке не указано ни одного расширения, то по умолчанию будут обрабатываться все типы файлов, с которыми предусмотрена работа в программе SurfaceXplorer:
mps spm ppm mtf txt bmp jpg .

Настройка размера пиктограмм также осуществляется с помощью панели настроек программы в поле ввода/селекторе Thumbnail size (Размер пиктограмм).

На панели настроек программы также содержится опция сохранения образов пиктограмм для каждой обработанной (т.е. активированной) папки на жестком диске в специальном файле - базе данных. Данная опция - Use database for thumbnails (Использовать БД для пиктограмм) - позволяет при выборе в панели папки значительно ускорять отображение пиктограмм в секторе быстрого просмотра.

Context menu in [Folders] panel

Контекстное меню панели [Folders] (Папки) содержит следующие команды:
- Refresh (Обновить) - команда обновления структуры дерева;
- Add to favorites (Добавить в избранное) - команда создания в панели [Favorites] (Избранное) ссылки на выбранную (активную) папку на жестком диске. Данная функция позволяет организовать быстрый доступ к наиболее часто используемым папкам с данными. После выполнения команды Add to favorites (Добавить в избранное) отображается диалоговая панель, в которой необходимо ввести имя, под которым выбранная папка будет занесена в список на панели [Favorites] (Избранное) (рис. 2.5.1.2.2).

Рис. 2.5.1.2.2 - Панель диалога для ввода имени ссылки для занесения в список на панели [Favorites] (Избранное).
Tab Browse Tab Properties Tab Data Head of panel [Objects] Head of panel [Folders] Head of panel [Favorites] Object tree in panel [Objects] Border area for panel resize Sector for thumbnails preview Object sector border Object sector border Button for hiding the object sector

2.5.1.3 Панель [Favorites] (Избранное)

Рис. 2.5.1.3.1 - Панель [Favorites] (Избранное) вкладки Browse (Обзор).

Tab Browse Tab Properties Tab Data Head of panel [Objects] Head of panel [Folders] Head of panel [Favorites] Controls for the list entries operation in panel [Favorites] List of favorite folders in panel [Favorites] Border area for panel resize Sector for thumbnails preview Object sector border Object sector border Button for hiding the object sector

Панель [Favorites] (Избранное) (рис. 2.5.1.3.1) отображает [image] список быстрого доступа - список ссылок (ярлыков) на наиболее часто используемые папки с СЗМ-данными, обеспечивающий быстрый доступ к ним.

Для внесения интересующей папки на жестком диске в список быстрого доступа необходимо:

1) В панели [Folders] (Папки) активировать (выбрать) интересующую папку (однократный щелчок левой кнопкой мыши по имени папки в дереве каталогов). Активная папка отмечается графическим символом [image] перед ее именем;
2) В контекстном меню, вызываемом нажатием правой кнопки мыши в панели [Folders] (Папки) выбрать команду Add to favorites (Добавить в избранное);
3) Ввести в открывшейся панели диалога имя для ссылки на папку в списке быстрого доступа, завершив процедуру нажатием кнопки OK на панели диалога. При необходимости отказаться от создания ссылки на папку, следует нажать кнопку Cancel на панели диалога.

Для выбора (активации) ссылки в списке необходимо щелкнуть по ней левой кнопкой мыши. Строка с активной ссылкой выделяется цветом фона. Так же, как и в панели [Folders] (Папки), содержимое активной (выбранной) папки (т.е. ссылки) в списке быстрого доступа отображается в виде пиктограмм в секторе быстрого просмотра (в нижней части вкладки Browse (Обзор)).

Entry control buttons in panel [Favorites] Для управления ссылками на папки данных в списке быстрого доступа панели [Favorites] (Избранное) используются управляющие кнопки, расположенные в верхней строке. Функции кнопок следующие:

- переименование текущей (активной) ссылки;
- удаление текущей (активной) ссылки;
- удаление всех ссылок из списка быстрого доступа (очистка списка);
- перемещение текущей (активной) ссылки на одну строку вверх в списке;
- перемещение текущей (активной) ссылки на одну строку вниз в списке.

Context menu in [Favorites] panel

Контекстное меню панели [Favorites] (Избранное) содержит следующие команды:
- Rename (Переименовать) - команда переименования текущей ссылки;
- Delete entry (Удалить пункт) - команда удаления ссылки из списка быстрого доступа;
- Purge list (Очистить список) - команда очистки списка - удаление всех ссылок.

2.5.1.4 Секция быстрого просмотра (секция пиктограмм)

Секция быстрого просмотра (рис. 2.5.1.4.1) размещается в нижней части вкладки Browse (Обзор) и служит для отображения в виде пиктограмм файлов данных, перечисленных на панели [Objects] (Объекты) либо содержащихся в активной (выбранной) папке на панелях [Folders] (Папки) или [Favorites] (Избранное). При смене активной папки (ссылки), а также при переключении панелей в верхней части вкладки содержание секции обновляется.

Рис. 2.5.1.4.1 - Секция быстрого просмотра вкладки Browse (Обзор) с активированным блоком просмотра содержания файла (справа от сектора объектов). Brief information about the image Thumbnail of SPM dta file Thumbnail of SPM dta file Thumbnail of SPM dta file Thumbnail of SPM dta file Thumbnail of SPM dta file Thumbnail of SPM dta file Thumbnail of linear dta file Thumbnail of SPM dta file Additional panel with thumbnails of current file cofields Object sector border Button for hiding the object sector
Click once with left mouse button when cursor is over the target object Activate...
Click once with left mouse button when cursor is over the target object Open...

Под каждой пиктограммой отображается также имя соответствующего ей файла. При активации (выборе) пиктограммы одиночным щелчком левой кнопки мыши имя файла выделяется изменением цвета фона (рис. 2.5.1.4.1). При этом справа от секции в рабочей области отображается блок просмотра содержания файла. Двойной щелчок левой кнопкой мыши по пиктограмме открывает соответствующий ей файл в рабочей области программы (загружает в окно визуализации).

В секции отображаются пиктограммы только тех файлов данных, расширения имен которых указаны в строке Scan folder mask (Маска файлов для обзора; раздел Browse (Обзор) на панели настроек программы). Все файлы в папке, чьи расширения совпадают с масками в данном списке, дополнительно анализируются для построения на основе содержащихся в них данных пиктограмм. Если в строке Scan folder mask (Типы файлов для обзора) не указано ни одного расширения, то по умолчанию будут анализироваться все типы файлов, с которыми предусмотрена работа в программе SurfaceXplorer:
mps spm ppm mtf txt bmp jpg .

Пиктограммы в секции быстрого просмотра представляют уменьшенное изображение, построенное на основе данных, содержащихся в файле, в соответствии с его типом. Размер пиктограммы, задается в поле ввода/селекторе Thumbnail size (Размер пиктограмм; раздел Browse (Обзор) на панели настроек программы).

Пиктограммы СЗМ-файлов. Если файл содержит СЗМ-данные, то его пиктограмма представляется как двухмерное СЗМ-изображение (уменьшеннное до размера пиктограммы). При наличии в СЗМ-файле совместных полей данных, для построения пиктограммы используется поле, соответствующее топографии (фактически - превое поле данных типа Topography).
Дополнительно в программе при построении пиктограмм СЗМ-файлов предусмотрена возможность автоматической оперативной обработки изображения для его оптимального представления. Даная возможность реализуется назначением для события Preview (Предварительный просмотр) макрокоманды из списка имеющихся в программе. Таким образом, для построения пиктограмм доступны все процедуры обработки и преобразования СЗМ-изображения, используемые для создания макрокоманд. Тем не менее следует учитывать, что применение дополнительных процедур для построения пиктограмм замедляет этот процесс, поэтому при недостаточной производительности комптьютера рекомендуется не назначать макрокоманду для события Preview (Предварительный просмотр) - задать для него пункт None (Нет).

Пиктограммы файлов с линейными данными. Если файл содержит набор линейных данных, то на его пиктограмме представляется первая кривая из набора (масштабированная до размера пиктограммы).

На панели настроек программы также содержится опция сохранения образов пиктограмм для каждой обработанной (т.е. активированной) папки на жестком диске в специальном файле - базе данных. Данная опция - Use database for thumbnails (Использовать БД для пиктограмм) - позволяет при включении значительно ускорять процесс отображение пиктограмм в секторе быстрого просмотра.

Блок просмотра содержания файла

Рис. 2.5.1.4.2 - Пример блока просмотра содержания файла

При активации пиктограммы файла данных в секции быстрого просмотра (один щелчок левой кнопкой мыши по пиктограмме) справа от зоны сектора объектов (поверх рабочей области) отображается дополнительная панель, в которой также в виде пиктограмм представлены поля данных, содержащиеся в выбранном (активном) файле (рис. 2.5.1.4.1). Эта панель - блок просмотра содержания файла (рис. 2.5.1.4.2) - отображается постоянно, пока курсором мыши не будет активирован другой объект за пределами секции быстрого просмотра. Если курсором мыши активируется другая пиктограмма в секции быстрого просмотра, то пиктограммы в блоке соответственно обновляются.

В верней части блока просмотра содержания файла (в заголовке) отображается краткая информация о параметрах СЗМ-изображения:
- размер поля по X X:###.#nm;
- размер поля по Y Y:###.#nm;
- диапазон по Z Z:###.#nm;
- размер матрицы данных в точках [###x###].

Под каждой пиктограммой также отображается наименование поля данных (информация воспроизводится согласно служебным записям в файле).

Click once with left mouse button when cursor is over the target object Open...

Двойной щелчок по пиктограмме в блоке просмотра содержания файла открывает файл в программе (если он не был до этого открыт) и отображает соответствующее пиктограмме поле данных в окне двухмерного представления. Если файл содержит набор линейных данных (в т.ч. в текстовом формате со специальным заголовком-описанием), то соответсвующий график будет отображен в окне представления профиля.


SurfaceXplorer :: Tab Properties

SurfaceXplorer
[Интерфейс пользователя] > [Сектор объектов] > [Вкладка Свойства]

2.5.2 Вкладка Properties (Свойства)

Вкладка Properties (Свойства) предоставляет средства для настройки параметров представления данных в специализированных окнах. Средства настройки функционально сгруппированы и размещены на соответствующих панелях:

  • [2D] - настройка параметров визуализации в окне двухмерного представления СЗМ-данных;
  • [3D] - настройка параметров визуализации в окне трехмерного представления СЗМ-данных;
  • [Palette] (Палитра) - настройка цветовой шкалы (палитры), используемой в окнах двух- и трехмерного представления СЗМ-данных;
  • [Profile] (Профиль) - настройка параметров отображения профилей поперечного сечения в окне Profile;
  • [Histogram] (Гистограмма)- настройка параметров отображения в окне анализа данных Histogram.

Панели вкладки допускают их отстыковку и расположение в изолированном виде в произвольном месте рабочего стола программы. Отстыковка панели производится перетаскиванием ее за ярлык с названием. Обратная пристыковка осуществляется перетаскиванием изолированной панели за ее заголовок на открытую вкладку Properties (Свойства) (курсор должен оказаться в зоне ярлыков вкладки).

Переключение между пристыкованными панелями производится однократным щелчком левой кнопкой мыши по ярлыку с соответствующим названием панели.


SurfaceXplorer :: 2D Settings Panel

[Интерфейс пользователя] > [Сектор объектов] > [Вкладка Свойства] > [Панель 2D]

2.5.2.1 Панель настройки двухмерного представления СЗМ-данных

Panel for color palette adjustment Option for switching light simulation Tilt of simulated light source over the horizontal plane Orientation angle of simulated light source Graphical zone for adjusting simulated light source position relative SPM image Command for pasting parameters of the selection from system clipboard into the node table Button for adjusting window background color Option for positioning zero point of scales in left top corner of the image Actiive type of selection instrument (object) Group of selected nodes coordinates table Command for copying current parameters of the selection into system clipboard Table of the installed nodes coordinates Command for clearing current selection nodes Option for placing number labels near nodes in selection objects Option for close polyline at the selection Option for bilinear interpolation of the SPM image in 2D window Dynamic group for adjusting height of isoline level. Appears at activation of isoline selection tool. Group for adjusting virtual light source position Command for setting current light source settings as default ones
Рис. 2.5.2.1.1 - Панель настройки двухмерного представления СЗМ-данных (нажмите на соответствующий элемент для перехода к его описанию)

Панель [2D] (рис. 2.5.2.1.1) предоставляет средства для настройки параметров отображения СЗМ-данных в окне двухмерного представления. На панели всегда отображается состояние и обеспечивается настройка активного окна визуализации, и при смене активного окна отображаемое состояние соответственно обновляется (актуализируется). Панель допускает ее отстыковку от родительской вкладки - Properties (Свойства) и свободное размещение в границах рабочего стола на мониторе компьютера поверх остальных окон программы SurfaceXplorer.

Для вызова панели можно воспользоваться одним из следующих способов:
- активировать ярлык панели [2D] на левой границе вкладки Properties (Свойства) в секторе работы с объектами программы (в случае, если панель пристыкована к вкладке);
- в контекстном меню, вызываемом правой кнопкой мыши в окне двухмерного представления, выбрать соответствующий пункт Properties);

- в окне двухмерного представления щелкнуть два раза левой кнопкой мыши в любом месте кроме зоны цветовой шкалы (справа от СЗМ-изображения).

Использование последних двух способов - наиболее быстрый путь вызова панели [2D], если активны вкладки, иные чем вкладка Properties (Свойства). Альтернативный подход для обеспечения быстрого доступа к ресурсам панели - отстыковать ее от вкладки и разместить панель отдельно.

Элементы панели настройки двухмерного представления

Секция настройки источника света - LIGHT - содержит средства настройки положения виртуального источника света относительно СЗМ-изображения в окне двухмерного представления.

Переключатель On/Off (Вкл./Выкл) активирует/деактивирует функцию виртуальной подсветки СЗМ-изображения. В отключенном (деактивированном) состоянии СЗМ-изображение представляется как карта высот, во включенном (активированном) состоянии - имитируется освещение отображаемого участка рельефа (режим виртуальной подсветки).

Представление в виде карты высот обеспечивает отображение вертикальной координаты каждой точки данных в соответствии с цветовой шкалой (рис. 2.5.2.1.2 слева). Вертикальная координата каждой точки изображения (т.е. ее высота) кодируется цветом в строгом соответствии с настроенной цветовой палитрой, и все изображение, таким образом, представляет собой карту высот (аналогично физической карте в географии).

Представление в режиме виртуальной подсветки обеспечивает отображение рельефа как карты высот, но с дополнительной имитацией его освещения виртуальным источником света (рис. 2.5.2.1.2 справа). Цвет каждой точки данных определяется в первую очередь цветовой шкалой, а его яркость корректируется в зависимости от геометрического положения этой точки относительно окружающих точек данных и виртуального источника света. Данный режим можно рассматривать как вид сверху на трехмерное изображение, расположенное в строго горизонтальной плоскости (т.е. в плоскости окна двухмерного представления).

Рис. 2.5.2.1.2 - Двухмерное СЗМ-изображение в виде карты высот (слева) и в режиме виртуальной подсветки с имитацией освещения (справа).

Зона графической установки положения источника света (окружность с закрашенным маркером внутри) - позволяет визуально устанавливать положение виртуального источника света относительно СЗМ-изображения в окне двухмерного представления. Установка (изменение положения) производится перетаскиванием маркера при нажатой левой кнопке мыши. При этом ориентация на плоскости радиуса, на котором расположен маркер, соответствует ориентации виртуального источника света относительно двухмерного СЗМ-изображения, а расстояние от маркера до центра окружности определяет угол наклона этого источника над СЗМ-изображением. Фактически, маркер представляет собой проекцию положения виртуального источника света в пространстве на плоскость СЗМ-изображения (рис. 2.5.2.1.3).

Рис. 2.5.2.1.3 - Схема соответствия положения виртуального источника света в пространстве положению маркера (проекции этого источника) в плоскости СЗМ-изображения.

Параметры расположения виртуального источника света в пространстве (в полусфере единичного радиуса над плоскостью СЗМ-изображения) в аналитическом (цифровом) виде отображаются и могут изменяться вручную в полях ввода слева от зоны графической установки.

Угол наклона - Tilt - цифровое поле, в котором отображается текущий угол наклона виртуального источника света над плоскостью СЗМ-изображения. В данном поле допускается ввод числовых значений вручную, что интерактивно изменяет положение маркера в зоне графической установки и, соответственно, виртуального источника относительно СЗМ-изображения.

Угол ориентации - Orientation - цифровое поле, в котором отображается текущий угол ориентации виртуального источника света в плоскости СЗМ-изображения. В данном поле допускается ввод числовых значений вручную, что интерактивно изменяет положение маркера в зоне графической установки и, соответственно, виртуального источника относительно СЗМ-изображения.

Билинейная интерполяция - Bilinear interpolation - функция билинейного сглаживания изображения в окне двухмерного представления при включенном угловом режиме ототбражения (симуляции подсветки). Ступенчатые границы элементов на СЗМ-изображении сглаживаются программным фильтром.

Замыкание ломаной линии - Close polyline - опция автоматического соединения концов выделенной ломаной линии (замыкание крайних сегментов ломаной) на СЗМ-изображении в окне двухмерного представления. Позволяет, например, выделять замкнутую линию, очерчивая некоторый элемент топографии на СЗМ-изображении, и определять ее периметр и, соответственно, периметр очерченного элемента.

Текстовые метки узловых точек - Marker labels - опция отображения над узловыми точками, установленными при операциях выделения объектов на СЗМ-изображении, текстовых меток с порядковыми номерами этих точек - Selection node with text label above. Метки упрощают идентификацию узловых точек на СЗМ-изображении, например, при анализе таблицы их координат.

Положение начала координат - Left-top axis - опция, позволяющая отображать размерные оси (соответственно, и масштабные шкалы) с началом координат в левом верхнем углу СЗМ-изображения. При этом ось X отображается сверху над СЗМ-изображением, отсчет начинается слева и увеличивается вправо по горизонтальной шкале. Ось Y отображается слева от СЗМ-изображения, отсчет начинается сверху и увеличивается вниз по вертикальной шкале.

Цвет фона окна - Bk color - кнопка для вызова системной панели настройки цвета для фона окна двухмерного представления. Цвет кнопки соотвествует текущему цвету фона окна. По умолчанию используется белый цвет фона. Следует учитывать, что цвет текста надписей в окне не изменяется, поэтому при установке черного цвета для фона текстовые метки осей не будут видны.

В секции NODES (Узлы) представлены средства для работы с установленными узловыми точками текущего объекта выделения в окне двухмерного представления.

Тип выделения - информация об активном инструменте выделения.

Таблица координат узловых точек - отображает в аналитическом виде положение узловых точек активного объекта выделения на СЗМ-изображении в текущем окне двухмерного представления. Следует иметь ввиду, что отображаемая информация актуализируется (автоматически обновляется) только для тех типов выделения, в которых для определения объектов используются узловые точки - точки, произвольный отрезок прямой линии, произвольная ломаная линия, прямоугольная область. Если после выделения какого-либо из этих объектов будет активирован инструмент выделения другого типа (линия сканирования, единичный островок, изолиния), то в таблице сохранятся данные о прежнем объекте.

В первой колонке (No.) перечисляются номера узловых точек на СЗМ-изображении (соответствующих меткам). Во второй (x) и третьей (y) колонках указываются координаты узловых точек по оси X и Y, соотвественно, в точках матрицы данных - данное число всегда целое. В четвертой (x, um) и пятой (y, um) колонках приводятся координаты узловых точек по оси X и Y, соотвественно, в указанных линейных единицах. Значения координат могут быть изменены вручную после установки курсора в необходимое поле ввода таблицы . После ввода нового значения (в любом из форматов - в точках или в линейных единицах) положение узловой точки соответствующим образом изменится и на СЗМ-изображении. Данная таблица аналогична таблице узловых точек в панели [Profile].

Удаление узловых точек - Clear (Очистить) - команда удаления всех узловых точек ("стирания" их координат в таблице). Выполнение команды фактически приводит к удалению активного объекта выделения, т.е. к очистке от него СЗМ-изображения.

Копирование координат узловых точек - Copy selection to clipboard (Скопировать выделение в буфер обмена) - команда для копирования текущей таблицы координат узловых точек в системный буфер обмена. Поскольку в буфер переносятся координаты установленных узловых точек, то данная функция имеет силу для тех типов объектов выделения, которые и определяются узловыми точками - точки, произвольный отрезок прямой линии, произвольная ломаная линия, прямоугольная область.

Вставка координат узловых точек - Paste selection from clipboard (Вставить выделение из буфера обмена) - команда для вставки из системного буфера обмена в текущее окно двухмерного представления объекта выделения, определяемого таблицей координат узловых точек , если предварительно она была туда занесена с помощью предыдущей команды. Автоматически в окне, для которого производится данная операция, соответствующим образом переключается инструмент выделения - активизируется тот инструмент, который определяла переносимая в него таблица координат узловых точек.

Сочетание команд копирования и вставки координат узловых точек используются для быстрого и точного переноса объекта выделения из одного ("донорского") окна двухмерного представления СЗМ-изображения в любое другое ("приемное"). Для корректного переноса объекта выделения из одного окна в другое необходимо следить, чтобы размерность матриц этих СЗМ-изображений (в точках) была однинаковой, поскольку перенос производится без проверки соответствия размерности.

Установка параметров по умолчанию - Set as default - кнонка для сохранения текущих настроек панели (установки виртуального источника света и опции) в качестве параметров, используемых программой по умолчанию при последующих запусках.

Вышеперечисленные элементы являются для панели настройки двухмерного изображения статическими, т.е. присутствующими постоянно. Кроме них при включении инструментов выделения единичного островка и изолинии в нижней части панели отображаются динамические элементы для управления соответствующими объектами выделения.

Инвертирование выделения - Invert selection - динамическая кнопка в нижней части панели настройки двухмерного изображения, активируемая при включении инструмента выделения единичного островка Island selection tool / Island selection tool . При нажатии кнопки вместо выделенной области на СЗМ-изображении будет закрашено ее окружение. Таким образом предоставляется возможность визуализировать рельеф выделенной области. Кнопка инвертирования выделения работает как переключатель - повторное нажатие возвращает исходное состояние объекта выделения.

Уровень изолинии - Isoline level - динамическая группа в нижней части панели настройки двухмерного изображения, активируемая при включении инструмента выделения изолинии Isoline selection tool / Isoline selection tool (рис. 2.5.2.1.4).

Рис. 2.5.2.1.4 - Динамическая группа для отображения и управления вертикальным положением уровня установленной изолинии

В группе представлено поле ввода, отображающее положение выделенной изолинии по вертикальной оси (по высоте СЗМ-изображения), а также допускающее интерактивное смещение вертикального уровня выделенной изолинии.

Изменение уровня производится при этом либо вводом вручную нового числового значения вертикального положения изолинии, либо с помощью кнопок увеличения/уменьшения значения справа от поля ввода.

После активации поля ввода или его кнопок увеличения/уменьшения значения (практически - их задействованием) изменять числовое значение в поле ввода допускается также с помощью клавиш управления курсором <Вверх> и <Вниз> на клавиатуре компьютера.


SurfaceXplorer :: Color Palette Adjustment Panel

[Интерфейс пользователя] > [Сектор объектов] > [Вкладка Свойства] > [Палитра]

2.5.2.3 Панель настройки цветовой палитры

Panel for color palette adjustment
Name of active data field Color distribution diagram combined with the image height histogram Color scale Color marker bar Title of group for active marker control Current color marker position in the physical scale represented in digital format Button setting color for current color marker CTitel of group for presets applying and management Panes for assignment of color in RGB format (digital format setting separate values for Red, Green and Blue channels of height level in the image) Button for adding new color marker to the scale. New marker will be placed between current marker and that one above it Button for deleting current color marker Pane for assignment of height distribution significance level that will be discarded after automatic color scale adjustment Button for automatic movement of the boundaries markers to the position where height distribution histogram equals to the set significance level Selector of supplied color schemes Button for assignment of current color scheme as default one Save button for current color scheme Load button for existing presets of color schemes if is not present in the presets selector Command for copying current color scheme to clipboard Command for inserting color scheme from the clipboard where it was placed with previous command Рис. 2.5.2.3.1 - Панель настройки цветовой палитры (нажмите на соответствующий элемент для перехода к его описанию)

На панели [Palette] (Палитра) (рис. 2.5.2.3.1) размещаются средства для настройки цветовой шкалы изображений в окне двухмерного представления СЗМ-данных. Цветовая палитра СЗМ-изображения в окне трехмерного представления определяется и автоматически обновляется в соответствии с настройками для его оболочки.

На панели [Palette] всегда отображается состояние и обеспечивается настройка цветовой палитры СЗМ-изображения в активном окне двухмерного представления, и при смене активного окна состояние панели соответственно обновляется (актуализируется). Панель допускает ее отстыковку от родительской вкладки - Properties (Свойства) и свободное размещение в границах рабочего стола на мониторе компьютера поверх остальных окон программы SurfaceXplorer.

Для вызова панели можно воспользоваться одним из следующих способов:
- активировать ярлык панели [Palette] (Палитра) на левой границе вкладки Properties (Свойства) в секторе работы с объектами программы (в случае, если панель пристыкована к вкладке);
- в контекстном меню, вызываемом правой кнопкой мыши в окне визуализации, выбрать соответстсвующий пункт (например, Edit palette);
- в окне двухмерного представления щелкнуть два раза левой кнопкой мыши по цветовой шкале (справа от СЗМ-изображения).

Использование последних двух способов - наиболее быстрый путь вызова панели настройки палитры, если активны вкладки, иные чем вкладка Properties (Свойства). Альтернативный подход для обеспечения быстрого доступа к ресурсам панели - отстыковать ее от вкладки и разместить панель отдельно.

Элементы панели настройки цветовой палитры

Заголовок (вверху панели) - отображает имя активного поля данных, для которого производится настройка параметров в панели (при наличии в файле набора полей данных).

Диаграмма распределения цветов (в верхней части панели, рис. 2.5.2.3.1) - отображает кривые интенсивности трех цветовых каналов для текущего СЗМ-изображения. При этом весь высотный диапазон изображения соответствует вертикальной оси диаграммы, а кривая распределения высот для удобства представлена здесь же черной линией. В программе используется стандартная для опреационной системы цветовая модель RGB - Red (красный) : Green (зеленый) : Blue (синий). Смешением трех этих компонент в различных соотношениях достигается необходимый цветовой оттенок.

Узлы на кривых цветовых компонент графически представляют интенсивность соответствующей цвету линии компоненты, которую можно интерактивно изменять, перемещая узел мышью влево или вправо в пределах поля диаграммы. Минимум соответствует левой границе поля диаграммы, максимум - правой. Альтернативный способ - изменение интенсивности компонент цветового маркера вручную в окнах ввода R ### G ### B ### go to delete marker button description . Другие способы изменения цвета маркера - настройка с помощью системной цветовой панели.

Линейка цветовых маркеров (на левой границе диаграммы, рис. 2.5.2.3.1) - вертикальная шкала, на которой размещаются [image] цветовые маркеры - узловые метки на шкале высот, в точках расположения которых предусматривается настройка цвета данного вертикального уровня. Графический символ маркера - квардрат с присоединенным справа треугольником, например - Example of inactive color marker. Цвет квадрата соответствует цвету шкалы на данном высотном уровне. Свободная вершина треугольника располагается на соответствующем ему высотном уровне. Минимальное количество маркеров - два, которые определяют цвета для нижней и верхней границ цветовой шкалы высот СЗМ-изображения. Промежуток между двумя любыми маркерами автоматически и равномерно заполняется соответствующими переходными тонами.

Установка дополнительного цветового маркера на линейке производится щелчком левой кнопки мыши в свободном месте на линейке. Автоматически новый маркер становится текущим (активным), и соответствующему ему уровню на шкале высот присваивается цвет промежуточный между двумя соседними (маркерами выше и ниже нового). На кривых интенсивности цветовых компонент на уровне нового маркера устанавливаются узлы, которыми можно воспользоваться для интерактивной настройки цвета маркера. Альтернативный способ - воспользоваться кнопкой + Add marker go to add marker button description .

Удаление цветового маркера на линейке производится щелчком по нему правой кнопки мыши. Автоматически текущим становится маркер, расположенный выше на линейке, а кривые интенсивности цветовых компонент спрямляются между соседними узлами (выше и ниже удаленного уровня/маркера). Альтернативный способ - воспользоваться кнопкой X Delete go to delete marker button description .

Перемещение установленного на линейке цветового маркера вверх или вниз осуществляется перетаскиванием его при нажатой левой кнопке мыши. Альтернативный способ - изменить вертикальную координату маркера вручную в окне ввода ### Marker position go to delete marker button description . По умолчанию доускается свободное перемещение (Free move) цветовых маркеров по линейке, в том числе таким образом, что его уровень пересекает уровень другого маркера с сохранением каждым маркером своего цвета. Однако при необходимости допускается в панели настройки общих параметров программы (Preferences) устанавливать и другие режимы передвижения маркеров на линейке - удаление пересекаемого маркера (уровня) при пересечении его активным маркером (Delete) и запрет пересечения уровней (No cross)

Активизация (выбор) маркера производится однократным щелчком по нему левой кнопкой мыши. Активный маркер отмечается треугольником красного цвета, например - Active color marker, а соответствующий ему горизонтальный уровень на диаграмме распределения цветов выделяется пунктирной линией (рис. 2.5.2.3.1).

Изменение цвета (настройка) маркера производится с помощью стандартной системной панели настройки цвета (рис. 2.5.2.3.2), вызываемой двойным щелчком левой кнопкой мыши по графическому символу маркера (например - Active color marker ). Альтернативный способ - вызов системной панели с помощью кнопки выбора цвета [image] . Другие способы настройки цвета текущего маркера - изменение соотношения цветовых компонент на диаграмме распределения цветов или в поле ввода RGB-параметров.

System color table in initial state Button for activating extended mode of the color table
Рис. 2.5.2.3.2 - Системная панель настройки цвета в исходном состоянии.

Цветовая шкала (справа от диаграммы, рис. 2.5.2.3.1) - отображает реальное распределение цветов по высоте для активного СЗМ-изображения с соответствующими метками высот (единицы измерения на шкале зависят от типа данных, для которых редактируется палитра).

В секции Marker (Маркер) панели (рис. 2.5.2.3.1) представлены следующие элементы управления параметрами активного цветового маркера.

Позиция маркера - ### Z - отображает в цифровом формате вертикальную координату активного маркера на шкале высот текущего СЗМ-изображения. Используются относительные координаты и единицы измерения соответствующей вертикальной шкалы. В поле ввода пердусматривается возможность ввода вручную новой координаты, после чего активный маркер перемещается в заданную этой новой координатой точку на вертикальной линейке.

Кнопка настройки цвета - Color selection button - отображает цвет вертикальной шкалы на уровне, на котором установлен активный маркера (т.е. цвет в позиции маркера). Цвет кнопки изменяется при смене текущего маркера соответственно его усановленному цвету. При однократном нажатии на кнопку вызывается стандартная системная панель настройки цвета (рис. 2.5.2.3.3), с помощью которой осуществляется визуальный выбор или создание необходимого цветового оттенка. Альтернативный способ - вызов системной панели двойным щелчком левой кнопкой мыши по графическому символу маркера на вертикальной линейке (например - Active color marker ) [image] . Другие способы настройки цвета текущего маркера - изменение соотношения цветовых компонент на диаграмме распределения цветов или в поле ввода RGB-параметров.

System color table i extended mode (after pressing button [DFefine Custom Colors ]
Рис. 2.5.2.3.3 - Системная панель настройки цвета в развернутом состоянии.

Наиболее точный выбор цвета для позиции маркера с непосредственным просмотром образцов осуществляется с помощью системной панели настройки цвета.

Интенсивность цветовых компонент - R ### G ### B ### - отображение в цифровом формате интенсивности цветовых компонент текущего высотного уровня (позиции маркера) - Red (красный) : Green (зеленый) : Blue (синий). Как и в операционной системе, интенсивность каждой компоненты имеет 256 градаций - от 0 до 255. Здесь используется десятичное представление параметра интенсивности, подобно тому, как это производится в системной панели настройки цвета (рис. 2.5.2.3.3). Минимальная интенсивность (или отсутствие в цветовом тоне данной составляющей) соответствует значению "0", а максимальная - значению "255". В полях ввода предусматривается возможность вручную изменять параметры интенсивности каждого из цветовых каналов, однако пользоваться данной функцией рекомендуется при наличии определенного опыта работы с настройками цвета в модели RGB. Альтернативный способ изменения интенсивности компонент цветового маркера - перемещение узлов на кривых диаграммы распределения цветов [image] . Другие способы изменения цвета маркера - настройка с помощью системной цветовой панели.

Кнопка добавления маркера - + Add marker - при нажатии вставляется новый цветовой маркер на линейке посредине между текущим маркером и маркером выше (кроме случая, когда текущим является верхний граничный маркер). Автоматически новый маркер становится текущим (активным), и соответствующему ему уровню на шкале высот присваивается цвет промежуточный между двумя соседними (маркерами выше и ниже нового). На кривых интенсивности цветовых компонент на уровне нового маркера устанавливаются узлы, которыми можно воспользоваться для интерактивной настройки цвета маркера. Альтернативный способ установки нового маркера - однократный щелчок левой кнопкой мыши в свободном месте на линейке маркеров [image] .

Кнопка удаления маркера - X Delete - при нажатии удаляет текущий (активный) цветовой маркер на линейке. Автоматически текущим становится маркер, расположенный выше на линейке, а кривые интенсивности цветовых компонент спрямляются между соседними узлами (выше и ниже удаленного уровня/маркера). Альтернативный способ удаления маркера - однократный щелчок по нему правой кнопкой мыши go to delete marker button description .

Уровень границ - Boundaries level, % ### - отображение и установка минимального уровня значимости высот (в %) для последующей автоматической установки границ цветовой шкалы (т.е. граничных маркеров) в положения, за внешними пределами которых цвет высот на СЗМ-изображении не будет изменяться (фактически - будет соответствовать цвету граничного маркера) [image] . Весь диапазон распределения высот, отображаемый черной линией на диаграмме цветов, принимается за 100% - независимо от реального значения максимальной вероятности, ее величина рассматривается как 100% и соответствует правой границе диаграммы, левая граница диаграммы соответствует 0.

Кнопка автоматической установки границ цветовой шкалы - Set (Уст.) - при нажатии производит перемещение граничных маркеров в положения, в которых уровень значимости высот на кривой распределения устанавливается параметром Boundaries level, % ### (уровень границ) [image] . Цель данной процедуры - при визуализации игнорировать статистически незначимые высоты. Производится оптимальное совмещение цветовой шкалы с диапазоном высот на СЗМ-изображении, что позволяет отображать топографию (или другие СЗМ-данные) с максимальной детализацией. Если на линейке размещены промежуточные цветовые маркеры, при автоматическом перемещении граничных маркеров все внутренние будут также автоматически передвинуты на новые уровни. Промежутки между всеми маркерами изменятся пропорционально изменению диапазона между границами.

Обычно оптимальные результаты "отключения" отображения незначимых диапазонов высот достигаются при установке уровня границ порядка 1-2%.

В секции Presets (Предустановки) панели (рис. 2.5.2.3.1) размещены элементы для работы с заготовленными цветовыми схемами.

Селектор цветовых схем - [image] - предоставляет быстрый доступ к цветовым схемам, содержащимся в подкаталоге Config программы SurfaceXplorer. Выбор осуществляется вызовом списка доступных схем путем нажатия на кнопку у правой стороны селектора.

Кнопка назначения цветовой схемы по умолчанию - Set as default - сохраняет текущую цветовую схему как схему, используемую программой по умолчанию. Фактически - записывает ее в файл настройки палитры default.pal в подкаталоге Сonfig программы SurfaceXplorer.

Кнопка сохранения текущей цветовой схемы - Save - при нажатии вызывает системный диалог сохранения файла, в который будет записана текущая цветовая схема. Расширение имени файла по умолчанию - *.pal. Рекомендуется не изменять предлагаемое расширение имени файла, а также предусмотреть сохранение файла в подкаталоге Сonfig программы SurfaceXplorer. В этом случае при последующем запуске программы сохраненная цветовая схема будет доступна для быстрой загрузки при помощи селектора.

Кнопка загрузки цветовой схемы - Load - при нажатии вызывает системный диалог открытия файла для выбора ранее сохраненной цветовой схемы. Расширение имени файла по умолчанию - *.pal. Рекомендуется использовать данную процедуру, если предустановленные цветовые схемы были сохранены в не в подкаталоге Сonfig программы SurfaceXplorer или недоступны для быстрой загрузки при помощи селектора цветовых схем.

Копирование текущей цветовой схемы в буфер - Copy palette to clipboard - команда для занесения параметров текущей цветовой схемы в системный буфер. Используется для быстрой переноски цветовой схемы из одного окна визуализации СЗМ-изображения в другое без сохранения схемы в файле на диске.

Вставка цветовой схемы из буфера - Paste palette from clipboard - команда для вставки цветовой схемы из системного буфера в текущую панель настройки цветовой палитры. Предварительно необходимо скопировать цветовую схему в буфер. Используется для быстрой переноски цветовой схемы из одного окна визуализации СЗМ-изображения в другое без сохранения схемы в файле на диске.

Комбинация двух последних команд позволяет быстро устанавливать единую цветовую схему для различных СЗМ-изображений, например, для приведения их к единой цветовой шкале.


SurfaceXplorer :: Panel [Histogram]

[Интерфейс пользователя] > [Сектор объектов] > [Вкладка Свойства] > [Панель Histogram]

2.5.2.5 Панель настройки параметров диаграмм анализа [Histogram]

Panel for color palette adjustment
Рис. 2.5.2.5.1 - Панель настройки параметров диаграмм анализа (нажмите на соответствующий элемент для перехода к его описанию)
Title of group for height distribution diagram settings Selector for adjusting number of bars in the height distribution histogram Step length for bars in height distribution histogram (equals to analyzed range shown by each bar) Horizontal marker position on vertical axis of height distribution diagram Selector for restricting range of analyzed tilt angles in tilt angles distribution histogram Pane for setting bottom limit of the restricted height range for analysis in tilt angle distribution histogram Pane for setting top limit of the restricted height range for analysis in tilt angle distribution histogram Selector for setting number of sectors (directions) in the SPM-image plane in which local orientation angles will be analyzed Title of control group defining colors for diagram elements Title of group of settings for angle distribution diagrams Selector of bar number in tilt angle distribution histogram Selector to choose between full or restricted height range for tilt angle analysis Button for adjusting color of selected element in the diagrams Selector of the diagram elements for adjusting its color Button for assignment of current panel settings as default ones

Панель [Histogram] (Гистограмма) (рис. 2.5.2.5.1) объединяет средства для настройки параметров отображения диаграмм анализа высотных и угловых характеристик СЗМ-данных в соответствующем специализированном окне.

На панели всегда отображается состояние и обеспечивается настройка параметров в активном окне анализа, и при смене активного окна отображаемое состояние соответственно обновляется (актуализируется). Панель допускает ее отстыковку от родительской вкладки - Properties (Свойства) и свободное размещение в границах рабочего стола на мониторе компьютера поверх остальных окон программы SurfaceXplorer.

Для вызова панели можно воспользоваться одним из следующих способов:
- активировать ярлык панели [Histogram] (Гистограмма) на левой границе вкладки Properties (Свойства) в секторе работы с объектами программы (в случае, если панель пристыкована к вкладке);
- в контекстном меню, вызываемом правой кнопкой мыши в окне представления данных анализа, выбрать пункт Properties;
- в свободном месте окна представления данных анализа щелкнуть два раза левой кнопкой мыши.

Использование последних двух способов - наиболее быстрый путь вызова панели настройки параметров диаграмм анализа, если активны вкладки, иные чем вкладка Properties (Свойства). Альтернативный подход для обеспечения быстрого доступа к ресурсам панели - отстыковать ее от вкладки и разместить панель отдельно.

Элементы панели настройки параметров диаграмм анализа

Диаграммы в окне данных анализа представляют два типа зависимостей - распределение высот и распределение углов. Анализ распределения высот приведен на левой диаграмме, совмещающей гистограмму распределения высот Heigh distribution, % на СЗМ-изображении и опорную кривую Bearing ratio, % для всей его площади. Анализ распределения углов, характеризующих положение элементарных площадок рассматриваемой поверхности, размещен на гистограмме распределения углов наклона (диаграмма в середине окна) и ориентационной диаграмме (правый график). Соответственным образом средства настройки двух типов зависимостей сгруппированы в двух секциях на панели (рис. 2.5.2.5.1).

В секции Height distribution (Распределение высот) сгруппированы средства настройки диаграммы распределения высот.

Количество столбцов гистограммы - Number of bars - селектор для установки количества столбцов (горизонтальных) на гистограмме распределения высот (правая диаграмма в окне представления данных анализа). Фактически устанавливает количество диапазонов на вертикальной шкале анализируемого СЗМ-изображения, в которых и будет определяться частота встречаемости выступов, чьи высоты попадают в данный высотный промежуток. Меньшее значение параметра количества столбцов приводит к увеличению размера диапазонов на вертикальной шкале и, соответственно, загрублению данных анализа. Большее количество столбцов уменьшает размер анализируемых диапазонов и повышает детализацию анализа. Изменение параметра количества столбцов допускается как с использованием кнопок увеличения/уменьшения значения, расположенных справа в поле ввода, так и непосредственным вводом нового числового значения вручную в поле ввода. При установке курсора в поле параметра допускается также увеличение или уменьшение отображаемого значения на единицу нажатеим, соответственно, кнопок <Вверх> или <Вниз> на клавиатуре компьютера.

Шаг анализируемых высот - Step - параметр, указывающий размер диапазона по вертикальной шкале, в котором и будет анализироваться частота встречаемости выступов. Шаг определяется автоматически как результат деления всего высотного диапазона СЗМ-изображения на количество столбцов гистограммы распределения высот. В поле ввода параметра шага допускается ввод нового числового значения вручную, после чего автоматически будет пересчитано и установлено соответствующее новое количество столбцов гистограммы. При установке курсора в поле параметра допускается также увеличение или уменьшение отображаемого значения на единицу нажатием, соответственно, кнопок <Вверх> или <Вниз> на клавиатуре компьютера.

Положение маркера - Marker position - текущая координата горизонтального маркера диаграммы распределения высот по вертикальной шкале высот СЗМ-изображения (правая ось диаграммы). Отображаемые единицы измерения указаны после имени параметра через запятую. В поле ввода координаты горизонтального маркера допускается ввод нового числового значения вручную. При установке курсора в поле параметра допускается также увеличение или уменьшение отображаемого значения на единицу нажатием, соответственно, кнопок <Вверх> или <Вниз> на клавиатуре компьютера. При изменении значения координаты любым способом соответствующим образом изменяется положение маркера на диаграмме.

В секции Tilt analysis (Анализ наклона) сгруппированы средства настройки диаграмм анализа углов, характеризующих положение элементарных площадок рассматриваемой поверхности.

Количество столбцов гистограммы - Number of bars - селектор для установки количества столбцов (вертикальных) на гистограмме распределения углов наклона (диаграмма в средней части окна представления данных анализа). Фактически устанавливает количество диапазонов, в которых будет определяться частота встречаемости локальных углов наклона, чьи значения попадают в данный промежуток. Меньшее значение параметра количества столбцов приводит к увеличению размера диапазонов и, соответственно, загрублению данных анализа. Большее количество столбцов уменьшает размер анализируемых диапазонов и повышает детализацию анализа. Изменение параметра количества столбцов допускается как с использованием кнопок увеличения/уменьшения значения, расположенных справа в поле ввода, так и непосредственным вводом нового числового значения вручную в поле ввода. При установке курсора в поле параметра допускается также увеличение или уменьшение отображаемого значения на единицу нажатием, соответственно, кнопок <Вверх> или <Вниз> на клавиатуре компьютера.

Локальный угол наклона (угол наклона) в программе SurfaceXplorer определяется как угол между нормалью к элементарной площадке СЗМ-изображения и вертикальной осью (угол a на рис. 2.5.2.5.2).

Рис. 2.5.2.5.2 - Схема определения: угол a - угол наклона между нормалью к элементарной площадке и вертикальной осью; угол b - угол ориентации проекции нормали к элементарной площадке на горизонтальной плоскости СЗМ-изображения.

Диапазон углов - Visible degrees (Видимый диапазон углов) - селектор для установки диапазона анализируемых локальных углов наклона менее 90°. Специфика СЗМ-изображений ограничивает полный диапазон локальных углов наклона значением +90°. Кроме того, в программе SurfaceXplorer анализируются абсолютные значения углов наклона, т.е. величины в диапазоне от 0 до 90°. На большинстве типов поверхностей локальные углы наклона обычно находятся в пределах 45°, поэтому для детального анализа распределения целесообразно ограничивать видимый диапазон углов с помощью данного селектора. Изменение параметра диапазона углов допускается как с использованием кнопок увеличения/уменьшения значения, расположенных справа в поле ввода, так и непосредственным вводом нового числового значения вручную в поле ввода. При установке курсора в поле параметра допускается также увеличение или уменьшение отображаемого значения на единицу нажатием, соответственно, кнопок <Вверх> или <Вниз> на клавиатуре компьютера.

При изменении видимого диапазона углов, тем не менее следует учитывать, что количество столбцов гистограммы распределения не пересчитывается и остается действующим для полного диапазона 0-90°. Поэтому для повышения детализации рекомендуется вместе с уменьшением диапазона углов увеличивать также количество столбцов гистограммы.

Анализируемый диапазона высот - Analyzed height range - селектор для установки диапазона высот СЗМ-изображения, который будет учитываться при анализе локальных углов наклона и ориентации. Предусматривается выбор либо полного - Full, либо ограниченного (настраиваемого) - Selected диапазона. При выборе ограниченного (Selected) диапазона необходимо вручную установить нижнюю и верхнюю границы анализируемого промежутка.

Нижняя граница анализируемого диапазона высот - from### - поле ввода цифрового значения нижней границы промежутка для анализа локалных углов. Значение вводится вручную после установки курсора в поле ввода. Ввод завершается либо при нажатии клавиши <Enter> на клавиатуре кпмьютера, либо установкой курсора в другом поле ввода.

Верхняя граница анализируемого диапазона высот - to### - поле ввода цифрового значения верхней границы промежутка для анализа локалных углов. Значение вводится вручную после установки курсора в поле ввода. Ввод завершается либо при нажатии клавиши <Enter> на клавиатуре компьютера, либо установкой курсора в другом поле ввода.

Задавая ограниченный диапазон, предоставляется возможность анализировать локальные углы интересующий пользователя промежуток высот (обычно - значимый промежуток высот).

Количество секторов ориентации - Orientation sectors - селектор для установки количества секторов на круговой диаграмме распределения углов ориентации (диаграмма в правой части окна представления данных анализа). Фактически устанавливает количество диапазонов, в которых будет определяться частота встречаемости локальных углов ориентации элементарных площадок, чьи значения попадают в данный промежуток. Меньшее значение параметра количества секторов приводит к увеличению размера диапазонов и, соответственно, загрублению данных анализа. Большее количество секторов уменьшает размер анализируемых диапазонов и повышает детализацию анализа. Изменение параметра количества секторов ориентации допускается как с использованием кнопок увеличения/уменьшения значения, расположенных справа в поле ввода, так и непосредственным вводом нового числового значения вручную в поле ввода. При установке курсора в поле параметра допускается также увеличение или уменьшение отображаемого значения на единицу нажатием, соответственно, кнопок <Вверх> или <Вниз> на клавиатуре компьютера.

Локальный угол ориентации (угол ориентации) в программе SurfaceXplorer определяется как угол орентации в горизонтальной плоскости (номинальной поверхности СЗМ-изображения) проекции нормали к элементарной площадке СЗМ-изображения (угол b на рис. 2.5.2.5.2).

В секции Colors (Цвета) представлены средства настройки цветов графических элементов диаграмм в окне данных анализа.

Селектор элементов диаграмм - используется для выбора элемента диаграмм, цвет которого будет настраиваться.

Кнопка выбора цвета - Color selection button - отображает цвет элемента диаграмм, выбранного в селекторе. Цвет кнопки изменяется соответственно текущему цвету выбранного элемента. При однократном нажатии на кнопку вызывается стандартная системная панель настройки цвета (рис. 2.5.2.5.3), с помощью которой осуществляется визуальный выбор или создание необходимого цветового оттенка.

System panel for adjusting color of the selected component
Рис. 2.5.2.5.3 - Системная панель настройки цвета в исходном состоянии (до нажатия кнопки Define Custom Colors >> )

Кнопка установки параметров по умолчанию - Set as default - при нажатии сохраняет текущие параметры, установленные в панели настройки диаграмм анализа, как параметры, используемые программой по умолчанию. Вновь открываемые окна представления данных анализа будут настроены согласно сохрененному набору параметров по умолчанию.


SurfaceXplorer :: Profile Adjustment Panel

[Интерфейс пользователя] > [Панель объектов] > [Вкладка Свойства] > [Профиль]

2.5.2.4 Панель настройки параметров профиля поперечного сечения

Panel for color palette adjustment
Рис. 2.5.2.4.1 - Панель настройки параметров профиля поперечного сечения (нажмите на соответствующий элемент для перехода к его описанию)
Button for adding new line Button for deleting active line Selector of active line Selector of the data type linked with the line Selector for assignment of the axis for the line Button for selecting color of the line Show midline option On-line normalization option On-line elimination of general straight line off the profile (tilt elimination) On-line elimination of general parabolic line off the profile Option allowing to plot first order derivative instead of original active line Option for depicting approximating staright line between marker points on active line Selector of the filtered points number Selector of the line thickness (in pixels) Selector of the data point markers Selector of spline type for the active line smoothing Option for displaying line legend on the plot Option of showing grid for the adjusted axis Option for autoscaling adjusted axis Field for entering maximum value for the axis range wihout autoscaling Field for entering minimum value for the axis range wihout autoscaling Selector of the axis for adjusting settings Button for showing the selection lines corresponding to the cross-section in active profile window in parential 2D visualisation window Table of the installed nodes coordinates Command for setting current settings as default ones Group of profile line control Group of controls for plot axes Group of selection nodes control

На панели [Profile] (Профиль) (рис. 2.5.2.4.1) размещены средства для настройки параметров отображения линий профиля поперечного сечения в соответствующем специализированном окне.

На панели всегда отображается состояние и обеспечивается настройка параметров в активном окне профиля, и при смене активного окна отображаемое состояние соответственно обновляется (актуализируется). Панель допускает ее отстыковку от родительской вкладки - Properties (Свойства) и свободное размещение в границах рабочего стола на мониторе компьютера поверх остальных окон программы SurfaceXplorer.

Для вызова панели можно воспользоваться одним из следующих способов:
- активировать ярлык панели [Profile] (Профиль) на левой границе вкладки Properties (Свойства) в секторе работы с объектами программы (в случае, если панель пристыкована к вкладке);
- в контекстном меню, вызываемом правой кнопкой мыши в окне визуализации профиля поперечного сечения, выбрать пункт Properties;
- в свободном месте окна визуализации профиля поперечного сечения щелкнуть два раза левой кнопкой мыши.

Использование последних двух способов - наиболее быстрый путь вызова панели настройки профиля, если активны вкладки, иные чем вкладка Properties (Свойства). Альтернативный подход для обеспечения быстрого доступа к ресурсам панели - отстыковать ее от вкладки и разместить панель отдельно.

Элементы панели настройки параметров профиля поперечного сечения

В секции LINE (Линия) сгруппированы средства настройки отображения линий профиля.

Селектор активной линии - [image] - в центральной части отображается номер активной линии, для которой производится настройка параметров в панели. Все перечисляемые линии относятся к текущему окну визуализации профиля поперечного сечения. Кнопки в левой части селектора позволяют переключаться между активными линиями. Кнопка в правой части селектора вызывает выпадающий список всех имеющихся в текущем окне линий профиля.

Активизировать линию профиля можно непосредственно щелчком по ней левой кнопкой мыши в окне визуализации профиля поперечного сечения.

Кнопка добавления линии профиля - + - добавляет новую линию профиля к списку доступных в текущем окне визуализации профиля поперечного сечения. Новая линия строится в окне профиля на основании данных для активной до этого момента линии (фактически - дублирует ее) и по умолчанию относится к левой шкале высот на графике профильных линий. Новая линия автоматически активизируется.

Кнопка удаления активной линии профиля - X - удаляет активную линию профиля в текущем окне визуализации профиля поперечного сечения.

Селектор типа данных - Data type - при наличии в файле совместных полей данных позволяет назначить для активной линии профиля отображаемый тип данных. Профили поперечного сечения автоматически подготавливаются для всех полей данных при выделении линии на СЗМ-изображении в окне двухмерного представления по идентичным параметрам. При переключении активной линии профиля имя отображаемого в селекторе поля автоматически переключается соответствующим образом (актуализируется).

Селектор вертикальной оси - Axis - относит активную линию к левой (L) или правой (R) вертикальной оси графика профильных линий. Использование двух осей позволяет использовать различные масштабы по вертикали для оптимального отображения данных.

Селектор цвета активной линии - Color - предоставляет средства для настройки цвета активной линии профиля на графике в текущем окне визуализации профиля поперечного сечения. При однократном нажатии на кнопку (цветовое поле) вызывается стандартная системная панель настройки цвета (рис. 2.5.2.4.2), с помощью которой осуществляется визуальный выбор или создание необходимого цветового оттенка. Цвет кнопки изменяется соответственно цвету активной линии.

System panel for color adjustment
Рис. 2.5.2.4.2 - Системная панель настройки цвета.

Опция отображения средней линии - Show middle line - при активации включает отображение средней линии для активного профиля поперечного сечения на графике. Средняя линия автоматически рассчитывается аппроксимацией всех точек соответствующего профиля по методу наименьших квадратов и характеризует общий наклон профиля.

Положение средней линии на графике можно изменять вручную перетаскиванием ее левой и правой частей в случае, если другие опции в секции отключены [image] .

Опция нормализации данных - Normalize - при активации смещает точку начала отсчета шкалы высот на один уровень с нижней точкой профиля.

Опция вычитания из профиля прямой линии - Eliminate line - вычитание "на лету" из линии профиля аппроксимирующей прямой линии. Функция автоматически устраненяет общий наклон линии профиля. Аппроксимация осуществляется по методу наименьших квадратов. Автоматический расчет аппроксимирующей линии активируется опцией отображения средней линии. При изменении положения аппроксимирующей прямой линии вручную из профиля вычитается прямая, установленная пользователем (практически - вычитается та прямая, которая отображается на графике). Активация данной опции автоматически отключает функцию вычитания из профиля параболической линии. В примере красная линия профиля получена вычитанием средней прямой из профиля синего цвета:

Опция вычитания из профиля параболической линии - Eliminate parabola - вычитание "на лету" из линии профиля аппроксимирующей параболической линии. Функция автоматически устраненяет общий наклон и сферическую составляющую из текущей линии профиля. Аппроксимация осуществляется по методу наименьших квадратов автоматически. Активация данной опции автоматически отключает функцию вычитания из профиля прямой линии. В примере красная линия профиля получена вычитанием параболы из профиля синего цвета:

Опция отображения производной первого порядка - 1st order derivative - при активации отображает вместо исходных данных их превую производную - фактически локальные изменения данных, разницу высот между соседними точками. В примере красная линия представляет собой производную первого порядка для синей линии профиля:

Опция отображения аппроксимирующей линии - Fit line between markers - при активации отображает аппроксимирующую прямую линию на участке между маркерами [a] и [b] для соответствующей линии профиля. Линия автоматически рассчитывается аппроксимацией по методу наименьших квадратов всех точек участка профиля, ограниченного маркерами. Аппроксимирующая линия отображается пунктирной линией толщиной 1 пиксел и того же цвета, что и соответствующая линия профиля, например:

Example of fit line between markers

List of available point markers

Маркер точек данных - Point marker - селектор для установки типа маркера (графической метки) для точек данных активной линии на графике в текущем окне визуализации профиля поперечного сечения. По умолчанию точки данных маркерами не отмечаются (вариант None). В списке доступны маркеры квадрат (Square), окружность (Circle), треугольник (Triangle), перевернутый треугольник (Triangle down), перекрестие + (Cross), диагональное перекрестие X (Diagonal cross), ромб (Diamond). Например:

Example of profile lines with markers

Селектор толщины линии - Thickness - устанавливает толщину (в пикселах) активной линии на графике в текущем окне визуализации профиля поперечного сечения. По умолчанию толщина линии составляет 1 пиксел. Максимальная толщина линии, предусмотренная в селекторе - 4 пиксела. При необходимости установить толщину линии более 4 пикселов допускается ввод целого числа в поле ввода селектора вручную. В примере для красной линии профиля установлена толщина 3, для синей - 1.

Селектор сглаживания - Spline - устанавливает тип сглаживания для активной линии на графике в текущем окне визуализации профиля поперечного сечения. По умолчанию функция сглаживания отключена (None). В селекторе предусмотренны варианты использования сплайнов 3-го (3rd order), 4-го (4th order) и 5-го (5th order) порядков.

Селектор точек фильтрации - Filter points - устанавливает количество окружающих точек линии профиля, высоты которых будут использованы для фильтрации - усреднения значения. Позволяет сгладить линию, но на линии отсекаются крайние точки данных. По умолчанию функция фильтрации отключена (0). Максимальное количество точек фильтрации, предусмотренное в селекторе - 10. Допускается установка иного произвольного целого числа точек фильтрации вводом его значения в поле ввода селектора вручную.

В секции AXES (Оси) сгруппированы средства настройки осей на графике профиля.

Опция отображения легенды - Show legend - при активации включает в правом верхнем углу поля графика подписи к цветам линий. Цветам отображаемых на графике линий ставятся в соответствие названия полей данных, определяемые в свою очередь селектором цвета активной линии. Данная опция относится ко всему графику.

Selector of actile axis for its adjustment

Селектор активной оси (поле в левой части сектора) - активирует левую (Left), правую (Right) или нижнюю (Bottom) оси графика для применения к ним настроек, справа от селектора. Активная в данный момент ось выделяется в поле селектора.

Опция отображения линий сетки - Show grid - выводит в поле графика линии сетки для настраиваемой в данный момент оси. Линии сетки отображаются как пунктирные линии препендикулярные настраиваемой оси. Состояние опции актуализируется при переключении активной оси в селекторе слева.

Опция автомасштабирования оси - Autoscale - включает функцию автоматического масштабирования оси в соответствии с отображаемой(-ыми) линией профиля на графике. Минимальное и максимальное значения настраиваемой оси автоматически устанавливаются программой так, чтобы соответствующая линия профиля (или все оносящиеся к данной оси линии профиля) помещались в поле графика. Автомасштабирование производится интерактивно при изменении параметров линии выделения и, соответственно, отображаемого профиля поперечного сечения по этой линии выделения. Состояние опции актуализируется при переключении активной оси в селекторе слева.

При отключении опции автомасштабирования для всех осей предоставляется возможность интерактивного масштабирования:

Ctrl + Zoom+

1. Приближение ("увеличение", "наезд", zoom-in) выделяемого участка графика с масштабированием до размера области построения. Выделение производится в области построения "растягиванием" прямоугольника - при удержании нажатой клавиши Ctrl на клавиатуре компьютера и одновременном проведении мышью с нажатой левой кнопкой диагональной линии из левого верхнего до правого нижнего угла интересующей зоны. Например:

Ctrl + Show all

2. Возврат к отображению в области построения всего графика (zoom-out). Выполняется "растягиванием" прямоугольника в любом месте области построения - при удержании нажатой клавиши Ctrl на клавиатуре компьютера и одновременном проведении мышью с нажатой левой кнопкой диагональной линии из правого нижнего до левого верхнего угла произвольной зоны. Например:

Alt+ Move

3. Перемещение линий графика в поле построения - перетаскиванием графика при нажатой левой кнопке мыши и удержании клавиши Alt на клавиатуре компьютера. Например:

Поле ввода минимального значения по оси - Min# - при отключении функции автомасштабирования оси позволяет вручную установить минимальное значение по настраиваемой оси. Состояние опции актуализируется при переключении активной оси в селекторе слева.

Поле ввода максимального значения по оси - Max# - при отключении функции автомасштабирования оси позволяет вручную установить максимальное значение по настраиваемой оси. Состояние опции актуализируется при переключении активной оси в селекторе слева.

В секции NODES (Узлы) сгруппированы средства для работы с узловыми точками на выделенной линии в окне двухмерного представления, определяющей линию поперечного сечения в текущем окне профиля.

Кнопка востановления узловых точек выделения - Show selection nodes - при нажатии восстанавливает на СЗМ-изображении в родительском окне двухмерного представления линию выделения, по которой был построен соответствующий профиль поперечного сечения. Данная функция выполняется независимо от того, какой объект выделения установлен на СЗМ-изображении в текущий момент. Параметры линии выделения для каждого профиля поперечного сечения сохраняются программой независимо как отдельный объект, и поэтому для активного окна профиля соответствующая линия выделения может быть восстановлена в родительском окне двухмерного представления при нажатии кнопки Show selection nodes.

Данная особенность может быть использована для выделения на СЗМ-изображении более чем одного объекта линейного типа. Для этого необходимо построить в отдельных окнах профиль поперечного сечения для каждой выделенной линии. Чтобы восстановить после этого объект выделения (линию) на СЗМ-изображении, необходимо активировать соответствующее ему окно профиля и затем в панели [Profile] нажать кнопку Show selection nodes.

Таблица координат узловых точек - отображает положение узловых точек линии выделения, определяющей текущий профиль поперечного сечения, на СЗМ-изображении в родительском окне двухмерного представления.

В первой колонке (No.) перечисляются номера узловых точек выделенной линии на СЗМ-изображении (соответствующих меткам). Во второй (x) и третьей (y) колонках указываются координаты узловых точек по оси X и Y, соотвественно, в точках матрицы данных - данное число всегда целое. В четвертой (x, um) и пятой (y, um) колонках приводятся координаты узловых точек по оси X и Y, соотвественно, в указанных линейных единицах. Значения координат могут быть изменены вручную после установки в необходимое поле ввода в таблице курсора. После ввода нового значения (в любом из форматов - в точках или в линейных единицах) положение узловой точки (соответственно - выделенной линии) соответствующим образом изменится и на СЗМ-изображении. Данная таблица аналогична таблице узловых точек в панели [2D], однако она активизируется только при построении профиля поперечного сечения.

Установки по умолчанию - Set as default - кнопка для сохранения текущих настроек панели как установок, используемых программой по умолчанию.


SurfaceXplorer :: 3D Settings Panel

[Интерфейс пользователя] > [Сектор объектов] > [Вкладка Свойства] > [Панель 3D]

2.5.2.2 Панель настройки трехмерного представления СЗМ-данных

Panel [3D] in simple (reduced) mode
Рис. 2.5.2.2.1 - Панель настройки трехмерного представления СЗМ-данных в упрощенном варианте (нажмите на соответствующий элемент для перехода к его описанию)

На панели [3D] (рис. 2.5.2.2.1) размещены средства для настройки параметров отображения СЗМ-данных в окне трехмерного представления. На панели всегда отображается состояние параметров активного окна трехмерной визуализации и обеспечивается их настройка. При смене активного окна трехмерного представления состояние настраиваемых параметров соответственно обновляется (актуализируется). Панель допускает ее отстыковку от родительской вкладки - Properties (Свойства) и свободное размещение в границах рабочего стола на мониторе компьютера поверх остальных окон программы SurfaceXplorer. Option for switching light simulation Tilt of simulated light source over the horizontal plane Orientation angle of simulated light source Graphical zone for adjusting simulated light source position relative SPM image Graphical zone for adjusting camera position relative SPM image Tilt of the view camera over the horizontal plane Orientation angle of the view camera Option of coloring 3D image in one color Slider for adjusting vertical scale in current 3D image Slider for adjusting distance from view camera to 3D SPM image (object) Button for assignment current panel settings as default ones Command for saving current settings under own name Command for loading earlier saved named settings scheme Button for switching into advanced version of the panel Selector of joint SPM-data fields to be used as a color skin for current 3D frame Selector of material simulation presets for current 3D image Title of group controlling simulated light source position Title of group for adjusting camera position Title of group for adjusting skin attributes of the 3D image

Для вызова панели можно воспользоваться одним из следующих способов:
- активировать ярлык панели [3D] на границе вкладки Properties (Свойства) в секторе работы с объектами программы (в случае, если панель пристыкована к вкладке);
- в контекстном меню, вызываемом правой кнопкой мыши в окне трехмерного представления, выбрать соответстсвующий пункт 3D View properties);

- в окне трехмерного представления щелкнуть два раза левой кнопкой мыши (необходимо следить при этом, чтобы курсор при нажатии был неподвижен).

Использование последних двух способов - наиболее быстрый путь вызова панели [3D], если активны вкладки, иные чем вкладка Properties (Свойства). Альтернативный подход для обеспечения быстрого доступа к ресурсам панели - отстыковать ее от вкладки и разместить панель отдельно.

Особенностью панели настройки трехмерного СЗМ-изображения является наличие двух вариантов ее представления - упрощенного Simple << и развернутого Advanced >>.

Элементы панели настройки трехмерного представления в упрощенном варианте

В упрощенном варианте панель [3D] предоставляет доступ к настройке наиболее часто используемых параметров трехмерного СЗМ-изображения. Все элементы настройки размещаются на одной панели, что позволяет пользоваться ими оперативно (без дополнительных переключений подгрупп).

Секция настройки источника света - Light - содержит средства настройки положения виртуального источника света относительно СЗМ-изображения в окне трехмерного представления.

Переключатель - On/Off (Вкл./Выкл) - включает/отключает функцию виртуальной подсветки трехмерного СЗМ-изображения. В отключенном (деактивированном) состоянии обеспечивается представление СЗМ-изображения с окрашиванием каждой точки данных в соответствии с настроенной цветовой палитрой, во включенном (активированном) состоянии - имитируется освещение трехмерного СЗМ-изображения виртуальным источником света. При имитации освещения предусматривается как сохранение исходной цветовой палитры оболочки, так и использование одного цвета для всего СЗМ-изображения, а также возможность выбора пользователем вариантов имитации цветовых характеристик поверхности того или иного материала.

Зона графической установки положения источника света (окружность с закрашенным маркером внутри) - позволяет визуально устанавливать положение виртуального источника света относительно СЗМ-изображения в окне трехмерного представления. Установка (изменение положения) производится перемещением маркера при нажатой левой кнопке мыши (т.е. перетаскиванием). При этом ориентация на плоскости радиуса, на котором расположен маркер, соответствует ориентации виртуального источника света относительно СЗМ-изображения, а расстояние от маркера до центра окружности определяет угол наклона этого источника над СЗМ-изображением. Фактически, маркер представляет собой проекцию положения виртуального источника света в пространстве на плоскость СЗМ-изображения (рис. 2.5.2.2.2).

Следует помнить, что настройка положения виртуального источника света для окон двухмерного и трехмерного представления осуществляется независимо друг от друга.

Scheme of light source position adjustment
Рис. 2.5.2.2.2 - Схема соответствия положения виртуального источника света в пространстве положению маркера (проекции этого источника) в плоскости СЗМ-изображения.

Параметры расположения виртуального источника света в пространстве относительно центра СЗМ-изображения в аналитическом (цифровом) виде отображаются и могут изменяться вручную в полях ввода слева от зоны графической установки.

Угол наклона источника света - Tilt - цифровое поле, в котором отображается текущий угол наклона виртуального источника света над плоскостью СЗМ-изображения. В данном поле допускается ввод числовых значений вручную, что интерактивно изменяет положение маркера в зоне графической установки и, соответственно, виртуального источника относительно СЗМ-изображения. При установке курсора в поле ввода допускается также увеличение или уменьшение отображаемого значения на единицу нажатеим, соответственно, кнопок <Вверх> или <Вниз> на клавиатуре компьютера.

Угол ориентации источника света - Orientation - цифровое поле, в котором отображается текущий угол ориентации виртуального источника света в плоскости СЗМ-изображения. В данном поле допускается ввод числовых значений вручную, что интерактивно изменяет положение маркера в зоне графической установки и, соответственно, виртуального источника относительно СЗМ-изображения. При установке курсора в поле ввода допускается также увеличение или уменьшение отображаемого значения на единицу нажатеим, соответственно, кнопок <Вверх> или <Вниз> на клавиатуре компьютера.

Секция настройки положения точки обзора (камеры) - Camera - содержит средства настройки положения виртуальной камеры обзора относительно трехмерного СЗМ-изображения в окне представления.

Зона графической установки положения точки обзора (камеры) (окружность с закрашенным маркером внутри) - позволяет визуально устанавливать положение виртуальной камеры (точки обзора) относительно СЗМ-изображения для его отображения в окне трехмерного представления. Установка (изменение положения) производится перемещением маркера при нажатой левой кнопке мыши (т.е. перетаскиванием). При этом ориентация на плоскости радиуса, на котором расположен маркер, соответствует ориентации виртуальной камеры относительно СЗМ-изображения, а расстояние от маркера до центра окружности определяет угол наклона между камерой и плоскостью СЗМ-изображения. Фактически, маркер представляет собой проекцию положения виртуальной камеры (точки обзора) на плоскость СЗМ-изображения (рис. 2.5.2.2.3).

Следует помнить, что, поскольку точка расположения камеры представляется наблюдателю (пользователю) неподвижной, реальное изменение положения виртуальной камеры в зоне графической установке выглядит как вращение трехмерного СЗМ-изображения в противоположном направлении.

Scheme of a view point (camera) position adjustment
Рис. 2.5.2.2.3 - Схема соответствия положения виртуальной камеры в пространстве положению маркера (проекции точки ее положенияа) в плоскости СЗМ-изображения.

Процедура изменения положения виртуальной камеры в зоне графической установки аналогична непосредственному трансформированию положения СЗМ-изображения в окне трехмерного представления с помощью мыши. Однако более естественным образом (и кроме того интерактивно) трансформация осуществляется именно с помощью мыши. Поэтому использование зоны графической установки точки обзора для изменения положения трехмерного СЗМ-изображения оправдано лишь на низкопроизводительных компьютерах, поскольку окончательная перерисовка изображения в окне в этом случае будет производиться именно по окончании установки точки обзора в новое положение.

Параметры расположения виртуальной камеры в пространстве относительно центра СЗМ-изображения в аналитическом (цифровом) виде отображаются и могут изменяться вручную в полях ввода слева от зоны графической установки.

Угол наклона виртуальной камры - Tilt - цифровое поле, в котором отображается текущий угол наклона виртуальной камеры над плоскостью СЗМ-изображения. В данном поле допускается ввод числовых значений вручную, что интерактивно изменяет положение маркера в зоне графической установки и, соответственно, точки обзора СЗМ-изображения. При установке курсора в поле ввода допускается также увеличение или уменьшение отображаемого значения на единицу нажатеим, соответственно, кнопок <Вверх> или <Вниз> на клавиатуре компьютера.

Угол ориентации виртуальной камеры - Orientation - цифровое поле, в котором отображается текущий угол ориентации виртуальной камеры в плоскости СЗМ-изображения. В данном поле допускается ввод числовых значений вручную, что интерактивно изменяет положение маркера в зоне графической установки и, соответственно, точки обзора СЗМ-изображения. При установке курсора в поле ввода допускается также увеличение или уменьшение отображаемого значения на единицу нажатеим, соответственно, кнопок <Вверх> или <Вниз> на клавиатуре компьютера.

Расстояние до точки обзора (виртуальной камеры) - Distance - вертикальный регулятор аналогового типа справа от зоны графической установки, обеспечивающий настройку расстояния между трехмерным СЗМ-изображением и точкой обзора (виртуальной камерой). Перемещение регулятора вниз по шкале "уменьшает", перемещение вверх - "увеличитвает" расстояние между СЗМ-изображением и точкой обзора. Для пользоваетля эти операции выглядят, соответственно, как увеличение и уменьшение СЗМ-изображения в окне трехмерного представления - т.е. практически данная функция равносильна масштабированию трехмерного СЗМ-изображения. После активации регулятора (т.е. его задействования) допускается также перемещение его вверх или вниз нажатеим, соответственно, кнопок <Вверх> или <Вниз> на клавиатуре компьютера. Процедура изменения расстояния до точки обзора аналогична непосредственному трансформированию положения СЗМ-изображения в окне трехмерного представления с помощью мыши (комбинация Ctrl + Left mouse button).

Секция параметров оболочки - Skin (Оболочка)- содержит средства настройки параметров оболочки трехмерного СЗМ-изображения в окне представления. Способ представления трехмерного СЗМ-изображения в программе SurfaceXplorer предусматривает совмещение исходного трехмерного каркаса, построенного на основе СЗМ-данных о топографии поверхности, с оболочкой, определяемой, например, картой свойств этой же поверхности (рис. 2.5.2.2.4).

Топография 2D topography image of the surface | Карта локальной жесткости 2D Phase contrast image: map of local material stiffness
3D frame of the topography SPM image | 3D каркас поверхности
3D topography image Трехмерное изображение топографии | Mixed 3D image: color skin (pase contrast image) covers 3D frame (constructed from topography data) Совместное трехмерное изображение
Рис. 2.5.2.2.4 - Схема формирования трехмерного СЗМ-изображения с накладыванием цветовой оболочки на трехмерный каркас. Правая колонка: формирование обычного трехмерного изображения топографии (внизу). Цветовая оболочка, характеризующая высоту точек рельефа, (вверху) накладывается на трехмерный каркас, сформированный на основе СЗМ-данных о топографии поверхности (посредине). Левая колонка: формирование смешанного СЗМ-изображения (внизу). Цветовая оболочка, характеризующая расппределение локальной жесткости на участке поверхности (на основе данных о фазовом контрасте ), (верху) накладывается на трехмерный каркас, сформированный на основе СЗМ-данных о топографии поверхности (посредине).

Оболочка - селектор вверху секции Skin для назначения одного из совместных типов данных, имеющихся в текущем СЗМ-файле, в качестве оболочки, совмещаемой с построенным трехмерным каркасом. Например, на рис. 2.5.2.2.4 оболочкой для трехмерного каркаса, сформированного из данных о топографии поверхности, служит совместное СЗМ-изображение фазового контраста (практически - карта локальной жесткости).

По умолчанию оболочка трехмерного СЗМ-изображения изначально формируется на основе тех же данных, что и трехмерный каркас, т.е., к примеру, трехмерная топография совмещается с картой высот, определяемой двухмерным изображением этой же топографии.

Цветовая палитра оболочки определяется пользователем в соответствующем ее типу данных окне двухмерного представления. Если, напрмер, трехмерный каркас топографии совмещается с оболочкой на основе изображения фазового контраста, то для изменения цветовой палитры оболочки необходимо активировать окно двухмерного представления с изображением фазового контраста (например, с помощью селектора [image] на панели инструментов или меню View > View 2D > Phase) и в нем произвести необходимые настройки с помощью панели [Palette].

Материал - Material - селектор выбора одной из предустановленных схем для имитации поверхности какого-либо материала. Имитация поверхности матерала осуществляется посредством функций OpenGL, на базе которых реализовано трехмерное представление СЗМ-изображений в программе SurfaceXplorer. Произвольная настройка цветовых параметров для имитации свойств материала поверхности предусматривется в секции Skin расширенного варианта панели [3D].

Один цвет для материала - Single color material - опция окрашивания оболочки в один цвет независимо от установленной пользователем цветовой шкалы. Цвет оболочки при включении данной опции определяется настройками функции OpenGL, отвечающей за имитацию материала поверхности (см. описание настройки параметров оболочки для расширенного варианта панели [3D]).

Вертикальный масштаб - Z scale [#.#:1] - горизонтальный регулятор аналогового типа для интерактивного изменения масштаба вертикальной шкалы (оси Z) СЗМ-изображения в окне трехмерного представления. В квадратных скобках после названия параметра приводится текущее значение масштаба. Данный параметр определяет, во сколько раз линейные размеры, отображаемые по вертикальной шкале, больше линейных размеров по оси, соответствующей наибольшему диапазону на СЗМ-изображении (практически - диапазону по X или Y). Линейный размер максимального диапазона принимается за единицу. Минимальное значение регулятора (крайнее левое положение) соответствует нулевому масштабу высот, т.е. делает трехмерное изображение плоским, сохраняя возможность его трансформации (поворота, общего масштабирования).

Назначение параметров по умолчанию - Set as default - кнопка для сохранения текущих настроек панели в качестве набора, используемую программой по умолчанию. Фактически - записывает ее в файл настройки палитры default.3dp в подкаталоге Сonfig программы SurfaceXplorer.

Сохранение текущего набора параметров - Save - кнопка для вызова системного диалогового окна сохранения файла, в который будет записана текущий набор параметров панели [3D]. Расширение имени файла по умолчанию - *.3dp. Рекомендуется не изменять предлагаемое расширение имени файла, а также предусмотреть сохранение файла в подкаталоге Сonfig программы SurfaceXplorer.

Загрузка набора параметров - Load - кнопка для вызова системного диалогового окна открытия файла с ранее сохраненным набором параметров панели [3D]. Расширение имени файла по умолчанию - *.3dp.

Развернутый вариант - Advanced >> - кнопка переключения в развернутый вариант панели [3D].

Элементы панели настройки трехмерного представления в развернутом варианте

В развернутом варианте панель [3D] предоставляет доступ к настройке всех изменяемых параметров изображения в окне трехмерного представления СЗМ-данных. Все элементы настройки размещаются в двух подгруппах: View (Просмотр) (рис. 2.5.2.2.5) и Draw (Оформление) (рис. 2.5.2.2.7), переключаемых соответсвующими закладками у верхней границы панели.

Group of View parameters in advanced mode of panel [3D] Button for activating View mode of the 3D settings panel Button for activating Draw mode of the 3D settings panel Orientation angle of simulated light source Selector of the adjusted illumination parameters Sliders for adjusting red, green and blue channels intensity of selected illumination parameter Example of the adjusted light color and button for bringing up a system panel for color adjustment Graphical zone for adjusting simulated light source position relative SPM image Tilt of simulated light source over the horizontal plane Slider for adjusting distance between virtual light source and 3D SPM image (object) Tilt of simulated light source over the horizontal plane Option for switching light simulation Option for switching directional light simulation Tilt of the view camera over the horizontal plane Slider for adjusting distance from view camera to 3D SPM image (object) Orientation angle of the view camera Button for switching into simple mode of the panel Command for loading earlier saved named settings scheme Graphical zone for adjusting camera position relative SPM image Example of the adjusted light color and button for bringing up a system panel for color adjustment Slider for adjusting shineness of the selected material color parameter Command for saving current settings under own name Option of coloring 3D image in one color Selector of joint SPM-data fields to be used as a color skin for current 3D frame Selector of material simulation presets for current 3D image Selector of the adjusted material color parameters Sliders for adjusting red, green and blue channels intensity of selected material color parameter Button for assignment current panel settings as default ones Title of group controlling simulated light source position Title of group for adjusting camera position Title of group for adjusting skin attributes of the 3D image
Рис. 2.5.2.2.5 - Подгруппа View (Просмотр) панели настройки трехмерного представления СЗМ-данных в развернутом варианте.(нажмите на соответствующий элемент для перехода к его описанию)

Подгруппа View (Просмотр) объединяет параметры, непосредственно относящиеся к управлению внешним видом трехмерного СЗМ-изображения. Практически данная подгруппа аналогична панели [3D] в упрощенном варианте, но содержит также дополнительные расширенные средства управления цветом с помощью функций OpenGL, на основе которых в программе реализуется трехмерное представление СЗМ-данных.

Секция настройки источника света - Light - содержит средства настройки положения виртуального источника света относительно СЗМ-изображения в окне трехмерного представления.

Переключатель On/Off (Вкл./Выкл) включает/отключает функцию виртуальной подсветки трехмерного СЗМ-изображения. В отключенном (деактивированном) состоянии обеспечивается представление СЗМ-изображения с окрашиванием каждой точки данных в соответствии с настроенной цветовой палитрой, во включенном (активированном) состоянии - имитируется освещение трехмерного СЗМ-изображения виртуальным источником света. При имитации освещения предусматривается как сохранение исходной цветовой палитры оболочки, так и использование одного цвета для всего СЗМ-изображения, а также возможность выбора пользователем вариантов имитации цветовых характеристик поверхности того или иного материала.

Направленный свет - Directional (Направленный) - опция включения имитации направленного освещения функции виртуальной подсветки. В выключенном состоянии предполагается, что виртуальный источник света обеспечивает равномерное (ненаправленное) освещение пространства над СЗМ-изображением.

Зона графической установки положения источника света (окружность с закрашенным маркером внутри) - позволяет визуально устанавливать положение виртуального источника света относительно СЗМ-изображения в окне трехмерного представления. Установка (изменение положения) производится перемещением маркера при нажатой левой кнопке мыши (т.е. перетаскиванием). При этом ориентация на плоскости радиуса, на котором расположен маркер, соответствует ориентации виртуального источника света относительно СЗМ-изображения, а расстояние от маркера до центра окружности определяет угол наклона этого источника над СЗМ-изображением. Фактически, маркер представляет собой проекцию положения виртуального источника света в пространстве на плоскость СЗМ-изображения (рис. 2.5.2.2.2).

Следует помнить, что настройка положения виртуального источника света для окон двухмерного и трехмерного представления осуществляется независимо друг от друга.

Параметры расположения виртуального источника света в пространстве относительно центра СЗМ-изображения в аналитическом (цифровом) виде отображаются и могут изменяться вручную в полях ввода слева от зоны графической установки.

Угол наклона источника света - Tilt - цифровое поле, в котором отображается текущий угол наклона виртуального источника света над плоскостью СЗМ-изображения. В данном поле допускается ввод числовых значений вручную, что интерактивно изменяет положение маркера в зоне графической установки и, соответственно, виртуального источника относительно СЗМ-изображения. При установке курсора в поле ввода допускается также увеличение или уменьшение отображаемого значения на единицу нажатеим, соответственно, кнопок <Вверх> или <Вниз> на клавиатуре компьютера.

Угол ориентации источника света - Orientation - цифровое поле, в котором отображается текущий угол ориентации виртуального источника света в плоскости СЗМ-изображения. В данном поле допускается ввод числовых значений вручную, что интерактивно изменяет положение маркера в зоне графической установки и, соответственно, виртуального источника относительно СЗМ-изображения. При установке курсора в поле ввода допускается также увеличение или уменьшение отображаемого значения на единицу нажатеим, соответственно, кнопок <Вверх> или <Вниз> на клавиатуре компьютера.

Расстояние до источника света - Distance - вертикальный регулятор аналогового типа справа от зоны графической установки, обеспечивающий настройку расстояния между трехмерным СЗМ-изображением и точкой расположения виртуального источника света. Перемещение регулятора вниз по шкале "уменьшает", перемещение вверх - "увеличитвает" расстояние между СЗМ-изображением и источником. Соответственно освещенность СЗМ-изображения при этом увеличивается и уменьшается. После активации регулятора (т.е. его задействования) допускается также перемещение его вверх или вниз нажатеим, соответственно, кнопок <Вверх> или <Вниз> на клавиатуре компьютера.

Selector of the illumination color parameters Цветовые параметры освещения - селектор настраиваемых параметров функции визуализации OpenGL, позволяющий пользователю регулировать цветовые характеристики виртуального освещения СЗМ-изображения.
- Ambient - окружающая среда;
- Diffuse - рассеянный свет;
- Specular - отраженный свет;
- Background - цвет фона окна трехмерного представления.

Выбрав один из перечисленных элементов в селекторе, его цвет настраивается затем с помощью либо регуляторов цветовых каналов, либо кнопки вызова системной панели настройки цвета

Интенсивность цветовых каналов - группа из трех регуляторов аналогового типа R, G, B, позволяющих настраивать цвет выбранного в селекторе параметра освещения, изменяя интенсивность компонент, соответственно - Red (красной), Green (зеленой), Blue (синей). Крайнее левое положение регулятора соответствует минимуму (отсутствию), а крайнее правое - максимуму интенсивности данной компоненты в цветовом оттенке. Образец установленного цветового оттенка отображается на кнопке под группой регуляторов интенсивности каналов. Альтернативный способ настройки цвета выбранного параметра - настройка с помощью системной цветовой панели, активируемой при нажатии на кнопку настройки цвета.

Цвет параметра - кнопка под группой регуляторов цветовых каналов, отображающая образец установленного цветового оттенка для выбранного параметра освещения, а также при однократном нажатии на нее активизирующая системную панель настройки цвета (рис. 2.5.2.2.6). Изменение цвета с помощью системной панели соответсвующим образом изменяет цвет выбранного параметра освещения.

System panel for the color adjustment
Рис. 2.5.2.2.6 - Системная панель настройки цвета в исходном состоянии.

Секция настройки положения точки обзора (камеры) - Camera - содержит средства настройки положения виртуальной камеры обзора относительно трехмерного СЗМ-изображения в окне представления. Данная секция полностью аналогична подобной секции в упрощенном варианте панели [3D].

Зона графической установки положения точки обзора (камеры) (окружность с закрашенным маркером внутри) - позволяет визуально устанавливать положение виртуальной камеры (точки обзора) относительно СЗМ-изображения для его отображения в окне трехмерного представления. Установка (изменение положения) производится перемещением маркера при нажатой левой кнопке мыши (т.е. перетаскиванием). При этом ориентация на плоскости радиуса, на котором расположен маркер, соответствует ориентации виртуальной камеры относительно СЗМ-изображения, а расстояние от маркера до центра окружности определяет угол наклона между камерой и плоскостью СЗМ-изображения. Фактически, маркер представляет собой проекцию положения виртуальной камеры (точки обзора) на плоскость СЗМ-изображения (рис. 2.5.2.2.3).

Следует помнить, что, поскольку точка расположения камеры представляется наблюдателю (пользователю) неподвижной, реальное изменение положения виртуальной камеры в зоне графической установке выглядит как вращение трехмерного СЗМ-изображения в противоположном направлении.

Процедура изменения положения виртуальной камеры в зоне графической установки аналогична непосредственному трансформированию положения СЗМ-изображения в окне трехмерного представления с помощью мыши. Однако более естественным образом (и кроме того интерактивно) трансформация осуществляется именно с помощью мыши. Поэтому использование зоны графической установки точки обзора для изменения положения трехмерного СЗМ-изображения оправдано лишь на низкопроизводительных компьютерах, поскольку окончательная перерисовка изображения в окне в этом случае будет производиться именно по окончании установки точки обзора в новое положение.

Параметры расположения виртуальной камеры в пространстве относительно центра СЗМ-изображения в аналитическом (цифровом) виде отображаются и могут изменяться вручную в полях ввода слева от зоны графической установки.

Угол наклона виртуальной камры - Tilt - цифровое поле, в котором отображается текущий угол наклона виртуальной камеры над плоскостью СЗМ-изображения. В данном поле допускается ввод числовых значений вручную, что интерактивно изменяет положение маркера в зоне графической установки и, соответственно, точки обзора СЗМ-изображения. При установке курсора в поле ввода допускается также увеличение или уменьшение отображаемого значения на единицу нажатеим, соответственно, кнопок <Вверх> или <Вниз> на клавиатуре компьютера.

Угол ориентации виртуальной камеры - Orientation - цифровое поле, в котором отображается текущий угол ориентации виртуальной камеры в плоскости СЗМ-изображения. В данном поле допускается ввод числовых значений вручную, что интерактивно изменяет положение маркера в зоне графической установки и, соответственно, точки обзора СЗМ-изображения. При установке курсора в поле ввода допускается также увеличение или уменьшение отображаемого значения на единицу нажатеим, соответственно, кнопок <Вверх> или <Вниз> на клавиатуре компьютера.

Ctrl +

Расстояние до точки обзора (виртуальной камеры) - Distance - вертикальный регулятор аналогового типа справа от зоны графической установки, обеспечивающий настройку расстояния между трехмерным СЗМ-изображением и точкой обзора (виртуальной камерой). Перемещение регулятора вниз по шкале "уменьшает", перемещение вверх - "увеличитвает" расстояние между СЗМ-изображением и точкой обзора. Для пользоваетля эти операции выглядят, соответственно, как увеличение и уменьшение СЗМ-изображения в окне трехмерного представления - т.е. практически данная функция равносильна масштабированию трехмерного СЗМ-изображения. После активации регулятора (т.е. его задействования) допускается также перемещение его вверх или вниз нажатеим, соответственно, кнопок <Вверх> или <Вниз> на клавиатуре компьютера. Процедура изменения расстояния до точки обзора аналогична непосредственному трансформированию положения СЗМ-изображения в окне трехмерного представления с помощью мыши (комбинация Ctrl + Left mouse button).

Секция параметров оболочки - Skin (Оболочка)- содержит средства настройки параметров оболочки трехмерного СЗМ-изображения в окне представления. Способ представления трехмерного СЗМ-изображения в программе SurfaceXplorer предусматривает совмещение исходного трехмерного каркаса, построенного на основе СЗМ-данных о топографии поверхности, с оболочкой, определяемой, например, картой свойств этой же поверхности (рис. 2.5.2.2.4).

Оболочка - селектор вверху секции Skin для назначения одного из совместных типов данных, имеющихся в текущем СЗМ-файле, в качестве оболочки, совмещаемой с построенным трехмерным каркасом. Например, на рис. 2.5.2.2.4 оболочкой для трехмерного каркаса, сформированного из данных о топографии поверхности, служит совместное СЗМ-изображение фазового контраста (практически - карта локальной жесткости).

По умолчанию оболочка трехмерного СЗМ-изображения изначально формируется на основе тех же данных, что и трехмерный каркас, т.е., к примеру, трехмерная топография совмещается с картой высот, определяемой двухмерным изображением этой же топографии.

Цветовая палитра оболочки определяется пользователем в соответствующем ее типу данных окне двухмерного представления. Если, напрмер, трехмерный каркас топографии совмещается с оболочкой на основе изображения фазового контраста, то для изменения цветовой палитры оболочки необходимо активировать окно двухмерного представления с изображением фазового контраста (например, с помощью селектора [image] на панели инструментов или меню View > View 2D > Phase) и в нем произвести необходимые настройки с помощью панели [Palette].

Материал - Material - селектор выбора одной из предустановленных схем для имитации поверхности какого-либо материала. Имитация поверхности матерала осуществляется посредством функций OpenGL, на базе которых реализовано трехмерное представление СЗМ-изображений в программе SurfaceXplorer. Произвольная настройка цветовых параметров для имитации свойтв поверхности материала осуществляется с помощью регуляторов интенсивности цветовых каналов либо кнопки настройки цвета внизу секции.

Один цвет для материала - Single color material - опция окрашивания оболочки в единый цвет независимо от установленной пользователем цветовой шкалы. Цвет оболочки при включении данной опции определяется настройками функции OpenGL, отвечающей за имитацию материала поверхности.

Selector of the skin color parameters Цветовые параметры оболочки - селектор настраиваемых параметров функции визуализации OpenGL, позволяющий пользователю регулировать цветовые характеристики виртуального освещения СЗМ-изображения.
- Ambient - окружающая среда;
- Diffuse - рассеянный свет;
- Specular - отраженный свет;
- Emission - светимость поверхности.

Выбрав один из перечисленных элементов в селекторе, его цвет настраивается затем с помощью либо регуляторов цветовых каналов, либо кнопки вызова системной панели настройки цвета

Интенсивность цветовых каналов - группа из трех регуляторов аналогового типа R, G, B, позволяющих настраивать цвет выбранного в селекторе параметра оболочки, изменяя интенсивность компонент, соответственно - Red (красной), Green (зеленой), Blue (синей). Крайнее левое положение регулятора соответствует минимуму (отсутствию), а крайнее правое - максимуму интенсивности данной компоненты в цветовом оттенке. Образец установленного цветового оттенка отображается на кнопке под группой регуляторов интенсивности каналов. Альтернативный способ настройки цвета выбранного параметра - настройка с помощью системной цветовой панели, активируемой при нажатии на кнопку настройки цвета.

Цвет параметра - кнопка под группой регуляторов цветовых каналов, отображающая образец установленного цветового оттенка для выбранного параметра оболочки, а также при однократном нажатии на нее активизирующая системную панель настройки цвета (рис. 2.5.2.2.6). Изменение цвета с помощью системной панели соответсвующим образом изменяет цвет выбранного параметра оболочки.

Регулятор уровня блеска - Shininess - регулятор аналогового типа для установки уровня "блеска" поверхности оболочки трехмерного СЗМ-изображения. Данный параметр является дополнительным к параметру отраженного света Specular. Максимальный уровень "блеска" (крайнее левое положение регулятора) придает всей поверхности оболочки цвет, установленный для параметра Specular ("зеркальные" свойства). Минимальный уровень "блеска" (крайнее правое положение регулятора) отключает влияние параметра Specular при имитации свойств поверхности материала.

Наиболее естественный блеск поверхности имитируется при установке белого цвета для параметра отраженного света Specular.

Group of Draw parameters in advanced mode of panel [3D] Button for activating View mode of the 3D settings panel Button for activating Draw mode of the 3D settings panel Parameters of 3D image rendering in still state Option for showing the X, Y, and Z axes in the 3D image Option of showing text labels for Z axis in the 3D image Selector of the surface rendering model Selector of pitch for rendered data points Parameters of the grid rendering when corresponding model is set Selector of pitch for rendered grid Slider for adjusting vertical axis scale of the 3D image Selector of pitch for rendered data points Selector of the surface rendering model Parameters of 3D image rendering during its movement (transformation) Example of X, Y and Z axes color and button for bringing up a system panel for the color adjustment Option of showing text labels for X and Y axes in the 3D image Title of group for adjusting XYZ axes parameters in 3D visualization window Selector of grid line thickness Button for switching into simple mode of the panel Command for loading earlier saved named settings scheme Command for saving current settings under own name Button for assignment current panel settings as default ones Example of font color of the general info text and button for bringing up a system panel for the color adjustment Example of block faces color and button for bringing up a system panel for the color adjustment Option of showing block faces in the 3D image Example of the text label font color and button for bringing up a system panel for the color adjustment Example of grid line color and button for bringing up a system panel for the color adjustment Title of group controlling rendering of 3D image Info on font of axes text labels and button for changing font parameters Info on font of the general information text and button for changing the font parameters Title of group for adjusting a block style rendering of the 3D image Option for showing general info in the 3D visualization window Title of group for adjusting text info attributes in the 3D visualization window Pane for entering a perspective view angle for 3D image Option for switching on a perspective view for 3D image Title of group for adjusting a projestion parameters
Рис. 2.5.2.2.7 - Подгруппа Draw (Оформление) панели настройки трехмерного представления СЗМ-данных в развернутом варианте.(нажмите на соответствующий элемент для перехода к его описанию)

Подгруппа Draw (Оформление) объединяет параметры, относящиеся к оформлению трехмерного СЗМ-изображения и окна трехмерного представления в целом.

Секция параметров отображения поверхности - Surface rendering (Отображение поверхности)- содержит средства настройки параметров и методов отрисовки поверхности трехмерного СЗМ-изображения.

Вертикальный масштаб - Z scale [#.#:1] - горизонтальный регулятор аналогового типа для интерактивного изменения масштаба вертикальной шкалы (оси Z) СЗМ-изображения в окне трехмерного представления. В квадратных скобках после названия параметра приводится текущее значение масштаба. Данный параметр определяет, во сколько раз линейные размеры, отображаемые по вертикальной шкале, больше линейных размеров по оси, соответствующей наибольшему диапазону на СЗМ-изображении (практически - диапазону по X или Y). Линейный размер максимального диапазона принимается за единицу. Минимальное значение регулятора (крайнее левое положение) соответствует нулевому масштабу высот, т.е. делает трехмерное изображение плоским, сохраняя возможность его трансформации (поворота, общего масштабирования).

Подсекция неподвижного изображения - Stationary image - параметры метода отрисовки неподвижного трехмерного СЗМ-изображения в окне представления.

Поверхность - Surface - селектор метода отрисовки трехмерной поверхности. Предусмотрены пять вариантов отрисовки:

- Поверхность (Surface) - трехмерное СЗМ-изображение представляется как сплошная оболочка, например:
Example of rendering 3D surface as continuous surface
Окраска поверхности оболочки определяется настроенной цветовой шкалой. Данный метод отрисовки поверхности является наиболее естественным и кроме того позволяет использовать возможность совмещения на одном трехмерном СЗМ-изображении двух типов данных, используемых соответственно для построения трехмерного каркаса и отрисовки совмещаемой с ним оболочки с собственной окраской (рис. 2.5.2.2.4).

- Поверхность + каркас (Surface+grid) - трехмерное СЗМ-изображение представляется как сплошная оболочка, на которую наложена сетка каркаса, например:
Example of rendering 3D surface as Surface + grid (joint)
Окраска оболочки определяется настроенной цветовой шкалой. Цвет линий сетки каркаса настраивается в подсекции параметров каркасного изображения.

- Каркас (Grid) - трехмерное СЗМ-изображение представляется как сетка каркаса, например:
Example of rendering 3D surface as Grid
Параметры сетки каркаса настраиваются в подсекции каркасного изображения.

- Линии X (X lines) - трехмерное СЗМ-изображение представляется сеткой из линий, перпендикулярных оси X, например:
Example of rendering 3D surface as X lines
Параметры линий сетки настраиваются в подсекции каркасного изображения.

- Линии Y (Y lines) - трехмерное СЗМ-изображение представляется сеткой из линий, перпендикулярных оси Y, например:
Example of rendering 3D surface as Y lines
Параметры линий сетки настраиваются в подсекции каркасного изображения.

Шаг точек данных - Step - селектор для установки шага между соседними точками данных СЗМ-матрицы, которые будут учитываться программой для отрисовки поверхности. Так, если шаг равен 1, то каждая точка данных (т.е. все точки СЗМ-матрицы) будут обрабатываться программой для расчета внешнего вида трехмерной поверхности. Если шаг равен, например, 3, то для для расчета внешнего вида трехмерной поверхности будут учитываться только каждая третья точка в СЗМ-матрице. Соответственно, минимальный шаг (т.е. 1) обеспечивает максимально возможную для данной СЗМ-матрицы детализацию (т.е. разрешение) трехмерного изображения. С увеличением шага между обрабатываемыми точками данных разрешение трехмерного СЗМ-изображения будет снижаться.

Подсекция движущегося изображения - Moving image - параметры метода отрисовки трехмерного СЗМ-изображения в процессе его интерактивной трансформации в окне представления.

Поверхность - Surface - селектор метода отрисовки трехмерной поверхности. Предусмотрены пять вариантов отрисовки:

- Поверхность (Surface);
- Поверхность + каркас (Surface+grid);
- Каркас (Grid);
- Линии X (X lines);
- Линии Y (Y lines).

Все методы отрисовки поверхности двужущегося трехмерного СЗМ-изображения аналогичны методам отрисовки неподвижного изображения.

Упрощенные методы отрисовки поверхности (например, каркас или линии) рекомендуется устанавливать для ускорения отображения трансформируемого трехмерного СЗМ-изображения на малопроизводительных компьютерах.

Шаг точек данных - Step - селектор для установки шага между соседними точками данных СЗМ-матрицы, которые будут учитываться программой для отрисовки поверхности в процессе трансформации. Данный параметр аналогичен такому же параметру для неподвижного изображения.

Загрубление детализации движущейся поверхности при установке шага более 1 (например, 3 или 5) рекомендуется использовать для ускорения отображения трансформируемого трехмерного СЗМ-изображения на компьютерах с низкопроизводительными графическими подсистемами.

Подсекция каркасного изображения - Grid - дополнительные параметры настройки линий сетки для методов отрисовки типа Каркас, Линии X, Линии Y.

Шаг линий сетки - Step - поле ввода числового значения для установки шага между ближайшими линиями сетки, участвующими в формировании изображения трехмерной поверхности. Шаг линий сетки исчислятся исходя из шага между точками данных, учитывающимися для отрисовки поверхности. Поэтому, основываясь на размерности исходной СЗМ-матрицы изображения, окончательный шаг линий сетки может быть рассчитан как произведение шага точек данных на шаг линий сетки. Так, например, если шаг точек данных равен 2, а шаг линий сетки установлен равным 4, то линии сетки будут проведены через каждые 2 x 4 = 8 линий (точек) исходной матрицы СЗМ-изображения. Соответственно, при шаге линий сетки 1 частота проведения линий, формирующих трехмерное изображение, будет определяться шагом между точками данных при отрисовке поверхности.

Толщина линий сетки - Thickness - селектор для установки толщины линий сетки (в пикселах). Предусмотрена установка для линий сетки толщины в 1, 2 или 3 пиксела.

Следует учитывать, что большие значения толщины линий сетки могут при малом масштабе всего трехмерного изображения (иначе - при большом расстоянии от точки обзора до поверхности) привести к перекрытию промежутков между соседними линиями (особенно при малых шаге точек данных и шаге линий сетки), что не позволит нормально отобразить трехмерную поверхность.

Цвет линий сетки - Color - кнопка, отображающая образец установленного цветового оттенка для линий сетки, а также при однократном нажатии на нее активизирующая системную панель настройки цвета (рис. 2.5.2.2.6), позволяющую пользователю устанавливать произвольный цвет линий сетки.

Секция настройки типа проекции - Projection - обеспечивает выбор типа проекции, используемой для отображения трехмерного СЗМ-изображения, а также настройки характерных параметров.

Перспективная проекция - Perspective - опция включения режима визуализации трехмерного СЗМ-изображения в перспективной проекции. При этом параллельные линии отображаются как сходящиеся в одной точке в перспективе, что имитирует естественный вид объекта (рис.2.5.2.2.8 слева). В отключенном состоянии обеспечивается визуализация трехмерного СЗМ-изображения в ортогональной проекции: все параллельные линии отображаются как параллельные (рис.2.5.2.2.8 справа).

Рис. 2.5.2.2.8 - Варианты визуализации трехмерного СЗМ-изображения в перспективной (слева) и ортогональной (справа) проекции.

Угол перспективы - ## ° - поле ввода числового значения, определяющего угол (в градусах) схождения линий в перспективной проекции.

Секция блочного стиля - Block style - обеспечивает вариант визуализации трехмерного СЗМ-изображения как верхней поверхности сплошного блока материала, верхняя сторона которого формируется из трехмерной поверхности.

Переключатель - On/Off (Вкл./Выкл) - включает/отключает функцию отображения трехмерного СЗМ-изображения в виде сплошного блока (рис.2.5.2.2.9 справа). Верхняя поверхность блока формируется из самого СЗМ-изображения, а остальные грани предсталяются как непрозрачные стенки. При отключении блочного стиля СЗМ-изображение визуализируется как трехмерная поверхность (рис.2.5.2.2.9 слева).

Example of 3D surface rendering by continuous surface
Рис. 2.5.2.2.9 - Варианты визуализации СЗМ-изображения как трехмерной поверхности (слева) и сплошного блока (справа).

Следует учитывать, что при активированном блочном стиле невозможно "увидеть" "обратную сторону" трехмерной поверхности при ее соответствующем повороте (рис.2.5.2.2.10).

Рис. 2.5.2.2.10 - Возможность просмотра обратной стороны СЗМ-изображения при его визуализации как трехмерной поверхности (слева) и сплошного блока (справа).

Цвет блока - Color - кнопка, отображающая образец установленного цветового оттенка для сплошных граней блока, а также при однократном нажатии на нее активизирующая системную панель настройки цвета (рис. 2.5.2.2.6), позволяющую пользователю устанавливать произвольный цвет граней.

При включенной функции виртуального освещения, тем не менее, окончательный цвет граней блока зависит от расположения виртуального источника освещения. Соответственно, нижняя сторона блока всегда будет черной, поскольку источник освещения всегда расположен в верхней полусфере относительно поверхности трехмерного СЗМ-изображения.

Секция параметров отображения осей - Axes - предоставляет возможность настройки параметров осей и текстовых меток на них, накладываемых на трехмерное СЗМ-изображение.

Отображение осей - Show axes - опция наложения осей координат на трехмерное СЗМ-изображение.

Цвет осей координат - Color - кнопка в верхней строчке секции, отображающая образец установленного цветового оттенка для осей координат, накладываемых на трехмерное СЗМ-изображение. При однократном нажатии на кнопку активизируется системная панель настройки цвета (рис. 2.5.2.2.6), позволяющая пользователю устанавливать произвольный цвет для осей кординат.

Отображение подписей к осям XY - XY labels - опция отображения подписей (числовых меток, названия осей и единиц измерения) к осям координат X и Y, накладываемых на трехмерное СЗМ-изображение. Отображение подписей возможно только при активированной опции отображения осей.

Отображение подписей к оси Z - Z labels - опция отображения подписей (числовых меток, названия осей и единиц измерения) к оси координат Z, накладываемой на трехмерное СЗМ-изображение. Отображение подписей возможно только при активированной опции отображения осей.

Шрифт - Font - кнопка под надписью Font отображает установленную гарнитуру шрифта для подписей (числовых меток, названия осей и единиц измерения) к осям координат, накладываемых на трехмерное СЗМ-изображение. При однократном нажатии на кнопку активируется системная панель, с помощью которой осуществляется настройка параметров шрифта для текстовых подписей к осям (рис. 2.5.2.2.11).

System panel for setting font attributes
Рис. 2.5.2.2.11 - Системная панель настройки параметров шрифта.

Цвет шрифта подписей - Color - кнопка в нижней строке секции, отображающая образец установленного цветового оттенка для подписей к осям координат. При однократном нажатии на кнопку активизируется системная панель настройки цвета (рис. 2.5.2.2.6), позволяющая пользователю устанавливать произвольный цвет для подписей. Цвет, установленый в системной панели настройки параметров шрифта не учитывается.

Секция параметров отображения общей информации - Info - параметры отображения общей информации в окне трехмерного представления СЗМ-данных.

Отображение общей информации - Show info - опция отображения общей информации в окне трехмерного представления СЗМ-данных. В левом верхнем углу представляется блок краткой информации - основные геометрические и статистические характеристики СЗМ-изображения. В правом верхнем углу окна отображается цветовая шкала высот.

Шрифт - Font - кнопка под надписью Font отображает установленную гарнитуру шрифта для блока краткой информации в левом верхнем углу окна трехмерного представления СЗМ-данных. При однократном нажатии на кнопку активируется системная панель, с помощью которой осуществляется настройка параметров шрифта для текста блока краткой информации (рис. 2.5.2.2.11).

Цвет шрифта подписей - Color - кнопка в нижней строке секции, отображающая образец установленного цветового оттенка для подписей к осям координат. При однократном нажатии на кнопку активизируется системная панель настройки цвета (рис. 2.5.2.2.6), позволяющая пользователю устанавливать произвольный цвет для подписей. Цвет, установленый в системной панели настройки параметров шрифта не учитывается.

Назначение параметров по умолчанию - Set as default - кнопка для сохранения текущих настроек панели в качестве набора, используемую программой по умолчанию. Фактически - записывает ее в файл параметров настройки панели default.3dp в подкаталоге Сonfig программы SurfaceXplorer.

Сохранение текущего набора параметров - Save - кнопка для вызова системного диалогового окна сохранения файла, в который будет записана текущий набор параметров панели [3D]. Расширение имени файла по умолчанию - *.3dp. Рекомендуется не изменять предлагаемое расширение имени файла, а также предусмотреть сохранение файла в подкаталоге Сonfig программы SurfaceXplorer.

Загрузка набора параметров - Load - кнопка для вызова системного диалогового окна открытия файла с ранее сохраненным набором параметров панели [3D]. Расширение имени файла по умолчанию - *.3dp.

Упрощенный вариант - Simple << - кнопка переключения в упрощенный вариант панели [3D].


SurfaceXplorer :: Tab Data

SurfaceXplorer
[Интерфейс пользователя] > [Сектор объектов] > [Вкладка Данные]

2.5.3 Вкладка Data (Данные)

Вкладка Data (Данные) (рис. 2.5.3.1) предоставляет информацию о


SurfaceXplorer :: Working with SPM images

[Работа с СЗМ-изображениями]

3. Работа с СЗМ-изображениями : обработка, визуализация и анализ

В данном разделе приводится описание основных приемов и методов работы с СЗМ-изображениями и другими типами данных, возможность обработки, визуализации и анализа которых предусмотрена в программе SurfaceXplorer.

3.1 Файлы данных
3.1.1 Структура данных
3.1.2 Открытие файлов данных
3.1.3 Сохранение данных в файле
3.2 Двухмерное представление СЗМ-данных
3.2.1 Визуализация совместных полей данных
3.2.2 Виртуальная подсветка (имитация освещения)
3.2.3 Преобразование СЗМ-изображения в окне двухмерного представления
3.3 Коррекция СЗМ-изображения
3.3.1 Искажение положения поверхности при получении СЗМ-изображения
3.3.2 Выравнивание по линиям
3.3.3 Выравнивание по поверхности
3.3.4 Выравнивание по выделению
3.3.5 Особенности применения процедуры выравнивания СЗМ-изображения
3.3.6 Сглаживание дефектов сканирования на СЗМ-изображении
3.4 Настройка цветовой палитры
3.5 Выделение объектов на СЗМ-изображении
3.6 Вырезание части СЗМ-изображения
3.7 Построение и анализ профиля поперечного сечения
3.8 Анализ высотных и угловых характеристик СЗМ-изображения
3.9 Трехмерное представление данных
3.10 Арифметические операции с СЗМ-изображениями
3.11 Макрокоманды


SurfaceXplorer :: Data Files

[Работа с СЗМ-изображениями] > [Файлы данных]

3.1 Файлы данных

3.1.1 Структура данных
3.1.1.1 Форматы СЗМ-файлов
3.1.1.2 Форматы импортируемых/экспортируемых файлов
3.1.2 Открытие файлов данных
3.1.2.1 Открытие файлов с помощью системных ресурсов
3.1.2.2 Предварительный просмотр и открытие файлов данных из секции пиктограмм
3.1.2.3 Импорт файлов текстового формата
3.1.2.4 Импорт графических файлов растрового формата
3.1.2.5 Генерация СЗМ-изображения
3.1.3 Сохранение данных в файле
3.1.3.1 Управление полями данных в файле
3.1.3.2 Сохранение данных в файле текстового формата
3.1.3.3 Сохранение изображения в файле растрового формата
3.1.3.4 Копирование изображения/данных в буфер обмена
3.1.3.5 Формирование файла отчета

3.1.1 Структура данных

Структура файлов с СЗМ-данными определяется методом их получения. Схема измерения поверхности с помощью СЗМ в общем случае (традиционная версия) предполагает, что острие чувствительного зонда перемещается относительно образца в плоскости XY от точки к точке по растровой схеме (рис. 3.1.1). При этом в начале зонд перемещается вдоль первой линии сканирования и возвращается обратно. Затем он перемещается на один шаг в перпендикулярном направлении ко второй линии сканирования, движется вдоль нее и обратно. Затем снова осуществляет перемещение на один шаг в перпендикулярном направлении к третьей линии и т.д.. В каждой точке измерений система отслеживает вертикальное положение зонда и регистрирует эти данные в виде СЗМ-матрицы. Измерения в точках обычно регистрируются при движении зонда по линиям сканирования в одном направлении (для уменьшения влияния нелинейностей пьезосканера).

Рис. 3.1.1 - Схема движения зонда в сканирующем зондовом микроскопе при измерении поверхности.

Направление вдоль линий сканирования называется [image] направлением быстрого сканирования. Направление перпендикулярное направлению быстрого сканирования, т.е. то, в котором совершается переход от одной линии сканировани к другой, называется [image] направлением медленного сканирования.

В общем случае [image] СЗМ-данные представляют собой двухмерную матрицу значений размера X*Y, в которой положение элемента Zxy в этой матрице соответствует координатам X и Y точки измерений в плоскости, а численное значение самого элемента Zxy характеризует интенсивность измеренного в данной точке параметра, например:

8.597 | 8.265 | 8.376 | 7.633 | ... | ZX1
8.984 | 8.358 | 8.432 | 7.953 | ... | ZX2
9.647 | 9.058 | 9.205 | 9.168 | ... | ZX3
9.757 | 9.131 | 9.279 | 9.426 | ... | ZX4
... | ... | ... | ... | ... | ...
Z1Y | Z2Y | Z3Y | Z4Y | ... | ZXY

В зависимости от режима работы и измерений сканирующего зондового микроскопа СЗМ-матрица может, например, содержать данные об измеренных:

  • высоте точек поверхности (СЗМ-изображение топографии)
  • латеральных силах, действующих на зонд со стороны поверхности в каждой точке измерений (СЗМ-изображение латеральных сил или карта локальных сил трения)
  • сдвиге фазы колебаний кантилевера в каждой точке измерений (СЗМ-изображение сдвига фазы или карта локальной жесткости)
  • локальных электрических характеристиках (карта локальной проводимости, электрической емкости)
  • локальных магнитных свойствах (карта локальных магнитных свойств)
  • и др. SPM basics review

3.1.1.1 Форматы СЗМ-файлов.
Форматы СЗМ-файлов предусматривают запись в них данных в цифровом виде непосредственно в тех единицах, в которых они были изначально получены при измерении на сканирующем зондовом микроскопе, как это показано на примере выше. Структуру записи (т.е. формат) определяют изготовители оборудования и программного обеспечения для сканирующей зондовой микроскопии. На текущий момент в мире нет стандартизованных или принятых в качестве таковых форматов СЗМ-файлов, однако принципы их построения сводятся к следующим схемам.

Простая запись данных предусматривает размещение в файле одного СЗМ-изображения (т. е. единичной или отдельной матрицы значений). Структуру такой записи файла можно схематически представить следующим образом:

СЗМ-файл
Заголовок
Данные

Практически файл, посторенный по схеме простой записи данных, состоит из заголовка со служебной информацией и одного поля данных, в котором, собственно, и размещается матрица, описывающая СЗМ-изображение.

Недостаток такого формата состоит в необходимости записи множества файлов, относящихся к одному измерению, если сканирующий зондовый микроскоп регистрирует одновременно несколько типов данных, как это производится в современных СЗМ (например, топографию и латеральные силы при работе в контактном режиме, изображение поверхности при первом и втором проходах при реализации двухпроходной методики и др.). В настоящее время простая запись данных для хранения СЗМ-изображений практически не используются. Тем не менее, подобная схема применяется, например, при экспорте данных в файл текстового формата, который может быть корректно использован для переноса результатов между приложениями различных производителей.

Слой данных отмечается символом [image] в панели [Objects] (Объекты) вкладки Browse (Обзор)

Многослойная запись данных предусматривает размещение в СЗМ-файле более одной матрицы значений (данных), обычно относящихся к одному измерению, проведенному на сканирующем зондовом микроскопе. Каждая матрица значений (данных) записывается в отдельный [image] слой внутри файла (практически - адресное пространство). Структура файла с многослойной записью данных, представлена на следующей схеме:

СЗМ-файл
Заголовок
Описание набора данных
Набор данных
Слой 1 (Матрица данных 1)
Слой 2 (Матрица данных 2)
...

Как видно из схемы, в файле содержатся:
- заголовок (служебная информация);
- информация с описанием набора данных (идентификаторы, смещение, или адреса записи соответствующих матриц данных, т.е. слоев);
- собственно матрицы данных, рассматриваемые как слои.

Каждый слой обычно представляет собой СЗМ-изображение какого-либо определенного типа, например – топография поверхности, карта латеральных сил, данные силовой спектроскопии и др. Все матрицы данных (слои), содержащиеся в СЗМ-файле с многослойной записью, по отношению друг к другу рассматриваются как [image] совместные.

Структура СЗМ-файла с многослойной записью может предусматривать как ограниченное, так и неограниченное число совместных слоев. Кроме того, производители СЗМ и обрабатывающих программ могут ограничивать тип и формат данных (чиловых значений), записываемых в слоях.

СЗМ-файл
Заголовок
Описание набора данных
Поля данных
Группа 1
Слой 1.1
Слой 1.2
...
Группа 2
Слой 2.1
Слой 2.2
...
Группа 3
Слой 3.1
Слой 3.2
...
Группа ...

Форматы файлов, поддерживаемые программой SurfaceXplorer. В программе SurfaceXplorer в качестве основного формата принята многослойная схема записи данных в СЗМ-файлах. Файлы внутренних форматов SPM2001 и MPS по умолчанию имеют расширения, соответственно, *.spm и *.mps. Дополнительно структура этих файлов содержит такую единицу, как [image] группа данных, объединяющую матрицы данных (слои) одного типа, например, группа данных (слоев) топографии, группа данных (слоев) сдвига фазы, и т.д., как на примере справа. Такая структура позволяет, например, легко отслеживать и соотносить друг с другом слои, характеризующие одно состояние данных, если в файле записаны более одного набора данных, полученных при обработке СЗМ-зображений.

Тип данных отмечается символом [image] в списке на панели [Objects] (Объекты) вкладки Browse (Обзор)

Формат SPM2001 (Scanning Probe Microscopy, версия 2001 г.) предусматривает запись данных без ограничения размеров и количества слоев. Данные записываются в виде двухмерных массивов (матриц) знаковых двухбайтных (16 бит) значений. Файл в формате SPM2001 обычно имеет достаточно компактный размер. Например, файл, включающий три совместных СЗМ-изображения с матрицей измерений 256х256 точек, имеет размер порядка 385 kB.

Формат MPS (Multi-Purpose Set, версия 2003 г.) также предусматривает многослойную запись данных без ограничения размеров полей и их количества, а также без ограничения типа и формата записываемых значений. Все эти параметры динамически определяются в описании набора данных файла и задаются при записи измерений. Таким образом, в файле данного формата могут содержаться как [image] СЗМ-матрицы (двухмерные массивы), так и [image] линейные (одномерные) массивы значений (например, данные силовой спектроскопии). Кроме того, формат MPS может использоваться при записи измерений других типов.

Помимо этих основных форматов файлов в программе SurfaceXplorer также непосредственно поддерживается работа со следующими типами файлов:

  • SPM - формат файлов СЗМ-данных с простой записью (расширение *.spm);
  • PPM - формат файлов СЗМ-данных с простой записью, специализированный для хранения изображений фазового контраста (phase contrast image) (расширение *.ppm);
  • MTF - (MTM text file) - текстовой формат файлов данных, содержащий специальный заголовок с описанием данных, обеспечивающий их автоматическую сортировку/обработку при загрузке (расширение *.mtf). Подробное описание данного формата записи приводится ниже;
  • TXT - текстовой формат файлов общего назначения (файл должен содержать цифровые дынные) (расширение *.txt); предусматривается специальная процедура импорта;
  • BMP - графический формат файлов растровых изображений (расширение *.bmp); предусматривается специальная процедура импорта;
  • JPG - графический формат файлов растровых изображений с алгоритмом сжатия (расширение *.jpg); предусматривается специальная процедура импорта.

Дополнительно в программе SurfaceXplorer реализована возможность работы с файлами СЗМ-данных других производителей СЗМ:

  • 0## - файлы СЗМ-данных DI/Veeco NanoScope;
  • SPM - формат файлов СЗМ-данных, создаваемых при измерениях на АСМ "ФемтоСкан", разработанном ООО НПП «Центр перспективных технологий» МГУ.

В программе SurfaceXplorer предусматривается специальная возможность копирования слоев (матриц данных) между открытыми в текущий момент файлами. Таким образом, в один файл с многослойной записью могут быть собраны изображения (данные) для различных режимов, участков, поверхностей, и т.д., что среди прочего позволяет рассматривать такой файл в дальнейшем как подобие базы данных или архива. Подробное описание функции управления слоями см. в п.3.1.3 "Сохранение данных в файле".

3.1.1.2 Форматы импортируемых/экспортируемых файлов
Форматы импортируемых/экспортируемых файлов предполагают наличие в них массивов данных, подобных описанной выше матрице значений. СЗМ-файлы в формате других производителей могут непосредственно обрабатываться программой SurfaceXplorer при наличии специализированных подключаемых модулей (plug-ins), ориентированных на данный формат. При отсутствии специализированного подключаемого модуля (plug-ins), ориентированного на данный формат СЗМ-файлов, может быть использована возможность импорта/экспорта СЗМ-изображения, записанного в файле текстового формата.

Необходимо отметить также, что структуру, подобную матрице СЗМ-данных имеют и традиционные графические файлы растровых форматов. Интерпретируя яркость каждого пиксела как характеристику высоты данной точки над плоскостью всего изображения, растровое изображение может быть преобразовано в матрицу СЗМ-данных. Благодаря этому растровые графические форматы иногда выступают альтернативой специальным форматам хранения СЗМ-данных.
Следует заметить, что для корректного преобразования растрового изображения в СЗМ-матрицу чаще всего необходимо вмешательство оператора, определяющего, например, масштабы и единицы измерений для всех трех осей преобразуемого изображения, поскольку в графическом файле отсутствует специальная служебная информация, необходимая для правильного отображения СЗМ-данных. Тем не менее, функция преобразования файлов графических форматов предоставляет уникальную возможность работать с данными, полученными методами, отличными от сканирующей зондовой микроскопии, например, с изображениями, полученными на растровом электронном микроскопе.

В программе SurfaceXplorer предусматривается возможность преобразования в СЗМ-матрицу графических файлов форматов *.bmp и *.jpg, а также сохранение изображения в любом из окон визуализации в файлах этих форматов.
Следует помнить, что в формате *.jpg информация записывается с использованием алгоритмов сжатия, что в итоге приводит к наличию определенных потерь в передаче полутонов. Однако применение сжатия позволяет получать файлы малых размеров.

Помимо описанных функций сохранения (экспорта) данных программа SurfaceXplorer предоставляет возможность сформировать специальный файл отчета в формате *.doc (MS Word) или *.htm, в который включается любое количество изображений из окон визуализации и вспомогательная информация о данных изображениях.

3.1.2 Открытие файлов данных

В программе SurfaceXplorer предусмотрены две разновидности открытия (загрузки) файлов СЗМ-данных:

  • с помощью системных ресурсов - из системного диалога открытия файлов, перетаскиванием файла данных (или группы выделенных файлов) из файлового менеджера операционной системы в окно программы (drag-and-drop), запуском файла данных непосредственно в файловом менеджере операционной системы;
  • с помощью специализированных ресурсов программы - из секции пиктограмм панелей обзора папок [Folders] и избранных папок [Favorites] на вкладке Browse (Обзор).

Открытие (загрузка) файлов данных с помощью системных ресурсов - из системного диалога, из файлового менеджера операционной системы (перетаскиванием или запуском) - не позволяет предварительно просмотреть содержание загружаемого файла.

3.1.2.1 Открытие файлов данных с использованием системных ресурсов

К системным ресурсам (т.е. возможностям, реализуемым встроенными средствами операционной системы), обеспечивающим открытие (загрузку) файлов данных в программу SurfaceXplorer для работы с ними, относятся

  • системный диалог открытия файлов;
  • функция drag-and-drop - перетаскивание файлов данных (в т.ч. группы выделенных файлов) из файлового менеджера операционной системы в окно программы;
  • запуск файла данных непосредственно в файловом менеджере операционной системы.

Системный диалог открытия файлов (рис. 3.1.2.1) вызывается командой меню File > Open или нажатием кнопки File open button на панели работы с файлами.

File open dialogue window
Рис. 3.1.2.1 - Пример окна системного диалога открытия файлов данных.
Click once with left mouse button when cursor is over the target object
/ Click once with left mouse button when cursor is over the target object
Click once with left mouse button when cursor is over the target object Load...

Навигация по папкам (переход между папками) на носителе осуществляется принятыми в операционной среде Win32 способами:
- для перехода на более низкий уровень - двойной щелчок по папке;
- для перехода на более высокий уровень - один щелчок по кнопке [image] / [image] в верхней строке окна диалога;
- открытие (загрузка) выбранного файла - двойным щелчком по имени файла в файловой панели диалога, либо выбором (один щелчок по имени файла) файла в файловой панели и нажатие кнопки Open окна.

Для отображения в файловой панели диалога того или иного типа файлов данных необходимо выбрать соответствующую опцию (маску расширения файлов) в селекторе Files of type: (Файлы типа:) в нижней части окна диалога. В селекторе предусморены следующие варианты (маски расширения файлов):

  • Multi-purpose set (*.mps)
  • SPM file format (*.spm)
  • PPM file format (*.ppm)
  • SPM2001 file format (*.spm)
  • MTM text file (*.mtf)
  • Text file (*.txt)
  • BMP file format (*.bmp)
  • JPG file format (*.jpg)
  • NanoScope file format (*.0??)
  • FemtoScan file format (*.spm)
  • List of files (*.lst) - открытие группы файлов по списку
  • All supported formats - все выше перечисленные форматы.

Следует помнить, что типы файлов анализируются не по их содержанию, а по расширению имени. Поэтому смена расширения файла данных или наоборот - присвоение файлу, не содержащему СЗМ-данных, расширения зарегистрированного типа приведет к неправильному отображению информации или вообще к ситуации, когда файл "не виден" в файловой панели диалога загрузки, а также в секции пиктограмм программы.

File icon Hold pressed left mouse button and drag cursor into necessary position Load...

Открытие файлов данных перетаскиванием из файлового менеджера операционной системы производится выделением в окне файлового менеджера (например, Windows Explorer (Проводник) или Total Commander) одного или нескольких файлов данных и перетаскиванием их в окно программы SurfaceXplorer при нажатой левой кнопке мыши. Рекомендуется загружать таким образом файлы основных форматов. Также перед загрузкой файлов перетаскиванием необходимо, чтобы программа SurfaceXplorer была запущена на компьютере.

File icon Click once with left mouse button when cursor is over the target object Open...

Запуск файла данных непосредственно в файловом менеджере операционной системы производится двойным щелчком левой кнопкой мыши по имени/пиктограмме/ярлыку файла. Рекомендуется загружать таким образом файлы основных форматов.

Открытие группы файлов по списку - одна из возможностей программы SurfaceXplorer, позволяющая сократить число однообразных часто использующихся операций. Предварительно необходимо создать сам список файлов, представляющий собой файл текстового формата, содержащий ссылки на загружаемые файлы данных. Формат файла списка следующий:

Файл списка

LST /специальный обязательный указатель файла списка/

SPM_data_file_name_1.spm /имя файла данных №1/

SPM_data_file_name_2.spm /имя файла данных №2/

SPM_data_file_name_3.spm /имя файла данных №3/

...

SPM_data_file_name_N.spm /имя файла данных №N/

Особенностью файла списка для загрузки его в программу SurfaceXplorer является наличие в его первой строке специального текстового указателя LST. В именах файлов допускается указание полного пути к ним.

3.1.2.2 Предварительный просмотр и открытие файлов данных из секции пиктограмм

Рис. 3.1.2.2 - Секция быстрого просмотра на вкладке Browse (Обзор) с активированным блоком просмотра содержания файла (справа от сектора объектов). Brief information about the image Thumbnail of SPM dta file Thumbnail of SPM dta file Thumbnail of SPM dta file Thumbnail of SPM dta file Thumbnail of SPM dta file Thumbnail of SPM dta file Thumbnail of linear dta file Thumbnail of SPM dta file Additional panel with thumbnails of current file cofields Object sector border Button for hiding the object sector

Дополнительные сервисные возможности предоставляются при использовании для открытия (загрузки) файлов данных с помощью ресурсов самой программы SurfaceXplorer. Это в первую очередь относится к функции быстрого просмотра содержания файлов данных в секции пиктограмм на вкладке Browse (Обзор) (рис. 3.1.2.2). Пиктограммы файлов отображают в уменьшенном виде их содержание, поэтому имеется возможность предварительно выбрать интересующее изображение и целенаправленно загрузить необходимый файл для работы с ним в программе, не прибегая к стандартной процедуре открытия файла для ознакомления с содержащимися в нем данными. Возможность загрузить в программу с помощью блока просмотра содержания файла непосредственно интересующий слой, отличный от топографии, загружаемой по умолчанию, также повышает удобство и скорость работы в программе.

Click once with left mouse button when cursor is over the target object Open...
Click once with left mouse button when cursor is over the target object Activate...

Загрузка файла данных из секции быстрого просмотра (в том числе конкретных слоев из блока просмотра содержания файла) производится двойным щелчком левой кнопкой мыши по соответствующей пиктограмме в ней, после чего файл загружается в окно двухмерного представления в рабочей области программы. При этом если необходимо непосредственно загрузить слой, отличный от топографии, необходимо вначале выделить (активировать) в секции быстрого просмотра пиктограмму интересующего файла, а затем из блока просмотра содержания файла загрузить необходимый слой.

3.1.2.3 Импорт файлов текстового формата

Импорт данных, хранящихся в файлах текстового формата, предусматривает в первую очередь наличие определенной структуры записи в импортирумом файле. В частности, основное требование заключается в размещении группы числовых параметров, определяющих каждую точку данных, в отдельной строке через разделители (предпочтительно - через табуляторы). Так, например, для СЗМ-данных строка должна содержать как минимум такие параметры, как координата точки по оси X, координата точки по оси Y, параметр(-ы) по оси Z (измеренная величина в данной точке с координатами XY). Наборы линейных данных должны содержать как минимум две координаты для каждой точки.

Знаком разделения целой и дробной части числа в программе SurfaceXplorer считается десятичная точка. Поэтому для корректной загрузки текстовых файлов необходимо следить, чтобы при их формировании в региональных установках операционной системы (Regional and Language Settings) в качестве разделителя целой и дробной части числа была установлена именно точка.

Открытие/импорт файла данных в текстовом формате производится:

  • с помощью процедур открытия файлов с выбором соответствующего типа файлов - MTM text file (*.mtf) либо Text file (*.txt), - командой меню File > Open или нажатием кнопки File open button на панели работы с файлами;
  • с помощью команды меню File > Import > Import text file.

При импорте данных в текстовом формате программа анализирует содержание открываемого файла и выводит специализированное диалоговое окно для определения (задания) диапазонов параметров (значений) вручную (рис. 3.1.2.3).

Необходимо отметить, что текстовые файлы данных, сохраненные в формате MTM text file (*.mtf), содержат заголовок с описанием содержания файла, что позволяет программе автоматически и корректно загружать его без необходимости определять диапазоны значений вручную.

Диалоговое окно задания диапазонов параметров импортируемых данных (рис. 3.1.2.3) содержит следующие элементы.

Рис. 3.1.2.3 - Диалоговое окно задания диапазонов параметров при импорте файла данных в текстовом формате.

Таблица данных - зона в левой части окна, в которой в табличной форме отображаются содержащиеся в файле данные (при соблюдении структуры данных в файле). Слева от таблицы размещается вертикальная линейка с номерами строк импортируемого файла. В таблице предусмотрена возможность панорамирования видимой области данных с помощью полос прокрутки (по горизонтали и вертикали).

Секция общих параметров (Common) - содержит средства для описания данных:

  • Тип (Type) - поле ввода, позволяющее задать наименование типа данных, которое будет соответствующим образом отображено в панели [Objects] (Объекты) вкладки Browse (Обзор), а также в заголовке окна визуализации данных.
  • Наименование (Name) - поле ввода, позволяющее задать имя набора (поля) данных, которое будет соответствующим образом отображено в панели [Objects] (Объекты) вкладки Browse (Обзор), а также в заголовке окна визуализации данных.
  • Начальная строка данных (Data start line) - поле ввода/селектор для указания строки в импортируемом файле, с которой начинаются числовые данные, предназначенные для загрузки в программу. Номер строки может быть определен по вертикальной линейке в таблице слева. Допускается как ввод параметра вручную, так и выбор необходимого значения с помощью кнопок селектора справа от поля ввода.
  • Конечная строка данных (Data end line) - поле ввода/селектор для указания конечной строки загружаемых числовых данных в импортируемом файле. Номер строки может быть определен по вертикальной линейке в таблице слева. Допускается как ввод параметра вручную, так и установка необходимого значения с помощью кнопок "вверх" и "вниз" справа от поля ввода.

Необходимо тщательно следить за тем, чтобы заданный диапазон загружаемых данных включал только однородный массив числовых параметров (как по формату данных, так и по размещению/структуре). В противном случае программа воспримет загружаемые данные как ошибочные и процедура будет отменена.

Секция описания столбцов (Columns) - предоставляет средства для описания групп данных в загружаемой таблице:

  • Количество столбцов (Number of columns) - поле ввода/селектор, определяющий количество загружаемых столбцов данных. Подразумевается загрузка групп данных, начиная с крайнего левого столбца таблицы. Параметр позволяет ограничить количество импортируемых групп данных. Допускается как ввод параметра вручную, так и выбор необходимого значения с помощью кнопок селектора справа от поля ввода.
  • Таблица описания групп данных - содержит поля, в которые вручную заносятся надписи для осей координат (Axis name) и единицы измерения величин (Unit), соответствующие импортируемым группам данных. Номера строк таблицы описания соответствуют номерам загружаемых столбцов.

Кнопки OK и Cancel служат, соответственно, для запуска или отмены процедуры импортирования (загрузки) данных.

В случае, если импортируемые данные представляют собой линейные наборы данных, они будут визуализированы в окне представления профиля поперечного сечения. Если импортируемый набор данных образует двухмерную матрицу значений, он будет визуализирован в окне двухмерного представления.

3.1.2.4 Импорт графических файлов растрового формата

Импорт графических файлов предназначен в первую очередь для обеспечения в программе полноцненной работы с изображениями поверхностей, полученных методами растровой электронной микроскопии или других аналогичных методик. Подобным образом возможна также загрузка СЗМ-изображений, сохраненных в графическом файле растрового формата. В программе SurfaceXplorer предусматривается загрузка (импорт) графических файлов в форматах *.bmp или *.jpg. Интерпретация графической информации производится только путем анализа яркости каждого пиксела изображения, поэтому предпочтительно, чтобы импортируемое изображение было выполнено в градациях серого (Grayscale) либо полутонах одного цвета.

Фактически импортировать в программу можно любой графический файл (соответственно, в формате *.bpm или *.jpg), однако рекомендуется следить, чтобы содержание данных соответствовало профилю программы SurfaceXplorer, а именно - изображениям поверхностей, т.е характеризовали топографию.

Открытие/импорт файла графического формата производится:

  • с помощью процедур открытия файлов с выбором соответствующего типа файлов - BMP file format (*.bmp) либо JPG file format (*.jpg), - командой меню File > Open или нажатием кнопки File open button на панели работы с файлами;
  • с помощью команды меню File > Import > Import bitmap file.

После выбора соответствующей процедуры открывается специализированное диалоговое окно импорта графического изображения Import bitmap file, в котором пользователь указывает калибровочные параметры для преобразования графического изображения в двухмерную матрицу данных (рис. 3.1.2.4).

Диалоговое окно задания калибровочных параметров импортируемого графического файла растрового формата (рис. 3.1.2.4 справа) содержит следующие элементы.

SEM micrograph to be imported into SurfaceXplorer Dialog box for imported bitmap image calibration
Рис. 3.1.2.4 - Исходное РЭМ-изображение в растровом фомате (слева) и диалоговое окно задания калибровочных параметров при импорте графического файла данных в растровом формате (справа).
Field for defining Scale on X direction Field for defining Scale on Y direction Field for defining range on Z direction Loaded area section Tool for Graphical calibration of the linear range Description of the data type Additional description of the data type Button for starting the image conversion and loading into program Button for cancelling the image import procedure

Сектор задания загружаемого участка - зона в левой верхней части окна, используемая для предварительного просмотра импортируемого (открываемого) растрового изображение. В этом секторе также производится выделение [image] загружаемого участка изображения - области на импортируемом изображении, который будет далее преобразован и загружен в программу дл ядальнейшей работы. Выделение загружаемого участка изображения осуществляется графически - "растягиванием" прямоугольника (проведением при нажатой левой кнопке мыши диагональной линии поперек предполагаемого прямоугольной области на изображении). Точка на изображении, над которой произведено нажатие левой кнопки мыши, считается начальной, а в которой кнопка отпускается - конечной. Выделенный участок обозначается на импортируемом изображении прямоугольной рамкой красного цвета (рис. 3.1.2.4 справа).

Размер в направлении X (Range X, nm) - цифровое поле ввода линейного размера выделенного загружаемого участка по оси X в нм. Ввод осуществляется вручную с клавиатуры компьютера и завершается нажатием клавиши Enter или переносом курсора в другое поле ввода.

Размер в направлении Y (Range Y, nm) - цифровое поле ввода линейного размера выделенного загружаемого участка по оси Y в нм. Ввод осуществляется вручную с клавиатуры компьютера и завершается нажатием клавиши Enter или переносом курсора в другое поле ввода.

Размер в направлении Z (Range Z,nm) - цифровое поле ввода диапазона высот шкалы серого для выделенного загружаемого участка по оси Z в нм. Ввод осуществляется вручную с клавиатуры компьютера и завершается нажатием клавиши Enter или переносом курсора в другое поле ввода. Высота каждого пиксела импортируемого изображения интерпретируется программой SurfaceXplorer исходя из яркости (независимо от цвета используется только яркостная составляющая данного пиксела). При этом самой нижней точкой считается наиболее темный (наименее яркий) пиксел в загружаемом участке изображения. Соответственно, самой верхней точкой считается наиболее яркий пиксел в загружаемом участке изображения. Все промежуточные значения яркости пикселей, составляющих импортируемый участок изображения, рассматриваются как соответствующие промежуточным высотам из заданного диапазона, рассчитываемом исходя из прорпорционального распределения яркости на зафиксированной шкале серого.

Секция калибровки (Calibrate) - служит для графического задания линейного размера загружаемого участка по имеющейся шкале.

  • Вкл/Откл (On/Off) - переключатель для активации графического режима калибровки линейного размера загружаемого участка. В активированном (включенном) состоянии задание линейного размера загружаемого участка осуществляется графически. В выключенном - явным заданием линейных размеров путем ввода соотвествующих чисел в цифровых полях масштабов по осям X и Y.
    После активации данного режима необходимо на изображении в секторе задания загружаемого участка мышью "растянуть" отрезок прямой над участком с известной длиной. Калибровочный отрезок прямой отображается желтым цветом.
    Следует помнить, что на РЭМ-изображении обычно приводится масштабная шкала с указанием ее соотвествующего размера (длины). На СЗМ-изображениях таким участком может служить размерная шкала по его краям.
  • Расстояние (Distance, nm) - цифровое поле для задания длины калибровочного отрезка в нм. Ввод осуществляется вручную с клавиатуры компьютера и завершается нажатием клавиши Enter или переносом курсора в другое поле ввода. Следует помнить, что при графической калибровке линейных размеров подразумевается использование единого масштаба для осей X и Y.

Тип данных (Type) - окно ввода наименования типа загружаемых данных. Например, "Топография", "Амплитуда" и т.п..

Имя данных (Name) - окно ввода имени для загружаемых данных. Это может быть любое уточняющее тип данных описание (слово), например, "Проход 2", "РЭМ" и т.п.

Импортирование (Import) - кнопка для запуска конвертации и окончательной загрузки растрового изображения с использованием калибровочных параметров, заданных в окне диалога (рис. 3.1.2.4 справа). Конвертированное и загруженное в программу растровое изображение визуализируется в окне двухмерного представления, например, как на рис. 3.1.2.5 слева вверху.

Отмена (Cancel) - кнопка для отмены окончательной загрузки растрового изображения.

Таким образом, для импорта графических файлов растрового формата необходимо выполнить следующие процедуры:

  1. Открыть исходный графический файл - с помощью команды меню File > Open, либо нажатия кнопки File open button на панели работы с файлами, либо команды меню File > Import > Import bitmap file. После открытия необходимого файла, он загружается в окно предварительного просмотра и ввода калибровочных данных (рис. 3.1.2.4 справа).
  2. Задать (выделить) в окне предварительного просмотра загружаемый участок на импортируемом изображении - графическим выделением прямоугольного участка (растягиванием при нажатой левой кнопке мыши).
  3. Ввести калибровочные значения для размеров загружаемого участка по осям X, Y, Z. Допускается либо явное задание размеров участка по осям X и Y, либо графическое задание калибровочного отрезка с последующим вводом его размера.
  4. При необходимости - ввести описания типа и имени импортируемых данных.
  5. Завершить процедуру конвертации изображения и окончательной загрузки данных - нажатием кнопки Import.
Рис. 3.1.2.5 - Пример импортированного РЭМ-изображения в двухмерном представлении с наложением цветовой палитры и симуляцией подсветки (слева) и в трехмерном представлении (справа).

Конвертированные данные представляют собой двухмерную матрицу данных и визуализируются в окне двухмерного представления, что позволяет в дальнейшем обрабатывать и/или трансформировать их подобно обычному СЗМ-изображению (рис. 3.1.2.5).

3.1.2.5 Генерация СЗМ-изображения

Button Image simulation

Plane, SinX, CosX, |SinX|, |CosX|, SinY, CosY, |SinY|, |CosY|,

Parallelepiped, Pyramid Tetrahedral, Pyramid Trihedral, Cone, Cylinder Vertical, Cylinder Horizontal, Ellipsoid

Uniform Noise, Gaussian Noise, Weibull Noise

3.1.3 Сохранение данных в файле

Все данные, с которыми производилась работа в программе SurfaceXplorer, могут быть сохранены в файле или переданы для работы в другие программы через системный буфер обмена. Для СЗМ-изображений и других данных, представляющих собой двухмерную матрицу значений, предусматривается возможность сохранения в файлах следующих форматов:

  • Multi-purpose set - *.mps
  • SPM file format - *.spm
  • PPM file format - *.ppm
  • SPM2001 file format - *.spm
  • BMP file format - *.bmp
  • JPG file format -*.jpg
  • Text file - *.txt (MTM text file - *.mtf)

Кроме того для многопольных наборов данных предусмотрена возможность выборочного сохранения слоев.

Линейные данные могут быть сохранены в файлах форматов

  • Multi-purpose set - *.mps
  • BMP file format - *.bmp
  • JPG file format -*.jpg
  • Text file - *.txt (MTM text file - *.mtf)

В любом случае, изображение в любом из специализированных окон программы может быть непосредственно скопировано в системный буфер обмена или сохранено в виде растрового изображения.

Кроме этого программа SurfaceXplorer предоставляет возможность сформировать специальный файл отчета в формате *.doc (MS Word) или *.htm, в который включается любое количество изображений из специализированных окон визуализации и вспомогательная (статистическая) информация о данных изображениях/объектах.

3.1.3.1 Управление полями данных в файле

Одной из специальных функций программы SurfaceXplorer является управление слоями данных файлов. Предусмотрены как возможность выборочного сохранения слоев в новом файле, так и возможность копирования (импорта) в текущий файл слоя из других файлов с СЗМ-изображениями или удаления из текущего файла существующих слоев.

Функция выборочного сохранения слоев текущего открытого файла СЗМ-изображения реализуется с помощью специализированной панели [Select layers for saving...] (рис. 3.1.3.1), вызываемой командой меню File > Save selectively или нажатием кнопки Button Save selectively на панели работы с файлами. Непосредственно после активации функции выводится системное диалоговое окно, где необходимо указать новое имя файла, в котором будет сохранен новый набор данных.

Selector of data sets for saving
Рис. 3.1.3.1 - Специализированная панель выбора слоев для сохранения в новом файле.

В центральной части панели (рис. 3.1.3.1) размещена зона, в которой перечисляются все присутствующие в текущем файле слои, в том числе сформированные в текущем сеансе работы с СЗМ-изображением в программе SurfaceXplorer. Слои сгруппированы при этом по их типу. Активация переключателя перед именем слоя включает его в число слоев, сохраняемых в новом файле. Для выбора всехслоев для сохранения можно воспользоваться кнопкой Select all /Выбрать все/ справа от зоны списка слоев. Обратную процедуру - отключить сохранение всех слоев - можно оперативно произвести кнопкой Unselect all. Опция Save only one layer for each type /Сохранять только по одному слою для каждого типа/ позволяет предупредить ошибочное включение в число сохраныемых слоев более одного слоя каждого типа.

Функция импорта/удаления слоя для текущего открытого файла СЗМ-изображения реализуется с помощью специализированной панели [Data Set management] (Управление наборами данных) (рис. 3.1.3.2), активируемой командой меню File > Data Set management или нажатием кнопки [image] на панели работы с файлами. Активировать панель также можно с помощью команды Data Set management в контекстном меню окна двухмерного представления.

Рис. 3.1.3.2 - Пример специализированной панели управления полями данных: слева - файлы с исходным набором слоев; справа - в активный файл скопирован (импортирован) слой из вспомогательного файла.
Selector of active (changeable) SPM file Data Fields of the active (changeable) SPM file Selector of secondary (donor) SPM file Data Fields of secondary (donor) SPM file Button for loading secondary (donor) SPM file from hard disk Button for copying selected data field from secondary (donor) SPM file to active one Button for deleting selected data field from active SPM file Button for bringing up additional panel with description of selected data field in active SPM file

Панель управления слоями (рис. 3.1.3.2) содержит два сектора, представляющих списки слоев двух файлов СЗМ-изображений. В левом секторе Active /Активный/ отображается содержание изменяемого файла. По умолчанию в активный (левый) сектор автоматически загружается текущий СЗМ-файл. Тем не менее с помощью селектора в верхней части области в качестве активного (т.е. изменяемого) пользователь может выбрать любой другой СЗМ-файл из числа открытых (загруженных) в данный момент в программе SurfaceXplorer.

В правом секторе 2nd /Вторичный/ отображается содержание вспомогательного ("донорского") СЗМ-файла, из которого будет производиться импортирование (копирование) слоев. Аналогично активному сектору, с помощью селектора предусмотрена возможность выбора в качестве вспомогательного любого СЗМ-файл из числа открытых (загруженных) в данный момент в программе SurfaceXplorer. Если интересующего вспомогательного файла нет в списке открытых (т.е. в селекторе), то его необходимо загрузить с жесткого диска с помощью кнопки [image] в центральной части панели.

В центральной части панели - между двумя секторами - размещены кнопки управления:
- кнопка загрузки вспомогательного файла. Вызывает системный диалог открытия файла, с помощью которого и производится загрузка;
- кнопка копирования выбранного во вспомогательном файле слоя в активный СЗМ-файл;
- кнопка удаления выбранного в активном СЗМ-файле слоя;
- кнопка вызова дополнительной информационной панели о текущем слое (и активном файле) (рис. 3.1.3.3). Данную панель можно также активировать с помощью команды Edit Data Field непосредственно в контекстном меню окна двухмерного представления (соответственно, для текущего типа данных).

Рис. 3.1.3.3 - Дополнительная информационная панель о слое

Дополнительная панель (рис. 3.1.3.3) представляет информацию о файле (группа Data Set /Набор данных/) и текущем слое (группа Data Field /Слой данных/). При наличии в файле вспомогательных записей о дате и времени измерения (Date and Time), наименовании измерительного устройства, на котором сформирован данный файл (Device name) и описании этого измерительного устройства (Device name) они будут представлены в соответствующих строках панели. В группе Data Field /Слой данных/ отображается информация о типе слоя (Type) и его имени (Name). Информация из строк панели может быть выделена и скопирована в системный буфер обмена с помощью комбинаций клавиш Ctrl-C или Ctrl-Ins . Bring up panel to edit data matrix

3.1.3.2 Сохранение данных в файле текстового формата

MTM TEXT FILE
\Field: matrix
\Type: Topography
\Name: Topography
\NumColumns: 256
\NumRows: 256
\Data:
------------------------------------------
  X,nm          Y,nm            Z,nm
------------------------------------------
0.000           0.000           -5.597
4.115           0.000           -5.265
8.230           0.000           -5.376
12.345          0.000           -5.633
...
0.000           637.842         15.133
4.115           637.842         14.213
8.230           637.842         13.329
12.345          637.842         12.592
...
------------------------------------------

MTM TEXT FILE
\Field: table
\Type: Profile
\Name: CS-Topography
\NumColumns: 2
\NumRows: 256
\Data:
-----------------------------
 Length,um       Z,um
-----------------------------
 0.000           1.162
 0.016           1.200
 0.032           1.199
 0.048           1.198
 0.064           1.199
 0.080           1.195
...
-----------------------------

MTM TEXT FILE
\Field: table
\Type: Table
\Name: Curve analysis
\NumColumns: 5
\NumRows: 256
\Data:
--------------------------------------------------------------------------
 Z,nm            Deflection,nm   Depth,nm        Load,nN         E,GPa
--------------------------------------------------------------------------
 0.000           0.000           0.000           0.000           0.000
 16.000          38.000          -22.000         2280.000        0.000
 32.000          37.000          -5.000          2220.000        0.000
 48.000          36.000          12.000          2160.000        6.950
 64.000          37.000          27.000          2220.000        2.116
--------------------------------------------------------------------------

MTM TEXT FILE
\Field: table
\Type: Table
\Name: Indentatio analysis - S1
\NumColumns: 5
\NumRows: 49
\Data:
-----------------------------------------------------------------------------------
 Z,nm            Deflection,nm   Depth,nm        Load,nN         E,GPa
-----------------------------------------------------------------------------------
 0.000           3.000           3.000           180.000         3.276
 16.000          3.000           13.000          180.000         0.363
 32.000          2.000           30.000          120.000         0.069
...
 738.000         266.000         472.000         15960.000       0.147
 754.000         268.000         486.000         16080.000       0.142
 770.000         270.000         500.000         16200.000       0.137
-----------------------------------------------------------------------------------

Information for S1:
Spring constant of cantilever, N/m: 60.000
Indentor curvature radius, nm: 40

3.1.3.3 Сохранение изображения в файле растрового формата

3.1.3.4 Копирование изображения/данных в буфер обмена

3.1.3.5 Формирование файла отчета

Создание нового отчета

New report (Новый отчет)

Добавление к отчету

Add to report (Добавить к отчету)

Сохранение файла отчета

Save report (Сохранить отчет)

Просмотр файла отчета

View report (Просмотр отчета)


SurfaceXplorer :: 2D View of SPM images

[Работа с СЗМ-изображениями] > [Двухмерное представление]

3.2 Двухмерное представление СЗМ-данных

Двухмерное представление СЗМ-данных
3.2.1 Визуализация совместных полей данных
3.2.2 Виртуальная подсветка (имитация освещения)
3.2.3 Преобразование СЗМ-изображения в окне двухмерного представления
Масштабирование СЗМ-изображения
Дублирование окна
Нормализация данных
Зеркальное отображение по вертикали
Зеркальное отображение по горизонтали
Поворот СЗМ-изображения на 90°
Отмена последнего действия обработки

Двухмерное представление СЗМ-данных является в программе SurfaceXplorer основным типом визуализации. Данные в этом случае отображаются в специализированном окне в виде карты высот (рис. 3.2.1 слева) или свойств (рис. 3.1.1 справа).

Рис. 3.2.1 - Примеры двухмерных СЗМ-изображений топографии (карта высот с имитацией подсветки) (слева) и совместной с ним карты сдвига фазы (карта локальной жесткости) (справа).

Двухмерное СЗМ-изображение строится таким образом, что координаты X и Y матрицы данных совпадают с аналогичными осями плоскости, а вертикальная координата Z каждой точки измерений (соответственно, точки на изображении) передается цветом согласно установленной цветовой шкале. Таким образом на СЗМ-изображении воспроизводится рельеф или карта других свойств.

Окно двухмерного представления открывается автоматически при загрузке (открытии) файла с СЗМ-данными, при измерении с помощью интегрированного модуля АСМ, а также при визуализации совместных полей данных уже открытого файла. Окно двухмерного представления предназначено также для отображения в первую очередь результатов применения специализированных процедур и функций обработки СЗМ-данных.

Обычно непосредственно после открытия файла СЗМ-данных для обеспечения оптимального отображения этих данных производится процедура выравнивания, а при необходимости - дополнительно проводится сглаживание дефектов сканирования. После выравнивания (и при необходимости - сглаживания сбоев) рекомендуется настроить цветовую шкалу высот СЗМ-изображения. Ниже описываются процедуры, также позволяющие оптимизировать отображение СЗМ-данных, и получить дополнительную информацию об исследуемом объекте.

3.2.1 Визуализация совместных полей данных

При наличии в одном файле совместных полей данных (рис. 3.2.1.1) программой SurfaceXplorer предусматриваются следующие способы их визуализации (отображения в окне двухмерного представления).

В случае, если файл СЗМ-данных открыт в программе:

  • активизировать одно из открытых окон двухмерного представления данных из интересующего файла и, воспользовавшись селектором совместных полей на панели типов визуализации:
    Cofield selector for 2D visualisation ,
    выбрать в списке имеющихся в файле полей данных необходимое;
  • в панели объектов ([Objects]) вкладки Browse (Обзор) найти необходимый файл и дважды щелкнуть левой кнопкой мыши по метке необходимого поля данных;
  • в секторе быстрого просмотра на панели объектов ([Objects]) вкладки Browse (Обзор) выбрать пиктограмму интересующего файла и в открывшемся блоке содержания файла дважды щелкнуть по пиктограмме необходимого поля данных.

Рис. 3.2.1.1 - Пример совместных полей данных, получаемых при одном измерении и записвываемых в файле СЗМ-данных.

  • Вверху слева - СЗМ-изображение топографии (без имитации освещения);
  • Вверху справа - карта локального сдвига фазы колебаний зонда (изображение контраста, получаемое в динамическом режиме);
  • Внизу справа - карта локальных изменений амплитуды колебаний зонда (изображение контраста, получаемое в динамическом режиме).

Цветовая палитра каждого СЗМ-изображения настроена индивидуально.

Если файл с СЗМ-данными в программе еще не открыт, выбрать для загрузки интересующее поле данных можно с помощью сектора быстрого просмотра . Для этого необходимо:
1) на панели [Folders] (Папки) или [Favorites] (Избранное) вкладки Browse (Обзор) отыскать необходимый файл на жестком диске;
2) в секторе быстрого просмотра активировать его пиктограмму;
3) в открывшемся блоке содержания файла дважды щелкнуть по пиктограмме интересующего поля данных.

3.2.2 Виртуальная подсветка (имитация освещения)

Немаловажную роль в процессе восприятия и интерпретации двухмерного СЗМ-изображения играет представление его в наиболее привычном для человеческого глаза виде. Это, в частности, относится к имитации освещения отображаемой поверхности, что реализуется с помощью функции виртуальной подсветки. В программе SurfaceXplorer предусмотрены варианты представления СЗМ-данных как без имитации освещения - в виде карты высот, так и с имитацией освещения рельефа виртуальным источником света.

Представление СЗМ-данных в виде карты высот обеспечивает отображение вертикальной координаты каждой точки данных в соответствии с цветовой шкалой (рис. 3.2.2.1 вверху слева). Вертикальная координата каждой точки изображения (т.е. ее высота) кодируется цветом в строгом соответствии с настроенной цветовой палитрой, и все изображение, таким образом, представляет собой карту высот (аналогично физической карте в географии).

Представление СЗМ-данных в режиме виртуальной подсветки обеспечивает отображение рельефа как карты высот, но с дополнительной имитацией его освещения виртуальным источником света (рис. 3.2.2.1 вверху справа). Цвет каждой точки данных определяется в первую очередь цветовой шкалой, а его яркость корректируется в зависимости от геометрического положения этой точки относительно окружающих точек данных и размещения виртуального источника света. Данный режим можно рассматривать как вид сверху на трехмерное изображение, расположенное в строго горизонтальной плоскости (т.е. в плоскости окна двухмерного представления).

Рис. 3.2.2.1 - Пример виртуальной подсветки СЗМ-изображения:
вверху слева - функция отключена (представление в виде карты высот);
вверху справа - функция включена (представление с имитацией освещения);
внизу слева - опция включена, но положение виртуального источника света настроено некорректно (перпендикулярно направлению быстрого сканирования).

Настройка функции виртуальной подсветки осуществляется в секции Light (Свет) панели настройки двухмерного представления [2D] вкладки Properties (Свойства). Активирование функции производится с помощью переключаетля On/Off. Для настройки положения виртуального источника света относительно СЗМ-изображения предусмотрено использование как графической зоны установки, в которой управление положением производится с помощью курсора мыши, так и цифровых полей ввода угла наклона и угла ориентации источника, где положение задается вручную в цифровом виде.

Одной из особенностей функции виртуальной подсветки является возможность скрытия некоторых линейных дефектов при ориентации виртуального источника света параллельно направлению быстрого сканирования данного СЗМ-изображения. Поэтому с учетом того, что наиболее естественно выглядят изображения, освещаемые слева или справа, рекомендуется в большинстве случаев устанавливать значения угла ориентации, соответственно, 180° или 90°. На рис. 3.2.2.1 эта особенность иллюстрируется сравнением вариантов имитации освещения одного и того же СЗМ-изображения, когда ориентация источника света совпадает с направлением быстрого сканирования (рис. 3.2.2.1 вверху справа, направление быстрого сканирования - слева направо, угол ориентации источника - 180°) и перпендикулярна ему (рис. 3.2.2.1 внизу слева, угол ориентации источника - 90°).

Угол наклона виртуального источника света над плоскостью СЗМ-изображения влияет на величину эффекта от имитации освещения. Чем меньше угол наклона, тем четче проявляется эффект объемности, но тем меньше освещенность поверхности.

Фактически, при имитации освещения СЗМ-изображение выглядит наиболее естественным для человеческого глаза образом, однако цвет каждой точки практически не соответствует приведенному на цветовой шкале высот. Кроме того, при определнных положениях источника света, взаимных положениях точек данных или специфики установленной цветовой шкалы высот (например, размещение более темного цветового тона выше более светлого) на СЗМ-изображении могут наблюдаться визуальные искажения (оптические иллюзии), когда, например, впадина выглядит как выступ и наоборот. Данные явления связаны с особенностями психологического восприятия человеком изображений.

3.2.3 Преобразование СЗМ-изображения в окне двухмерного представления

Для оптимального отображения СЗМ-данных в окне двухмерного представления в программе предусматриваются следующие специализированные процедуры обработки СЗМ-изображения:

  • выравнивание по линиям сканирования: вычитание прямой линии или параболы;
  • выравнивание по поверхности: вычитание плоскости или параболоида;
  • выравнивание по выделению: вычитание плоскости, задаваемой тремя установленными опорными точками; вычитание параболических линий, плоскости или параболоида внутри или по образцу выделенной прямоугольной области;
  • сглаживание линии сканирования или прямоугольной области интерполяцией граничных данных;
  • вырезание прямоугольного участка;
  • арифметические операции с матрицами СЗМ-данных.

Также предусмотрены следующие базисные процедуры преобразования СЗМ-изображения:

  • масштабирование СЗМ-изображения (произвольное и ступенчатое);
  • нормализация;
  • транспонирование (отображение) по вертикали, по горизонтали, поворот изображения на 90°;
  • дублирование текущего окна.

Ниже приводится описание процедур преобразования.

Масштабирование (изменение размеров) СЗМ-изображения в окне двухмерного представления осуществляется как ступенчато (в соответствии с предустановленными параметрами масштабирования), так и произвольно. Кроме того допускается как пропорциональное, так и непропорциональное изменение размера окна двухмерного представления и, соответственно, СЗМ-изображения в нем.

Исходный размер СЗМ-изображения в окне двухмерного представления определяется размером матрицы данных: кажая точка СЗМ-матрицы представляется на экране одним пикселом. Например, СЗМ-изображение с матрицей 256*256 точек данных на экране будет представлено избражением размером 256*256 пикселов.

Ступенчатое пропорциональное изменение размера СЗМ-изображения предусматривается до 25%, 50%, 75%, 100%, 150%, 200%, 400%, 800% от исходного размера и производится с помощью:

  • команд контекстного меню окна;
  • команд пункта меню View > Zoom >;
  • селектора масштаба [image] на панели типов визуализации.

Произвольное пропорциональное изменение размера области визуализации (и, соответственно, СЗМ-изображения) производится:

  • с помощью селектора масштаба [image] на панели типов визуализации вводом произвольного масштаба представления текущего СЗМ-изображения;
  • перетаскиванием угловой зоны окна двухмерного представления (рис. 3.2.3.1 слева).
Рис. 3.2.3.1 - Произвольное изменение размеров окна двухмерного представления: слева - пропорциональное с помощью перетаскивания угловой зоны границы окна; справа - непропорциональное (в одном направлении) перетаскиванием границы окна (здесь - в вертикальном направлении).

Произвольное непропорциональное изменение размера окна двухмерного представления (и, соответственно, самого СЗМ-изображения в нем) производится перетаскиванием границ окна при нажатой левой кнопке мыши (рис. 3.2.3.1 справа). При этом перетаскивание вертикальной или горизонтальной границы окна вызывает непропорциональное изменение одного размера, соотвественно, по горизонтали или вертикали.

Увеличение СЗМ-изображения до размера рабочей области программы производится с помощью кнопки [image] (Maximize) в заголовке окна.

Вернуть исходный размер СЗМ-изображению можно, выбрав масштаб 100%

  • в подменю параметров масштабирования Zoom > контекстного меню окна;
  • в селекторе масштаба [image] на панели типов визуализации.

Дублирование окна. Создание дубликата текущего окна двухмерного представления в его текущем состоянии. Процедура создает новое автономное окно с копией СЗМ-изображения, над которым можно производить операции независимо от родительского окна. Дублирование выполняется с помощью:

  • кнопки Duplication of current 2D window на панели инструментов обработки;
  • команды меню Process > Duplicate;
  • сочетания "быстрых" клавиш <Ctrl + D> на клавиатуре компьютера.

В результате дублирования окно с новым изображением отображается в перечне на панели [Objects] (Объекты) вкладки Browse (Обзор) как отдельный объект с именем #.Duplicate.

Нормализация данных. Нормализация - смещение точки начала отсчета шкалы высот на один уровень с нижней точкой рельефа на СЗМ-изображении. Процедура переустанавливает нулевую плоскость в положение нижней значащей точки рельефа и соответствующим образом пересчитывает вертикальные координаты всех точек СЗМ-матрицы. Иначе говоря - для пользователя результат процедуры выглядит как смещение всего СЗМ-изображения вдоль вертикальной шкалы таким образом, что самая нижняя точка рельефа оказывается на нулевом уровне (рис. 3.2.3.2). Нормализация выполняется с помощью:

  • кнопки Normalize button на панели инструментов обработки;
  • команды меню Process > Normalize.
Рис. 3.2.3.2 - Пример выполнения процедуры нормализации СЗМ-изображения. Изменения видны по меткам цветовой шкалы высот.

Зеркальное отображение по вертикали текущего СЗМ-изображения (транспонирование относительно горизонтальной оси) (рис. 3.2.3.3) выполняется с помощью:

  • кнопки Flip image vertically на панели инструментов обработки;
  • команды меню Process > Flip vertically.
Рис. 3.2.3.3 - Пример выполнения зеркального отображения СЗМ-изображения по вертикали.

Зеркальное отображение по горизонтали текущего СЗМ-изображения (транспонирование относительно вертикальной оси) (рис. 3.2.3.4) выполняется с помощью:

  • кнопки Flip image horizontally на панели инструментов обработки;
  • команды меню Process > Flip horizontally.
Рис. 3.2.3.4 - Пример выполнения зеркального отображения СЗМ-изображения по горизонтали.

Поворот СЗМ-изображения на 90° по ходу часовой стрелки (рис. 3.2.3.5) выполняется с помощью:

  • кнопки Rotate SPM image 90 degree clockwise на панели инструментов обработки;
  • команды меню Process > Rotate 90° right.
Рис. 3.2.3.5 - Пример выполнения поворота СЗМ-изображения на 90° по ходу часовой стрелки.

Процедура реализуется транспонированием СЗМ-матрицы. Количество последовательных поворотов не ограничено. Для поворота СЗМ-изображения на 180° (в отличие от зеркального отображения), таким образом, необходимо выполнить данную процедуру дважды. Поворот на 270° по ходу часовой стрелки выполняется трехкратным выполнением процедуры. Четырехкратное повторение процедуры возвращает СЗМ-изображение (СЗМ-матрицу) в исходное состояние.

Отмена последнего действия обработки СЗМ-изображения ("откат"). Данная функция позволяет вернуть состояние СЗМ-изображения, в котором оно было до последней применявшейся к нему процедуры обработки. Функция отмены выполняется с помощью:

  • кнопки Undo button на панели инструментов обработки;
  • команды меню Process > Undo;
  • сочетания "быстрых" клавиш <Ctrl + Z> на клавиатуре компьютера.

К процедурам обработки, для которых в программе предусмотрена отмена последнего действия, относятся функции, сгруппированные в пункте меню Process (Обработка) или на панели инструментов обработки, за исключением Crop (Вырезать) и Duplicate (Дублировать) (т.е. тех, которые обработанные данные отображают в новых окнах). Это:

  • процедуры выравнивания;
  • процедуры сглаживания дефектов сканирования;
  • процедуры транспонирования изображения;
  • процедура нормализации;
  • процедуры арифметики изображений;
  • а также процедуры отображения вершин и впадин при анализе данных.

Возврат настройки цветовой палитры в программе не производится.

Количество последовательных шагов отмены последнего действия ("отката") в программе не ограничено.

Изображение, сформированное в окне двухмерного представления, а также дополнительная статистическая информация о нем могут быть сохранены в отчете для последующего использования.


SurfaceXplorer :: SPM Image Correction

[Работа с СЗМ-изображениями] > [Коррекция]

3.3 Коррекция СЗМ-изображения

3.3.1 Искажение положения поверхности при получении СЗМ-изображения
3.3.2 Выравнивание по линии
Вычитание прямой линии вдоль направления X
Вычитание прямой линии вдоль направления Y
Вычитание параболической линии вдоль направления X
Вычитание параболической линии вдоль направления Y
3.3.3 Выравнивание по поверхности
Вычитание общей плоскости
Вычитание общего параболоида
3.3.4 Выравнивание по выделению
Выравнивание по трем точкам
Выравнивание по выделенному прямоугольному участку
3.3.5 Особенности применения процедур выравнивания СЗМ-изображения
Выравнивание СЗМ-изображений регулярных плоских структур
Выравнивание СЗМ-изображений статистически однородных регулярных плоских структур
Выравнивание СЗМ-изображений единичных объектов
3.3.6 Сглаживание дефектов сканирования на СЗМ-изображении
Сглаживание сбоев на линии сканирования
Сглаживание выделенной прямоугольной области
Сглаживание выделенной области в направлении X
Сглаживание выделенной области в направлении Y

Коррекцию СЗМ-изображения рекомендуется проводить непосредственно после открытия файла данных для обеспечения оптимального отображения данных. В первую очередь необходимо выровнять положение всего СЗМ-изображения, и затем в случае необходимости произвести устранение дефектов сканирования.

3.3.1 Искажение положения поверхности при получении СЗМ-изображения

В процессе получении СЗМ-изображения наклон поверхности образца (ее отклонение от горизонтальной плоскости) и сферический характер движения трубчатого сканера могут вносить соответствующие искажения в регистрируемые данные о топографии. В результате на сохраненном СЗМ-изображении могут присутствовать, например, общий наклон измеренной поверхности (рис. 3.3.1), сферическая компонента, искажающие реальную топографию.

General inclination of SPM image due to sample surface tilt
Рис. 3.3.1 - Общий наклон поверхности на СЗМ-изображении, обусловленный негоризонтальностью поверхности измеряемого образца. Здесь и далее на аналогичных иллюстрациях в данном параграфе, слева направо: двухмерное представление в виде карты высот, двухмерное представление с имитацией подсветки, трехмерное представление одного СЗМ-изображения.

Также в СЗМ-матрице возможно наличие рассогласования среднего наклона между линиями быстрого сканирования, обусловленное конечным временем реакции измерительной системы прибора на изменения топографии поверхности образца. Последний тип искажений, тем не менее, может быть устранен непосредственно при получении СЗМ-изображения (т.е. "на лету") применением соответствующих функций обработки регистрируемых данных [image].

В связи с возможным наличием в исходном СЗМ-изображении описанных выше искажений, рекомендуется непосредственно после открытия файла с СЗМ-изображением провести процедуру его [image] выравнивания - устранения из СЗМ-матрицы постоянной составляющей поверхности макроскопического порядка (общего наклона, смещения по вертикальной оси, сферичности, или их суммы). В результате выравнивания значимый диапазон высот СЗМ-изображения масштабируется по вертикальной оси наиболее оптимальным образом, что позволяет отображать топографию с максимальной детализацией. Пример общего наклона поверхности на исходном СЗМ-изображении представлен на рис. 3.3.1.

Следует иметь ввиду, что описанные искажения присущи СЗМ-изображениям топографии. На СЗМ-изображениях контрастов (латеральных сил, сдвига фазы и др.) подобные искажения как правило отсутствуют в связи со спецификой способа регистрации данных при измерениях, а следовательно, проведение процедур выравнивания на них не рекомендуется.

В программе SurfaceXplorer предусмотрены процедуры выравнивания, заключающиеся в автоматическом нахождении и вычитании из исходного СЗМ-изображения одномерных (прямая линия, парабола) и двухмерных (плоскость, параболоид) постоянных компонент. Дополнительные расширенные и/или определяемые пользователем процедуры подобного характера могут быть реализованы с помощью арифметических операций над СЗМ-изображениями. Предусмотрены также специальные варианты выравнивания, для проведения которых пользователю необходимо выделить на СЗМ-изображении опорные объекты - три точки, определяющие плоскость выравнивания, или прямоугольный участок.

Процедуры выравнивания производятся над СЗМ-изображением в активном окне двухмерного представления с помощью:
- команд подменю Process > Leveling > ;
- кнопок на панели инструментов обработки СЗМ-изображения: Toolbar Process Button 'Macros operations' Button 'Normalize current SPM image' Button 'Arithmetic operations with SPM image' Button 'Duplicate current 2D image' Button for vertical flip of the SPM image Button for horizontal flip of the SPM image Button for rotation of the SPM image 90 degree clockwise Button of flatten the selecetd line or area in the SPM image Button of flatten selecetd area in the SPM image along X axis direction Button of flatten selecetd area in the SPM image along y axis direction Button 'Crop selected rectangular area' Leveling general paraboloid surface Leveling general inclination plane Leveling parabola lines on Y axis Leveling parabola lines on X axis Leveling lines on Y axis Leveling lines on X axis Undo procedure button
- команд подменю Leveling > (Выравнивание) контекстного меню окна двухмерного представления.

Все перечисленные способы выполнения процедур выравнивания функционально идентичны.

3.3.2 Выравнивание по линиям

Выравнивание по линиям (одномерное выравнивание) производится путем аппроксимации каждой линии в СЗМ-матрице либо прямой либо параболой с последующим вычитанием рассчитанной линии из исходного профиля. Аппроксимация осуществляется по методу наименьших квадратов. Линии выравнивания могут иметь одно из двух направлений - либо вдоль оси X либо вдоль оси Y. (При этом одно из них совпадет с направлением быстрого, а другое - медленного сканирования в СЗМ при получении изображения).

При выравнивании из каждой линии вычитается ее общий наклон и некоторый незначимый диапазон высот (т.е. происходит смещение линии по вертикальной оси). Кроме этого процедуры вычитания параболических линий позволяют устранить в каждой отдельной линии сферическую составляющую искажений.

Наибольшая эффективность процедуры выравнивания по линии достигается, когда направление выравнивания совпадает с направлением быстрого сканирования при получении СЗМ-изображения.

Вычитание прямой линии вдоль направления X производится с помощью команды меню программы Process > Leveling > Line on X-direction, либо команды контекстного меню в окне двухмерного представления Leveling > Line on X-direction, или при нажатии кнопки Leveling on X direction button на панели инструментов обработки СЗМ-изображения. Результат выполнения данной процедуры для исходного СЗМ-изображения (рис. 3.3.1) представлен на рис. 3.3.2. В представленном примере ось X соответствует направлению быстрого сканирования при получении СЗМ-изображения.

Leveling lines on X direction (Fast scan) - 2D
Рис. 3.3.2 - Результат вычитания прямой линии в направлении X (здесь - быстрого сканирования) (исходное СЗМ-изображение - на рис. 3.3.1)

Специфика алгоритма выполнения данной процедуры может привносить собственные [image] артефакты (т.е. искуственно созданные самой системой элементы рельефа поверхности) в топографию, особенно заметные на изображениях с резкими одиночными пиками (выступами) или на регулярных структурах. Например, на структуре, представленной на рис. 3.3.2 после выравнивания появились выступающие полосы вдоль направления оси X. Однако данные артефакты обычно не проявляются на относительно однородных нерегулярных поверхностях (рис. 3.3.3).

Leveling on X direction button
Рис. 3.3.3 - Пример выравнивания СЗМ-изображения нерегулярной поверхности с помощью функции вычитания прямой линии по направлению быстрого сканирования: слева - исходное изображение; справа - изображение после выравнивания.

Вычитание прямой линии вдоль направления Y производится с помощью команды меню программы Process > Leveling > Line on Y-direction, либо команды контекстного меню в окне двухмерного представления Leveling > Line on Y-direction, или при нажатии кнопки Leveling on X direction button на панели инструментов обработки СЗМ-изображения. Результат выполнения данной процедуры для исходного СЗМ-изображения (рис. 3.3.1) представлен на рис. 3.3.4. В представленном примере ось Y соответствует направлению медленного сканирования при получении СЗМ-изображения.

Рис. 3.3.4 - Результат вычитания прямой линии в направлении Y (здесь - медленного сканирования) (исходное СЗМ-изображение - на рис. 3.3.1).

Так же, как и в случае вычитания прямой линии по направлению X, данная процедура может привносить артефакты на изображениях с резкими одиночными пиками (выступами) или на регулярных структурах (например, полосы в направлении оси Y на рис. 3.3.4).

Вычитание параболической линии вдоль направления X производится с помощью команды меню программы Process > Leveling > Parabola on X-direction, либо команды контекстного меню в окне двухмерного представления Leveling > Parabola on X-direction, или при нажатии кнопки Leveling parabola on X direction button на панели инструментов обработки СЗМ-изображения. Результат выполнения данной процедуры для исходного СЗМ-изображения (рис. 3.3.1) представлен на рис. 3.3.5. В представленном примере ось X соответствует направлению быстрого сканирования при получении СЗМ-изображения.

Рис. 3.3.5 - Результат вычитания параболической линии в направлении X (здесь - быстрого сканирования) (исходное СЗМ-изображение - на рис. 3.3.1).

Особенности работы алгоритма данной процедуры не устраняют полностью общий наклон поверхности в направлении, перпендикулярном направлению выравнивания (рис. 3.3.5) - в данном случае некоторый наклон вдоль оси Y сохраняется.

Вычитание параболической линии вдоль направления Y производится с помощью команды меню программы Process > Leveling > Parabola on Y-direction, либо команды контекстного меню в окне двухмерного представления Leveling > Parabola on Y-direction, или при нажатии кнопки Leveling parabola on Y direction button на панели инструментов обработки СЗМ-изображения. Результат выполнения данной процедуры для исходного СЗМ-изображения (рис. 3.3.1) представлен на рис. 3.3.6. В представленном примере ось X соответствует направлению быстрого сканирования при получении СЗМ-изображения.

Рис. 3.3.6 - Результат вычитания параболической линии в направлении Y (здесь - медленного сканирования) (исходное СЗМ-изображение - на рис. 3.3.1).

Так же как и в случае предыдущей процедуры, особенности работы алгоритма не устраняют полностью общий наклон поверхности в направлении, перпендикулярном направлению выравнивания (рис. 3.3.6) - в данном случае наклон вдоль оси X сохраняется.

Несмотря на определенные недостатки, процедура выравнивания по линии незаменима при наличии на исходном СЗМ-изображении рассогласования между линиями сканирования - т.е. когда высота отдельных линий заметно отличается ("выпадает") от высоты соседних (но содержит при этом информацию о топографии).

3.3.3 Выравнивание по поверхности

Выравнивание по поверхности (двухмерное выравнивание) производится путем аппроксимации всего описанного СЗМ-матрицей рельефа плоскостью или параболоидом с последующим вычитанием рассчитанной поверхности из исходной. Аппроксимация осуществляется по методу наименьших квадратов. При выравнивании вычитается общий наклон поверхности и некоторый незначимый диапазон высот (т.е. происходит смещение всего рельефа по вертикальной оси). Кроме этого процедура вычитания общего параболоида позволяет также устранить сферическую составляющую общих искажений.

Вычитание общей плоскости производится с помощью команды меню программы Process > Leveling > Plane, либо команды контекстного меню в окне двухмерного представления Leveling > Plane, или при нажатии кнопки Button 'Leveling plane' на панели инструментов обработки СЗМ-изображения. Результат выполнения данной процедуры для исходного СЗМ-изображения (рис. 3.3.1) представлен на рис. 3.3.7.

Рис. 3.3.7 - Результат вычитания общей плоскости из исходного СЗМ-изображения (исходное СЗМ-изображение - на рис. 3.3.1).

Выравнивание по поверхности с вычитанием общей плоскости достаточно корректно обрабатывает исходное СЗМ-изображение, особенно если на нем содержится достаточно боьшое количество характерных элементов топографии. Однако данная процедура не устраняет общую сферическую составляющую искажений, для чего может быть применена следующая функция.

Вычитание общего параболоида производится с помощью команды меню программы Process > Leveling > Paraboloid, либо команды контекстного меню в окне двухмерного представления Leveling > Paraboloid, или при нажатии кнопки Button 'Leveling paraboloid' на панели инструментов обработки СЗМ-изображения. Результат выполнения данной процедуры для исходного СЗМ-изображения (рис. 3.3.1) представлен на рис. 3.3.8.

Рис. 3.3.8 - Результат вычитания общего параболоида из исходного СЗМ-изображения (исходное СЗМ-изображение - на рис. 3.3.1).

Выравнивание по поверхности с вычитанием общего параболоида обычно достаточно корректно проводит обработку исходного СЗМ-изображения, устраняя как общий наклон, так и сферическую составляющую искажений. Тем не менее, наиболее заметные результаты выполнения данной процедуры достигаются при выравнивании СЗМ-изображений заведомо плоских поверхностей (например, кремниевой подложки как на рис. 3.3.8).

3.3.4 Выравнивание по выделению

Функция выравнивания по выделению предполагает явное задание пользователем некоторого опорного объекта на СЗМ-изображении, параметры которого будут использоваться как основа при выполнении процедуры. В программе SurfaceXplorer реализованы два типа выравнивания по выделению: (1) выравнивание плоскости по трем точкам и (2) выравнивание по выделенному прямоугольному участку.

Выравнивание по трем точкам производится с вычитанием общей плоскости, задаваемой тремя предварительно установленными точками, определяющими опорную плоскость.
Таким образом, процедура выполняется в два этапа:

  1. Установить на СЗМ-изображении три выделенные точки, воспользовавшись инструментами выделения точки (рис. 3.3.9 слева) или произвольной ломаной линии (рис. 3.3.10 слева).
  2. После задания трех опорных точек провести процедуру выравнивания по поверхности с вычитанием общей плоскости - с помощью команды Process > Leveling > Plane меню программы, либо команды Leveling > Plane контекстного меню в окне двухмерного представления, или кнопки Button 'Leveling plane' на панели инструментов обработки СЗМ-изображения. Для расчета общего наклона будет использована не аппроксимированная плоскость всего СЗМ-изображения, а плоскость, явно определяемая тремя заданными точками.

Пример выполнения функции выравнивания по трем точкам представлен на рис. 3.3.9 и рис. 3.3.10.

Leveling general inclination plane
Рис. 3.3.9 - Выравнивание СЗМ-изображения по трем выделнным точкам: слева - исходное изображение с установленными на нем тремя точками; справа - результат вычитания общей плоскости, заданной тремя точками.

Для выполнения данной процедуры необходимо наличие не менее трех выделенных точек. При наличии на СЗМ-изображении более трех узловых точек (соответственно, более двух сегментов в заданной ломаной линии, рис. 3.3.10 слева) программа для определения опорной плоскости автоматически будет использовать первые три точки (первые два сегмента ломаной).

Leveling general inclination plane
Рис. 3.3.10 - Выравнивание СЗМ-изображения по трем выделнным точкам: слева - исходное изображение с установленной на нем произвольной ломаной линией (как минимум с двумя сегментами); справа - результат вычитания общей плоскости, заданной тремя точками на ломаной линии.

Для достижения наилучшего результата при выравнивании три опорные точки должны располагаться как можно дальше друг от друга и не лежать на одной прямой.

Процедура выравнивания по трем выделенным точкам особенно эффективна при выравнивании СЗМ-изображений поверхностей с заведомо плоскими участками, лежащими на одном уровне (например, кремниевая подложка на рис. 3.3.9 или компакт-диск на рис. 3.3.10). Если после применения процедуры выравнивания по трем точкам на СЗМ-изображении заведомо плоской поверхности заметна сферическая составляющая, рекомендуется дополнительно провести выравнивание по поверхности с вычитанием общего параболоида.

Выравнивание по выделенному прямоугольному участку предусматривает два варианта: (1) выравнивание всего изображения по образцу выделенного участка и (2) выравнивание области изображения внутри выделенного участка. В обоих случаях программа рассчитывает исходные параметры для выполнения процедуры, учитывая (аппроксимируя) только данные, ограничиваемые выделенным участком. Однако в первом варианте с использованием рассчитанных параметров производится выравнивание всего СЗМ-изображения, а во втором - только выделенного участка, в то время как окружающие области остаются неизмененными (т.е в исходном состоянии).

Проведение процедуры выравнивания по выделенному участку (в двух вариантах) в программе SurfacXplorer предусматривается для таких функций, как:
- вычитание общей плоскости;
- вычитание общего параболоида;
- вычитание параболической линии вдоль направления X;
- вычитание параболической линии вдоль направления Y.

В общем случае процедура выполняется в два этапа:

  1. Выделить на СЗМ-изображении прямоугольный участок, воспользовавшись инструментом выделения прямоугольной области [image] на панели инструментов.
  2. После выделения прямоугольной области выполнить соответствующую процедуру выравнивания, используя команду общего меню программы или контекстного меню окна двухмерного представления СЗМ-данных. Для выполнения первого варианта процедуры допускается использовать также соответствующие кнопки на панели инструментов.

Ниже приводится описание и примеры выполнения всех вариантов выравнивания по выделенному участку

Initial SPM image of CD RW surface

Исходное СЗМ-изображение с выделенным прямоугольным участком.

Образец - участок поверхности диска CDRW, на котором присутствуют выступ (левая половина кадра), сформированный при записи информации, и элемент основной поверхности (правая половина кадра). На изображении выделен участок основной поверхности, о котором известно, что он плоский.
Leveling plane based on selection

Вычитание из СЗМ-изображения общей плоскости, рассчитанной аппроксимацией выделенного участка.
Выполняется с помощью:

  • команды меню Process > Leveling > Plane > Based on selection;
  • команды контекстного меню в окне двухмерного представления Leveling > Plane > Based on selection;
  • кнопки Leveling general inclination plane на панели инструментов выделения.

Общая плоскость наклона рассчитывается аппроксимацией выделенного участка, а затем вычитается из всего СЗМ-изображения. Процедура дает адекватный результат при корректном выборе опорного участка, используемого для определения параметров плоскости наклона. В данном примере (изображение одной ступеньки) подобная процедура в отличие от обычного вычитания общей плоскости обеспечивает более коректное выравнивание СЗМ-изображения в целом. Альтернатива - вычитание общего параболоида по образцу выделения или выравнивание по трем точкам.
Leveling plane inside selection

Вычитание внутри выделенного участка на СЗМ-изображении общей плоскости наклона.
Выполняется с помощью:

  • команды меню Process > Leveling > Plane > Inside selection;
  • команды контекстного меню в окне двухмерного представления Leveling > Plane > Inside selection.

Общая плоскость наклона рассчитывается аппроксимацией выделенного участка, а затем вычитается из этого выделения. Положение участка выравнивается относительно его средней точки, а остальные области исходного СЗМ-изображения остаются без изменений.
Leveling paraboloid based on selection

Вычитание из СЗМ-изображения общего параболоида, рассчитанного аппроксимацией выделенного участка.
Выполняется с помощью:

  • команды меню Process > Leveling > Paraboloid > Based on selection;
  • команды контекстного меню в окне двухмерного представления Leveling > Paraboloid > Based on selection;
  • кнопки Leveling general inclination plane на панели инструментов выделения.

Общий параболоид рассчитывается аппроксимацией выделенного участка, а затем вычитается из всего СЗМ-изображения. Процедура дает адекватный результат при корректном выборе опорного участка, используемого для определения параметров параболоида. В данном примере (изображение одной ступеньки) подобная процедура в отличие от обычного вычитания параболоида обеспечивает более коректное выравнивание СЗМ-изображения в целом. Альтернатива - вычитание общей плоскости по образцу выделения или выравнивание по трем точкам.
leveling paraboloid inside selection

Вычитание внутри выделенного участка на СЗМ-изображении общего параболоида.
Выполняется с помощью:

  • команды меню Process > Leveling > Paraboloid > Inside selection;
  • команды контекстного меню в окне двухмерного представления Leveling > Paraboloid > Inside selection.

Общий параболоид рассчитывается аппроксимацией выделенного участка, а затем вычитается из этого выделения. Положение участка выравнивается относительно его средней точки, а остальные области исходного СЗМ-изображения остаются без изменений.
Leveling parabola lines in X direction based on selection

Вычитание из СЗМ-изображения параболических линий вдоль направления X, рассчитанных аппроксимацией отрезков линий сканирования внутри выделенного участка.
Выполняется с помощью:

  • команды меню Process > Leveling > Parabola on X-direction > Based on selection;
  • команды контекстного меню в окне двухмерного представления Leveling > Parabola on X-direction > Based on selection;
  • кнопки Leveling general inclination plane на панели инструментов выделения.

Параметры параболических линий рассчитываются аппроксимацией отрезков линий сканирования, ограничиваемых выделенным участком, а затем экстраполируются для вычитания параболических линий из всех линий сканирования СЗМ-изображения. Процедура устраняет общий наклон между общей плоскостью поверхности и осью X, но сохраняет наклон между общей плоскостью поверхности и осью Y.

Leveling parabola lines in X direction inside selection

Вычитание внутри выделенного участка на СЗМ-изображении параболических линий вдоль направления X.
Выполняется с помощью:

  • команды меню Process > Leveling > Parabola on X-direction > Inside selection;
  • команды контекстного меню в окне двухмерного представления Leveling > Parabola on X-direction > Inside selection.

Параметры параболических линий рассчитываются аппроксимацией отрезков линий сканирования, ограничиваемых выделенным участком, а затем данные параболические линии вычитаются из соответствующих отрезков линий сканирования внутри выделения. Процедура устраняет наклон между общей плоскостью выделенного участка и осью X, но сохраняет наклон между общей плоскостью выделенного участка и осью Y. Положение участка выравнивается относительно стороны выделнного прямоугольного участка, находящейся ближе к началу координат изображения (т.е. сторона выделения, перпендикулярная оси X и имеющая наименьшую координату по этой оси, является осью поворота выделенного участка).
Leveling parabola lines in Y direction based on selection

Вычитание из СЗМ-изображения параболических линий вдоль направления Y, рассчитанных аппроксимацией отрезков линий сканирования внутри выделенного участка.
Выполняется с помощью:

  • команды меню Process > Leveling > Parabola on Y-direction > Based on selection;
  • команды контекстного меню в окне двухмерного представления Leveling > Parabola on Y-direction > Based on selection;
  • кнопки Leveling general inclination plane на панели инструментов выделения.

Параметры параболических линий рассчитываются аппроксимацией отрезков линий сканирования, ограничиваемых выделенным участком, а затем экстраполируются для вычитания параболических линий из всех линий сканирования СЗМ-изображения. Процедура устраняет общий наклон между общей плоскостью поверхности и осью Y, но сохраняет наклон между общей плоскостью поверхности и осью X.

Leveling parabola lines in Y direction inside selection

Вычитание внутри выделенного участка на СЗМ-изображении параболических линий вдоль направления Y.
Выполняется с помощью:

  • команды меню Process > Leveling > Parabola on Y-direction > Inside selection;
  • команды контекстного меню в окне двухмерного представления Leveling > Parabola on Y-direction > Inside selection.

Параметры параболических линий рассчитываются аппроксимацией отрезков линий сканирования, ограничиваемых выделенным участком, а затем данные параболические линии вычитаются из соответствующих отрезков линий сканирования внутри выделения. Процедура устраняет наклон между общей плоскостью выделенного участка и осью Y, но сохраняет наклон между общей плоскостью выделенного участка и осью X. Положение участка выравнивается относительно стороны выделнного прямоугольного участка, находящейся ближе к началу координат изображения (т.е. сторона выделения, перпендикулярная оси Y и имеющая наименьшую координату по этой оси, является осью поворота выделенного участка).

Процедура выравнивания всего СЗМ-изображения по образцу выделенного прямоугольного участка эффективна, если заведомо известно, что на измеренной поверхности присутствуют плоские области. В этом случае их можно однозначно использовать для задания опорного участка. Для образцов поверхностей с неизвестной структурой данную процедуру выполнять не рекомендуется во избежание внесения искуственных искажений (артефактов).

3.3.5 Особенности применения процедур выравнивания СЗМ-изображения

В общем случае обработку и анализ СЗМ-изображения поверхности с неизвестной морфологией рекомендуется начинать с выравнивания вычитанием общей плоскости. Данная процедура для случайного рельефа обеспечивает наименьшую вероятность внесения артефактов обработки. Дополнительные процедуры выравнивания и коррекции применяются в зависимости от визуально оцениваемого наличия искажений и сбоев (дефектов сканирования) на СЗМ-изображении. Чаще всего дополнительно применяются вычитание прямой линии в направлении быстрого сканирования и вычитание общего параболоида, позволяющие устранить сферичность на изображении. Для гомогенных (т.е. структурно однородных, без явно выраженных направленности и структуризации элементов) поверхностей выравнивание вместо вычитания общей плоскости может ограничиваться вычитанием общего параболоида. В любом случае, критерием корректности проведенной прцедуры выравнивания (коррекции) является отсутствие артефактов на обработанном изображении.

Тем не менее, существует ряд специфических образцов поверхностей, для получения корректного результата выравнивания которых необходимо тщательно подбирать тип применяемой процедуры. Среди таких поверхностей, в первую очередь, регулярные структуры (как линейные, так и пространственные), а также единичные объекты (на плоской подложке) и (сверх)гладкие поверхности.

В любом случае следует помнить, что в программе SurfaceXplorer допускается отмена результата выполнения процедуры. Кроме того, всегда можно создать дубликат окна двухмерного представления в его текущем состоянии перед выполнением процедуры. Совокупность этих средств позволяет пользователю активно экспериментировать с функциями обработки СЗМ-изображения без угрозы потери или порчи промежуточных (и тем более исходных) данных.

Выравнивание СЗМ-изображений регулярных плоских структур. Регулярные структуры используются в СЗМ не только как объекты иследований, но также как средство калибровки измерительной системы самого прибора. Для проведения этой процедуры широко используются, например, тест-решетки с известными параметрами, изготавливаемые компанией Mikromasch и др.. На рис. 3.3.11 представлена схема одной из таких тест-решеток - TGZ01.

Рис. 3.3.11 - Структура тест-решетки TGZ01. Шаг решетки b = 3 мкм.

Для правильной настройки измерительной системы крайне необходимо иметь СЗМ-изображение подобной структуры, наиболее близко отображающее ее реальную топографию. Ниже приводятся примеры и комментарии к использованию различных процедур выравнивания СЗМ-изображения тест-решетки TGZ01.

Исходное СЗМ-изображение тест-решетки TGZ01.
Левая граница отсканированного участка проходит по выступу (ступеньке) решетки, а правая - по впадине. Линейные структуры (ступеньки) ориентированы практически строго параллельно оси Y. На изображении заметен общий наклон по диагонали. СЗМ-изображение данного образца получено при направлении быстрого сканирования вдоль оси X, т.е поперек ориентации линейных структур (ступенек).

Leveling lines in X direction Результат выравнивания вычитанием прямой линии вдоль направления X (здесь - направление быстрого сканирования).
Устранен наклон вдоль оси Y, но сохранился наклон вдоль оси X, т.к. левая и правая границы попали на элементы, расположенные на различной высоте. Кроме того, на изображении присутствует цилиндрическая составляющая, т.к. аппроксимирующие прямые линии не устраняют в своем направлении сферическую компоненту.

Leveling lines in Y direction button Результат выравнивания вычитанием прямой линии вдоль направления Y.
Устранен наклон вдоль оси X, но одновременно искажен (фактически - уничтожен) рельеф (ступеньки), поскольку направление выравнивания практически полностью совпадает с ориентацией линейных структур на поверхности. Кроме того, на изображении заметна цилиндрическая составляющая (аппроксимирующие прямые линии не устраняют в своем направлении сферическую компоненту).
Leveling lines in X direction Результат выравнивания вычитанием параболической линии вдоль направления X.
Устранена цилиндрическая составляющая вдоль оси Y, но наклон вдоль оси Y сохранился. Общий наклон вдоль оси X уменьшен, но полностью не устранен, т.к. левая и правая границы попали на элементы, расположенные на различной высоте.

Leveling lines in X direction Результат выравнивания вычитанием параболической линии вдоль направления Y.
Устранена цилиндрическая составляющая вдоль оси Y, но наклон вдоль оси Y сохранился. Общий наклон вдоль оси X уменьшен, но полностью не устранен, т.к. левая и правая границы попали на элементы, расположенные на различной высоте.
Leveling general inclination plane Результат выравнивания вычитанием общей плоскости наклона.
Устранен наклон по оси Y, наклон вдоль оси X уменьшен, но полностью не устранен, т.к. левая и правая границы попали на участки, расположенные на различной высоте. Сферическая составляющая не устранена в силу специфики алгоритма.
Leveling paraboloid surface Результат выравнивания вычитанием общей параболы.
Устранен наклон по оси Y, наклон вдоль оси X уменьшен, но полностью не устранен, т.к. левая и правая границы попали на участки, расположенные на различной высоте. Сферическая составляющая автоматически устранена.
+ Leveling paraboloid Результат выравнивания вычитанием общего параболичоида по образцу выделенного участка.
Прямоугольный участок выделен в одласти впадины, которая в реальности представляет собой плоскость. Устранен наклон по оси Y, наклон вдоль оси X полностью не устранен, т.к. опорный участок выделен не в центре изображения и имеет начальный наклон, который рассматривается как общий. Сферическая составляющая устранена.
Leveling paraboloid +( Selecting three point + Leveling plane by three points ) Результат выравнивания в два этапа: (1) вычитанием общего параболоида и затем (2) вычитанием общей плоскости по трем точкам.
Устранена цилиндрическая составляющая вдоль оси Y, но наклон вдоль оси Y сохранился. Общий наклон вдоль оси X уменьшен, но полностью не устранен, т.к. левая и правая границы попали на элементы, расположенные на различной высоте.

Выравнивание СЗМ-изображений статистически однородных регулярных плоских структур. Для изображений регулярных структур, статистически равномерно распределенных на плоской поверхности, процедура выравнивания обычно упрощается и ограничивается вычитанием общего параболоида. На рис. 3.3.12 для сравнения представлены результаты вычитания общей плоскости (вверху посредине) и вычитания общего параболоида (вверху справа) из СЗМ-изображения исходной поверхности (вверху слева). Очевидно, что выравнивание вычитанием общего параболоида сразу приводит к наиболее удовлетворительному резултату, что подтверждается этим же изображением в трехмерном представлением (внизу справа).

Рис. 3.3.12 - Пример выравнивания СЗМ-изображения статистически однородной регулярной плоской структуры.
Вверху - исходное изображение (слева), результат вычитания общей плоскости (посредине), результат вычитания общего параболоида (справа).
Внизу (справа) - трехмерное СЗМ-изображение поверхности после вычитания общего параболоида.

Пример выравнивания СЗМ-изображения двухмерной регулярной структуры с равномерным распределением элементов рассмотрен выше на рис. 3.3.1, 3.3.2, 3.3.4, 3.3.5, 3.3.6, 3.3.7, 3.3.8.

Выравнивание СЗМ-изображений единичных объектов. Особая ситуация возникает при выравнивании СЗМ-изображений одиночных объектов. В этом случае результаты автоматического выравнивания, доступного в программе, в значительной степени искажают форму данного единичного объекта и зависят от размещения его в поле изображения (кадре). Существенную помощь для корректного выполнении подобной задачи может оказать наличие в поле изображения участка плоской поверхности, к примеру, подложки. Это даст возможность выделить на них три точки или прямоугольный участок, определяющих опорную поверхность для выравнивания по выделению.

На рис. 3.3.13 представлены результаты сравнения процедур выравнивания единичного объекта - эритроцита, размещенного в центре поля СЗМ-изображения. Слева представлен результат выравнивания по трем точкам, установленным на участках, отображающих плоскую подложку, справа - результат применения к тому же изображению процедуры вычитания общего параболоида. Как видно из сравнения, автоматически проведенная процедура в силу специфических особенностей объекта некорректно преобразовала исходное изображение и исказила форму объекта (а также и подложки).

Рис. 3.3.13 - Сравнение результатов выполнения процедур выравнивания единичного эритроцита. Слева - результат выравнивания по трем точкам, установленным на участках, отображающих плоскую подложку, справа - результат применения процедуры вычитания общего параболоида.

Отдельная ступенька, представляющая собой две плоскости на различных уровнях - еще один пример единичного объекта, СЗМ-изображение которого крайне сложно выровнять с помощью автоматических процедур. Особо неоднозначная ситуация возникает, когда одну часть изображения занимает выступ, а другую - впадина. Ниже приведены примеры выполнения автоматических процедур выравнивания с анализом результирующих ошибок. Также в заключение представлен способ корректного выравнивания данного образца.
Исходное СЗМ-изображение ступеньки.
Особенность объекта - ориентация ступеньки вдоль оси Y, а также локализация левой и правой границ кадра над выступом и впадиной соответственно.

Leveling lines in X direction button Результат вычитания прямых линий вдоль направления X.
Наклон по оси Y устранен, но наклон вдоль оси X искажен в силу особенностей объекта. Цилиндричность незаметна на фоне внесенных искажений.

Leveling lines in Y direction button Результат вычитания прямых линий вдоль направления Y.
Общий наклон устранен, но цилиндричность вдоль оси X не исправлена в силу специфики алгоритма процедуры. Особенности ориентации структуры и ее совпадение с направлением выравнивания привели к уничтожению реального рельефа.

2D image of a step levelled by subtraction of parabolic lines in X direction 3D image of a step levelled by subtraction of parabolic lines in X direction
Leveling parabolic lines in X direction button Результат вычитания параболических линий вдоль направления X.
Наклон по оси Y не устранен, наклон вдоль оси X искажен в силу особенностей объекта.

2D image of a step levelled by subtraction of parabolic lines in Y direction 3D image of a step levelled by subtraction of parabolic lines in Y direction
Leveling parabolic lines in X direction button Результат вычитания параболических линий вдоль направления Y.
Наклон по оси Y устранен, наклон вдоль оси X не устранен.

2D image of a step levelled by subtraction of general plane 3D image of a step levelled by subtraction of general plane
Leveling general inclination plane Результат вычитания общей плоскости.
Наклон по оси Y устранен, но наклон вдоль оси X искажен в силу особенностей объекта. Цилиндрическая составляющая незаметна на фоне внесенных искажений.

2D image of a step levelled by subtraction of paraboloid surface 3D image of a step levelled by subtraction of paraboloid surface
Leveling general inclination plane Результат вычитания общего параболоида.
Наклон по оси Y устранен, но наклон вдоль оси X искажен в силу особенностей объекта.

2D image of a step levelled by subtraction of paraboloid surface based on selected area 3D image of a step levelled by subtraction of paraboloid surface based on selected area
Select area + Leveling general inclination plane Результат вычитания общего параболоида по выделенному участку (шаг 1 из 2).
Прямоугольный участок выделен в области впадины. Наклон по оси Y устранен, наклон вдоль оси X полностью не исправлен , т.к выделнный участок находился не в центре изображения. Сферическая составляющая устранена. Следующий шаг устраняет оставшиеся недостатки ...

2D image of a step levelled by subtraction of paraboloid surface 3D image of a step levelled by subtraction of paraboloid surface
... Select area + Leveling general inclination plane Результат вычитания общей плоскости по выделенному участку (шаг 2 из 2).
Завершающий шаг выравнивания изображения ступеньки. Использован тот же прямоугольный участок, который был выделен в области впадины для предыдущего шага. Изображение максимально приближено к реальной топографии.

3.3.6 Сглаживание дефектов сканирования на СЗМ-изображении

Помимо искажения положения поверхности при полчении СЗМ-изображения в работе измерительной системы иногда возникают сбои, обусловленные рядом случайных факторов, как, например, внезапное изменение (повышение) уровня вибрации (особенно заметное при измерении гладких поверхностей), перестройка параметров системы обратной связи, наличие локальных загрязнений и др. При этом возникают [image] дефекты сканирования - линейные или точечные элементы (выбросы), высота которых резко отличается от высоты окружающих участков рельефа поверхности (рис. 3.3.14). Тем не менее, средства сглаживания дефектов сканирования, доступные в программе SurfaceXplorer, позволяют продолжить работу с СЗМ-изображенияем.

Рис. 3.3.14 - Пример СЗМ-изображения с дефектами сканирования.

Устранение сбоев осуществляется путем выделения дефектного элемента рельефа на СЗМ-изображении вручную в окне двухмерного представления, и выполнения соответствующих процедур сглаживания с помощью команд меню или кнопок на панели инструментов обработки.

Общий алгоритм сглаживания дефектов предусматривает расчет и установку новой высоты для точек внутри выделенного участка путем интерполяции вертикальных координат точек на границах заданной области. На рис. 3.3.15 представлена схема даной процедуры. Например, в выделенной области ABCD необходимо устранить дефект, проявляющийся как точечный выброс с пиком в точке Z0. Положение точки Z0 для этого корректируется, с тем точбы определить координаты ее нового положения Z1 путем усреднения высот точек на границах области. В данном случае искомая точка Z1 будет находиться на пересечении линий X1-X2 и Y1-Y2. Вначале эти линии заменяются отрезками прямых, после чего рассчитываются высоты промежуточных точек Z1X и Z1Y, находящихся в месторасположении проекции точки Z0 на линии X1-X2 и Y1-Y2, соответственно. Окончательно, высота точки Z1 определяется как среднеарифметическое значение между высотами точек Z1X и Z1Y. Аналогично корректируется положение и других точек внутри выделенной области ABCD (рис. 3.3.15).

Рис. 3.3.15 - Схема коррекции высоты точек в выделенной области.

В программе SurfaceXplorer реализованы четыре разновидности описанного алгоритма, ориентированные на выполнение задач со своей спецификой:
- сглаживание сбоев на отдельной линии сканирования;
- сглаживание выделенной области с полной интерполяцией граничных параметров;
- сглаживание выделенной области в направлении X;
- сглаживание выделенной области в направлении Y.

Сглаживание сбоев на линии сканирования представляет собой адаптацию общего алгоритма к условиям коррекции единичной линии. Производится усреднением высоты точек выделенной линии сканирования на основании данных о вертикальных координатах точек на соседних параллельных с ней линий (рис. 3.3.16).

Line flatten scheme
Рис. 3.3.16 - Схема проведения коррекции единичной линии сканирования.

Например, положение точки Z0 (рис. 3.3.16) корректируется для нахождения координат ее нового положения Z1 путем усреднения высот точек на соседних параллельных линиях сканирования. В данном случае искомая точка Z1 будет находиться посредине отрезка X1-X2, и ее вертикальная координата будет определяться как среднеарифметическое между высотами точек X1 и X2. Аналогично корректируется положение и других точек на выделенной линии сканирования (пунктирная линия).

Процедура сглаживания сбоев на линии сканирования включает следующие этапы:

  1. Выделить линию сканирования с дефектом, воспользовавшись соответствующим инструментом выделения [image] / [image] [image] ;
  2. Произвести сглаживание с помощью команды меню Process > Flatten > Selection, либо с помощью кнопки Flatten selection на панели инструментов обработки.

Для точного позиционирования выделения над дефектной линий можно воспользоваться следующим способом. После активации инструмента выделения линии сканирования открыть окно профиля поперечного сечения (кнопка [image] на панели типов визуализации) и, перемещая с помощью мыши линию выделения в окне духмерного представления, следить за появлением профиля, существенно отличающегося по своим очертаниям от соседних линий (рис. 3.3.17).

Рис. 3.3.17 - Методика установки выделенения линии сканирования на дефектную линию.
Вверху - профиль поперечного сечения, характерный для данной поверхности без сбоя сканирования (Y=1.75 um); сбой на линии с кординатами Y=1.8 um.
Посредине - выделена дефектная линия сканирования с резко отличающимся профилем поперечного сечения (Y=1.8 um).
Внизу - результат сглаживания: сбой линии сканирования в районе выделения устранен (Y=1.8 um).

Данный способ поиска основывается на том факте, что соседние линии сканирования обычно незначительно отличаются друг от друга, демонстрируя определенную тенденцию в изменении своего очертания при последователеьном переходе от одной линии к следующей (для статистически подавляющего большинства разновидностей рельефов поверхностей).

Сглаживание выделенной прямоугольной области в общем случае производится согласно описанному выше алгоритму.

Процедура сглаживания выделенной области включет следующие этапы (рис. 3.3.18):

  1. Выделить прямоугольную область с дефектом, предназначенным для корррекции, воспользовавшись соответствующим инструментом выделения [image] ;
  2. Произвести сглаживание с помощью команды меню Process > Flatten > Selection, либо с помощью кнопки [image] на панели инструментов обработки.
Рис. 3.3.18 - Пример сглаживания точечного дефекта в выделенной прямоугольной области. Слева - выделение прямоугольного участка вокруг точечного дефекта на СЗМ-изображении; справа - результат сглаживания.

Для минимизации искажений недефектных данных о топографии образца, а также предотвращения внесения артефактов при выполнении процедуры рекомендуется выделять как можно меньшую прямоугольную область вокруг дефекта.

Минимизировать искажения недефектных данных при сглаживании выделенной прямоугольной области можно также применяя адаптированные алгоритмы, предусматривающие коррекцию линий в матрице только в одном направлении, как это показано ниже.

Сглаживание выделенной области в направлении X. Данная разновидность процедуры сглаживания основывается на общем алгоритме, однако отличается от него тем, что корректируются только линии, параллельные оси X матрицы. На схеме, изображенной на рис. 3.3.19, новая вертикальная координата для корректируемой точки Z0 таким образом будет определяться положением ее проекции Z1 на участке прямой X1-X2.

Scheme of selected area flattening
Рис. 3.3.19 - Схема проведения коррекции области сканирования по направлениям..

Процедура сглаживания выделенной области в направлении X включает следующихе этапы:

  1. Выделить прямоугольную область с дефектом, предназначенным для корррекции, воспользовавшись соответствующим инструментом выделения [image] ;
  2. Произвести сглаживание с помощью команды меню Process > Flatten > Area on X direction, либо с помощью кнопки [image] на панели инструментов обработки.

Сглаживание выделенной области в направлении Y. Данная разновидность процедуры сглаживания также основывается на общем алгоритме, однако отличается от него тем, что корректируются только линии, параллельные оси Y матрицы. На схеме, изображенной на рис. 3.3.19, новая вертикальная координата для корректируемой точки Z0 таким образом будет определяться положением ее проекции Z1 на участке прямой Y1-Y2.

Процедура сглаживания выделенной области в направлении Y включает следующихе этапы:

  1. Выделить прямоугольную область с дефектом, предназначенным для корррекции, воспользовавшись соответствующим инструментом выделения [image] ;
  2. Произвести сглаживание с помощью команды меню Process > Flatten > Area on Y direction, либо с помощью кнопки [image] на панели инструментов обработки.

Наличие двух последних функций позволяет выбрать наилучшее направление для сглаживания в прямоугольной области, с тем чтобы обеспечить внесение минимума искажений в реальные данные. На примере (рис. 3.3.20) видно, что выбор направления, в котором изменение рельефа вокруг дефекта менее значительно (здесь - направление Y, результат внизу слева) практически не оставляет искажений после сглаживания, в то время как выбор направления с бОльшими изменениями (здесь - направление X, результат вверху справа) приводит к появлению аретфакта - прямоугольной площадки (на месте выделения).

Рис. 3.3.20 - Пример результатов корреции точечного дефекта (вверху слева) по прямоугольной области в направлении X (вверху справа) и направлению Y (внизу слева).

Наиболее оптимальную разновидность сглаживания в выделенной прямоугольной области можно подобрать, экспериментирую со всеми тремя (обычно даже двумя - по направлению X или Y) процедурами и выбирая тот результат, при котором менее всего заметны следы вмешательства (т.е. меньше искусственно внесенных процедурой элементов рельефа).


SurfaceXplorer :: Color Palette Adjustment

[Работа с СЗМ-изображениями] > [Палитра]

3.4 Настройка цветовой палитры

Panel for color palette adjustment
Рис. 3.3.1 - Панель настройки цветовой палитры (в исходном состоянии)

Панель [Palette] (Палитра) (рис. 3.3.1) предоставляет средства для настройки цветовой шкалы (палитры) изображений в окнах двухмерного и трехмерного представления СЗМ-данных. Ресурсы панели всегда отображают состояние и обеспечивают настройку цветовой палитры изображения в активном окне визуализации и при смене активного окна соответственно обновляются (актуализируются).

Для вызова панели можно воспользовваться одним из следующих способов:
- активировать ярлык Palette (Палитра) на вкладке [Свойства] / [Properties] панли настроек программы;
- в контекстном меню, вызываемом правой кнопкой мыши в окне визуализации, выбрать соответстсвующий пункт (например, Edit palette);
- в окне двухмерного представления щелкнуть два раза левой кнопкой мыши по цветовой шкале справа от изображения.

Использование последних двух способов - наиболее быстрый путь вызова панели настройки палитры, если активны вкладки, иные чем вкладка [Свойства]. Альтернативный подход для обеспечения быстрого доступа к ресурсам панели - отстыковать ее от вкладки и разместить панель отдельно.

Основные операции с цветовой палитрой производятся с помощью интерактивной диаграммы распеределения цветов в верхней части панели.
Слева от диаграммы расположена вертикальная линейка [image] цветовых маркеров - узловых меток на высотной шкале, в точках расположения которых предусматривается настройка цвета.
Справа от диаграммы расположена цветовая шкала, отображающая реальное распределение цветов по высоте с соответствующими метками высот (единицы измерения на шкале зависят от типа данных, для которых редактируется палитра).
Дополнительные и сервисные функции настройки цветовой шкалы размещаются в нижней части панели (под диаграммой).

3.4.1 Работа с цветовыми маркерами

Изменение границ значимого диапазона высот на цветовой шкале

предоставляется возможность настроить палитру для каждого изображения пакета. Выбрать тип изображения, для которого будет происходить редактирование палитры можно в выпадающем списке сверху окна. После выбора изображения можно приступать непосредственно к редактированию палитры. Редактирование происходит путем добавления, удаления и редактирования маркеров, которые отображены справа от столбика палитры. Текущий маркер окрашен в красный цвет. Для текущего курсора снизу указаны цвет в окошке, значения составляющих цвет (Red, Green, Blue) и высота, на которой находится маркер. Эти значения можно редактировать. А при двойном щелчке по окошку цвета можно выбрать цвет в стандартном окне Windows. Значения маркеров можно также изменять путем перемещения маркера по шкале высот вверх/вниз и соответствующих составляющих цветов вправо/влево. Создать или удалить маркер можно при помощи кнопок «Добавить» и «Удалить». Причем новый маркер появляется между текущим маркером и маркером, расположенным выше. Опция Уровень границ осуществляет перемещение крайних маркеров в положение, соответствующее распределению высот в ?. Меню Предустановки содержит предустановки с настойками различных материалов.

Copyright © 2005-2006, Microtestmachines Co.
All rights reserved.

Name of active data field Color distribution diagram combined with the image height histogram Color scale Color marker bar Current color marker position in the physical scale represented in digital format Button setting color for current color marker Panes for assignment of color in RGB format (digital format setting separate values for Red, Green and Blue channels of the image) Button for adding new color marker to the scale. New marker will be placed between current marker and that one above it Button for deleting current color marker Pane for assignment of height distribution significance level that will be discarded after automatic color scale adjustment Button for automatic movement of the boundaries markers to the position where height distribution histogram equals to the set significance level Selector of supplied color schemes Button for assignment of current color scheme as default one Save button for current color scheme Load button for existing presets of color schemes if is not present in the presets selector Command for copying current color scheme to clipboard Command for inserting color scheme from the clipboard where it was placed with previous command


SurfaceXplorer :: Selection

SurfaceXplorer
[Работа с СЗМ-изображениями] > [Выделение]

3.5 Выделение объектов на СЗМ-изображении

3.5.1 Выделение точки
3.5.2 Выделение произвольного отрезка прямой
3.5.3 Выделение произвольной ломаной линии
3.5.4 Выделение прямоугольной области
3.5.5 Выделение линии сканирования
3.5.6 Выделение единичного островка
3.5.7 Выделение изолинии

Процедура выделения объектов на СЗМ-изображении производится как предварительная операция для выполнения таких функций обработки и анализа, как выравнивание по выделению, вырезание участка, посторение профиля поперечного сечения, настройка цветовой палитры по выделению, сглаживания дефектов сканирования и др., а также для анализа параметров этих объектов.

Выделенные объекты в каждом окне визуализации уникальны и существуют непосредственно только на том СЗМ-изображении, на котором они были установлены, в т.ч. и при наличии в файле совместных полей данных*. Например, выделяя прямую на изображении топографии, она не будет автоматически воспроизведена в окне визуализации совместной с ней карты латеральных сил. Тем не менее, в панели настройки двухмерного представления предусмотрены команды для быстрого переноса параметров выделения между любыми окнами. Кроме того при построении профиля поперечного сечения по линии в одном окне двухмерного представления программа автоматически отслеживает аналогичные линии в совместных полях данных и предоставляет возможность строить соответствующие профили без необходимости переноса параметров выделения.
*Примечание. Вырезание прямоугольной области производится параллельно из всех совместных полей в соответствии с координатами выделенного участка в активном (текущем) окне визуализации.

Функция выделения активируется при выборе соответствующего инструмента на панели инструментов выделения. При активации инструментов курсор в текущем окне изменяет свою конфигурацию на "+". Текущей точкой является точка пересечения штрихов.

Для объектов выделения типа отдельной точки, произвольного отрезка прямой, произвольной ломаной линии и прямоугольной области определяются [image] узловые точки - точки объекта выделения, однозначно и достаточным образом характеризующие его положение в плоскости СЗМ-изображения. Узловые точки отображаются закрашенной окружностью с текстовой меткой над ней - Selection node mark. При необходимости вывод меток узловых точек можно отключить на панели [2D] вкладки Properties (Свойства) (опция Marker labels).

Координаты точки СЗМ-изображения, над которой находится курсор, и ее высоту можно отслеживать по показаниям в статус-строке в нижней части главного окна программы или на вкладке Data (Данные). Координаты узловых точек выделения отображаются в секции NODES панели [2D] вкладки Properties (Свойства) и на вкладке Data (Данные). Кроме того, в секции NODES панели [2D] вкладки Properties (Свойства) предусмотрена возможность интерактивного редактирования координат узловых точек.

С помощью команд Copy selection to clipboard (Скопировать выделение в буфер обмена) и Paste selection from clipboard (Вставить выделение из буфера обмена) в секции NODES панели [2D] вкладки Properties (Свойства) предусмотрена возможность быстрого переноса установленного объекта выделения из одного окна в другое. Допускается перенос тех типов объектов выделения, которые определяются узловыми точками - точки, произвольный отрезок прямой линии, произвольная ломаная линия, прямоугольная область. Процедура переноса выделения осуществляется следующим образом:
1) активировать окно двухмерного представления, в котором установлен интересующий(-ие) объект(ы) выделения;
2) в панели [2D] выполнить команду Copy selection to clipboard;
3) перейти в (активировать) новое окно двухмерного представления, в котором предполагается установить переносимый объект выделения. Это может быть, например, другое или совместное СЗМ-изображение;
4) в панели [2D] выполнить команду Paste selection from clipboard.

Перемещение установленной узловой точки производится перетаскиванием ее в новое положение при нажатой левой кнопке мыши. О возможности перемещения установленной узловой точки говорит изменение конфигурации курсора на [image] при подведении его к данной точке.

Shift +

Удаление установленной узловой точки (для одиночной точки и произвольной ломаной линии) производится щелчком по ней левой кнопкой мыши при нажатой клавише Shift на клавиатуре компьютера . При нажатой клавише Shift конфигурация курсора изменяется на "X" (например, рис. 3.5.1 справа).

На СЗМ-изображении одновременно может отображаться только один объект выделения (за исключением отдельных точек). Если в одном окне двухмерного представления выделены объекты различных типов, переключение между ними (соответственно, и их отображение) осуществляется нажатием соответствующей кнопки на панели инструментов.

При построении более одного профиля поперечного сечения параметры линии выделения для каждого из них сохраняются программой независимо, и поэтому для соответствующего активного окна профиля каждая линия выделения может быть восстановлена в родительском окне двухмерного представления при нажатии кнопки Show selection nodes на панели Profile вкладки Properties. Это означает, что количество объектов выделения линейного типа - отрезков, ломаных, линий сканирования - может быть практически неограниченным.

3.5.1 Выделение точки

Функция выделения точки на СЗМ-изображении активируется нажатием кнопки Point selection tool на панели инструментов.

...

Выделение точки на СЗМ-изображении производится позиционированием над ней курсора и однократным нажатием левой кнопки мыши (рис. 3.5.1). В одном окне визуализации допускается выделение более одной точки, которые будут отмечаться метками с порядковыми номерами. Каждая выделенная точка рассматривается как узловая.

Рис. 3.5.1 - Выделение точки на СЗМ-изображении (курсор смещен) (слева), перемещение установленной точки в новое положение (посредине) и удаление установленной точки (справа).

Изменение положения установленных точек производится одним из следующих способов:
(1) перемещением точек в новое положение (рис. 3.5.4);
(2) введением новых координат точек вручную в таблице секции NODES (Узлы выделения) на панели [2D] вкладки Properties (Свойства);
(3) выделением новых точек после удаления существующих.

Функция выделения точки используется для:
- расстановки меток на элементах СЗМ-изображения;
- получения информации о высотных характеристиках отмеченных элементов (на СЗМ-изображении топографии и контрастов);
- проведения процедуры выравнивая плоскоскти по трем точкам (функция выравнивания по выделению) - соответственно, при наличии на СЗМ-изображении трех и более точек выделения. Первые три точки будут использованы в качестве задающих опорную плоскость [image] .

3.5.2 Выделение произвольного отрезка прямой

Функция выделения произвольного отрезка прямой на СЗМ-изображении активируется нажатием кнопки Free line selection tool на панели инструментов.

Выделение отрезка произвольной прямой на СЗМ-изображении производится "растягиванием" линии на СЗМ-изображении:
1) установите курсор над начальной точкой предполагаемого отрезка,
2) нажмите и удерживайте левую кнопку мыши,
3) проведите линию к конечной точке предполагаемого отрезка (рис. 3.5.2) и отпустите левую кнопку мыши.
Выделенный орезок отображается на СЗМ-изображении пунктирной сине-белой линией. Начальная и конечная точки выделенного отрезка являются узловыми точками данного объекта и отмечаются соответственно метками "1" и "2". В одном окне визуализации отображается только один выделенный отрезок.

Несмотря на ограничение, второй отрезок может быть установлен как произвольная ломаная линия с одним сегментом. В этом случае переключение между отображением двух выделенных отрезков будет осуществляется нажатием соответствующей кнопки на панели инструментов.

Рис. 3.5.2 - Выделение отрезка произвольной прямой линии на СЗМ-изображении (слева) и перемещение узловой точки выделенного отрезка в новое положение (справа).

Изменение положения выделенного отрезка производится одним из следующих способов:
(1) перемещением узловых точек в новое положение (рис. 3.5.2);
(2) введением новых координат узловых точек вручную в таблице секции NODES (Узлы выделения) на панели [2D] вкладки Properties (Свойства);
(3) выделением нового отрезка. При выделении нового отрезка на СЗМ-изображении старый автоматически удаляется.

Выделение произвольного отрезка используется для:
- последующего построения профиля поперечного сечения. по выделенной линии;
- получения информации о расстоянии между узловыми точками (на вкладке Data (Данные)).

3.5.3 Выделение произвольной ломаной линии

Функция выделения произвольной ломаной линии на СЗМ-изображении активируется нажатием кнопки PoLyline selection tool на панели инструментов.

+ [image]...

Выделение произвольной ломаной линии на СЗМ-изображении производится "растягиванием" первого сегмента на СЗМ-изображении (подобно выделению отрезка), и затем, после отпускания кнопки мыши - поочередным позиционированием курсора над следующими предполагаемыми точками и фиксацией их щелчком левой кнопкой мыши (рис. 3.5.3).

Сегменты выделенной ломаной отображаются на СЗМ-изображении пунктирной сине-белой линией. Точки на концах сегментов ломаной являются узловыми точками данного объекта и отмечаются цифровыми метками согласно очередности их установки на СЗМ-изображении. Количество сегментов в ломаной не ограничивается. В одном окне визуализации отображается только одна выделенная ломаная.

Следует обратить внимание, что при наличии в окне визуализации выделенной ломаной линии все щелчки левой кнопкой мыши в свободном месте на поле изображения будут рассматриваться как фиксация очередной узловой точки.

Произвольная ломаная линия с одним сегментом может использоваться как альтернатива выделению отрезка.

Рис. 3.5.3 - Выделение произвольной ломаной линии: "растягивание" первого сегмента (слева) и фиксация последующей точки для задания следующего сегмента (справа).

Изменение положения выделенной ломаной линии осуществляется одним из следующих способов:
(1) перемещением узловых точек в новое положение (рис. 3.5.4);
(2) введением новых координат узловых точек вручную в таблице секции NODES (Узлы выделения) на панели [2D] вкладки Properties (Свойства);
(3) выделением новой ломаной после удаления существующей.

Удаление узловой точки на выделенной ломаной линии приводит также к сокращению на единицу общего числа сегментов данного объекта и перенумерации меток (рис. 3.5.4).

Рис. 3.5.4 - Изменение положения узловой точки выделенной ломаной линии (слева) и удаление узловой точки (справа).

Для произвольной ломаной линии предусмотрена опция замыкания крайних сегментов (опция Close polyline на панели [2D] вкладки Properties (Свойства)) (рис. 3.5.5).

При выделении замкнутой ломаной линии на вкладке Data (Данные) приводится ее общая длина, что позволяет определять, например, периметр сложных объектов на СЗМ-изображении.

Рис. 3.5.5 - Выделение произвольной ломаной линии без замыкания (слева) и с установленной опцией замыкания крайних сегментов (справа).

Выделение ломаной линии используется для:
- последующего построения профиля поперечного сечения;
- получения информации о расстоянии между узловыми точками;
- получения информации об углах между сегментами ломаной (на вкладке Data (Данные));
- получения информации о периметре замкнутой линии (на вкладке Data (Данные));
- проведения процедуры выравнивая плоскоскти по трем точкам (функция выравнивания по выделению) - соответственно, при наличии на СЗМ-изображении двух и более сегментов выделнной ломаной линии (соответственно, не менее трех узловых точек). Первые три узловые точки будут использованы в качестве задающих опорную плоскость [image] .

3.5.4 Выделение прямоугольной области

Функция выделения прямоугольной области на СЗМ-изображении активируется нажатием кнопки Area selection button на панели инструментов.

Выделение прямоугольной области на СЗМ-изображении производится "растягиванием" прямоугольника - проведением при нажатой левой кнопке мыши диагональной линии поперек предполагаемого прямоугольного участка на СЗМ-изображении (аналогично выделению отрезка) (рис. 3.5.6). Точка на СЗМ-изображением, над которой произведено нажатие левой кнопки мыши, считается начальной, а в которой кнопка отпускается - конечной.

Границы выделенного участка на СЗМ-изображении отображаются пунктирной сине-белой линией. Все вершины выделенного прямоугольника являются узловыми точками, однако метки ("1" и "2") устанавливаются только у начальной и конечной точек отрезка, проведенного при задании области (двух точек, установленных по диагонали, достаточно для определения прямоугольника). В одном окне визуализации допускается выделение только одной прямоугольной области.

Рис. 3.5.6 - Выделение прямоугольной области на СЗМ-изображении (слева) и изменение конфигурации выделенного участка (справа).

Изменение положения выделенной прямоугольной области производится одним из следующих способов:
(1) перемещением узловых точек в новое положение (рис. 3.5.6);
(2) введением новых координат двух определяющих узловых точек вручную в таблице секции NODES (Узлы выделения) на панели [2D] вкладки Properties (Свойства);
(3) выделением нового участка. При выделении новой прямоугольной области на СЗМ-изображении старая автоматически удаляется.

Выделение прямоугольной области используется для:
- последующего вырезания участка на СЗМ-изображении;
- получения информации о площади выделенного участка (на вкладке Data (Данные));
- сглаживания дефектов сканирования с усреднением высоты выделенной области на основе высот ее границ;
- процедуры вычитания общей плоскости (выравнивание по выделению [image] ) в качестве опорного участка. Допускается также проведение процедур выравнивания изолированно внутри выделенного прямоугольного участка;
- настройки цветовой палитры по образцу диапазона высот выделенного участка (команда Adjust palette by selection (Настроить палитру по выделению) контекстного меню, вызываемого в окне двухмерного представления щелчком правой кнопки мыши).

3.5.5 Выделение линии сканирования

Функция выделения линии сканирования на СЗМ-изображении активируется нажатием на панели инструментов кнопки [image] (линия вдоль направления X) или [image] (линия вдоль направления Y). Переключение между режимами выделения инструмента осуществляется повторным нажатием на кнопку.

/

Выделение линии сканирования на СЗМ-изображении производится позиционированием над ней курсора и однократным нажатием левой кнопки мыши (рис. 3.5.7). Выделенная линия сканирования на СЗМ-изображении отображается пунктирной сине-белой линией. В одном окне визуализации отображается только одна линия. Данный объект узловыми точками не маркируется.

Рис. 3.5.7 - Выделение линии сканирования параллельной оси X на СЗМ-изображении (слева), измение положения установленной линии перетягиванием (посредине) и перемещение линии сканирования, выделенной в направлении Y (справа).

Изменение положения выделенной линии производится либо перетаскиванием ее в новое положение при нажатой левой кнопке мыши (курсор при этом имеет конфигурацию Cursor at the selected sacn line movement ), либо позиционированием курсора в новом положении с последующим однократным нажатием левой кнопки мыши.

Если в таблице координат узловых точек отображаются какие-либо данные, то изменить положение выделенной линии сканирования можно вводом вручную нового значения в любом поле соответствующей колонки - [x] для выделенной линии сканирования в направлении Y, [y] - для выделенной линии сканирования в направлении X.

Выделение линии сканирования используется для:
- последующего построения профиля поперечного сечения СЗМ-изображения строго по линии сканирования;
- сглаживания сбоев на линии сканирования с усреднением высоты точек выделенной линии на основании вертикальных координат точек на соседних параллельных с ней линий.

3.5.6 Выделение единичного островка

Функция выделения единичного островка на СЗМ-изображении активируется нажатием на панели инструментов кнопки [image] (заполнение диапазона высот выше указанного) или [image] (заполнение диапазона высот ниже указанного). Переключение между режимами выделения инструмента осуществляется повторным нажатием на кнопку.

Выделение единичного островка на СЗМ-изображении с заполнением диапазона высот выше установленного уровня ( [image] ) производится позиционированием курсора над точкой с намеченной высотой и однократным нажатием левой кнопки мыши (рис. 3.5.8). Выделение единичного островка на СЗМ-изображении с заполнением диапазона высот ниже установленного уровня ( [image] ) производится аналогично (рис. 3.5.9). Программа автоматически определяет контуры единичного выступа (впадины) на указанном уровне и затем заполняет пространство выступа белым цветом, а впадины - черным. В одном окне визуализации допускается выделение одного островка. Данный объект узловыми точками не маркируется.

Рис. 3.5.8 - Выделение единичного островка на СЗМ-изображении с заполнением диапазона высот выше установленного уровня (слева) и то же изображение после инвертирования выделения (справа).

Кнопка Invert selection (Инвертировать выделение) на панели [2D] вкладки Properties (Свойства) позволяет переключаться между отображением собственно выделенного выступа (впадины) и окружающего его (ее) пространства (рис. 3.5.8, рис. 3.5.9).

Рис. 3.5.9 - Выделение единичного островка на СЗМ-изображении с заполнением диапазона высот ниже установленного уровня (слева) и то же изображение после инвертирования выделения (справа).

Изменение положения выделенного островка осуществляется определением (установкой) новой опорной точки. Отключение визуализации выделенного островка производится повторным щелчком левой кнопки мыши в выделенной области, а также переключением на другой инструмент выделения или кнопкой отключения функции выделения [image].

Основное назначение функции выделения единичного островка - определение контуров единичного выступа или впадины на СЗМ-изображении.

3.5.7 Выделение изолинии

Функция выделения изолинии на СЗМ-изображении активируется нажатием на панели инструментов кнопки [image] (заполнение диапазона высот выше указанного) или [image] (заполнение диапазона высот ниже указанного). Переключение между режимами выделения инструмента осуществляется повторным нажатием на кнопку.

Выделение изолинии на СЗМ-изображении с заполнением диапазона высот выше установленного уровня ( [image] ) производится позиционированием курсора над точкой с намеченной высотой и однократным нажатием левой кнопки мыши (рис. 3.5.10 слева). Выделение изолинии на СЗМ-изображении с заполнением диапазона высот ниже установленного уровня ( [image] ) производится аналогично (рис. 3.5.10 справа). Программа автоматически определяет высоту установочной точки и заполняет все пространство на изображении белым (при выборе заполнения диапазона выше, т.е. вершин) или черным (при выборе заполнения диапазона ниже, т.е. впадин) цветом. В одном окне визуализации допускается выделение одной изолинии. Данный объект узловыми точками не маркируется.

Рис. 3.5.10 - Выделение изолинии на СЗМ-изображении с заполнением диапазона высот выше (слева) и ниже (справа) установленного уровня.

Изменение положения выделенной изолинии осуществляется определением (установкой) новой опорной точки. Также допускается интерактивное изменение контуров выделенного на СЗМ-изображении уровня вручную путем изменения параметра "Уровень выделения" в поле ввода группы Isoline level на панели [2D] вкладки Properties :
Isoline level definition pane

Отключение визуализации выделенной изолинии производится повторным щелчком левой кнопки мыши в выделенной области, а также переключением на другой инструмент выделения или кнопкой отключения функции выделения.

Основное назначение функции выделения изолинии - определение контуров одного уровня на СЗМ-изображении.

С помощью функции выделения изолинии осуществляется, например, имитация срезания вершин микрорельефа (при выделении вершин, т.е. диапазона выше уровня) либо заполнения впадин жидкостью, например, смазочным материалом (при выделении впадин, т.е. диапазона ниже уровня). С помощью последовательного изменения уровня изолинии в поле ввода Isoline level на панели [2D] вкладки Properties (Свойства) также можно аналогично анимации имитировать процесс заполнения впадин или срезания вершин.


SurfaceXplorer :: Cropping SPM Image

[Работа с СЗМ-изображениями] > [Вырезание]

3.6 Вырезание части СЗМ-изображения

Вырезание части СЗМ-изображения применяется, например, для более детального анализа и/или сохранения в отдельном файле участка, представляющего интерес для дальнейших исследований. Другой причиной для проведения подобной процедуры может быть наличие на СЗМ-изображении дефектов сканирования (сбоев), влияющих как на статистические параметры самой топографии, так и на результаты обработки изображения. Это, к примеру, срывы на линиях сканирования, резкие пики или провалы, имеющие явный характер [image] артефактов (т.е. искуственно привнесенных самой измерительной системой элементов рельефа поверхности).

Вырезание части СЗМ-изображения производится в окне двухмерного представления. При наличии в файле более одного поля данных вырезание участка в одном окне визуализации автоматически будет повторяться в остальных полях этого файла.

Для вырезания части СЗМ-изображения необходимо:

1. Активировать окно двухмерного представления с СЗМ-изображением, в котором будет производиться вырезание, и включить инструмент выделения прямоугольной области кнопкой Area selection button на панели инструментов выделения программы:

2. В окне двухмерного представления выделить интересующий прямоугольный участок : при нажатой левой кнопке мыши провести диагональ поперек интересующего участка (рис. 3.6.1).

Selecting rectangular area in SPM image shown in topography 2D visualisation window
Рис. 3.6.1 - Выделение прямоугольной области на СЗМ-изображении в окне двухмерного представления топографии.

3. Вырезать выделенный участок, воспльзовавшись:

  • командой меню Process > Crop;
  • или кнопкой Crop button на панели инструментов обработки
  • или командой Crop в контекстном меню, вызываемом в поле СЗМ-изображения правой кнопкой мыши.

В перечне на панели [Objects] (Объекты) вкладки Browse (Обзор) новое изображение будет представлено как отдельный объект - подуровень с именем Crop родительского объекта (поля)(рис. 3.6.2).

Tab Object before cropping the iamge New sublevel of objects in tab Object after cropping the iamge
Рис. 3.6.2 - Отображение новых полей данных, образованных в результате вырезания участка, в перечне на панели [Objects] (Объекты) вкладки Browse (Обзор): слева - до выполнения процедуры; справа - после.

Вырезанный участок автоматически отображается в новом окне (рис. 3.6.3 слева). Просмотреть совместные поля данных (рис. 3.6.3 справа) для нового изображения можно с помощью :
- селектора окон двухмерного представления (рис. 3.6.3 посредине),
- контекстного меню,
- активации объекта в перечне на панели [Objects] (Объекты) вкладки Browse (Обзор) (рис. 3.6.2).

Рис. 3.6.3 - Представление результата вырезания участка в новом окне двухмерного представления (слева) и пример автоматически вырезанного участка из совместного поля данных (справа), открываемого с помощью селектора окон (посредине).

В процессе выделения координаты выделяемого участка интерактивно отображаются в секции Nodes (Узлы выделения) на панели [2D] вкладки Properties (Свойства) (рис. 3.6.4 вверху слева), что позволяет следить за параметрами интересующей области на СЗМ-изображении. Кроме этого, текущие координаты курсора (т.е. точки, над которой в данный момент находится крусор) в поле СЗМ-изображения можно проконтролировать на вкладке Data (Данные) (параметр Cursor position at) (рис. 3.6.4 вверху справа) и по показаниям в строке состояния, расположенной в нижней части рабочего окна программы (рис. 3.6.4 внизу). По окончании выделения на вкладке Data (Данные) также выводятся параметры начальной и конечной точек выделенного прямоугольного участка (рис. 3.6.4 вверху справа).

Watching the selection area coordinates in tab [Properties] of the settings panel Selection nodes block showing coordinates of the selcted area Watching coordinates of the cursor current position in tab [Data] of the settings panel Current coordinates of the cursor Information about the selected rectangular start and end nodes
Watching coordinates of the cursor current position in status line of the program desktop
Рис. 3.6.4 - Отображение информации о положении курсора и координатах выделяемого участка на СЗМ-изображении. Вверху слева: на панели [2D] вкладки Properties - секция Selection nodes; вверху справа: на вкладке Data - параметр Cursor position at; внизу: в статус-строке в нижней части части рабочего окна программы (параметры в квадратных скобках).

Изменение конфигурации выделенной области после ее установки может осуществляться либо графически - перемещением ("перетаскиванием") узловых точек мышью непосредственно в окне двухмерного представления, либо аналитически - введением необходимых значений новых координат области выделения в таблице секции Nodes (Узлы выделения) на панели [2D] вкладки Properties (Свойства) (рис. 3.6.5)

Drag the area node to resize it

Рис. 3.6.5 - Изменение конфигурации выделенной прямоугольной области: вверху - перемещением узлов выделения (маркеров) в окне визуализации; справа - введением соответствующих координат области выделения в секции "Selection nodes" (Узлы выделения) на панели [2D] вкладки Properties
 Tab Properties provides options for control over the selection area coordinates

Возможность аналитического (рис. 3.6.5) задания координат прямоугольной области выделения может быть использована непосредственно для установки выделенной области. Для этого после включения инструмента выделения прямоугольной области необходимо просто ввести необходимые координаты в таблице секции Nodes (Узлы выделения) на панели [2D] вкладки Properties (Свойства).

Дополнительные возможности определения области выделения реализуются при помощи команд, расположенных внизу секции Nodes (Узлы выделения) на панели [2D] вкладки Properties (Свойства) (рис. 3.6.5) :

  • Copy selection to clipboard (Копировать выделение в буфер) : заносит координаты узлов выделения в буфер;
  • Paste selection from clipboard (Вставить выделение из буфера) : вставляет координаты узлов выделения из буфера после запоминания их с помощью предыдущей команды.

Указанные команды доступны для всех окон двухмерного представления программы, поэтому основное их применение - точный перенос области выделения между различными СЗМ-изображениями, из одного окна в другое.

Сохранение вырезанного участка возможно следующими способами:

  • включением в состав исходного файла в виде дополнительных полей - с помощью команды File > Save или кнопки на панели инструментов:
    Save file button
  • выборочным сохранением вырезанных полей в отдельном файле - с помощью команды File > Save selectively.

При выборочном сохранении рекомендуется присвоить новому файлу неиспользованное имя, а затем необходимо в специальной панели Select fields for saving... (Выбор полей для сохранения) (рис. 3.6.6) отметить поля, предназначенные для записи в новый файл. Одновременно в нижней части панели необходимо включить опцию сохранения только одного поля для каждого типа данных Save only one field for each type.

Panel Select fields for saving
Рис. 3.6.6 - Панель выбора полей для сохранения (слева) .

После сохранения вырезанного участка отдельно в новом файле полям Crop будут присвоены соответствующие имена их типов (пример содержания нового файла приведен на рис. 3.6.6 справа).

Copyright © 2005-2006, Microtestmachines Co.
All rights reserved.

Table of the selection area nodes coordinates Command for pasting the selection area coordinates from clipboard into current 2D window Command for copying the selection area coordinates into clipboard


SurfaceXplorer :: Analysis for Height and Angular Parameters

[Работа с СЗМ-изображениями] > [Анализ]

3.8 Анализ высотных и угловых характеристик СЗМ-изображения


SurfaceXplorer :: Selection

SurfaceXplorer
[Работа с СЗМ-изображениями] > [Профиль поперечного сечения]

3.7 Построение и анализ профиля поперечного сечения

Построение профилей поперечного сечения

  • по произвольной прямой линии
  • по произвольной ломаной линии
  • по линии сканирования
  • возможность совместного анализа профилей топографии и карт свойств (возможность постро
  • автономное выравнивание линий профиля с вычитанием прямой или параболической линии; возможность задания пользователем произвольной прямой линии для вычитания из профиля
  • транспонирование (зеркальное отображение) линии по вертикали, по горизонтали
  • анализ статистических параметров линий профиля и расчет параметров шероховатости
  • возможность расстаноки текстовых меток в произвольных точках линий профиля
  • возможность импорта данных линейного типа для анализа в специализированном окне

После выбора профиля сечения

окно профиля активирутся кнопкой [image]. При этом на экране появляется окно просмотра двухмерной поверхности с линией на изображении.

Вертикальные пунктирные линии в окне профиля в случае выделения по ломаной линии являются метками узлов, т.е. обозначают границы сегментов. Имеется возможность работы с двумя маркерами (по умолчанию они распологаются по краям окна профиля). При этом в статусной строке (в нижней части окна профиля) отображаются расстояние между маркерами вдоль линии профиля (по X) и разность высот между этими маркерами (по Z).Для перемещения маркеров необходимо нажать левую кнопку мыши на линии маркера, и, удерживая ее, перемещать мышь. Кроме того, переместить маркер возможно нажатием мыши в необходимой точке профиля при удерживании клавиши Ctrl (для правого маркера) и Alt (для левого маркера). В этом случае вы увидите, что в соответствии с перемещением мыши изменяется линия сечения (линия с окружностью в точке ее пересечения с линией профиля). Для использования закладок необходимо передвинуть к нужному месту маркер и нажать кнопку «Добавить» в окне Закладки панели Профиль закладки Свойства. После этого около точки на профиле появится информационное окно с характеристиками, которое «привязано» к профилю в указанном месте. Активировать закладку возможно нажатием мыши в необходимой точке профиля при удерживании клавиши Shift. Для удаления всех закладок необходимо нажать кнопку «Очистить» в окне Закладки панели Профиль закладки Свойства. Удалить закладку возможно нажатием наведенной на нее мыши при удерживании клавиши Shift. Окно закладки можно передвигать при помощи мыши.
При необходимости можно сохранить данные профиля в текстовый (*.txt) или графический (*.bmp) файл. Для этого необходимо выбрать пункт меню «Сохранить» или соответствующую кнопку на рабочей панели. При этом в текстовый файл будут сохранены данные профиля в текстовой форме, а также максимальная высота, длина сечения и физическая длина поверхности, среднее значение, средняя высота отклонения, среднеквадратичное отклонение, асимметрия, эксцесс.

3.6.1


SurfaceXplorer :: View 3D image

[Работа с СЗМ-изображениями] > [Трехмерное представление]

3.9 Трехмерное представление данных


SurfaceXplorer :: Arithmetic Operations with SPM Images

[Работа с СЗМ-изображениями] > [Арифметика]

3.10 Арифметические операции с СЗМ-изображениями

Функция выполняет произвольное выражение. Названия изображений должны быть заключены в квадратные скобки, например [Topography]. Допускается указывать тип изображения [Topography.Normalize], где Topography - тип, Normalize - имя. Допускается конкретизировать файл, к которому принадлежит это изображение, через '::'. Например: [app17r.spm::Topography.Normalize]. В данном случае изображение указано однозначно. Можно использовать числа с плавающей запятой, арифметические операции +,-,*,/, а также (). Реализованы следующие тригонометрические функции - sin, cos, tan, atan, где аргумент задается в градусах.


SurfaceXplorer :: Specialized Functions

[Специализированные функции]

4. Специализированные функции обработки и анализа СЗМ-изображений

4.1 ...
4.1.1 ...
4.* Сравнение СЗМ-изображений
4.* Расчет модуля упругости по данным силовой спектроскопии
4.* Специальные фильтры СЗМ-изображений
4.*.1.1 Импульсный фильтр
4.*.1.2 Медианный фильтр


SurfaceXplorer :: Elastic modulus calculation

[Специализированные функции] > [Расчет модуля упругости]

4.* Расчет модуля упругости по данным силовой спектроскопии

Functions > Elastic modulus from FvsD


SurfaceXplorer :: Image Compare Function

[Специализированные функции] > [Сравнение изображений]

4.* Сравнение СЗМ-изображений

Functions > Compare images


SurfaceXplorer :: SPM image filters

[Специализированные функции] > [Фильтры]

4.* Специальные фильтры СЗМ-изображений

Пункт меню Functions > Filters > предоставляет доступ к группе специальных фильтров, предназначенных для обработки СЗМ-изображений.

4.*.1 Упрощенные фильтры

Группа упрощенных фильтров позволяет произвести быструю обработку СЗМ-изображения с минимальным объемом настроек. Имеющиеся две разновидности упрощенных фильтров реализованы с использованием одного алгоритма и различаются .... Ресурсный файл - sxfltea.dll. Данные фильтры включают специальные процедуры для обработки данных на границах матрицы. Это позволяет корректно проводить фильтрацию матрицы по всему полю и в конечном итоге избежать искажения зон по краям изображения после завершения обработки и, соответственно, их вырезания.

4.*.1.1 Импульсный фильтр

Functions > Filters > Pulse filter

Размер матрицы:
Число значимых отсчетов - (рекомендуется: X*Y - 2)

Входные данные:
X – размеры фильтра по X;
Y – размеры фильтра по Y.
Threshold fault – Порог погрешности. Если после применения фильтра разность между старым и новым значением высоты в одной и той же точке по абсолютному значению меньше или равно порогу, то в эту точку записывается старое значение высоты. Рекомендуется 0;
Number significant counting out – Количество значащих отсчётов в выборке. Позволяет не учитывать при усреднении слишком малые и слишком большие высоты, случайно попадающие в выборку. Рекомендуется значение X * Y - 2.

Исходное СЗМ-изображение | Результат применения импульсного фильтра с рекомендуемым числом значимых отсчетов (7 при матрице 3*3)
Результат применения импульсного фильтра с завышенным числом значимых отсчетов (12 при матрице 3*3) - точечные дефекты полностью не устранены | Результат применения импульсного фильтра с заниженным числом значимых отсчетов (2 при матрице 3*3) - привнесена дополнительная "зернистость"
 | Результат применения импульсного фильтра с матрицей большого размера при рекомендуемом числе значимых отсчетов (47 при матрице 7*7) - мелкие детали "выглажены"

4.*.1.2 Медианный фильтр

Functions > Filters > Medium filter

Последующий набор функций реализует фильтрацию с расширенными возможностями при выборе типа применяемой процедуры и настройке ее рабочих параметров. Файл ресурсов расширенных фильтров - sxFiltersPool.dll. Доступ ко всем типам расширенных фильтров осуществляется как с помощью меню Functions > Filters > , так и непосредственно из ранее открытой панели настройки расширенных фильтров (рис. ).

Панель настройки расширенных фильтров в общем случае содержит следующие элементы.

Селектор типа применяемого фильтра Filters - позволяет выбрать тип применяемого фильтра в ранее открытой панели. Доступны следующие типы фильтров:

4.*.2 Сглаживающие линейные фильтры

4.*.2.1 Gaussian (Гауссовский)

Фильтр линейного усредняющего преобразования. Аналогичен фильтру Mean > Strong (1.4.3).

1.2 Max (максимизирующий)
Фильтр линейного усредняющего преобразования.
Размер окна изменяется в пределах от [1,9] и [9,1] до [9,9]. Выходом фильтра является максимальный элемент окна.

1.3 Mean Lines
Фильтр линейного усредняющего преобразования (т.н. разделимая фильтрация). Окно в исходном изображении преобразуется при помощи переходной матрицы с единичными коэффициентами.
Апертура переходной матрицы и, соответственно, размер окна изменяется в пределах от 3 до 9 в горизонтальном или вертикальном направлении. Соответственно N равно количеству элементов окна с учётом их весовых коэффициентов. Преобразование происходит дважды, сначала в одном затем другом направлении.

1.4 Mean (усредняющий)
Фильтр линейного усредняющего преобразования (низкочастотная фильтрация). Окно в исходном изображении преобразуется при помощи переходной матрицы.
Апертура переходной матрицы и соответственно размер окна изменяется в пределах от [1,9] и [9,1] до [9,9]. Соответственно N равно количеству элементов окна с учётом их весовых коэффициентов.

1.5 Min (минимизирующий)
Фильтр линейного усредняющего преобразования.
Размер окна изменяется в пределах от [1,9] и [9,1] до [9,9]. Выходом фильтра является минимальный элемент окна.

2 Сглаживающие нелинейные

2.1 Median (медианный)
Фильтр нелинейного усредняющего преобразования (импульсная фильтрация).
Апертура переходной матрицы и соответственно размер окна изменяется в пределах от [1,9] и [9,1] до [9,9]. Для неквадратных апертур, рекомендуется разность размера окна по cтолбцам и строкам не более 3. Соответственно N равно количеству элементов окна. Элементы окна сортируются. Выходом фильтра является элемент, имеющий номер N/2 после сортировки. Перед сортировкой элементы могут преобразовываться при помощи весовых коэффициентов.

3 Контрастирующие

3.1 Laplacian
Фильтр линейного контрастирующего преобразования. Подчёркивает перепады без учёта их ориентации.
Окно в исходном изображении преобразуется при помощи переходной матрицы (т.н. операция свёртки).
Апертура переходной матрицы и соответственно размер окна изменяется в пределах от [1,9] и [9,1] до [9,9].

3.2 Sharpness
Фильтр линейного контрастирующего преобразования. Высокочастотный фильтр. Подчёркивает перепад яркости и границы.
Окно в исходном изображении преобразуется при помощи переходной матрицы.
Апертура переходной матрицы и соответственно размер окна изменяется в пределах от [1,9] и [9,1] до [9,9].

3.3 Sobel
Фильтр контрастирующего преобразования. Окно в исходном изображении преобразуется при помощи переходной матрицы.
Апертура переходной матрицы и соответственно размер окна изменяется в пределах от [1,9] и [9,1] до [9,9].

3.4 Sharpness of 8-connected
Фильтр линейного контрастирующего преобразования восьмисвязанных (не четырёхсвязаннsх).

3.5 Normal (нормализующий)
Фильтр линейного контрастирующего преобразования.


SurfaceXplorer :: Macros

[Работа с СЗМ-изображениями] > [Макрокоманды]

3.11 Макрокоманды

Назначение макрокоманды событию

Автоматическая обработка СЗМ-изображений при открытии файла

Автоматическая обработка СЗМ-изображений для предварительного просмотра


SurfaceXplorer :: Measurements with AFM

[Измерения на АСМ]

5. Измерения с помощью атомно-силового микроскопа

В данной части приводится описание устройства атомно-силового микроскопа NT-206, подключаемого к персональному компьютеру и работающему под управлением специалзированного модуля программы SurfaceXplorer, а также описание методики работы с данным прибором.

5.1 Атомно-силовой микроскоп NT-206
5.1.1 Комплектация АСМ NT-206
5.1.2 Характеристики АСМ NT-206
5.1.3 Блок сканирования
5.1.4 Блок электроники управления
5.2 Установка АСМ NT-206
5.2.1 Размещение АСМ
5.2.2 Подключение АСМ
5.3 Подготовка АСМ NT-206 к работе
5.3.1 Включение и выключение АСМ NT-206
5.3.2 Установка зонда
5.3.3 Настройка системы детектирования
5.3.4 Установка образца
5.4 Работа с АСМ NT-206
5.4.1 Статический режим
5.4.2 Динамический режим
5.4.3 Режим двухпроходного сканирования
5.4.4 Многослойное сканирование
5.4.5 Силовая спектроскопия
5.4.6 Микротрибометрические измерения
5.4.7 Использование термоячейки
5.5 Калибровка измерительной системы АСМ
5.5.1 Калибровка пьезосканера
5.5.2 Коррекция нелинейности пьезосканера


SurfaceXplorer :: AFM NT-206

[Измерения на АСМ] > [АСМ NT-206]

5.1 Атомно-силовой микроскоп NT-206

Атомно-силовой микроскоп NT-206
5.1.1 Комплектация АСМ NT-206
5.1.2 Характеристики АСМ NT-206
5.1.3 Блок сканирования
5.1.4 Блок электроники управления

Атмно-силовой микроскоп (АСМ) в комплексе с управляющим программным обеспечением и средствами обработки АСМ-изображений предназначен для измерения и анализа микро- и субмикрорельефа поверхностей, объектов микро- и нанометрового размерного диапазона с высоким разрешением.

Основной принцип работы АСМ заключается в воздействии сил со стороны поверхности образца на острие зонда. Сила, которая чаще всего ассоциируется с АСМ, – это межатомная сила, называемая также Ван-дер- Ваальсовой. На рисунке схематически представлена кривая зависимости межатомной силы от расстояния между острием зонда и образцом. Правая часть кривой характеризует ситуацию, когда атомы острия и поверхности разделены большим расстоянием. По мере постепенного сближения они будут сначала слабо, а затем все сильнее притягиваться друг к другу. Сила притяжения будет возрастать до тех пор, пока атомы не сблизятся настолько, что их электронные облака начнут отталкиваться электростатически. При дальнейшем уменьшении межатомного расстояния электростатическое отталкивание экспоненциально ослабляет силу притяжения. Эти силы уравновешиваются при расстоянии между атомами порядка двух ангстрем, что приблизительно составляет длину химической связи. Когда суммарная межатомная сила становится положительной (отталкивающей), то это означает, что атомы вступили в контакт.
Interatomic force acting between AFM tip and sample surface
Рисунок - Зависимость силы межатомного взаимодействия от расстояния между острием и образцом.

Области применения АСМ – физика твердого тела, тонкопленочные технологии, нанотехнологии, микро- и нанотрибология, микроэлектроника, оптика, испытательные системы прецизионной механики, магнитной записи, вакуумной техники и др. АСМ может использоваться в научных и промышленных лабораториях.

Изображение поверхности в атомно-силовом микроскопе получают при сканировании образца острием с радиусом кривизны порядка десятков–сотен нанометров. Острие размещается на гибкой консоли – кантилевере, который отклоняется под воздействием поверхностных сил со стороны образца. Острие вместе с кантилевером представляют собой чувствительный зонд АСМ. Управляющая система АСМ следит за отклонением кантилевера в каждой точке измерений и поддерживает его на постоянном заданном уровне, чтобы сохранить постоянное расстояние между острием и поверхностью образца. Изменения вертикального положения зонда в каждой точке измерений образуют матрицу АСМ данных, которая записывается в файл, и используется в дальнейшем для обработки, визуализации и анализа.

АСМ NT-206 характеризуется следующими особенностями:

  • использование лазерно-лучевой системы для детектирования отклонения консоли и кручения;
  • работа в статическом и динамическом режимах, реализация статической и динамической спектроскопии;
  • цифровая система управления сканированием;
  • автоматизированная система перемещения измерительной головки относительно образца;
  • интегрированная в измерительную головку видеосистема для наблюдения за зондом и сканируемой областью поверхности образца;
  • соединение с управляющим компьютером через USB-порт;
  • модульная структура электронного блока управления и программного обеспечения, обеспечивающая возможность модификации для решения специфических исследовательских задач.

5.1.1 Комплектация АСМ NT-206

БАЗОВЫЙ КОМПЛЕКТ
Блок электроники управления Блок сканирования (базовая платформа и измерительная головка со встроенной видеосистемой)
Набор соединительных кабелей:
- сетевой шнур (220 В);
- кабель USB (тип A-to-B);
- аналоговый кабель;
- цифровой кабель;
- высоковольтный кабель
Пакет программ для управления атомно-силовым микроскопом с управляющего компьютера, обработки, визуализации и анализа СЗМ-изображений, драйверы для подключения блока электроники управления к управляющему ПК, драйверы для встроенной видеосистемы (платформа Win32)
ДОПОЛНИТЕЛЬНЫЕ ПРИНАДЛЕЖНОСТИ (ОПЦИЯ)
Сменный сканер с областью сканирования:
- 10x10x3 мкм /
- 20x20x3 мкм /
- 40x40x3 мкм

Сменный держатель зонда*

*Примечание. Один держатель зонда входит в состав измерительной головки (базовый комплект)
Сменный держатель для проводящих зондов
Сменный держатель с оснасткой для микротрибометрии и адгезиометрии
Нагревательная платформа для образцов (специализированный блок питания прилагается)
Расширяющая вставка для измерений образцов высотой до 35 мм
Тест-решетка для калибровки измерительной системы АСМ
(пр-во Mikromasch)
Набор АСМ-зондов
(пр-во Mikromasch)
Виброизолирующий пружинный подвес для блока сканирования

АСМ работает под управлением специализированного программного обеспечения, исполняемом на персональном компьютере с операционной системой Windows 98SE/Me/2000/NT/XP. Настоятельно рекомендуется выделить отдельный персональный компьютер для целей управления АСМ, сбора данных, хранения, обработки, визуализации и анализа АСМ-изображений. Рекомендуемая конфигурация ПК должна быть не ниже: Pentium IV/Celeron 1700 MHz, RAM 256 Mb, HDD 40 Gb, USB-порт, VRAM 32, монитор 17”, операционная система Windows 98SE/2000/XP.

Для обеспечения дополнительных возможностей при настройке и работе можно воспользоваться длиннофокусным оптическим микроскопом с увеличением x50…400 и осциллографом с чувствительностью 5мВ/дел.

Расходные материалы (зонды, калибровочные решетки) рекомендуется приобретать у их изготовителей (например, Mikromasch, NT-MDT и др.).

5.1.2 Характеристики АСМ NT-206

Режимы работы
  1. Контактная статическая АСМ
  2. Латерально-силовая микроскопия /одновременно с контактной статической АСМ/
  3. Бесконтактная динамическая АСМ
  4. Полуконтактная динамическая АСМ (аналог Tapping Mode®)
  5. Микроскопия фазового контраста /одновременно с полуконтактной динамической АСМ/
  6. Двухпроходный режим (для статической и динамической АСМ)
  7. Двухпроходный режим с переменным подъемом (для статической и динамической АСМ) /Оригинальная методика!/
  8. Многоцикловое сканирование участка (для статической и динамической АСМ) /Оригинальная методика!/
  9. Многослойное сканирование участка с переменной нагрузкой (для статической и динамической АСМ) /Оригинальная методика!/
  10. Электростатическая силовая микроскопия (двухпроходная методика) *, **
  11. Токовый режим *, **
  12. Магнитно-силовая микроскопия (двухпроходная методика) *, **
  13. Статическая силовая спектроскопия (с расчетом количественных характеристик, поверхностной энергии и модуля упругости образца в точке анализа)
  14. Динамическая силовая спектроскопия
  15. Динамическая частотная силовая спектроскопия /Оригинальная методика!/
  16. Наноиндентирование *
  17. Наноцарапание *
  18. Наноизнашивание по линии *
  19. Нанолитография *
  20. Микротрибометрия * /Оригинальная методика!/
  21. Микроадгезиометрия * /Оригинальная методика!/
  22. Микротрибометрия в режиме shear-force * /Оригинальная методика!/
  23. Температурно-зависимые измерения (для всех вышеперечисленных режимов) *

Примечание.
* - требуется использование специализированной оснастки
** - требуется использование специализированных зондов
Поле сканирования | 10х10 мкм; 20х20 мкм; 40x40 мкм
Максимальный диапазон измерения высот | 4 мкм
Латеральное разрешение (плоскость XY) | 1–5 нм (в зависимости от жесткости поверхности образцов)
Вертикальное разрешение (ось Z) | 0,1–0,5 нм (в зависимости от жесткости поверхности образцов)
Размер матрицы сканирования | до 1024x1024 точек
Скорость сканирования | 40–250 точек/с в плоскости X-Y
Коррекция нелинейностей | Программная коррекция движения сканера
Минимальный шаг сканирования | 0,3 нм (в плоскости XY),
Схема сканирования | Образец перемещается в плоскости X-Y (горизонтальной) и в Z-направлении (вертикальном) под неподвижным зондом.
Тип сканнера | Пьезокерамический трубчатый.
Зонды | Промышленно выпускаемые зонды (чипы размером 3.4*1.6*0.4 мм). Рекомендуются зонды Mikromasch Co. или NT-MDT Co.
Система детектирования отклонения измерительной консоли | Лазерно-лучевая с четырехсекционным позиционно-чувствительным фотодетектором
Размеры образца | До 30x30x5 мм (ширина–глубина–высота)
Условия работы | Открытый воздух, 760+40 мм рт. ст., 22+4°С, относительная влажность <70%
Автоматический подвод | Диапазон 18 мм, шаг ~200 нм
Диапазон автоматизированных перемещений измерительной головки | 10x10 мм в плоскости XY для микропозиционирования зонда относительно исследуемого объекта с шагом 2,5 мкм с оптическим визуальным контролем.
Характеристики источника лазерного излучения | Мощность на выходе - до 5 мВт; длина волны излучения - 650 нм; фокусное расстояние - 40 мм; диаметр луча в фокусе - около 20 мкм.
Поле обзора встроенной видеосистемы | 1x0.75 мм, размер окна визуализации 640x480 пиксел, частота смены кадров до 30 кадр/с
Выходное напряжение высоковольтного усилителя | +190 В
Разрядность ЦАП сканера | 16 bit
АЦП | 16 bit
Характеристики нагревательной платформы | Максимальная температура нагрева: 150 град.С. Напряжение питания: 15 В, потребляемый ток: до 1.2 А. Встроенный датчик температуры. Габариты: диам.24*10 мм (без проводов). Контроллер прилагается. Возможность термостатирования или задания режимов нагрева.
Характеристики микротрибометрического датчика shear-force | Сферический индентор диам.0.8-1 мм, линейная скорость 10-4 ….10-1 м/с; нормальная нагрузка – 0.1….10 мН; сила трения – 0.001….1 мН.
Габариты Блок сканирования (с видеокамерой): 185x185x290 мм
Блок электроники управления: 360x420x220 мм
Масса блоков, не более | Блок сканирования: 4.7 кг; Блок электроники управления: 7.7 кг
Напряжение питания | 220 В, 50 Гц
Потребляемая мощность | Не более 300 Вт
Виброизоляция | Рекомендуется использовать дополнительную антивибрационную платформу или подвес для блока сканирования при измерениях в диапазоне менее 1 мкм
Управляющий компьютер Не хуже, чем: Celeron® 1700, RAM 128 MB, HDD 40 GB, Windows® 98/2000/XP, USB port.
Рекомендуется: Pentium IV® 2.2, RAM 256 MB, HDD 120 GB, monitor 19", Windows® 2000/XP, 2 USB ports.
Интерфейс связи с управляющим компьютером | USB 1.1
Программное обеспечение | Интегрированное программное обеспечение для управления АСМ и обработки АСМ-изображений SurfaceXplorer входит в комплект поставки прибора.

Перед измерениями зонд может быть перемещен в необходимую область над образцом при помощи автоматизированной платформы. Для обеспечения обзора области сканирования и объектов, над которыми находится зонд, в приборе используется видеокамера, позволяющая в реальном масштабе времени наблюдать за перемещениями зонда над поверхностью. Видеосистема и платформа автоматизированного перемещения зонда над образцом включены в базовую комплектацию прибора (встроены по умолчанию). Сочетание этих двух опций позволяет достаточно гибко выбирать на поверхности области (объекты) для сканирования при непосредственном визуальном контроле оператора.

5.1.3 Блок сканирования

Блок сканирования (Рис. 1.2) предназначен для работы на открытом воздухе и предоставляет удобный доступ для установки образца и смены зонда. В приборе применена измерительная схема с неподвижным зондом над подвижным образцом. В ходе измерений прецизионные перемещения образца обеспечиваются трубчатым пьезосканером, на котором образец устанавливается. Перед измерениями зонд может быть перемещен в необходимую область над образцом при помощи автоматизированной платформы.

Рис. 5.1.3.1 - Блок сканирования атомно-силового микроскопа NT-206.

  1. корпус (базовая платформа);
  2. ступень грубого позиционирования по Y;
  3. шаговый электродвигатель ступени грубого позиционирования по Y;
  4. ступень грубого позиционирования по X;
  5. шаговый электродвигатель ступени грубого позиционирования по X;
  6. соединение типа «ласточкин хвост» для установки измерительной головки;
  7. винт фиксации измерительной головки в соединении «ласточкин хвост»;
  8. измерительная головка;
  9. ручка механизма регулировки лазера в направлении X;
  10. ручка механизма регулировки лазера в направлении Y;
  11. ось поворота зеркала;
  12. держатель зонда;
  13. винт фиксации держателя зонда;
  14. ручка механизма регулировки фотодетектора в направлении X;
  15. ручка механизма регулировки фотодетектора в направлении Y;
  16. предметный столик, закрепленный на торце пьезосканера;
  17. труба видеосистемы;
  18. модуль видеокамеры;
  19. поворотное кольцо для тонкой фокусировки видеосистемы;
  20. кабель измерительной головки;
  21. кабель видеосистемы (USB).

Блок сканирования состоит из базовой платформы (корпуса) (1) и сменной измерительной головки (8). Все механизмы смонтированы на верхней плите корпуса, которая является базовой. С нижней стороны (внутри корпуса) базовой плиты установлен механизм вертикального перемещения пьезосканера. Данный механизм обеспечивает подвод (подъем) и отвод пьезосканера с образом на предметном столике, установленном на верхнем (подвижном) торце пьезотрубки (16), относительно зонда (вертикальное или Z-перемещение). Диапазон хода механизма вертикального перемещения составляет 20 мм с шагом около 200 нм.

На верхней стороне базовой плиты смонтирована платформа горизонтального (XY) перемещения для подготовительных передвижений измерительной головки над образцом (грубое XY-позиционирование) для выбора необходимой области. Платформа горизонтального перемещения состоит из Y-ступени (2) с приводным шаговым двигателем (3) и X-ступени (4) с соответствующим шаговым двигателем (5). Платформа XY-перемещения обеспечивает диапазон хода 10 мм в обоих направлениях с шагом 2,5 мкм.

Сверху на ступени X смонтирована направляющая «ласточкин хвост» (6), в которой устанавливается измерительная головка (8). Измерительная головка (8) вставляется в ласточкин хвост спереди движением ее в горизонтальной плоскости. Винт (7) служит для надежной фиксации измерительной головки на базовой платформе. Для подключения измерительной головки к системам прибора, вставьте ее кабель (20) в разъем на задней стенке корпуса. Дополнительно необходимо подключить USB-кабель (21) видеокамеры (18) к свободному USB-разъему на управляющем компьютере. Чтобы снять измерительную головку с базовой платформы (корпуса), отсоедините ее разъемы (кабель измерительной головки и кабель USB видеокамеры), освободите фиксирующий винт (7) и выньте измерительную головку из ласточкиного хвоста (6).

Измерительная головка (8) представляет собой высокоточную систему, содержащую механические, оптические и электронные компоненты и оборудованную специально разработанной видеокамерой (18). В нижней части измерительной головки устанавливается держатель зонда (12). Винт (13) используется для фиксации держателя зонда после его установки в измерительной головке. Ручки (9) и (10) служат для настройки лазерного луча на зонде при настройке. Источник лазерного излучения и видеокамера интегрированы в одной оптической системе, поэтому видеокамера (18) будет перемещаться вместе с источником лазерного излучения при его настройке. Данное решение обеспечивает постоянное нахождение области вокруг центра лазерного луча в поле обзора видеокамеры.

Ручки (14) и (15) используются для настройки фотодетектора на луч, отраженный от обратной стороны кантилевера зонда. Ось (11) служит для подстройки положения зеркала поворачивающего луч, отраженный от обратной стороны кантилевера зонда, на фотодетектор. Изменяя угол поворота зеркала, можно производить дополнительную подстройку системы детектирования (тем не менее, рекомендуется не изменять положение зеркала, установленное изготовителем, и использовать данную опцию в крайнем случае).

Кольцо (19) на трубке видеосистемы (17) служит для точной фокусировки видеосистемы в диапазоне около 1 мм вдоль вертикальной оси оптической системы. Модуль видеокамеры (18) может быть отсоединен от оптической системы путем освобождения специального винта на трубке (17) и выемки модуля вверх. Необходимо помнить, что оптическая система содержит точные оптические элементы, и поэтому открытые отверстия трубки необходимо защищать от пыли и грязи.

Горизонтальное перемещение образца в процессе сканирования (перемещение в плоскости XY) осуществляется посредством пьезокерамического сканера. Образец перемещается под острием зонда от точки к точке по растровой схеме (рис. 5.1.3.2). Сканер начинает перемещаться вдоль первой линии сканирования и обратно. Затем он осуществляет перемещение на один шаг в перпендикулярном направлении ко второй линии сканирования, движется вдоль ее и обратно. Затем снова осуществляет перемещение на один шаг в перпендикулярном направлении к третьей линии и т.д.. АСМ регистрирует данные только при движении зонда в одном направлении, которое называется направлением быстрого сканирования.

Data collection scheme
Рис. 5.1.3.2 - Движение образца под зондом в процессе сбора данных.

Для перемещения сканера по подобной растровой схеме электроника АСМ прикладывает соответствующее напряжение к сегментам пьезотрубки, что вызывает ее изгиб в плоскости, параллельной поверхности образца (рис. 5.1.3.3).

Рис. 5.1.3.3 - Изгиб пьезокерамического сканера при приложении напряжения к электродам.

АСМ детектирует положение зонда в каждой точке измерений. Когда острие зонда находится у поверхности образца на расстоянии около нескольких нанометров, консоль с зондом изгибается под действием молекулярных сил (притяжения или отталкивания), возникающих между острием и поверхностью образца. Для измерения отклонения кантилевера зонда используется позиционно-чувствительный фотодетектор (ФД) (рис. 5.1.3.4). Луч света, отраженный от обратной стороны кантилевера зонда попадает на фотодетектор. В результате изменения положения зонда (изгиба кантилевера) происходит перемещение отраженного светового пятна по фотодетектору. Данное перемещение может быть легко измерено. Таким образом, по изменению положения отраженного пятна на ФД электронная система определяет изменение расстояния между зондом и образцом и прикладывает соответствующее напряжение к Z-электроду пьезотрубки, с тем чтобы сжать или удлинить ее в направлении Z и поддержать зазор между зондом и образцом на постоянном уровне. В результате острие зонда перемещается на постоянной высоте над поверхностью образца и в точности повторяет ее рельеф.

Рис. 5.1.3.4 - Схема организации системы сканирования и детектирования положения зонда в АСМ NT-206.

В каждой точке измерений регистрируется величина напряжения, приложенного к пьезотрубке. Это значение запоминается и используется системой для формирования матрицы АСМ-изображения. На основе полученных данных о высоте рельефа и соответствующих изображений контрастов строится трехмерное АСМ-изображение поверхности.

Position sensitive photodetector Установленный в системе четырехсекционный фотодетектор дает возможность измерить как отклонение, так и кручение кантилевера. Благодаря этому возможно одновременное измерение топографии и картографирование латеральных сил (локальных сил трения) в контактном режиме. Схема этих измерений, а также отличие двухсекционного фотодетектора, допускающего измерение только вертикального отклонения, показаны на рис. 5.1.3.5.

Рис. 5.1.3.5 - Детектирование вертикального Dz и горизонтального Dt (кручение) отклонений консоли фотодетектором: а – измерение вертикального Dz отклонения двухсекционным детектором; б – четырехсекционный детектор латерального силового микроскопа для одновременного измерения вертикального Dz и горизонтального Dt отклонений.

При работе в динамическом режиме, система возбуждает вынужденные колебания зонда с частотой от 10 Гц до 400 кГц. Частота колебаний подбирается соответствующей собственной резонансной частоте зонда, что существенно повышает чувствительность измерительной системы. Колебания зонда возбуждаются приложением модулированного напряжения к пьезоактюатору, непосредственно соединеному с зондом (рис. 5.1.3.6).

Для установки зондов (сформированных на чипах) в АСМ NT-206 предусмотрено использование специализированного сменного держателя, размещаемом в нижней части измерительной головки. Это обеспечивает простую и удобную для пользователя процедуру установки/замены АСМ-зондов (рис. 5.1.3.6).

Рис. 5.1.3.6 - Схема устройства сменного держателя зонда.

АСМ NT-206 ориентирован на использование промышленно выпускаемых зондов, формируемых на чипах размером 3.4*1.6*0.4 мм (рис. 5.1.3.7). На схеме ниже представлена конфигурация зондов, выпускаемых компанией Mikromasch Co..

AFM probe chip with V-type cantilever AFM probe chip with V-type cantilever by Mikromasch
AFM probe chip with straight cantilever AFM probe chip with straight cantilever by Mikromasch
Рис. 5.1.3.7 - Конфигурация чипов с АСМ-зондами с кантилеверами V-типа (вверху) и прямоугольными (внизу). Справа приведены примеры соответствующих зондов. (По данным www.spmtips.com).

Кроме рекомендованных, в приборе допускается использование и других зонды (чипов с зондами), если геометрические параметры позволяют устанавливать их в сменном держателе, а конструкция обеспечиает отражение лазерного луча системы детектирования от обратной стороны кантилевера.
Примером таких "нестандартных" зондов могут быть продукты фирмы Nanosensor, отличающиеся по геометрическим параметрам, но обеспечивающие повышенную жесткость кантилевера, необходимую для специальных приложений.

5.1.4 Блок электроники управления

General schematic diagram of AFM NT-206 control structure


SurfaceXplorer :: Getting ready for operation with AFM NT-206

[Измерения на АСМ] > [Подготовка АСМ NT-206 к работе]

5.3 Подготовка АСМ NT-206 к работе

5.3.1 Включение и выключение АСМ NT-206
5.3.2 Установка зонда
5.3.3 Настройка системы детектирования
5.3.4 Установка образца

5.3.1 Включение и выключение АСМ NT-206

5.3.2 Установка зонда

5.3.3 Настройка системы детектирования

5.3.4 Установка образца


SurfaceXplorer :: Calculation of correction equation coefficients

[Работа с СЗМ-изображениями] > [Расчет коэффициентов коррекции]

3.12 Calculation of correction equation coefficients

Calculation of correction equation coefficients is a specialized function allowing nonlinearity correction of piezoscanner motion at the measurement with Microtestmachines' AFM NT-206.

The function calculates coefficients a, b, and c of a cubic polynom of type

y = ax2 + bx + c

that can be then directly used in the AFM NT-206 control program module.

To realize this function, you need to aquire at least one test image (assuming application of Microtestmachines' AFM NT-206 and control program). Test image is an AFM image of a test grating with known regular structure (e.g., Mikromasch' TGZ01) and set number 65535 for X and Y range in the Calibration panel. Additionally, scan area in Area panel is to be set to maximum.

Note that the function calculates two equations that are applied for cases of increasing and decreasing numbers of bits in hardware matrix based on one profile. The calculated data can be used for 'Simple cubic correction' in control program module Calibration panel. If you plan to activate 'Advanced cubic correction', use only that equation that corresponds to actual scanning direction at the preparation of the test image.

The procedure is as follows.

1. Open file with prepared test image. If necessary, use leveling commands to eliminate tilt and a spherical surface from the test image, for example

2. Activate cross section function pressing button [image] in tool bar. After that, drag a line (with mouse at pressed left button) perpendicular to the imaged regular structures:

3. Create a cross section for the selected profile line (press button [image] in the tool bar). A window with selecetd cross-section line will appear.

4. Place bookmarks in regular characteristic points of the profile. To place bookmarks, you can use a marker [a] or [b] in the plot, moving it to necessary point and pressing button Add in the panel [Profile] of tab Properties. Alternative way is simply moving a mouse cursor top the necessary point in the profile line and then clicking on it with left mouse button at pressed key Shift an the PC keyboard.

Note, that you need to place at least four bookmarks in the profile line.

5. After placing all bookmarks on the profile, call a context menu pressing right mouse button within the plot area. Choose command Calculate correction.

6. After choosing the command, a specialized window with correction functions curves and corresponding coefficients of the cubic polynom will appear:

You can then save the calculated parameters in a file by pressing button OK in the Curve window. Button Cancel will delete the Curve window.

Note that default file name for saving calculated data is 'SurfaceScan.ini'. It means that you can directly write the calculated coefficients into existing INI file of SurfaceScan program (the program should not run during this procedure). Necessary data will be added or inserted instead of old ones in the INI file. Structure of the saved information is as follows:

I.e. it is a section [Nonlinearity correction] with necessary data.

If necessary, you can also view calculated correction parameters in tab Data of SurfaceXplorer program when profile window is active:


SurfaceXplorer :: Glossary

[Глоссарий]

SurfaceXplorer :: Глоссарий

Артефакт
элемент рельефа поверхности на СЗМ-изображении, искуственно созданный самой измерительной системой или процедурой обработки
Выравнивание СЗМ-изображения
устранение из СЗМ-матрицы постоянной составляющей поверхности макроскопического порядка (общего наклона, смещения по вертикальной оси, сферичности, или их суммы)
Группа данных
группа слоев (матриц данных) в СЗМ-файле с многослойной записью, характеризующих один параметр, например, слои топографии, слои локальных сил трения и т.д.. Структурная организация данных с подразделением на группы используется в файлах формата *.mps
Двухмерное представление данных
вариант графического отображения данных в виде карты высот (или свойств) в соотвтествии с цветовой шкалой
Динамический элемент
пункт меню или параметр настройки, отображаемые отображаемые в меню или панели настройки только при определенных условиях (событиях), например, активизации определенного инструмента выделения, активация окна представления профиля и др.
Дефекты сканирования
линейные или точечные элементы (выбросы) на СЗМ-изображении, высота которых резко отличается от высоты окружающих участков рельефа поверхности
Интерфейс пользователя
совокупность графических средств программы, предоставляющих пользователю информацию, данные или доступ к элементам управления и настройки как самих визуализируемых данных, так и аппаратной частью подключенного к компьютеру измерительного прибора (т.е. совокупность средств взаимодействия пользователя с компьютерной системой, графически реализованных исполняемой программой)
Карта высот
представление двухмерного массива данных, при котором вертикальная координата каждой точки данных кодируется в соответствии с установленной цветовой шкалой
Линейные данные
одномерные массивы значений, описывающие, например, кривую
Локальный угол наклона
в программе SurfaceXplorer - угол между нормалью к элементарной площадке СЗМ-изображения и вертикальной осью данного СЗМ-изображения
Локальный угол ориентации
в программе SurfaceXplorer - угол орентации в горизонтальной плоскости проекции нормали к элементарной площадке СЗМ-изображения
Многослойная запись данных
размещение в одном файле более одной СЗМ-матрицы (массива данных), обычно относящихся к одному измерению, проведенному на сканирующем зондовом микроскопе, но характеризующих параметры различных типов
Нормализация
смещение точки начала отсчета шкалы высот на один уровень с нижней точкой рельефа на СЗМ-изображении
Объект выделения
1) отдельная точка (точка измерений в СЗМ-матрице);
2) произвольный отрезок прямой;
3) поизвольная ломаная линия;
4) прямоугольная область;
5) прямая линия, параллельная оси X или Y СЗМ-изображения (линия быстрого или медленного сканирования);
6) единичная область, ограничиваемая указываемым уровнем по высоте ("островок");
7) набор всех областей, соответствующих указываемому уровню по высоте ("изолиния")
"Откат"
отмена последнего действия обработки
Пиктограмма
в секции быстрого просмотра - уменьшенное изображение, построенное на основе данных, содержащихся в файле специального формата, в соответствии с их типом
Простая запись данных
размещение в одном файле одного СЗМ-изображения (т. е. единичной или отдельной СЗМ-матрицы), характеризующего один измеренный параметр
Рабочая область
зона главного окна программы, в которой отображаются специализированные окна визуализации данных
Рабочие объекты
СЗМ-файлы (т.е. файлы специального формата) и содержащиеся в них слои, а также массивы данных, полученные при измерении в текущем сеансе работы программы
Режим виртуальной подсветки
отображение двухмерного рельефа как карты высот, но с дополнительной имитацией его освещения виртуальным источником света
Сглаживание СЗМ-изображения
устранение дефектного элемента рельефа на СЗМ-изображении (т.е. устранение из СЗМ-матрицы дефекта сканирования)
СЗМ-данные
двухмерная матрица размера X*Y, в которой положение элемента Zxy в этой матрице соответствует координатам X и Y точки измерений в плоскости, а численное значение самого элемента Zxy характеризует интенсивность измеренного в данной точке параметра
СЗМ-изображение
графическое изображение, построенное на основе матрицы СЗМ-данных и представленное в двухмерном или трехмерном виде
СЗМ-матрица
двухмерный массив данных размера X*Y, в которой положение элемента Zxy в этой матрице соответствует координатам X и Y точки измерений в плоскости, а численное значение самого элемента Zxy характеризует интенсивность измеренного в данной точке параметра
СЗМ-файл
файл специализированного формата, содержащий данные, полученные при измерении на сканирующем зондовом микроскопе, и/или результаты обработки этих данных
Слой
отдельный массив данных в СЗМ-файле с многослойной записью, характеризующий один измеренный параметр. Двухмерный массив данных, содержащийся в слое, представляет собой СЗМ-матрицу. Одномерный массив данных – линейные данные. В файле формата *.mps могут одновременно содержаться как двух-, одномерные массивы, так и другие их типы
Специализированные окна визуализации данных
окна в рабочей области главного окна программы SurfaceXplorer, предназначенные для отображения в графической форме как исходных данных, так и результатов их обработки или анализа
Список быстрого доступа
список ссылок (ярлыков) на наиболее часто используемые папки с СЗМ-данными, обеспечивающий быстрый доступ к ним
Совместные слои
все слои данных, содержащиеся в СЗМ-файле с многослойной записью, по отношению друг к другу
Статический элемент
пункт меню или параметр настройки, отображаемые в меню или панели настройки постоянно
Тест-решетка
регулярная структура с известными геометрическими параметрами, используемая как средство калибровки измерительной системы сканирующего зондового микроскопа
Транспонирование
отображение СЗМ-матрицы относительно вертикальной или горизонтальной оси или поворот на 90°
Угол наклона
см. "Локальный угол наклона"
Угол ориентации
см. "Локальный угол ориентации"
Узловые точки
точки объекта выделения, однозначно и достаточным образом характеризующие его положение в плоскости СЗМ-изображения
Цветовая шкала
вертикальная шкала, отображающая распределение цветов по высоте СЗМ-изображения с соответствующими метками высот
Цветовые маркеры
узловые метки на шкале высот, в точках расположения которых предусматривается настройка цвета данного вертикального уровня


SurfaceXplorer :: Index

[Предметный указатель]

SurfaceXplorer :: Предметный указатель


Review on SPM • Обзор СЗМ

Return to MTM SurfaceXplorer manual Суслов А. А., Чижик С. А. Сканирующие зондовые микроскопы (обзор) // Материалы, Технологии, Инструменты – Т.2 (1997), №3, С. 78–89 Visit Microtestmachines Co. home site

УДК 621.385.833

СКАНИРУЮЩИЕ ЗОНДОВЫЕ МИКРОСКОПЫ (обзор)

А. А. СУСЛОВ, С. А. ЧИЖИК

Институт механики металлополимерных систем им. В. А. Белого НАН Беларуси. 246652, г. Гомель, ул. Кирова 32а.

Рассматриваются принципы работы основных типов сканирующих зондовых микроскопов (сканирующего туннельного и атомно-силового). Представлены зондовые технологии, получившие распространение в настоящее время, для реализации которых используются эти устройства, и представляющие собой их вариации или развитие.

ВВЕДЕНИЕ. В 1981 году Герхард Бинниг и Хайнрих Рёрер из лаборатории IBM в Цюрихе представили миру сканирующий туннельный микроскоп (СТМ). С его помощью были получены поразившие всех изображения поверхности кремния в реальном масштабе. Человек впервые смог увидеть атомы и прикоснуться к ним [1–3].

Развивая идеи, заложенные в СТМ, в 1986 году Герхард Бинниг, Калвин Куэйт и Кристофер Гербер создают атомно-силовой микроскоп (АСМ), благодаря которому были преодолены присущие СТМ ограничения [4, 5]. В свою очередь АСМ стал родоначальником широкого семейства сканирующих зондовых устройств и использующих их технологий, которое продолжает увеличиваться и по сей день. В том же 1986 г. Г. Бинниг и Х. Рёрер были удостоены Нобелевской премии в области физики за открытие принципа туннельной, атомно-силовой и световой сканирующей микроскопии [3].

Сканирующие зондовые микроскопы (СЗМ) – таково общее название такого типа устройств – используются сегодня в широком диапазоне дисциплин, включающем как фундаментальную науку о поверхности, так и традиционный анализ шероховатости поверхности. Не менее эффектно применение СЗМ-технологий для построения трехмерных изображений – от атомов до микронных образований на поверхности биологических объектов.

Сканирующий зондовый микроскоп — это инструмент со множеством возможностей. С его помощью можно строить реальные трехмерные изображения с широким динамическим диапазоном, охватывающим традиционные “сферы деятельности” оптических и электронных микроскопов. Это также и профилометр с беспрецедентным разрешением. Сканирующий зондовый микроскоп может измерять такие физические свойства, как, например, проводимость поверхности, распределение статических зарядов, магнитных полей и модуля упругости, свойства смазочных пленок и др. Современные приложения СЗМ весьма разнообразны [6–12].

Изображения, получаемые с помощью СЗМ, относятся к разряду создаваемых микроскопическими методами образам, которые достаточно легко интерпретировать. В случае электронного или оптического микроскопа принцип получения изображения базируется на сложных электромагнитных дифракционных эффектах. Поэтому иногда могут возникнуть затруднения при определении, является ли некоторый элемент микрорельефа поверхности выступом или впадиной. Напротив, СЗМ регистрирует истинно трехмерные параметры. На СЗМ-изображении выступ однозначно предстает выступом, а впадина ясно видна как впадина. На получаемых при помощи оптических или электронных микроскопов изображениях, например, плоского образца, состоящего из чередующихся отражающих и поглощающих участков, могут возникать искусственные изменения контрастности. Атомно-силовой микроскоп, в свою очередь, практически безразличен к изменениям оптических или электронных свойств и дает информацию об истинной топографии поверхности.

В настоящее время в мире в широком ассортименте выпускаются СЗМ и принадлежности к ним. Среди наиболее известных фирм можно назвать Digital Instruments, Park Scientific Instruments, Omicron, Topometrix, Burleigh и др. Цены на СЗМ-устройства промышленного производства колеблются в широких пределах — от 40 тыс. долл. за простейший АСМ до 100–200 тыс. долл. и выше в зависимости от комплектации и спектра решаемых задач. Изготавливаются СЗМ также в России (фирмы Nanotechnology MDT, HTE) и Республике Беларусь (ИММС НАНБ [image] ).

Терминология, сложившаяся в сканирующей зондовой микроскопии, несет на себе отпечаток своего англоязычного происхождения. Для большинства терминов несложно найти русский эквивалент, однако достаточно часто можно слышать и читать, к примеру, не “острие”, а “тип”, не “консоль”, а “кантилевер”, появившиеся от непосредственного прочтения английских “tip” и “cantilever”. Некоторую неопределенность вносят в терминологию появляющиеся в последнее время новые методики. Так, фирма Digital Instruments, впервые реализовавшая в своих устройствах “режим обстукивания”, зарегистрировала само название этого режима как торговую марку – Tapping Mode®. В итоге сходные режимы в СЗМ других фирм, остающиеся по сути тем же процессом, называются иначе.

Все СЗМ содержат компоненты, схематично представленные на рис. 1 [7]. В конструкции каждого сканирующего зондового микроскопа есть свои отличия. В комплекте прибора могут также присутствовать дополнительные устройства, позволяющие модифицировать базовый блок для решения специальных задач. Однако общая структура СЗМ остается более или менее одинаковой. В состав СЗМ-комплекса обычно входит компьютер, который управляет работой электромеханической части микроскопа, принимает и записывает регистрируемые зондом данные, производит на их основе построение СЗМ-изображения и, кроме того, позволяет обрабатывать полученное изображение, без чего подчас бывает трудно или вообще невозможно проанализировать наблюдаемую картину.

Рис 1. Общая схема сканирующего зондового микроскопа

АСМ и СТМ являются на сегодня наиболее распространенными в практике СЗМ-технологиями. Тем не менее, большинство промышленно выпускаемых устройств обычно разработаны таким образом, что для добавления к прибору новых функций и возможностей достаточно переоснастить его основной блок, заменив отдельные небольшие части. Иногда единственным необходимым изменением является переключение из одного режима в другой непосредственно в обслуживающей компьютерной программе.

СКАНИРУЮЩИЙ ТУННЕЛЬНЫЙ МИКРОСКОП И СВЯЗАННЫЕ С НИМ ТЕХНОЛОГИИ. Сканирующий туннельный микроскоп (СТМ) исторически является предшественником всех сканирующих зондовых микроскопов. СТМ был первым устройством, давшим реальные изображения поверхностей с атомным разрешением [1, 3, 7, 13].

В качестве зонда в СТМ используется острая проводящая игла. Между острием иглы и образцом прикладывается рабочее напряжение, и при подводе острия к образцу примерно до 0,5–1,0 нм электроны с образца начинают “туннелировать” через зазор к острию, или наоборот, в зависимости от полярности рабочего напряжения (рис. 2) [1, 3, 7, 13]. На основании данных о токе туннелирования в СТМ проводится визуализация топографии. Чтобы происходило туннелирование, как образец, так и острие должны быть проводниками или полупроводниками. Изображений непроводящих материалов СТМ дать не может.

Рис. 2. Схема работы сканирующего туннельного микроскопа

Останавливаясь на физических принципах, положенных в основу работы СТМ, отметим, что процесс туннелирования электронов происходит при перекрытии волновых функций атомов острия сканирующей иглы и поверхности. Туннельный ток между двумя металлическими телами описывается уравнением I = 10exp[–C(j z)1/2]. При типичной высоте потенциального барьера j = 4 эВ туннельный ток снижается на порядок, если зазор z уменьшается на 0,1 нм. Эти свойства и являются причиной того, что острие туннельного микроскопа обычно должно находится так близко к образцу – на расстоянии 0,5–1 нм. Экспоненциальная зависимость туннельного тока от расстояния придает СТМ очень высокую чувствительность: считается, что с помощью туннелирования можно измерять объекты порядка 0,001 нм.

Основное приложение СТМ – это измерения топографии. Именно благодаря своей чрезвычайно высокой чувствительности СТМ способен формировать изображения поверхностей с субангстремной точностью по вертикали и атомным латеральным (т.е. в горизонтальном направлении) разрешением.

Существуют два варианта конструкции СТМ в зависимости от режима сканирования образцов (рис. 3). В режиме постоянной высоты острие иглы перемещается в горизонтальной плоскости над образцом, а ток туннелирования изменяется (рис. 3а). Исходя из данных о величинах тока туннелирования, промеренных в каждой точке сканирования поверхности образца, строится образ топографии [7].

Рис. 3. Схема работы СТМ: а – в режиме постоянной высоты; б – в режиме постоянного тока

В режиме постоянного тока СТМ задействуется система обратной связи для поддержания постоянного тока туннелирования путем подстройки высоты сканирующего устройства над поверхностью в каждой точке (рис. 3б). Например, когда система детектирует увеличение туннельного тока, то она подстраивает напряжение, прикладываемое к пьезоэлектрическому сканирующему устройству, так, чтобы отвести острие дальше от образца. В режиме постоянного тока визуализация топографии осуществляется на основании данных о величине вертикальных перемещений сканирующего устройства. Если система поддерживает ток туннелирования постоянным в пределах нескольких процентов, то расстояние между острием и образцом будет постоянным с погрешностью в несколько сотых ангстрема [3, 7, 13].

У каждого режима есть преимущества и недостатки. Режим постоянной высоты более быстрый, так как системе не приходится передвигать сканирующее устройство вверх и вниз, но при этом можно получить полезную информацию только с относительно гладких поверхностей. В режиме постоянного тока можно с высокой точностью измерять нерегулярные поверхности, но измерения занимают больше времени.

Сканирующая туннельная спектроскопия (СТС) является наряду с измерениями топографии другой важной областью приложения СТМ. В первом приближении образ, составленный из значений тока туннелирования, отражает топографию поверхности образца. Если же говорить более точно, туннельный ток соответствует электронной плотности состояний поверхности. В действительности СТМ регистрирует количество заполненных или незаполненных электронных состояний вблизи поверхности Ферми в диапазоне значений энергии, определяемом прикладываемым рабочим напряжением. Можно сказать, что СТМ измеряет скорее не физическую топографию, а поверхность постоянной вероятности туннелирования [2, 7, 14].

Чувствительность СТМ к местной электронной структуре может вызвать затруднения, если необходимо картографировать топографию (т.е. получить изображение топографии). Например, если какой-то участок образца окислен, то, когда острие сканирующей иглы попадет на него, туннельный ток резко уменьшится. СТМ, работающий в режиме постоянного тока, даст команду острию приблизиться к поверхности, чтобы поддержать установленную величину тока туннелирования. В результате острие может углубиться в поверхность. В то же время, чувствительность СТМ к электронной структуре может быть огромным преимуществом. Более традиционные спектроскопические методы, такие как рентгеновская фотоэлектронная спектроскопия, ультрафиолетовая фотоэлектронная спектроскопия или инверсная фотоэмиссионная спектроскопия, детектируют и усредняют данные, исходящие с относительно большой площади размерами от нескольких микрон до нескольких миллиметров в поперечнике. СТМ, наоборот, может получать спектры с площадей, сравнимых по размерам с отдельными атомами.

Электронная структура атома зависит от его разновидности (является ли он, к примеру, атомом кремния или атомом углерода), а также от его местного химического окружения (сколько вокруг него атомов, какого они типа и как симметрично распределены). Исследование зависимости сигнала СТМ от местной электронной структуры поверхности известно как сканирующая туннельная спектроскопия.

СТС охватывает ряд методов: получение “топографических” (в режиме постоянного тока) изображений с использованием различных рабочих напряжений и сравнение их; получение “токовых изображений” (в режиме постоянной высоты) при различных зазорах; варьирование рабочего напряжения при позиционировании острия над интересующим элементом топографии с одновременной регистрацией тока туннелирования.

В последнем случае получают вольт-амперные характеристики электронной структуры в данной точке. Можно настроить СТМ для снятия вольт- амперных кривых в каждой точке сканирования, создавая, таким образом, трехмерную карту электронной структуры. Используя синхронизированный усилитель, можно непосредственно получать кривые зависимостей dI/dU (проводимость) или dI/dz (рабочая функция – изменение тока при изменении зазора) от напряжения U. Все это методы зондирования местной электронной структуры поверхности с применением СТМ.

АТОМНО-СИЛОВОЙ МИКРОСКОП. АСМ появились как развитие СТМ-технологии, однако заложенные в них совершенно иные принципы позволяют исследовать поверхности любых материалов – проводящих, полупроводников, а также изоляторов, т.е. непроводящих электрический ток [2–5, 7, 14–16]. АСМ зондируют поверхность образца острой иглой длиной 1–2 мкм и диаметром обычно не более 10 нм. Игла устанавливается на свободном конце измерительной консоли.

Основной принцип работы АСМ заключается в воздействии сил со стороны поверхности образца на острие сканирующей иглы. Сила, которая чаще всего ассоциируется с АСМ, – это межатомная сила, называемая также Ван-дер- Ваальсовой.

На рис. 4 схематически представлена кривая зависимости межатомной силы от расстояния между острием иглы и образцом. Правая часть кривой характеризует ситуацию, когда атомы острия и поверхности разделены большим расстоянием. По мере постепенного сближения они будут сначала слабо, а затем все сильнее притягиваться друг к другу. Сила притяжения будет возрастать до тех пор, пока атомы не сблизятся настолько, что их электронные облака начнут отталкиваться электростатически. При дальнейшем уменьшении межатомного расстояния электростатическое отталкивание экспоненциально ослабляет силу притяжения. Эти силы уравновешиваются при расстоянии между атомами порядка двух ангстрем, что приблизительно составляет длину химической связи. Когда суммарная межатомная сила становится положительной (отталкивающей), то это означает, что атомы вступили в контакт.

Рис. 4. Зависимость силы межатомного взаимодействия от расстояния между острием и образцом

В отношении контакта между острием сканирующей иглы и поверхностью исследуемого образца работа атомно-силового микроскопа обычно проходит в одном из режимов, соответствующим обозначенным на рис. 4 участкам кривой межатомного взаимодействия. Это контактный и бесконтактный режимы, сочетание которых дает т.н. режим “обстукивания” [7, 17–19].

При контактном режиме, известном иначе как режим отталкивания, острие сканирующей иглы АСМ приходит в мягкий “физический контакт” с образцом. Измерительная консоль, на свободном конце которой расположена игла, обычно характеризуется низкой константой упругости, величина которой должна быть меньше, чем эффективная константа упругости, удерживающая атомы образца вместе.

Наклон кривой на графике межатомных сил в области отталкивания, или контакта, очень крутой (рис. 4). Вследствие этого отталкивающая сила уравновешивает практически любую силу, которая пытается сблизить атомы друг с другом. Для АСМ это означает, что если измерительная консоль прижимает острие иглы к поверхности, то консоль скорее изогнется, чем ей удастся приблизить острие к атомам образца. Даже если изготовить очень жесткую консоль, чтобы приложить огромную силу к образцу, межатомное расстояние между острием и атомами образца уменьшится ненамного. Вероятнее всего деформируется поверхность образца.

Для контактного АСМ отталкивающая межатомная сила должна быть уравновешена другими усилиями. Это происходит благодаря наличию двух сил – капиллярной и консольной.

Капиллярная сила – это воздействие на острие сканирующей иглы со стороны тонкого слоя влаги, обычно присутствующего на поверхностях, находящихся в обычной среде. Капиллярная сила возникает, когда адсорбированная на поверхности влага приподнимается вокруг острия (рис. 5). Оказываемое на острие сильное притягивающее воздействие (около 10–8 Н) удерживает его в контакте с поверхностью. Величина капиллярной силы зависит от расстояния между острием и образцом.

Рис. 5. Схема возникновения капиллярной силы

Ввиду того, что острие находится в контакте с образцом, капиллярная сила должна быть постоянной, поскольку расстояние между острием и образцом фактически не изменяется. Другое условие, позволяющее считать капиллярную силу постоянной, это предположение о достаточной однородности слоя влаги.

Воздействие со стороны самой измерительной консоли подобно усилию в сжатой пружине. Величина и знак (отталкивающая или притягивающая) “консольной” силы зависит от отклонения консоли и ее константы упругости. Сила, прилагаемая измерительной консолью контактного АСМ, в отличие от капиллярной является переменной.

Общее усилие, прикладываемое со стороны острия сканирующей иглы к образцу, это сумма капиллярной и консольной сил. Величина суммарной силы варьируется от 10–8 Н (когда измерительная консоль отводится от образца почти с таким же усилием, как вода притягивает острие к его поверхности) до более типичного рабочего диапазона в пределах 10–7...10–6 Н.

В бесконтактном режиме, также известном как режим притяжения, АСМ отслеживает притягивающие Ван-дер-Ваальсовы силы между острием сканирующей иглы и образцом. Зазор между острием и образцом обычно составляет 5–10 нм. На таком расстоянии электронные орбитали атомов острия сканирующей иглы начинают синхронизироваться с электронными орбиталями атомов образца. В результате возникает слабое притяжение, потому что в любой момент времени атомы острия и образца поляризованы в одном и том же направлении. В свободном пространстве эти атомы будут сближаться до тех пор, пока сильное электростатическое отталкивание, описанное выше, не станет преобладающим. Чаще всего бесконтактные АСМ конструируются для работы в динамическом режиме.

Из рис. 4 видно, что в области бесконтактной работы АСМ наклон кривой Ван-дер-Ваальсовых сил более пологий, чем в контактной. Такой пологий наклон означает меньшие отклонения измерительной консоли при реакции на изменения величины зазора между острием и образцом. Кроме того, здесь необходимо использовать более жесткую консоль, так как в противном случае острие сканирующей иглы залипнет на поверхности образца как только приблизится к ней на достаточно малое расстояние, когда начинают работать силы притяжения. Однако следует учитывать, что жесткая консоль в ответ на малые силы отклоняется меньше, чем мягкая, и поэтому для бесконтактного АСМ должна быть использована более чувствительная схема детектирования.

В бесконтактном режиме работы АСМ суммарная сила между острием и образцом небольшая – обычно ~10–12 Н. Эта малая сила является преимуществом при исследовании мягких и упругих образцов. Еще одно преимущество заключается в том, что такие образцы, как, например, кремниевые подложки не загрязняются при контакте с острием.

При исследовании жестких образцов изображения, полученные в контактном и бесконтактном режимах, могут выглядеть одинаково. Однако если на поверхности жесткого образца лежат, к примеру, несколько монослоев конденсированной влаги, то эти изображения могут значительно различаться. АСМ, работающий в контакте, будет проникать через слой жидкости, отображая нижележащую поверхность, тогда как бесконтактный АСМ будет давать изображение поверхности слоя влаги (рис. 6).

Рис. 6. АСМ-профили при наличии на поверхности влаги: а – в бесконтактном; б – контактном режиме

В отношении возбуждения вынужденных колебаний измерительной консоли АСМ различают два режима – статический и динамический. Если в измерительной консоли АСМ модулируют колебания, то такой режим называют динамическим, в противном случае – статическим.

В статическом режиме силы взаимодействия между острием иглы и поверхностью образца вызывают отклонение измерительной консоли, изгибая ее до достижения статического равновесия. В процессе сканирования образца (при движении острия над неподвижным образцом или образца под неподвижным острием) АСМ детектирует отклонения консоли, формируя набор данных о топографии одним из двух способов. В первом, называемом режимом постоянной высоты (его другое название – режим переменного отклонения), данные об изменениях положения консоли в пространстве могут быть непосредственно использованы для формирования образа топографии. Под постоянной высотой здесь подразумевается неизменность расстояния между зондирующим узлом и образцом. Режим постоянной высоты часто используется для получения изображений атомно плоских поверхностей в атомном масштабе, где отклонения консоли и, следовательно, изменения прикладываемой силы всегда будут малыми. Режим постоянной высоты также важен для визуализации в реальном масштабе времени изменяющихся поверхностей, когда нельзя пренебречь высокой скоростью сканирования. Аналогичный метод построения изображений с таким же названием существует и у СТМ.

В другом методе, который называют режимом постоянной силы, отклонение измерительной консоли используется в качестве входного параметра для системы обратной связи, которая поддерживает величину этого отклонения постоянной. В данном случае сканирующее устройство передвигается вверх и вниз по оси Z в соответствии с текущими условиями микрорельефа поверхности образца, и на основании данных об этих перемещениях формируется изображение топографии. Режим постоянной силы обычно наиболее предпочтителен в большинстве приложений: хотя скорость сканирования здесь ограничена скоростью реакции системы обратной связи, но общее воздействие, оказываемое на образец острием сканирующей иглы, хорошо контролируется. Действительно, при поддержании постоянного отклонения консоли суммарная сила, прикладываемая к образцу, остается постоянной. Изображения, полученные в режиме постоянной силы, обычно достаточно легко интерпретировать как образы топографии. Если проводить аналогию с СТМ, то подобным здесь будет режим постоянного тока.

В динамическом режиме система АСМ модулирует механические колебания измерительной консоли на частоте, близкой к резонансной (типичные значения находятся в пределах от 30 до 300 кГц), с амплитудой в несколько нанометров. Величина самой резонансной частоты зависит от прикладываемой внешней силы, и поэтому в процессе приближения острия сканирующей иглы к поверхности образца она изменяется, поскольку при этом изменяется и величина Ван-дер-Ваальсовой силы (рис. 4). Отталкивающая сила стабилизирует упругую реакцию консоли и увеличивает резонансную частоту, тогда как при воздействии притягивающей силы наблюдается обратная картина.

В процессе сканирования образца в динамическом режиме система обратной связи АСМ передвигает сканирующее устройство вверх и вниз, сохраняя либо амплитуду, либо резонансную частоту измерительной консоли постоянной, что позволяет поддерживать постоянным и среднее расстояние между острием и образцом. Как и при работе в статическом режиме постоянной силы, данные о передвижениях сканирующего устройства используются для визуализации топографии. При таком методе измеряется и визуализируется поверхность постоянного градиента сил. В качестве альтернативного метода можно получать образы поверхности переменного градиента сил, для чего необходимо просто отключить систему обратной связи. Подобно статическому режиму эти два метода обеспечивают, соответственно, легкость восприятия АСМ-изображения и высокую скорость сканирования. Чувствительность схемы детектирования в динамическом режиме обеспечивает субангстремное вертикальное разрешение на изображениях.

Для получения изображений поверхности образца можно использовать не только данные о перемещении сканирующего устройства (т.н. “запись по высоте”), но и об изменении в процессе сканирования амплитуды или частоты колебаний консоли. В случае “записи по амплитуде” или “по частоте” появляется возможность визуализировать распределение механических свойств по поверхности образца, что дает не менее ценную информацию, чем данные о его топографии.

В таблице дается сравнение основных режимов работы АСМ в их различных комбинациях.

Таблица. Режимы работы атомно-силового микроскопа

 |  | Статический | Динамический
Контактный | + | Высокое латеральное разрешение. Возможность определять деформацию в системе острие – поверхность. | Возможность определять площадь контакта или модуль упругости. Высокое силовое разрешение (~0.001 нН). Незначительный температурный дрейф.
 | – | Возможно повреждение поверхности. Низкое силовое разрешение (~1 нН). Подверженность температурному дрейфу. | Возможно повреждение поверхности. Модуляция нарушает адгезионное взаимодействие между острием и поверхностью.
Бесконтактный | + | Работа без повреждения поверхности. | Работа без повреждения поверхности. Высокое силовое разрешение. Незначительный температурный дрейф.>
 | – | Низкое силовое и пространственное разрешение. Подверженность температурному дрейфу. | Низкое пространственное разрешение (~10 нм).

Качество результатов, которые можно получить на бесконтактном АСМ, в значительной мере зависит от использования качественной измерительной консоли и сканирующей иглы. Измерительная консоль для бесконтактного режима, как отмечалось, должна быть значительно жестче, чем консоль для контактного АСМ, чтобы в процессе своих осцилляций (колебаний) она случайно не коснулась поверхности. Более того, острая игла для бесконтактного АСМ даже более важна, чем для контактного: при работе в бесконтактном режиме наклон кривой Ван-дер-Ваальсовых сил пологий, поэтому с поверхностью образца будет взаимодействовать большее количество атомов острия.

Режим “обстукивания” по сути является реализацией контактного АСМ в динамическом режиме, образ действия которого подобен бесконтактному. В режиме “обстукивания” измерительная консоль колеблется на своей резонансной частоте с высокой амплитудой порядка 100 нм. При каждом колебании острие касается образца в своей нижней точке (отсюда термин режим “обстукивания”). При работе в режиме “обстукивания” повреждение образца менее вероятно, чем в контактном, поскольку в процессе перехода к каждой последующей точке сканирования устраняются боковые (латеральные) силы (трение или протягивание) между образцом и острием. Однако вертикальные силы в режиме “обстукивания” должны быть значительно выше, чем капиллярная сила (10–8 Н), для того чтобы дать острию сканирующей иглы возможность проникать внутрь и выходить из водного слоя без задержки. Эта вертикальная сила достаточно велика, чтобы деформировать поверхность мягких и упругих материалов. Поэтому изображения, полученные в режиме “обстукивания”, часто представляют собой смесь топографии и упругих свойств поверхности образца [17].

КРИВЫЕ ПОДВОДА/ОТВОДА. Аналогом сканирующей туннельной спектроскопии для АСМ является возможность снимать кривые зависимости силы взаимодействия зонда с поверхностью образца от расстояния между ними — кривые подвода/отвода. Эти кривые важны для измерения вертикальной силы, прикладываемой к поверхности со стороны острия в процессе сканирования. Кроме того, анализируя изменения формы этой кривой, можно оценивать вязкость загрязнений поверхности, толщину слоя смазки, а также местные вариации упругих свойств поверхности [7, 8, 15, 16, 20–25].

Кривая подвода/отвода представляет собой график зависимости отклонения измерительной консоли от удлинения сканирующего устройства. Ван-дер-Ваальсовы силы (рис. 4) представляют только одну составляющую, воздействующую на отклонение консоли: на измерения будут дополнительно влиять тонкий слой влаги, обычно присутствующий при работе АСМ на открытом воздухе, а также смазки и загрязнения.

Кривые подвода/отвода, получаемые в лаборатории, достаточно сложны и специфичны для каждого конкретного образца, однако для них можно выделить общие характерные участки, схематично изображенные на рис. 7.

Рис. 7. Номограмма кривых подвода/отвода. Сплошной линией схематически показана кривая, получаемая в вакууме. Пунктирными линиями отмечены вариации кривой подвода/отвода, обусловленные упругими свойствами образца и присутствием на поверхности слоя адсорбированной влаги и смазки (загрязнений)

Участок A–B. В левой части кривой сканирующее устройство полностью отведено, и консоль не изгибается, поскольку острие не касается образца. При подводе зонда к поверхности консоль продолжает оставаться неизогнутой до тех пор, пока острие не приблизится к поверхности образца настолько, чтобы на него начала действовать притягивающая Ван-дер-Ваальсова сила (т. В). На этом участке кривая не содержит никакой полезной информации.

Участок В–С. В точке В консоль внезапно изгибается по направлению к поверхности, и игла касается поверхности (т. С). Этот участок известен как “скачок к контакту”. При работе в воздушной среде кроме притягивающей Ван-дер-Ваальсовой и электростатической сил на острие будет дополнительно воздействовать капиллярная составляющая со стороны адсорбированного слоя влаги, а также загрязнений или смазки. Изменение величины силы на участке В–С кривой может быть пересчитано в смещение острия иглы по закону Гука (F = –kx), что позволяет оценить толщину адсорбированного на поверхности слоя.

Участок С–D. Этот участок характеризует дальнейший подвод зонда к образцу, сопровождающийся прижатием острия иглы к поверхности и почти линейным изгибом измерительной консоли в направлении от поверхности. По конфигурации участка C–D можно судить о модуле упругости системы “зонд–поверхность”. В случае, если измерительная консоль намного мягче поверхности образца, как например, в случае неразрушающего сканирования, наклон кривой большей частью отражает величину константы упругости самой консоли. Однако, когда жесткость консоли намного больше жесткости поверхности, наклон участка C–D позволяет исследовать упругие свойства образца [21, 26]. Участок С–D не обязательно должен быть прямой линией: изменения наклона в пределах этого сегмента кривой указывают на различие в реакции поверхности на различную прикладываемую силу. Это может происходить по причине перехода от упругой к пластической деформации, различия в поверхностных и объемных свойствах, а также изменения в составе образца по глубине.

Участок D–E. Точка D соответствует завершению фазы подвода и началу отвода зонда от поверхности. При отсутствии гистерезиса сканирующего устройства сегмент D–E практически повторяет участок С–D кривой, полученный при подводе. Если оба эти участка прямые и параллельны друг другу, то дополнительной информации (кроме отмеченной выше) они не содержат. В случае их непараллельности различие между ними дает возможность оценить либо пластическую, либо упругую деформацию образца (если скорость восстановления его геометрических размеров меньше скорости отвода зонда).

Участок E–F. Точка Е соответствует нейтральному отклонению консоли. При дальнейшем отводе зонда от поверхности консоль начинает изгибаться в направлении к образцу, поскольку на острие воздействует притягивающая, или адгезионная сила. На конфигурацию участка E–F влияет наличие на поверхности адсорбированных слоев. В случае работы в вакууме на острие иглы воздействуют Ван-дер-Ваальсова и, возможно, электростатическая силы. Если же снятие кривых происходит на воздухе, то к ним обычно добавляется достаточно мощная капиллярная сила со стороны слоя влаги, смазки или загрязнений. Толщина приповерхностного слоя влияет на длину участка E–F, а его наклон, отличающийся от наклона участка, соответствующего реакции жесткого образца, будет указывать на поднятие адсорбированных слоев вслед за отводимым зондом.

Участок F–G. Когда упругая реакция консоли превосходит притягивающую силу со стороны поверхности и находящихся на ней слоев, зонд отрывается от образца. На кривой подвода/отвода этому соответствует точка F, известная под названием точки отрыва. Величина усилия в точке F равна максимальной общей адгезионной силе между зондом и образцом и представляет ключевую информацию при исследованиях адгезии. Если слой влаги дополнительно покрыт слоем смазки или загрязнений, то можно наблюдать не одну точку отрыва (Рис. 7, тт. F1 и F2). Положение точек F1 и F2 зависит от вязкости и толщины этих слоев. Переход между участками E–F и F–G не обязательно представляет собой резкий скачок. Если адсорбционный слой достаточно вязкий, то зонд может отходить от поверхности постепенно, а переход E–F – F–G будет иметь в этом случае скругленные очертания.

ЛАТЕРАЛЬНО-СИЛОВОЙ МИКРОСКОП (ЛСМ) – это контактный АСМ, отображающий латеральные (т.е. боковые) отклонения измерительной консоли (закручивание), которые возникают в ней в плоскости параллельной поверхности образца. с помощью ЛСМ возможна визуализация изменений поверхностного трения, являющихся результатом негомогенности материала поверхности, а также для получения контрастных изображений любых поверхностей [5, 7, 12, 27, 28].

С созданием ЛСМ связано возникновение такой области исследований, как нанотрибология: эта технология предоставляет исключительную возможность исследовать процессы трения и изнашивания на молекулярном уровне при взаимодействии как отдельных выступов микрорельефа, так и отдельных атомов или молекул [9, 27, 28].

Как показано на рис. 8, латеральные отклонения консоли обычно возникают по двум причинам: изменение наклона поверхности и изменение ее фрикционных параметров (коэффициента трения). В первом случае консоль может закручиваться, когда ей попадается постепенный наклон. Во втором случае сканирующая игла, пересекая некоторый участок, может испытать большее трение, вызывая тем самым и большее закручивание измерительной консоли. Чтобы разделить эти два эффекта, ЛСМ должен “уметь” одновременно считывать данные о латеральном и вертикальном отклонении (т.е. визуализировать топографию).

Рис. 8. Элементы ЛСМ- профиля образца, отражающие прохождение сканирующей иглой участков с измененным наклоном поверхности и с отличающимся коэффициентом трения m1

МАГНИТНО-СИЛОВОЙ МИКРОСКОП (МСМ) отображает пространственные вариации магнитных сил на поверхности образца. Особенностью конструкции МСМ является то, что острие сканирующей иглы покрывается тонкой ферромагнитной пленкой (рис. 9). МСМ работает в бесконтактном режиме и детектирует изменения в резонансной частоте измерительной консоли, обусловленные изменениями магнитного поля в зазоре между острием сканирующей иглы и образцом. МСМ может визуализировать естественно встречающиеся и свободно записанные доменные структуры в магнитных материалах [7, 11].

Рис. 9. Схема работы магнитно-силового микроскопа. МСМ-профиль отображает магнитную структуру поверхностного слоя образца

Изображения, полученные с помощью МСМ, содержат информацию как о топографии, так и о магнитных свойствах поверхности. Какая информация преобладает на изображении, зависит от величины расстояния между острием и поверхностью, потому что межатомная магнитная сила существует при больших зазорах, чем это наблюдается для Ван-дер-Ваальсовой силы. Если острие находится близко к поверхности (<10 нм), то в режиме работы стандартного бесконтактного АСМ на изображении будет отражена преимущественно топография. При увеличении зазора между острием и образцом (примерно до 30–300 нм) влияние топографии снижается, и становятся видны магнитные эффекты. Анализируя ряд изображений, полученных при различной высоте острия над поверхностью, можно успешно отделить магнитные эффекты от влияния топографии. Подобное поведение характерно также и для электростатических сил.

В ЭЛЕКТРОСТАТИЧЕСКОМ СИЛОВОМ МИКРОСКОПЕ (ЭСМ) напряжение прикладывается между острием и образцом, в то время как измерительная консоль движется над поверхностью, не касаясь ее. Консоль отклоняется, когда попадает на статически заряженные области (рис. 10). Величина этого отклонения пропорциональна плотности заряда и может быть измерена стандартной системой. ЭСМ применяется для исследования распределения поверхностной плотности носителей заряда [7].

Рис. 10. Картографирование электростатических полей с помощью ЭСМ

Методы МИКРОСКОПИИ ПОВЕРХНОСТНЫХ СВОЙСТВ используют возможность отслеживания и регистрации амплитуды и частоты колебаний зонда (измерительной консоли) в процессе сканирования. Устройства, реализующие такие методики, представляют собой АСМ, в конструкции которого предусмотрена возможность модуляции вынужденных колебаний в зонде или образце. Эти методы обычно позволяют одновременно с получением изображений топографии также регистрировать изменения механических свойств поверхности образца [7–10, 23].

На рис. 11а представлен вариант, когда АСМ работает в контактном режиме, и в измерительной консоли возбуждаются колебания с постоянной амплитудой А. С помощью системы обратной связи отклонение консоли поддерживается постоянным; частота ее колебаний изменяется в соответствии с жесткостью сканируемого участка поверхности. Таким образом можно, например, выявлять разнородные включения в материале поверхности.

Рис. 11. Визуализация механических свойств поверхности: а – при отслеживании частоты колебаний зонда (частота увеличивается на более жестких участках); б – при записи разности фаз частоты сигнала, прикладываемого для возбуждения колебаний, и частоты колебаний зонда (построение фазового образа)

Аналогично, при поддержании постоянной частоты колебаний консоли и регистрации изменений их амплитуды возможна визуализация распределения вязких характеристик поверхности. При этом на более вязких участках амплитуда будет меньше.

Механические свойства поверхности можно исследовать также путем построения ее фазового образа (рис. 11б). Для этого необходим АСМ, работающий в динамическом режиме. Как и в предыдущих случаях, в измерительной консоли или образце модулируются вынужденные колебания. Система при этом сравнивает реальную частоту колебаний консоли с частотой сигнала, прикладываемого для возбуждения колебаний. Изменения в сдвиге фаз между этими двумя сигналами будет отражать изменения механических свойств поверхности образца.

С помощью СКАНИРУЮЩЕЙ ТЕРМАЛЬНОЙ МИКРОСКОПИИ (СТерМ) можно визуализировать локальные вариации теплофизических параметров поверхностей [7]. Данная методика реализуется за счет использования терморезистивного зонда, работающего в одном из двух режимов — постоянного тока или постоянной температуры.

В первом случае электрическое сопротивление термочувствительного зонда изменяется вместе с изменением температуры в данной точке сканирования. Это регистрируется путем измерения падения напряжения при пропускании через зонд слабого постоянного тока, исключающего, однако, его нагрев. При такой схеме работы картографируются температурные поля на сканируемой поверхности.

В режиме постоянной температуры отслеживается тепловой поток от зонда к образцу при поддержании постоянной температуры зонда, что позволяет визуализировать локальные изменения теплопроводности поверхности образца. Набор данных составляется из значений напряжения, прикладываемого к зонду для его обогрева и изменяющегося в каждой точке сканирования в зависимости от теплопроводности материала образца.

БЛИЗКОПОЛЬНАЯ СКАНИРУЮЩАЯ ОПТИЧЕСКАЯ МИКРОСКОПИЯ (БСОМ) является особой разновидностью сканирующей зондовой технологии, в которой используется видимый свет [7]. Другое название этой методики — сканирующая световая микроскопия. Традиционно разрешение оптических микроскопов ограничено длиной волны света — примерно половиной микрона. БСОМ улучшает разрешение оптического микроскопа на порядок.

Зондом в БСОМ является “световая воронка”, которой сканируют образец. Видимый свет исходит из узкого конца световой воронки диаметром 10–30 нм и попадает на детектор либо после отражения от образца, либо пройдя сквозь него. Интенсивность оптического сигнала регистрируется детектором в каждой точке измерений, а набор данных, считанных со всей сканируемой поверхности, составляет БСОМ-образ. С помощью БСОМ можно формировать изображение поверхности в видимом свете с разрешением около 15 нм при условии, что расстояние между источником света и образцом очень мало – ~ 5 нм.

Световая воронка и система поддержания постоянного расстояния между источником света и образцом – это две достаточно “тонкие” части БСОМ. Обычно световая воронка изготавливается нагреванием оптического волокна, протяжкой его до малого диаметра с проследующим скалыванием с одного конца. После этого на волокно для лучшей светопроводимости наносят слой металла (металлизируют). Другой способ изготовления световой воронки предусматривает высверливание небольшого отверстия в острие пустотелой сканирующей иглы АСМ и направление внутрь ее света. Разработка эффективной световой воронки в настоящее время является областью активных исследований.

БСОМ должен поддерживать расстояние между острием сканирующей иглы и образцом постоянным, чтобы получить простое оптическое изображение поверхности. Для этого могут быть использованы традиционные для АСМ методики поддержания постоянного отклонения измерительной консоли.

Одной из эффектных СЗМ-технологий является НАНОЛИТОГРАФИЯ. Обычно СЗМ применяются для формирования изображения поверхности без ее повреждения. Однако АСМ или СТМ могут быть использованы для направленной модификации поверхности путем приложения либо повышенной нагрузки в случае АСМ, либо повышенных пульсаций тока в случае СТМ. Эта технология известна как нанолитография. Примеры поверхностей, которые были с помощью подобных методик модифицированы атом за атомом, появлялись не только в научной литературе, но также в газетах и популярных журналах [3]. Большинство СТМ могут быть использованы и для нанолитографии, если они содержат устройства для генерации повышенных пульсаций тока. В случае АСМ необходимо, чтобы он имел возможность работать в контактном режиме. Кроме того, необходимым условием является контролируемое перемещения острия зонда по схеме, задаваемой оператором.

В заключение, комментируя возможность элементного распознавания атомов, необходимо отметить, что в настоящее время никакая технология СЗМ не может позволить определить тип атома или молекулы при отсутствии другой информации. Тем не менее, с помощью СЗМ можно проводить ограниченную идентификацию материалов. Выше уже обсуждалось использование для этих целей данных об электронной структуре. Кроме того, сегодня реальностью является картографирование жесткости и вязкости поверхностей с использованием модуляционных силовых методов. С помощью ЛСМ можно также попытаться идентифицировать материалы, основываясь на различиях в их фрикционных свойствах. Например, сила трения острия сканирующей иглы по полимерной матрице и материалу заключенного в ней наполнителя будет различной. Чтобы классифицировать материалы, взяв за критерий упругие свойства, необходимо снимать кривые подвода/отвода на элементах АСМ-изображения. Наконец, притягивающее Ван-дер-Ваальсово взаимодействие, используемое в бесконтактном АСМ, может оказаться чувствительным к типам атомов – ведь пределы чувствительности материалов не изучены пока что достаточно глубоко.

ОБОЗНАЧЕНИЯ

C – постоянная, =10,25 эВ–1/2 нм–1; j – высота потенциального барьера; z – расстояние между электродами; U – напряжение; I – ток туннелирования; m; – коэффициент трения; А – амплитуда.

ЛИТЕРАТУРА

  1. Binnig G., Rohrer H. Scanning tunneling microscopy // Helvetica Physica Acta 55 (1982), 726
  2. Куейт Ф. Вакуумное туннелирование: новая методика в микроскопии / Физика за рубежом. Сер. А. Москва: Мир (1988), 93–111
  3. Шермергор Т., Неволин В. Новые профессии туннельного микроскопа // Наука и жизнь (1990), № 11, 54–57
  4. Binnig G., Quate C. F., Gerber Ch. Atomic force microscopy // Phys. Rev. Lett. 56 (9) (1986), 930–933
  5. Шермергор Т. Знакомьтесь: атомный силовой // Наука и жизнь (1991), № 9, 7–9
  6. Sarid D. Scanning Force Microscopy With Application to Electric, Magnetic and Atomic Forces. New York: Oxford University Press (1991)
  7. Howland R., Benatar L. A practical guide to scanning probe microscopy. Park Scientific Instruments (1996)
  8. Heubrger M., Dietler G., Schlapbach L. Mapping the local Yong’s modulus by analysis of the elastic deformations occurring in atomic force microscopy // Nanotechnology, 5 (1994), 12–23
  9. Salmeron M. B. Use of the atomic force microscope to study mechanical properties of lubricant layers // MRS Bulletin (1993), May, 20–25
  10. Гоглинский К. В., Кудрявцева В. И., Новиков С. В., Решетов В. Н. Применение атомно-силовой микроскопии для исследования микроструктуры твердых сплавов на основе карбида вольфрама. Препринт/002-96. Москва: МИФИ (1996)
  11. Campbell A. N., Cole E. I. Jr., Dodd B. A., Anderson R. E. Magnetic force microscopy/Current contrast imaging: A new technique for internal current probing of ICs // Microelectronic Engineering 24 (1994), 11–22
  12. Labardi M., Allegrini M., Salerno M., Fredriani C., Ascoli C. Dynamical friction coefficient map using a scanning force and friction force microscope // Appl. Phys. A59 (1994), 3–10
  13. Grafstrom S., Kowalski J., Neumann R. Design and detailed analysis of a scanning tunneling microscope // Meas. Sci. Technol. 1 (1990), 139–146
  14. Weisendanger R. Scanning Probe Microscopy and Spectroscopy. Cambridge: Cambridge University Press (1994)
  15. Meyer E. Atomic Force Microscopy // Progress in Surface Science, 41/1 (1992), 3–49
  16. Burnham N. A., Colton R. J. Force Microscopy / Scanning Tunneling Microscopy and Spectroscopy. Chapter 7. New York (1994), 191–249
  17. Spatz J. P., Sheiko S., Moller M., Winkler R. G., Reineker P., Marti O. Forces affecting the substrate in resonant tapping force microscopy // Nanotechnology, 6 (1995), 40–44
  18. Luthi R., Meyer E., Howald L., Haefke H., Anselmetti D., Dreier M., Ruetschi M., Bonner T., Overney R. M., Frommer J., Guntherodt H.- J. Progress in noncontact dynamic force microscopy // J. Vac. Sci. Technol. 3 (1994) B12,1673–1676.
  19. Hartmann U. Theory of Noncontact Force Microscopy/Scanning Tunneling Microscopy III; Theory of STM and Related Scanning Techniques / Eds. R. Wiensendanger and J.-H. Guntherodt. Berlin: Springer (1985)
  20. Burnham N. A., Colton R. J., Pollock H. M. Interpretation of force curves in force microscopy // Nanotechnology, 4 (1993) 64–80
  21. Weisenhorn A. L., Hansma P. K., Albrecht T. R., Quate C. F. Forces in Atomic Force Microscopy in Air and Water // Appl. Phys. Lett. 54 (26), (1989), 2651–2653
  22. Моисеев Ю. Н., Мостепаненко В. М., Панов В. И., Соколов И. Ю. Экспериментальное и теоретическое исследование сил и пространственного разрешения в атомно-силовом микроскопе. ЖТФ, 60 (1990), №1, 141–148.
  23. Burnham N. A., Colton R. J. Measuring the nanomechanical properties and surface forces of materials using an atomic force microscope // J. Vac. Sci. Technol. A.7, 4 (1989), 2906–2913
  24. Chizhik S. A., Goldade A. V., Jr., Gorbunov V. V. Mathematical intepretation of force gradient vs. distance curves obtained by atomic force microscopy for local analysis of adhesive properties of solids // Proc. Int. Conf. “Computer Methods and Inverse Problems in Nondestructive Testing and Diagnostics” (CM NDT-95). Minsk (1995), 271–274
  25. Landman U., Luedtke W. D. Nanomechanics and dynamics of tip-substrate interactions // J. Vac. Sci. Technol. 2 (1991), B9, 414–423
  26. Hutter J. L., Bechhoefer J. Measurement and manipulation of Van der Waals forces in atomic force microscopy // Journal of Vacuum Science and Technology B, 12 (1994), 2251–2253
  27. Belak J. F. Nanotribology // MRS Bulletin (1993), May, 15–17
  28. Overney R., Meyer E. Tribological investigations using friction force microscopy // MRS Bulletin (1993), May, 26–34

Suslov A. A., Chizhik S. A.

Scanning probe microscopes (a review)

Basic types of the scanning probe microscopes – scanning tunneling and atomic force ones – as well as principles of their operation are considered in the review. Described are some other currently spreaded probe technologies built on the basis of the latter instruments.

Поступила в редакцию 29.08.97.

© А. А. Суслов, С. А. Чижик, 1997.

This page was prepared by A. Suslov 10.10.98


SurfaceXplorer :: Credits

[Разработчики]

Go to Help Index Авторский коллектив

  • Андрей Суслов (к.т.н.) :: Текст данного руководства, иллюстрации, консультации по реализации функций и дизайну GUI, программирование данного руководства, тестирование программы
    В создании программы SurfaceXplorer также принимали участие:
  • Дмитрий Шашолко :: Исходный код программы SurfaceXplorer, алгоритмы функций, графический пользовательский интерфейс (GUI)
  • Сергей Чижик (д.т.н., профессор) :: Алгоритмы функций, консультации по реализации функций и дизайну GUI, тестирование программы
  • Владислав Чикунов :: Тестирование программы, консультации по реализации и дизайну GUI

Go to Help Index Благодарность

При подготовке материалов для настоящего руководства были использованы АСМ-изображения образцов, предоставленных следующими организациями:

  • ПО "Интеграл" (г. Минск, Беларусь)
  • Институт высокомолекулярных соединений РАН (г. Санкт-Петербург, Россия)
  • Корейский институт науки и технологии (г. Сеул, Республика Корея)
  • Институт микромеханики и фотоники, Варшавский Технологический Университет (г. Варшава, Республика Польша)
  • Гомельский государственный медицинский университет (г. Гомель, Беларусь)

Разработчики выражают личную благодарность:

  • М. И. Игнатовскому
  • С. О. Абетковской
  • Т. А. Кузнецовой
  • А. И. Шельманову
  • Т. Е. Сухановой
  • Т. Г. Матюхиной
  • З. Римузе

СЗМ-изображения были получены на атомно-силовых микроскопах NT-206 (ОДО "Микротестмашины") с использованием АСМ-зондов (NSC11, CSC12, CSC38) и тест-решеток (TGZ01, TGZ02, TGZ03) фирмы Mikromasch.


SurfaceXplorer :: SPM image processing software with integrated measuring module

Программа обработки, визуализации и анализа СЗМ-изображений
 SurfaceXplorer

Руководство пользователя

SurfaceXplorer :: программа для обработки, визуализации и анализа данных сканирующей зондовой микроскопии с интегрированным модулем для управления атомно-силовым микроскопом NT-206. Для платформы Win32.

Код программы | Дмитрий Шашолко
Консультанты | Сергей Чижик, Владислав Чикунов, Андрей Суслов
Руководство пользователя | Андрей Суслов
SurfaceXplorer by Microtestmachines Co. Copyright © 2005-2006, Microtestmachines Co.


SurfaceXplorer :: Undocumented Features

[Недокументированные функции]

SurfaceXplorer :: Недокументированные возможности

Программа SurfaceXplorer помимо доступных функций содержит набор возможностей, предназначенных для специализированных процедур отладки, настройки или редактирования данных.

Данные возможности программы предусматривают пользование ими исключительно персоналом, владеющим глубокими знаниями об устройстве и функционировании самой программы и управляемого ей оборудования (атомно-силового микроскопа). Поэтому настоятельно не рекомендуется прибегать к помощи описываемых ниже функций в повседневной работе!

Go to Help Index Редактирование параметров матрицы данных

На активированной панели просмотра служебной информации о полях данных - нажать комбинацию клавиш [Alt-Ctrl-E] для активации дополнительной закладки.

Name - имя оси
Unit - единицы измерения
Scale - коэффициент масштабирования, используемый для пересчета аппаратных данных в физические
Start pt - начальная точка, с которой начинается масштабирование
Data deskewing - смещение данных, проводимое перед масштабированием
Data memory type - метод хранения данных (двухбайтное знаковое, двухбайтное беззнаковое и т.п.)

Общая формула получения физического значения координаты точки:

Vhw = (hADC + DataDeskewing)* Scale + StartPt

где hADC - аппаратное значение параметра (координаты) в битах.

Go to Help Index Вывод информации о сетевых потоках

В серверной части:

[Ctrl-F10] - Показать/спрятать на панели параметров сервера закладки с информацией о сетевых потоках

Go to Help Index Панель тестирования аппаратной части

В серверной части: [Ctrl-F12]


Untitled Document

SurfaceExplorer
[Главная] > [Панели инструментов] > [Просмотр] [Выделение] 		Microtestmachines Co.

Работа с профелем поверхности

Выбор необходимого профиля сечения осуществляется нажатием соответствующей иконки панели инструментов выделения.
Выбор линии профиля можно осуществить различными способами, при этом изменения сразу же отобразятся в окне профиля:

  • Можно «захватить» узел линии сечения (на концах линии находятся кружочки) мышью, нажав левую кнопку, затем, перемещая ее, указать следующий узел в нужной точке поверхности;
  • Если нажать левую кнопку мыши не на узле, и, удерживая ее, переместить мышь, то вы увидите, что в соответствии с перемещением мыши изменяется линия сечения, которая начинается в точке нажатия левой кнопки и заканчивается в точке ее отжатия;
  • Удаление узла можно произвести нажатием левой кнопки мыши на нем при удерживании клавиши Shift;
  • Для более точного задания координат линии сечения имеется возможность ручного ввода координат узлов (в таблице параметров выделения Узлы панели Профиль закладки Свойства в левой части окна программы (рис.1)), между которыми она будет проведена.

После выбора профиля сечения

окно профиля активирутся кнопкой [image]. При этом на экране появляется окно просмотра двухмерной поверхности с линией на изображении.

Вертикальные пунктирные линии в окне профиля в случае выделения по ломаной линии являются метками узлов, т.е. обозначают границы сегментов. Имеется возможность работы с двумя маркерами (по умолчанию они распологаются по краям окна профиля). При этом в статусной строке (в нижней части окна профиля) отображаются расстояние между маркерами вдоль линии профиля (по X) и разность высот между этими маркерами (по Z).Для перемещения маркеров необходимо нажать левую кнопку мыши на линии маркера, и, удерживая ее, перемещать мышь. Кроме того, переместить маркер возможно нажатием мыши в необходимой точке профиля при удерживании клавиши Ctrl (для правого маркера) и Alt (для левого маркера). В этом случае вы увидите, что в соответствии с перемещением мыши изменяется линия сечения (линия с окружностью в точке ее пересечения с линией профиля). Для использования закладок необходимо передвинуть к нужному месту маркер и нажать кнопку «Добавить» в окне Закладки панели Профиль закладки Свойства. После этого около точки на профиле появится информационное окно с характеристиками, которое «привязано» к профилю в указанном месте. Активировать закладку возможно нажатием мыши в необходимой точке профиля при удерживании клавиши Shift. Для удаления всех закладок необходимо нажать кнопку «Очистить» в окне Закладки панели Профиль закладки Свойства. Удалить закладку возможно нажатием наведенной на нее мыши при удерживании клавиши Shift. Окно закладки можно передвигать при помощи мыши.
При необходимости можно сохранить данные профиля в текстовый (*.txt) или графический (*.bmp) файл. Для этого необходимо выбрать пункт меню «Сохранить» или соответствующую кнопку на рабочей панели. При этом в текстовый файл будут сохранены данные профиля в текстовой форме, а также максимальная высота, длина сечения и физическая длина поверхности, среднее значение, средняя высота отклонения, среднеквадратичное отклонение, асимметрия, эксцесс.


SurfaceXplorer :: AFM Control Toolbar

[Панель инструментов] > [Инструменты управления АСМ]

2.4.5 Панель инструментов управления АСМ NT-206

Панель инструментов управления АСМ NT-206 (рис. 2.4.5.1) обеспечивает переключение отображения панели управления АСМ в главном окне программы, первичные процедуры связи с аппаратным обеспечением (соединнение, разъединение, инициализация устройства), а также быстрый доступ к наиболее часто используемым функциям панели упраления АСМ.

Toolbar File Button for bringing up AFM control panel Disconnect hardware command button Command for connecting with the AFM as host computer Command for connecting with the AFM as guest computer
Рис. 2.4.5.1 - Панель инструментов управления АСМ.

Кнопки на панели инструментов управления АСМ имеют следующие функции:
Toggle AFM control panel button |
Connect as guest button |
Copy image into clipboard button |
Disconnect buttton |
Initialization button |
AFM operation selector |
Scan matrix button |
Two pass scanning button |
Multilaer scanning button |
Force spectroscopy button |
Dynamic frequency spectroscopy button | 15. Динамическая частотная силовая спектроскопия
Line scanning button |
Tribometry button |
STOP button |
Camera capture window button |